About

Created using
htm2chm 3.0

Download it NOW!


Оглавление

Иллюстрированный самоучитель по устранению сбоев и неполадок домашнего ПК
  • Предисловие
    Введение
  • Глава 1. Что делать, если компьютер плохо работает?
  • Глава 2. Диагностические сообщения BIOS
  • Глава 3. Диагностические сообщения операционной системы
  • Глава 4. Диагностические программы
  • Глава 5. Вы купили компьютер
  • Глава 6. Питание компьютера и его компонентов
  • Глава 7. Первое включение
  • Глава 8. Установка операционной системы
  • Глава 9. Настройка операционной системы
  • Глава 10. Установка программ и игр
  • Глава 11. Настройка программ и игр
  • Глава 12. Удаление программ и игр
  • Глава 13. Работа с файлами и каталогами
  • Глава 14. Работа с офисными программами
  • Глава 15. Мультимедийные функции компьютера
  • Глава 16. Работа в сети Интернет
  • Глава 17. Работа в локальной сети
  • Глава 18. Компьютерные вирусы
  • Глава 19. Зависания операционной системы
  • Глава 20. Подключение новых устройств
  • Приложение 1. Преврати свой сайт в портал
  • Приложение 2. Используй то, что под рукою
  • Приложение 3. На сайте - как в "Винде"


Предисловие

Для кого эта книга?

Как ни банально это звучит, но я все-таки напишу, что эта книга предназначена для пользователя. Для самого обычного пользователя, который ни разу в своей жизни не сталкивался с самостоятельной сборкой компьютера или его настройкой.
Если вы держите в руках эту книгу, значит, вы уже не раз попадали в различные ситуации, когда персональный компьютер (дома, на работе, у друга), несмотря на все ваши усилия, начинал работать не так, как ему положено работать.
Первая мысль: "Надо везти компьютер по гарантии; наверное, что-то сломалось". Но каково будет ваше удивление, когда вам специалист какого-нибудь сервисного центра начнет объяснять "откуда у вас растут руки", откажет в гарантийном обслуживании или потребует оплаты проведенных работ. И в большинстве случаев будет прав.
Объяснение данной ситуации лежит практически на поверхности. Мало кто из нас хотя бы иногда задумывается над причинами появления сбоев в работе компьютера. Большая часть пользователей сразу же начинает искать причины в "железе", но поспешу вас огорчить — на практике доказано, что причиной 95% сбоев в работе компьютера является не аппаратная часть компьютера, а некорректная работа операционной системы или программного обеспечения (в том числе игровых программ).
"Как, — возмутитесь вы, — ведь я платил деньги и за установку Windows, и за диски с программами!" Вот здесь-то и кроется главный секрет сбоев и неполадок. Позвоните в службу техподдержки компании Microsoft и первое, что у вас спросят, — это то, где и за какую сумму вы купили диск с операционной системой. Скорее всего, вы приобрели диск с пиратской версией Windows, поэтому вам откажут в поддержке и будут правы — вполне естественно, что компания Microsoft защищает свои продукты от нелегального использования. Чтобы установить на свой компьютер защищенную операционную систему и при этом не платить за нее больших денег, применяются различного рода ухищрения: от генераторов серийного номера до "ломалок", которые попросту блокируют функцию проверки серийного номера и другие функции, немало мешающие дальнейшей эксплуатации пиратской версии Windows. Вы можете дать гарантию того, что при этом не были затронуты какие-нибудь функции, влияющие на стабильность работы операционной системы? Скорее всего, нет.
Яркий пример, с которым столкнулось немало пользователей. Операционная система Windows XP изначатьно не поддерживала стандарт USB 2.0, но впоследствии этот, как оказалось, недостаток, был устранен в пакете обновления Service Pack 1. При этом возможность обновления пиратских версий Windows оказалась блокированной, так что в большинстве случаев приходится переустанавливать систему и только после установки обновления применять "волшебное средство". Такова плата за "бесплатный сыр". Есть реальная альтернатива — использовать лицензионную версию Windows, но российского пользователя такая перспектива по традиции не очень радует со всеми вытекающими последствиями.
То же происходит и с программным обеспечением — первое, что делает любой мало-мальски "знающий" пользователь, так это ищет в сети Интернет решение, как "сломать" защиту или откуда скачать уже готовую "ломапку" (более распространенное название такой программы — "crack"). Ситуация усугубляется тем, что в большинстве случаев при покупке компакт-диска вы сразу же получаете взломанные программы. При этом мало кто задумывается, что использует пиратское программное обеспечение, которое вовсе не обязано работать стабильно, ведь оно распространяется "как есть" — вот мы "сломали" программу, чтобы она стала бесплатной, и уж извините, если что-то не так работает.
Естественно, призыв использовать только лицензионное программное обеспечение будет воспринят большинством читателей с легкой ухмылкой, поэтому мы отложим в сторону "розовые очки" и взглянем на ситуацию несколько по-другому. А можно ли сделать так, чтобы те программы, которые мы привыкли использовать, не так часто давали сбой, а еще лучше — работали бы вообще без сбоев? Ответ: можно, но придется потрудиться.
Теперь, наверное, стоило бы заменить в первом абзаце слово "обычный" на более достоверное — "российский". Эта книга посвящена, в первую очередь, всем тем, кто ежедневно сталкивается с пиратским программным обеспечением, не способным работать стабильно, как было отмечено ранее.

Как пользоваться книгой?

Загляните в оглавление этой книги, она разделена на двадцать глав, которые вполне подробно рассказывают обо всех ситуациях, встречающихся каждому пользователю в ежедневной практике.
Предисловие
Не стоит читать всю книгу подряд. Несмотря на относительно малый объем, в ней можно найти массу интересной информации, которую попросту нет смысла запоминать. Пусть книга лежит в ящике стола — она вам поможет при решении конкретных проблем или, например, если захотите "предохраниться" и заранее изучить интересующий вас вопрос.
По ходу изложения материала акцент делается на поиск проблемы в программах, а не в аппаратном обеспечении, что не исключает необходимости периодической диагностики всего оборудования. Это позволит полностью исключить возможность проведения лишней работы, а также избежать потери ценной информации.

Примечание
Анализируйте!!! Даже потратив на поиски не одно десятилетие, вы не сможете найти книгу, которая помогла бы вам во всех возможных ситуациях. Времени от того, когда пишется любая книга, до того, как она выходит в свет, проходит немного, но и за этот небольшой промежуток, как правило, успевает произойти немало самых разнообразных событий: от представления рынку принципиально новых процессоров до повсеместного отказа от некоторых устаревших морально устройств или стандартов. Все эти события привносят в мир компьютеров не только массу полезных и интересных устройств, которые увеличивают возможности персонального компьютера. Не менее сильно они увеличивают шансы приобретения нестабильно работающего ("глючащего") железа. Для устранения "глюков", например, новых моделей видеоплат, возможно, нельзя будет использовать старые способы.


ГЛАВА 1. Что делать, если компьютер плохо работает?

  • Как правильно описать неполадку (сбой)?
  • Средства предупреждения сбоев и неполадок
  • Спасение важных данных и настроек
  • Правила гарантийного обслуживания


Как правильно описать неполадку (сбой)?

Наиболее серьезно сегодня стоит та проблема, что пользователь, обращаясь в сервис-центр за помощью, не может достаточно внятно сказать, что же с его компьютером приключилось и что ему не нравится в работе "электронного друга". И ничего тут не поделаешь, в наше время компьютер очень часто приобретают лишь для того, чтобы он стоял на своем месте в углу комнаты (почти как телевизор). Усугубляет эту проблему отношение к персональному компьютеру как к игровой приставке: сунул диск в дисковод и играй. О каком-нибудь уровне подготовки не может идти и речи.
Более или менее точно указать признаки неполадки поможет нижеследующий список "состояний" компьютера при возникновении проблем. Можно выделить следующие категории.

  • 1. Компьютер не подает "признаков жизни". Ни один из индикаторов не загорается, не слышно привычного шума вентиляторов и жесткого диска и т. п. Скорее всего, один из компонентов компьютера "приказал долго жить", хотя не исключено, что вполне достаточно, например, очистить блок питания от накопившейся пыли. При этом возможны варианты:
    • • компьютер нормально запускается при отключении одного из устройств;
    • • компьютер нормально запускается после "обнуления" CMOS-памяти;
    • • компьютер нормально запускается только после отключения сетевого шнура от блока питания и повторного его подключения:
    • • компьютер нормально запускается только после тщательной очистки от пыли блока питания, замены предохранителя, вентилятора и т. п.
    2. Проблемы при прохождении программы диагностики POST. При этом возможны варианты:
    •  • компьютер зависает без вывода каких-либо текстовых сообщений на экран монитора и звуковых сигналов на системный динамик. Найти
              причину поломки можно при помощи, например, платы диагностики POST или осциллографа, но последний вариант доступен только опытным мастерам;
• компьютер выдает текстовое сообщение на экран монитора или звуковой сигнал на системный динамик. Диагностика осуществляется путем расшифровки данного сообщения;
• компьютер выдает текстовое сообщение на экран монитора. При этом вам предлагается вариант, при помощи которого удастся добиться стабильной работы компьютера. Например, войти в программу CMOS Setup Utility и установить верные параметры содержащихся там опций;
• компьютер выдает текстовое сообщение на экран монитора или звуковой сигнал на системный динамик и продолжает загрузку (появляется стартовая надпись или заставка операционной системы).
  • 3. Проблемы при загрузке операционной системы. При этом возможны варианты:
    • • система не может найти ни одного загрузочного диска;
      • система обнаружила критическую ошибку на загрузочном диске, продолжение загрузки невозможно. При этом на экран монитора выводится соответствующее текстовое сообщение;
      • компьютер зависает на определенном этапе загрузки или загрузка прекращается с выводом на экран монитора сообщения об ошибке (или без него).
  • 4. Проблемы при работе операционной системы. При этом возможны варианты:
    • • операционная система загружается, но слишком медленно;
      • операционная система загружается, но практически сразу же на экране монитора появляется сообщение о критической ошибке или компьютер зависает;
      • операционная система загружается нормально, но при запуске разных программ на экран монитора выводится сообщение об ошибке или компьютер зависает;
      • операционная система загружается нормально, не работают некоторые из программ или некоторые функции, оборудование (например, сканер).
  • 5. Компьютер работает без каких-либо нареканий. Такое, не побоюсь этого слова, иногда бывает, но достаточно редко, т. к. при активной работе на ПК практически постоянно сталкиваешься то с несовместимостью программного обеспечения, то с загрязнением системного блока пылью, то еще с чем-нибудь, что потенциально опасно для стабильности работы компьютера и, в частности, для установленной операционной системы.

Основные причины появления сбоев и неполадок — это поломка компонентов ПК, нарушение условий эксплуатации, возникновение аппаратных и программных сбоев, конфликтов и т. п.

Поломка компонентов компьютера

Согласно статистическим данным, чаще всего компоненты компьютера перестают работать (при соблюдении основных правил эксплуатации) по следующим причинам:

  • микротрещины в печатных проводниках, которые могут появиться в результате чрезмерного нажима при подключении кулера, соединительных шлейфов и т. п. Этот вид неисправности крайне сложно устранить;
  • отсутствие контактов в разъемных соединениях. Ситуация может встретиться на старых компьютерах, где могут использоваться контакты без золотого покрытия, что приводит к постепенному окислению. Устранить проблему можно, протерев все подозрительные контакты ластиком;
  • наличие проводящей пыли на контактах электронных компонентов и вследствие этого изменение уровня логических сигналов. Проблема устраняется удалением всей пыли при помощи мягкой кисти и пылесоса;
  • отсутствие контакта в переходном отверстии печатной платы. Может появиться в результате механического воздействия металлическим предметом или перегрева. Проблему устранить крайне сложно;
  • критичное изменение параметров транзисторов, резисторов и конденсаторов. Может появиться в результате их перегрева, устраняется их заменой;
  • пробой на "землю" или питание информационных выводов микросхем. Можно устранить только заменой "пробитых" элементов, хотя иногда подобная проблема может быть вызвана металлическим предметом, замкнувшим контакты;
  • некорректные установки параметров в CMOS-памяти. Могут появиться как из-за настроек пользователя, так и в результате разрядки аккумулятора или воздействия компьютерных вирусов. Устраняется путем "обнуления" CMOS-памяти или, если есть в этом необходимость, обновления/восстановления содержимого BIOS;
  • некорректные установки перемычек (джамперов). Причиной могут стать только "кривые" руки пользователя, который поленился прочитать инструкцию;
  • порча информации в микросхеме ПЗУ (BIOS). "Лечится" восстановлением при помощи программатора.

Несмотря на внешнюю простоту дефектов, их поиск и идентификация требуют от пользователя достаточно высокой квалификации. При поиске неисправности внутри системного блока в большинстве случаев вам следует придерживаться следующей последовательности:

  • оценка всех компонентов по их внешнему виду. Искать следует детали, которые явно изменили свой цвет или форму (например, вздутые конденсаторы);
  • оценка условий эксплуатации каждого из них (запыленность, изменение формы, состояние контактов разъемов, нарушение паяных соединений);
  • оценка правильности установки всех компонентов, подключения разъемов, всех перемычек (даже если вы сами ничего не трогали) и т. д.;
  • измерение сопротивления между контактами питания +5 В и "землей". Разница между прямым и обратным замером должна находиться в пределах соотношения 3:2;
  • измерение напряжения на аккумуляторе, питающем микросхему CMOS-памяти. Оно должно быть в пределах от 2,8 до 3,3 вольт.

Если все параметры находятся в пределах допустимого уровня, можно переходить к следующему этапу. Включаем напряжение питания системного блока и наблюдаем за происходящими событиями. Более подробную информацию о неисправности можно получить исходя из следующих признаков:

  • состояние индикаторов материнской платы и подключенных к ней устройств;
  • наличие звуковых эффектов, издаваемых механически вращающимися узлами;
  • наличие тепловых эффектов и запахов, вызываемых нагревом компонентов;
  • наличие звуковых сигналов, издаваемых системным динамиком;
  • наличие текстовых сообщений, выводимых на экран монитора.

Нарушение условий эксплуатации

Все та же неумолимая статистика говорит о том, что более 70% всех случаев поломок и сбоев возникают из-за отсутствия у пользователя навыков использования данного устройства (компонента компьютера). Этот факт усугубляется еще тем, что пользователь практически никогда не читает инструкций, то ли полагаясь на опыт работы, то ли на то, что раз устройство новое, с ним не может быть проблем. Если инструкции не имеется, следует обратиться в компанию, продавшую устройство. Уже достаточно давно был принят закон, в котором говорится о том, что к любому изделию должна прилагаться инструкция, переведенная на русский язык. Если таковая отсутствует, то налицо нарушение ваших прав, ведь вас лишают возможности изучить основные принципы работы с устройством.
Нередко приходится видеть, как системный блок устанавливается почти вплотную к трубам отопления. Это, конечно же, недопустимо, т. к. внутренние компоненты ПК, такие как процессор, видеоплата, жесткий диск, сами по себе выделяют немало тепла, а тут еще их дополнительно подогревают, что сильно уменьшает шансы стабильной работы компьютера в целом. К тому же дополнительный нагрев обычно приводит к преждевременному выходу из строя компонентов ПК. Иногда встречаются довольно нестандартные компьютерные столы, которые весьма ограничивают поток воздуха позади системного блока, что также приводит к перегреву компонентов системного блока.
Однако не все зависит от желания и возможностей пользователя соблюдать все меры безопасности при работе с компьютером. Перепады в электросети не менее опасны для компонентов компьютера, чем их перегрев. Чрезмерное увеличение или падение напряжения, в лучшем случае, приводит к перезагрузке компьютера или аварийному отключению блока питания. В худшем случае происходит поломка одного или даже нескольких компонентов, таких как оперативная память, жесткий диск и т. п.
Не менее опасным является скопление пыли внутри системного блока или монитора, что может привести как к перегреву, так и к короткому замыканию.

Аппаратные конфликты и несовместимость устройств

Практически любой пользователь ПК слышал о том, что некоторые устройства могут занимать "не те" прерывания, использовать "не те" области оперативной памяти и т. п. Некоторые в это не верят, считая, что им пытаются подсунуть нерабочую плату или плату, бывшую в употреблении. Некоторые пользователи настолько боятся этой проблемы, что, услышав, что на компьютере возник конфликт, сразу же начинают думать о продаже своего "электронного друга" и покупке нового, у которого не будет никаких конфликтов. Подобная реакция ничем не оправдана, т. к. практически любой аппаратный конфликт можно устранить.
Аппаратный конфликт устройств — это ситуация, когда несколько устройств одновременно пытаются получить доступ к одному и тому же системному ресурсу. Конфликт прерываний возникает в том случае, если несколько устройств используют, например, одну линию для передачи сигналов и отсутствует механизм, позволяющий распределять эти сигналы, в результате чего либо отказ распространяется только на одно из устройств, либо компьютер вообще перестает работать.
Нюанс проблемы аппаратных конфликтов состоит в том, что ресурсы компьютера "раздаются" при помоши соответствующего программного обеспечения, которое мы называем системой Plug and Play. Поэтому основная масса сбоев при распределении ресурсов вполне решаема либо отключением этой системы и ручным распределением прерываний, каналов DMA и областей памяти, либо переключением между Plug and Play BIOS и Plug and Play операционной системы, при этом отдавая приоритет в распределении BIOS или Windows. Определить наличие аппаратных конфликтов можно несколькими способами.

  1. 1. Войти в Панель управления и двойным щелчком левой кнопки мыши запустить ярлык Система. После этого активизировать вкладку Оборудование | Диспетчер устройств. Наличие восклицательного знака возле одного из устройств может говорить о возникновении конфликта при распределении ресурсов. Этот способ имеет силу для операционной системы Windows 2000 или Windows XP.
  2. 2. Войти в Панель управления и двойным щелчком левой кнопки мыши запустить ярлык Система. После этого активизировать вкладку Устройства. Наличие восклицательного знака возле одного из устройств может говорить о возникновении конфликта при распределении ресурсов. Этот способ имеет силу для всех операционных систем семейства Windows 9x.
  3. 3. Запустить программу Сведения о системе, которая находится в меню Пуск | Все программы | Стандартные | Служебные, в которой можно получить полную информацию о совместном использовании практически всех аппаратных ресурсов компьютера, таких как прерывания, каналы DMA, области оперативной памяти. Этот способ действителен для любой версии Windows.

Как ни печально осознавать, но время от времени встречаются случаи крайне яркой несовместимости устройств, когда никакие ухищрения не могут заставить работать их вместе.
Несовместимость — невозможность совместного функционирования некоторых из устройств, например, модулей оперативной памяти и материнской платы. Причиной обычно служит несоблюдение производителем общепринятых спецификаций или же использование нестандартных методов увеличения производительности.
Яркий пример несовместимости — струйный принтер марки Lexmark Z45 сложно подключить к некоторым материнским платам с чипсетом производства Intel. Это становится возможным только лишь после установки специального обновления от компании Microsoft, которое, кстати, не всегда дает нужный эффект.

Сбои в операционной системе

Вот мы и подошли к очень распространенной причине нестабильной работы ПК.
Первой и самой опасной проблемой являются ошибки в файловой системе жесткого диска. Если говорить простым языком, то наиболее опасны нарушения в структуре расположения файлов и каталогов, когда ссылки на информацию, расположенные в таблице размещения файлов, указывают совершенно не на то место, где на самом деле располагается файл. Еще одна проблема — неверные свойства файла, например, указан неправильный размер, что может привести к потере части документа.
Время от времени встречается такой сбой, как нестандартные записи в именах файлов или каталогов. К этой категории относятся имена файлов и каталогов, содержащие недопустимые символы вроде "/", "<", "?" и т. п.
Не менее часто встречаемая проблема при работе операционных систем — это наличие ошибочных записей в системном реестре. Откуда они появляются? Как правило, из-за того, что при установке и удалении многих программ в системном реестре остаются временные метки, создающие почву для появления конфликтов.
Довольно часто после некорректной установки/удаления программного обеспечения может возникнуть следующая проблема — отсутствие необходимых библиотек DLL (Dynamic Link Library, динамически подключаемая библиотека). При этом при загрузке или работе операционной системы появляются текстовые сообщения, сигнализирующие об отсутствии некоторых нужных файлов. А иногда, даже при корректном удалении программ, удаляются необходимые элементы операционной системы.

Сбои в программном обеспечении и драйверах

Основной причиной сбоев в программном обеспечении является то, что, во-первых, нет строго определенного стандарта на написание программ и драйверов. Во-вторых, программы и драйверы запускаются и используются в различных операционных системах, которые имеют массу различий в работе с компонентами компьютера, что особенно заметно в операционных системах семейства Windows NT. В-третьих, все программы (драйверы) могут подвергнуться "заражению" компьютерным вирусом или же повреждению из-за аппаратных сбоев.
Очень часто возникают весьма характерные проблемы с русифицированным, или, как чаще всего его называют, локализованным программным обеспечением.
Разработчики программного обеспечения иногда забывают, что для работы программ, написанных, например, на языке программирования Visual Basic, требуется загрузка в память компьютера специальных библиотек, обеспечивающих "перевод" программ на понятный операционной системе язык. Без этих файлов программа не запустится, выдав на экран монитора сообщение об отсутствующих файлах. Подобных случаев на практике встречается более чем достаточно, поэтому жизнь пользователя не перестает быть весьма разнообразной.


Средства предупреждения сбоев и неполадок

В большинстве случаев пользователю рекомендуется в первую очередь проверять те параметры компьютера, которые максимально зависят от аппаратного обеспечения и условий его эксплуатации. Это температура центрального процессора, материнской платы, видеоплаты, жесткого диска, модулей памяти, напряжения питания этих же компонентов и прочее.

Средства контроля температуры процессора (CPU)

Производительность персонального компьютера постоянно растет, и вместе с этим его устройство становится все более сложным. Энергопотребление и тепловыделение компонентов повышаются все больше и больше, что заставляет производителей думать о том, как лучше всего обеспечить надежную защиту компонентов от перегрева. Поэтому нам с вами приходится теперь думать не только о быстродействии отдельных компонентов, но и о качестве их охлаждения.
Для контроля над качеством охлаждения и уровнем напряжений разработан целый ряд решений, позволяющих пользователю самостоятельно контролировать каждый отдельный параметр либо позволяющих включить автоматическое отключение ПК при возникновении аварийной ситуации. Центральному процессору всегда уделялось особое внимание, это не только главный вычислительный узел компьютера, но и самый горячий его компонент. Кстати, работоспособность процессора напрямую зависит от качества его охлаждения. При значении температуры выше определенного уровня повышается вероятность ошибок в работе, при дальнейшем ее росте процессор останавливается и в наихудшем случае выходит из строя. Практически любые современные материнские платы имеют средства температурного контроля центрального процессора. Для этого используют специальный термодатчик, который располагается внутри процессорного разъема. Он очень похож на "лепесток", прижимаемый силами собственной упругости к обратной стороне процессора. Надо лишь следить, чтобы он плотно прижимался всей поверхностью кончика обязательно в центре процессора. Термодатчиком может служить и небольшая деталь, стоящая на тонких металлических ножках, но у такого варианта немного хуже упругость и контакт прилегания. В третьем случае внутри процессорного разъема ничего не видно, т. к. датчик находится под разъемом, напаянный на широкой дорожке платы. При этом датчик имеет тепловой контакт с ножками процессора. Медные, позолоченные выводы обеспечивают хороший отвод тепла, поэтому и являются точкой снятия температуры.
К сожалению, подобный контроль над температурой не очень эффективен, г. к., во-первых, показания датчика никогда не соответствуют реальному -нагреву, что обычно выражается в реальной разнице на 5—15 °С между реальной температурой и тем, что показывает датчик. Во-вторых, при резком нагреве процессора внешний датчик не способен сразу отреагировать, т. к. внешний корпус всегда нагревается дольше.
Сомпания Intel, начиная с процессоров Pentium II, стала монтировать тер-иодатчик внутрь ядра, что позволило в некоторой степени устранить инертность, т. е. датчик теперь нагревается практически одновременно с ядром троцессора. Но имеется еще одна проблема: любая цифровая технология измерений "страдает" дискретностью, т. е. система мониторинга считывает температуру через определенные промежутки времени, которые обычно составляют десятые доли секунды и не могут быть меньше. За время между пересчетами температура ядра процессора может подскочить до 10 и более градусов. Поэтому в процессорах Intel Pentium 4 применяется аналоговая система контроля Thermal Monitor, с отдельным датчиком, которая не привязана к дискретным пересчетам и действует постоянно. В результате при достижении 85 °С включается система пропуска тактовых сигналов, что приводит к снижению тактовой частоты ядра процессора. Процессоры компании AMD, начиная от Athlon XP и Duron Morgan, также имеют интегрированный термодатчик. К сожалению, значительная часть материнских плат под Socket А не включает в свой состав даже цифровой системы мониторинга, способной взаимодействовать с внутренним термодатчиком процессора. Производители зачастую ограничиваются установкой старого внешнего термодатчика со всеми его недостатками.
Из всего вышесказанного можно сделать вывод, что компьютеры, собранные на базе процессоров от AMD, требуют особого контроля над качеством охлаждения. Для процессоров от Intel контроль над температурой не столь критичен, особенно для тех процессоров, которые обладают аналоговым датчиком (Pentium 4), но это вовсе не повод для халатного отношения к их охлаждению. Даже для самых "горячих", Duron или Athlon, процессоров недопустима рабочая температура выше 55-60 °С, т. к. это может привести к их преждевременному выходу из строя и к "тормозам" при работе компьютера.

Средства мониторинга материнской платы

На материнской плате имеется достаточно большое количество датчиков, которые постоянно контролируют состояние основных параметров ее работы. Это и контроль над температурой чипсета, и контроль над всеми напряжениями, поступающими на электронные компоненты материнской платы, и контроль над частотой вращения вентиляторов на центральном процессоре, дополнительного системного вентилятора. В "обязанности" материнской платы также входит и задача отслеживать критичные изменения всех измеряемых величин, на уровне BIOS или аппаратной части, включая защитный механизм в случае их превышения. К сожалению, полноценной функцией мониторинга обладают только достаточно дорогие модели материнских плат, в то же время наиболее дешевые образцы обладают лишь минимальным набором подобных средств, к тому же не с самым эффективным механизмом их реализации. Точность измерения температуры обычно составляет ±3 °С.
Контроль и отображение показаний аппаратного мониторинга обычно реализуются на уровне BIOS, хотя большую часть показаний можно контролировать и средствами операционной системы. Наиболее критичными параметрами являются температура центратьного процессора и скорость вращения охлаждающих вентиляторов. Причем контроль этих параметров осуществляется только при старте компьютера во время прохождения процедуры самодиагностики POST. Некоторые модели плат оснащены системой аналогового контроля, который действует независимо от программы BIOS, поэтому в случае аварийной ситуации независимо от настройки и состояния системы материнская плата может мгновенно отключиться. Средства мониторинга во всех платах реализуются с помощью универсальных микросхем аппаратного мониторинга производства компании Winbond. Из-за того, что параметры аппаратного мониторинга материнских плат отображаются только в программе CMOS Setup Utilities, "которая не является основной программой при работе компьютера, рекомендуется использовать программы мониторинга для операционной системы Windows. Дело в том, что максимально система загружается только после запуска операционной системы при работе в ресурсоемких программах или играх. Только в этом случае аппаратный мониторинг можно считать наиболее объективным. Поэтому для полноценного мониторинга рекомендуется применять специальные утилиты вроде MBProbe или Motherboard Monitor.

Средства мониторинга на видеоплатах

На наиболее современных видеоплатах, в частности GeForce FX, начали внедрять не менее мощные средства аппаратного мониторинга, чем на материнских платах. Диагностике подвергаются напряжения питания, температура видеочипа и скорость вращения охлаждающего вентилятора. Средства мониторинга на них по традиции реализуются при помощи микросхем производства Winbond. Правда, контроль над состоянием датчиков осуществляется только в среде Windows с помощью утилит вроде SmartDoctor, V-Tuner, WinFox, что не позволяет вовремя выключить систему при возникновении неполадки. Хотя и в этом имеется определенный смысл: самую большую нагрузку на видеоплату дают трехмерные приложения, например игры, так что контролировать параметры видеоплаты во время загрузки операционной системы, вроде бы, нет необходимости.

Средства аппаратного мониторинга жестких дисков

Жесткие диски одними из первых устройств в компьютере "приобрели" автономную систему диагностики, способную определять состояние накопителя, предупреждать ошибки и аварийные ситуации. Эта технология называется SMART (Self-Monitoring, Alerting and Reporting Technology), что переводится как технология самодиагностики, анализа и отчетности. "Пионером" в этой области стала компания Quantum.
Суть технологии SMART заключается в постоянном контроле состояния винчестера, отслеживания механических и электрических параметров, сканирования поверхности диска и, по возможности, самостоятельном исправлении некоторых дефектов. Сегодня производители так и не пришли к единому мнению по поводу спецификации на эту технологию, поэтому разные производители на разных моделях своих накопителей сами могут определять число контролируемых параметров.
Пользователь при помощи специальных программ может самостоятельно проверять состояние жесткого диска, делая своевременный вывод о целесообразности его дальнейшего использования для хранения ценной информации. Для этого, например, можно использовать программу SMARTUDM, которая не только позволяет увидеть цифровые значения всех контролируемых параметров, но и составляет прогноз даты предположительного выхода диска из строя.

Средства программной защиты от сбоев и неполадок

Программный мониторинг температуры и напряжений питания

Как рассматривалось ранее, наиболее важные компоненты современного компьютера (материнская плата, процессор и видеоплата) оснащены развитой системой контроля над температурным режимом. Пользователю информация от датчиков температуры доступна только при включении или перезагрузке компьютера, когда на экране монитора отображаются текущие значения температуры процессора и материнской платы, ну, а во время работы остается только надеяться на функцию аварийного отключения при достижении некоторой критической отметки, указанной в BIOS. To есть вы никак не успеете сохранить важные изменения в файлах в случае возникновения аварийной ситуации. Для предотвращения подобных ситуаций обычно применяют специальные программы мониторинга, которые постоянно "наблюдают" за состоянием датчиков и при приближении температуры к критической отметке выдают соответствующее предупреждение. Это дает возможность пользователю успеть сохранить изменения в документах, например в программе 1С-Бухгалтерия, и самостоятельно выключить компью тер, не дожидаясь перегрева компонентов.

Антивирусные программы

Очень важным условием бесперебойной работы персонального компьютера всегда было и остается применение антивирусных программ, которые позволяют исключить возможность деструктивного (разрушительного) дейст вия компьютерных вирусов, которые, кстати, в подавляющем своем боль шинстве направлены на создание сбоев и неполадок. Более подробно об этом будет рассказано в главе 18 .


Спасение важных данных и настроек

Появление серьезных проблем в работе компьютера всегда неожиданно для любого, даже подготовленного пользователя, поэтому следует иметь в наличии некоторое количество программ, которые можно использовать как для резервного копирования важной информации (например, документов), так и для восстановления утраченной (например, по ошибке удаленной) ин формации.

В связи с тем, что скорость работы жестких дисков постоянно увеличивает ся, всегда нужно думать о возможности появления сбоев и неполадок. Именно поэтому вам следует регулярно копировать наиболее важную информацию на носители, которые меньше подвержены риску случайного повреждения в процессе работы компьютера. Это такие носители, как компакт-диски и гибкие диски различных форматов.

Существует две разновидности резервного копирования: полное копирова ние диска и копирование важных файлов. Полную резервную копию реко мендуется обновлять после каждой инсталляции новой программы. Частота копирования отдельных файлов зависит от того, насколько много в них на копилось изменений.

Примечание Следует помнить , что восстановление данных в любом случае займет значи тельно больше времени и средств , чем резервное копирование

Для резервного копирования очень удобно использовать пишущий привод CD - RW , который позволяет записать до 700 Мбайт полезной информации. При этом следует иметь в виду, что для компакт-дисков очень опасны цара пины поверхности. Кстати, не только со стороны записи данных, по и с внешней стороны, где обычно имеется наклейка с какой-либо надписью.

На самых дешевых "болванках" нет защитного слоя краски, что еще больше усугубляет проблему.

При резервном копировании важной информации стоит придерживаться следующих моментов.

  • Надежность хранения информации повышается пропорционально с увеличением стоимости носителя. Наилучший носитель, естественно, — это жесткий диск, за ним следует Flash -память, компакт-диски, диски Iomega ZIP и на самом последнем месте стоят флоппи-дискеты.
  • Если имеющихся носителей для сохранения всей информации недостаточно, то для уменьшения занимаемого объема рекомендуется пользо ваться программами-архиваторами вроде WinRAR или WinZIP . Более подробно об использовании этих программ будет рассказано в главе 13.

Для восстановления информации обычно используют программу под назва нием Unerase или Undelete , которая позволяет, загрузившись с системной дискеты, восстановить только что удаленные файлы. Если вы после удале ния работали достаточно большой промежуток времени, возможность удач ного восстановления файлов уменьшается пропорционально количеству вновь записанных файлов.

Существует ряд программ, которые могут восстановить файлы даже после полного форматирования или воздействия компьютерных вирусов, когда обычные программы вроде Unerase никакой пользы принести не могут. Более подробно об этом будет рассказано в главе 13.

Для того чтобы можно было быстро начать работу с вновь установленной системой, рекомендуется сохранять не только файлы (документы и прочее), но и настройки наиболее используемых программ. В состав Window XP входит специальная утилита, как раз предназначенная для переноса основных настроек и документов на другой компьютер, что можно использовать и при переустановке операционной системы. Иногда можно рекомендовать сохра нять каталог, в котором установлена программа, но в этом случае сохранять ся только те настройки, которые записаны в специальных файлах с расши рением INI .


Правила гарантийного обслуживания

ПОМНИТЕ!!! На любой компьютер или его отдельный компонент при про даже дают гарантию, которой некоторые пользователи просто забывают пользоваться. Наиболее яркий пример, который приходит в голову: компью тер при включении издает звуки, говорящие о неисправности видеоплаты, но спустя некоторое время (после прогрева) компьютер нормально запуска ется. В этом случае следует заменить видеоплату, а не списывать данный эффект на то, что наступила зима и компьютер замерзает. Ведь он установлен в отапливаемом помещении и поэтому должен работать нормально.

Прочитайте перечисленные ниже правила гарантийного обслуживания. Обычно все компании, торгующие компьютерами и отдельными компонента ми, придерживаются их, правда, иногда добавляя какие-нибудь особые условия, которые можно найти в гарантийных документах на ваш компьютер.

  • Гарантийное обслуживание включает в себя бесплатный ремонт или за мену вышедших из строя комплектующих в составе компьютера в тече ние срока, указанного в гарантийном талоне с момента приобретения изделия.
  • Владелец изделия осуществляет доставку компьютера для выполнения гарантийного ремонта и обратно самостоятельно, кроме изделий, обслу живаемых на рабочем месте по отдельному договору. Прием изделия в ремонт осуществляется только при наличии гарантийного талона и то варно-денежных документов, подтверждающих факт покупки.
  • Срок гарантийного ремонта определяется степенью неисправности изде лия и наличием необходимых для ремонта комплектующих и может до ходить до 20 календарных дней с момента обращения.
  • Претензии по комплектации, внешнему виду изделия принимаются толь ко при его покупке. Претензии по внутренней комплектности систем ного блока принимаются в течение двух недель со дня покупки и только при наличии неповрежденных фирменных наклеек на корпусе изделия и комплектующих.
  • Гарантийные обязательства не включают в себя устранение проблем некорректной работы программного обеспечения (ПО), обусловленных его качеством или неправильной установкой и эксплуатацией (несоответствие правилам, процедурам и рекомендациям производителей ПО).
  • Гарантийные обязательства не распространяются на изделие в следующих случаях:
    • выход изделия из строя по вине пользователя (нарушение правил экс плуатации, работа в нерасчетных режимах, неправильная установка и подключение, превышение допустимой рабочей температуры и т. п.);
    • наличие внешних и внутренних механических повреждений (замятых контактов, трещин, следов удара, сколов на кристалле процессора и т. п.), полученных в результате неправильной эксплуатации, уста новки или при транспортировке изделия;
    • наличие на изделии признаков ремонта неуполномоченными лицами;
    • наличие повреждений, полученных в результате аварии либо при воз действии огня, влаги, насекомых, пыли, попадания внутрь посторон них предметов;
    • факт использования некачественных носителей информации (флоппи- диск, компакт-диск и т. п.), приведших к их разрушению внутри уст ройства;
    • визуального наличия следов электрического пробоя, прогар микросхем, проводников и т. п.;
    • повреждение или изменение, по сравнению с оригинальным, содер жимого BIOS материнских плат, видеоплат, модемов и прочих уст ройств;
    • отказ портов подключения периферийных устройств ( COM , LPT , GAME , KB , PS /2, USB ). Претензии по работе портов рассматриваются сервис-центром в течение 14 дней с момента приобретения ПК.
  • Внимание! Гарантия может быть прервана или ограничена при обнаруже нии неисправностей, вызванных повышенной запыленностью внутрен них компонентов системного блока.
  • Продавец не дает гарантии совместимости системного блока с оборудованием, не входящим в состав системного блока в момент его продажи покупателю.
  • При необоснованном обращении за гарантийным обслуживанием поку пателю может быть выставлен счет за диагностику неисправности. Необоснованным считается обращение по устранению неисправностей в работе компьютеров и периферийных устройств, не потребовавших за мены или ремонта комплектующих, а также в случаях, признанных нега рантийными.
  • Будьте внимательны! В случае если устройство подключается не через USB -порт, перед соединением компьютера с устройством необходимо отключить питание системного блока и устройства. В противном случае может произойти электрическое повреждение портов ввода/вывода. Гарантия на повреждения такого рода не распространяется. При обнаружении техническим специалистом повреждений, связанных с неправиль ным подключением шлейфа, гарантийный ремонт не производится!


Глава 10. Установка программ и игр

  • Что такое компьютерная программа (игра)?
  • Что такое дистрибутив программы (игры)?
  • Разновидности программ
  • Процесс установки программ и игр
  • Особенности установки программ MS-DOS
  • Чем грозит установка каждой новой программы?
  • Пиратские и лицензионные программы


Что такое компьютерная программа ( игра )?

Компьютерная программа — это упорядоченная последовательность команд.

На первый взгляд, компьютер совершает действия под управлением челове ка, но если разобраться, то сразу же станет понятно, что компьютер абсо лютно бесполезен без программ. С момента включения до момента его вы ключения на нем работают самые разнообразные программы, причем сам процесс загрузки и завершения работы находится под постоянным управлением соответствующих служебных программ. Такова сущность любого элек тронного механизма.

"Прозрачность" выполнения всех команд, которые мы даем компьютеру при работе за ним, выполняется благодаря операционной системе, которая загружается при его запуске. Без операционной системы, хотя бы самой про стейшей (например, MS - DOS ), компьютер — не более, чем "груда железа". Именно на этом основана политика таких компаний, как Microsoft — де ваться пользователю просто-напросто некуда, все равно придется устанавливать операционную систему.

В простейшем случае программа состоит всего из одного файла с расшире нием СОМ или ЕХЕ. Первый тип расширения указывает на то, что про грамма предназначена для работы в MS - DOS или окне эмуляции MS - DOS . Второй тип файлов предназначен в основном для работы в Windows , хотя встречаются и такие файлы, которые способны работать и в MS - DOS . Их структура намного сложнее, чем у первого типа, да и размер этих файлов намного больше. Последний фактор вынуждает производителей программ применять программы для их сжатия. В результате чего конечный файл по лучается меньше оригинала раза в два, а то и в десять раз меньше, но при этом функциональность нисколько не страдает. При запуске файла идет ав томатическая распаковка архива в оперативную память компьютера, после чего уже передается управление непосредственно запущенной программе. Конечно, это отнимает некоторое время, да и ресурсы центрального процес сора, зато позволяет сильно сэкономить на дисковом пространстве, ведь только в операционной системе имеется огромное количество таких вот файлов, которые в распакованном виде будут занимать просто огромные объемы.

Стоит отметить, что файлы с расширением СОМ или ЕХЕ называют испол- шемыми файлами, т. к. они в своем теле содержат инструкции, подлежащие [сполнению.

Современные программы выполняют просто огромное количество разнообразнейших функций, что очень сильно усложняет их структуру, поэтому место единственного исполняемого файла, содержащего все необходимые ля работы инструкции, теперь часто используются группы файлов. При том один файл, как и прежде, является исполняемым в прямом смысле того слова, т. е. имеет расширение ЕХЕ (в сложных программах не встре- аются исполняемые файлы с расширением СОМ), а все остальные, практически, могут иметь любые расширения. Главное, чтобы основной ис-олняемый модуль мог распознать "свой" файл. Несмотря на столь широкие амки, производители программ все-таки используют определенные стандарты. Например, файлы с расширением DLL являются библиотеками под- рограмм, которые используются в процессе выполнения строго определеных функций. Яркий пример — сама операционная система, другой пример может составить практически любая современная игра, хотя именно в играх асто используются нестандартные расширения файлов — то ли для защиты г взлома, то ли просто по прихоти производителя.

Все программы, которые только можно встретить, объединены единым термином — программное обеспечение.

Про компьютерные игры следует сделать только лишь одно отступление — все они представляют собой самые обыкновенные программы, цель которых эеспечить хороший досуг с применением компьютера.


Что такое дистрибутив программы ( игры )?

Программное обеспечение распространяется (от производителя к пользователю) на компакт-дисках, гибких дисках, а также посредством глобальной сети Интернет, что позволяет в итоге сохранять его на любой тип носителя, программы распространяются в виде программного пакета, который, как завило, содержит помимо непосредственно самой программы все дополнительные модули, необходимые для ее работы, а также текстовые, графичесие и мультимедийные файлы, необходимые (по мнению разработчиков) w изучения основных функций программы.

Программы могут распространяться в трех вариантах:

  • в виде отдельного файла с расширением ЕХЕ, СОМ или ВАТ (также CMD для Windows XP ). Обычно такие программы выполняют различные обслуживающие функции и обладают простым интерфейсом, например, NDD ( Norton Disk Doctor );
  • в виде архива, в котором содержатся все необходимые для работы про фаммы файлы. В таком виде в основном распространяются профаммы, работающие в MS - DOS , а также профаммы, работающие в Windows , но не требующие установки;
  • в виде запакованного файла или набора файлов, который может распако вываться в автоматическом режиме, задавая при этом наводящие вопросы вроде указания каталога, куда следует устанавливать программу и т. п. Иногда в таком же виде распространяются профаммы, работающие в MS - DOS , хотя это изначально удел тех программ, которые требуют для своей работы Windows .

Последний вариант имеет название "дистрибутивный комплект/пакет" или просто "дистрибутив". Получается, что, покупая компакт-диск с дистрибу тивом программы, вы приобретаете полуфабрикат, требующий определен ных действий, чтобы получить работоспособную профамму. Процесс этот называют установкой программного обеспечения, или, по-другому, инсталля цией. Установка программы осуществляется под управлением специальной программы {инсталлятора), которая обычно входит в комплект дистрибути ва и запускается из файла SETUP . EXE или INSTALL . EXE .

Игровые профаммы отличаются от любых других в первую очередь тем, что файлы, которые необходимы для их работы, занимают преимущественно большие объемы (не менее одного компакт-диска), что сильно замедляет их инсталляцию.


Разновидности программ

Все программы можно разделить на следующие разновидности:

  • прикладные программы — применяются для расширения возможностей операционной системы (компьютера). Яркий пример — пакет программ Microsoft Office , позволяющий работать с таблицами данных, более ши роким набором шрифтов, вставлять в текст графику и многое другое;
  • системные программы — их еще называют утилитами. Они предназначе ны для обслуживания операционной системы. Например, это программы для проверки файловой системы жесткого диска или системного реестра. Яркий пример — программа для проверки жесткого диска ScanDisk ;
  • программы-оболочки — это профаммы, используемые для облегчения ра боты с другими профаммами. Яркий пример — программа автозапуска на компакт-диске или оболочка, запускаемая при старте Norton SystemWorks . Сами по себе эти программы не выполняют никаких полез ных функций.


Процесс установки программ и игр

Проблема номер один при установке программного обеспечения — найти файл, при помощи которого запускается процесс установки. Конечно, если вы скачиваете файл из Интернета, то никаких особых проблем быть не должно. Обычно исполняемый файл в скаченных архивах всего один. Но вот если вы хотите установить программу с компакт-диска с целой кол лекцией программ, то здесь может возникнуть множество различных про блем. Например, существует несколько каталогов с названием, весьма похо жим на название программы, которую вы хотите установить и т. д. В этом случае вам остается только лишь надеяться на возможности той программы, которая автоматически запускается при установке компакт-диска в привод. Если программа автозапуска не запустилась самостоятельно по каким-то причинам, можно ее запустить вручную. Откройте файл AUTORUN . INF , который можно найти в корневом каталоге компакт-диска, напротив слова OPEN будет указано имя и путь к программе, которая должна была запус титься автоматически. С другой стороны, вы можете обойтись и без этой программы. Часто на сборниках программ (в том числе игровых) помещают текстовый файл или несколько текстовых файлов, в которых вы можете найти краткое описание каждой программы, а главное, какой файл какой из программ (игр) соответствует. Как правило, процесс установки запускается при помощи файла с именем AUTORUN , SETUP или INSTALL . Расшире ние этого файла естественно должно быть ЕХЕ.

Для успешной инсталляции любой программы требуется соблюдение сле дующих условий:

  • диск, на который будет осуществляться инсталляция программы, должен быть доступен для записи — часто встречается ситуация, когда программа установки "по умолчанию" предлагает установить программу на компакт- диск. По вполне естественным причинам это невозможно, поэтому создается впечатление того, что диск записан неправильно и т. п. Но доста точно вручную выбрать другой диск, как установка будет начата и завершена успешно;
  • на диске, на котором "по умолчанию" располагаются временные файлы, должно быть достаточно свободного пространства, в противном случае установка может прекратиться с сообщением об ошибке. И естественно, места должно хватать еще и на программные файлы, которые останутся после окончания установки. Часть программ, что часто встречается среди игровых программ, перед установкой проверяют наличие необходимого пространства, но они редко учитывают, что на диске еще нужно место под временные файлы.

Процесс установки может быть сильно замедлен, если компакт-диск с дист рибутивом программы поцарапан или привод плохо читает диски. В этом случае лучше всего предварительно скопировать дистрибутив на жесткий диск, а после этого запустить программу установки. Правда, при этом требу ется значительно больше свободного пространства, чем при обычной уста новке.

Обратите внимание на то , что устанавливаемые программы могут вносить изменения в системные файлы операционной системы . Никто , кроме производителя программного обеспечения , не может дать гарантии , что соблюдены все требования , предъявляемые компанией Microsoft . Фактически , мы вынуждены доверять производителям программ , что в принципе само по себе не несет никакой угрозы . Единственный фактор , который смущает в этой ситуации , — ог ромное количество пиратских версий программ , которые не известным для нас образом были " обработаны " и , возможно , имеют ряд серьезных и неустрани мых ошибок . Как заявила однажды компания Microsoft — все программы , напи санные не специалистами нашей компании , в какой - то мере несовместимы с операционными системами Windows .

Здесь мы сталкиваемся с очень серьезной проблемой. С одной стороны, опе рационная система должна каким-то образом защищать свои системные фай лы от посягательств любых программ. С другой стороны, существует немалое количество очень полезных программ, написанных любителями, и которые, как правило, не придерживаются тех или иных стандартов Microsoft .

Наиболее удачно эта проблема решена в Windows XP . В ней все системные файлы защищены от замены или удаления, в то время как программы могут использовать собственные версии некоторых файлов, причем подмена дела ется на виртуальном уровне, т. к. все остальные программы могут свободно использовать оригинальные системные файлы.

В операционных системах Windows 9 x вам придется самостоятельно решать, стоит ли заменять тот или иной системный файл. С одной стороны, файл может иметь более раннюю версию, которая в дальнейшем будет некоррект но работать с операционной системой или какой-либо одной программой (рядом программ). С другой стороны, та программа, которую вы устанавли ваете, может работать некорректно со стандартным файлом, имеющимся в операционной системе. Остается только выбирать между тем, что вы смо жете использовать пусть старую, но нужную программу в ущерб тем же компьютерным играм, и тем, что вы не сможете использовать эту програм му, зато от души наиграетесь в компьютерные игры. Стоит отметить, что для любой программы сегодня можно найти либо обновление, позволяющее ей работать в новых условиях, либо просто новую версию, в которой данный недостаток устранен.

Существует целый класс программ, которые позволяют следить за измене ниями, происходящими в процессе установки программного обеспечения. Такие программы способны контролировать не только заменяемые и созда

ваемые файлы, но и ссылки, вносимые в системный реестр и другие кон фигурационные файлы.

В Windows 2000 при установке часто встречается следующая ситуация: ин дикатор инсталляции доходит до 99% и останавливается. При этом компью тер не зависает, но и программа не устанавливается. Причина проблемы в длинном пути к каталогу с временными файлами. Используйте каталог C :\ Temp и не будете знать проблем. Хотя иногда проблема заключается в том, что профамма устанавливается под профилем пользователя, имя которого состоит из русских символов.

Очень часто пользователи задают имена учетных записей русскими симво лами, что приводит к сбоям при установке некоторых программ, некорректно работающих с кириллицей. Дело в том, что при установке многие про фаммы предлагают задать имя пользователя и при этом автоматически вводят имя учетной записи (иногда имя компьютера). Если заменить это имя на другое, состоящее из латинских символов или цифр, то проблема будет исчерпана.

Некоторые из программ, созданные за рубежом, не могут быть установлены из каталога, имя которого состоит из русских символов. Для устранения этой проблемы нужно переименовать каталог или скопировать дистрибутив в каталог, имя которого состоит из латинских символов..

Нередко дистрибутив профаммы помещают в самораспаковывающийся ар хив, что позволяет несколько уменьшить объем, занимаемый дистрибути вом, но привносит в процесс установки программы ряд проблем. Яркий пример — если имя инсталлятора совпадает с именем самораспаковываю щегося архива, то после его запуска система входит в цикл постоянной рас паковки архива. Как только будет исчерпана память, компьютер либо зависнет, либо резко замедлит свою работу, что, в общем-то, почти равнозначно. Такой особенностью обладают в первую очередь архивы формата ZIP , не зависимо от того, какой профаммой они были созданы.


Особенности установки программ MS - DOS

Установка программ, работающих в MS - DOS , зачастую оказывается намного проще, чем установка программ, работающих в Windows .

Обычно процесс установки состоит в том, чтобы запустить файл INSTALL . EXE с гибкого диска или компакт-диска. Удобнее запускать про- фамму установки в окне эмуляции MS - DOS . В процессе установки копи руемые файлы нигде не фиксируются, что позволяет впоследствии удалить каталог вручную.

Стоит отметить, что при установке любых профамм, работающих в MS - DOS , никаких ярлыков на рабочем столе и в меню Пуск не создается, поэтому придется создать их самостоятельно.


Чем грозит установка каждой новой программы ?

Устанавливая очередную программу, вы думаете, что сможете беспрепятст венно ее удалить в любой момент? Ваша наивность просто изумляет, хотя давайте по порядку.

В основе архитектуры Windows лежит принцип совместного использования ресурсов. Каждая программа во время своей работы выполняет множество операций, многие из которых являются практически стандартными (напри мер, создание нового каталога). Включать модули, ответственные за выполнение этих вот "стандартных" операций, в каждую программу крайне нерацио нально, т. к. от этого резко возрастает размер дискового пространства, занимаемый программными файлами. Поэтому любые мало-мальски стандартные функции выполняются посредством системных файлов операцион ной системы, хотя устанавливаемые программы некоторые модули все-таки копируют на диск. Обычно это происходит в тех случаях, когда для работы программы необходим обновленный системный файл, в то время как со стан дартным файлом эта программа работать не сможет. Особенно это заметно на примере ифовых программ и драйверов DirectX , которые очень тесно взаимо связаны друг с другом. Многие компьютерные ифы для своей работы используют стандартные модули драйверов DirectX , в то время как для нормальной работы некоторых иф требуется обновление версии этих драйверов.

На практике принцип использования общих ресурсов выглядит следующим образом. При установке любая программа проверяет доступность необходи мых программных ресурсов и при отсутствии некоторых из них копирует недостающие файлы. После вы устанавливаете другую программу, которая аналогичным образом проверяет, все ли программные ресурсы доступны, причем учитываются уже и те ресурсы, которые были установлены с первой программой. Так постепенно при установке все более новых программ ко личество общих ресурсов в операционной системе увеличивается, а взаимо связь установленного программного обеспечения становится более сложной.

Проблемы возникают, когда какая-либо программа при установке один из ресурсов меняет на новую версию, необходимую для ее работы. При этом не учитывается тот факт, что одна или несколько из установленных программ могут отказаться работать с новой версией определенного файла или начнут работать некорректно.

Еще сложнее ситуация обстоит с удалением программ. Если удалить одну из программ вместе с теми ресурсами, которые устанавливались вместе с ней, то можно привести к полной неработоспособности другие программы, кото рые использовали для своей работы удаленные файлы. В этом случае остается единственный вариант возвращения работоспособности таких программ — это их переустановка, которая позволит восстановить все утерянные ресурсы

Существует ряд правил, придерживаясь которых вы сможете уменьшить шансы появления сбоев операционной системы в результате некорректной установки или же некорректной работы одной из установленных вами программ:

  • старайтесь не устанавливать программы, которые предназначены для ра
    боты в MS - DOS или Windows 3.11. Они не предназначены для работы
    в многозадачной среде, поэтому могут нарушать работу других программ;
  • обязательно сохраняйте дистрибутивы всех устанавливаемых программ.
    Иногда корректное удаление программы невозможно без доступа к ее ди
    стрибутиву. Тем более, что это поможет в дальнейшем переустановить
    программу в случае, если она стала работать со сбоями;
  • рекомендуется устанавливать все программы в каталоги, в которых не имеется никаких важных файлов (документов, рисунков и т. п.). При удалении может встретиться ситуация, когда программа при деинсталля ции самостоятельно, без дополнительных запросов, удаляет каталог, который использовался для хранения программных файлов, в то время как некоторые программы сохраняют документы именно в каталоге с про- граммными файлами.


Пиратские и лицензионные программы

Как многие уже наслышаны, существует два типа программ: лицензионные и, более многочисленный тип, — пиратские. Давайте рассмотрим различия между программами обеих категорий.

Лицензионное программное обеспечение отличается в первую очередь тем, что за его использование надо платить (иногда очень большие деньги). Ко нечно, хакеры могут сломать любую защиту, но это приводит к некоторым неприятным последствиям, самое безобидное из которых — это отсутствие технической поддержки и отсутствие любого рода обновлений программы.

Лицензионные программы могут иметь разнообразные ограничения, например:

  • ограничение на количество запусков или количество часов непрерывной работы. Яркий пример — программа FineReader;
  • отключение в бесплатной версии некоторых, иногда очень важных, функций. При этом встречаются программы, которые вполне можно ис пользовать даже в таком "обрезанном" виде, например, Venta Fax ;
  • невозможность установки программы или отдельных ее компонентов без ввода серийного номера и других регистрационных данных.

Пиратское программное обеспечение, в первую очередь, отличается от ли цензионного тем, что за него не надо платить. Точнее, достаточно купить компакт-диск с набором программ или скачать дистрибутив из Интернета.

При этом к программе прилагается специальный файл, который позволяет сгенерировать серийный номер или который отключает проверку наличия лицензии (серийного номера и т. п.). Во втором случае в исполняемый файл вносятся изменения, которые не всегда осуществляются вполне корректно. То есть после того как вы "сломали" защиту программы, никто не может (дать вам гарантию, что все функции программы будут работать без сбоев.

Наиболее оптимальным является ввод серийного номера, который однажды получен кем-то после покупки программы. В этом случае вам придется так же ввести и имя, а также другие данные, принадлежащие этому "зарегистри рованному" пользователю. Иногда такой серийный номер просто-напросто подбирают при помощи специальных программ. В этом случае возможно, что к дистрибутиву программы прилагается генератор серийных номеров.

В итоге можно вывести несколько "подтипов" пиратских программ. Бес платность программ преимущественно достигается следующими способами:

  • вводом заранее известного серийного номера, иногда и других данных. Такой способ является наиболее безопасным методом "взлома", т. к. в программе ничего не меняется и она работает точно так же, как и офи циально купленная версия;
  • удалением из программного кода функции проверки правильности се рийного номера, после чего достаточно ввести любой номер. Такой спо соб применяется в программах, содержащих подпрограмму проверки се рийного номера по так называемому "черному списку", в который внесены самые распространенные "левые" номера. В этом случае в программу вносятся изменения, после которых достаточно сложно гарантировать бессбойную работу программы;
  • копированием в рабочий каталог заранее созданный кем-нибудь файл лицензии. Такой способ применяется зачастую для программ, работаю щих в MS - DOS . В этом случае никаких изменений в программу не вно сится, поэтому программа работает точно так же, как и ее официальная версия;
  • удалением из программного кода функции проверки наличия файла ли цензии. Такой способ применяется зачастую для программ, работающих в MS - DOS . В этом случае в программу вносятся изменения, после кото рых достаточно сложно гарантировать бессбойную работу программы;
  • удалением из программного кода функции проверки количества запус ков, что позволяет длительное время использовать программы, имеющие ограничение на количество запусков. Тот же подход используется и в программах с офаничением на количество часов (дней) непрерывной работы. В этом случае в программу вносятся изменения, после которых достаточно сложно гарантировать бессбойную работу программы.

Какие программы использовать, решать только вам, но имеется несколько вопросов, которые нельзя не отразить в этой книге.

  1. 1. Тот, кто взломал программу, не может гарантировать ее бессбойную ра боту в любых условиях, поэтому именно у вас программа может дать серьезный сбой. Естественно, что никто не возьмет на себя ответствен ность за последствия этого сбоя.
  2. 2. Пиратские версии программ невозможно официально обновить, что осо бенно чревато при применении их для бухгалтерского учета. В результате, элементарная проблема способна обратиться в сущий кошмар. Так, на пример, было при переходе на новую форму платежного поручения — все официальные версии программ обновлялись в основном бесплатно, тогда как владельцы "бесплатных" версий только успевали хрустеть купю рами за каждое мелкое обновление.
  3. 3. К пиратскому программному обеспечению не прилагается никакого руко водства по эксплуатации, что несколько усложняет освоение программы.
  4. 4. Вместе с "бесплатной" версией программы вы можете получить новей ший вирус, который будет собирать всю ценную информацию и отсылать ее на электронный ящик хакера, взломавшего ее .


Глава 11. Настройка программ и игр

  • Готовы ли вы самостоятельно настроить любую программу?
  • В чем заключается процесс настройки программ (игр)?
  • Установка дополнительных программ и компонентов операционной системы
  • Перенос программ на другой компьютер
  • "Обнуление" настроек программ
  • Особенности программ (игр) под MS-DOS


Готовы ли вы самостоятельно настроить любую программу ?

Самая большая проблема, с которой сталкиваются начинающие, да и не только, пользователи, — это нежелание разбираться в причинах того, что программа так и не запустилась или что программа работает совсем не так, как у друга (коллеги, соседа). Подавляющее большинство таких вот владельцев компьютеров начинает винить во всем компанию, где они купили ком пьютер, — мол, продали им плохой компьютер, который не хочет работать (вроде как у соседа такая же конфигурация и у него все работает без проблем). На это можно ответить лишь одно: "Требуется сменить ... между компьюте ром и стулом". Если вы не умеете пользоваться ни операционной системой, ни программами, которые вы устанавливаете (в том числе игровыми), то и будет регулярно складываться впечатление, что компьютер работает как-то не так.

Поэтому самое главное правило, которого вы должны придерживаться при работе на компьютере, — больше читайте. Особое внимание обратите на следующие источники информации:

  • текстовые файлы, прилагаемые к дистрибутиву программы;
  • текстовые файлы, на которые имеются ссылки в группе программы в ме
    ню Пуск;
  • файлы помощи, к которым можно получить доступ нажатием клавиши < Fl > сразу же после первого запуска программы;
  • некоторые программы при первом запуске самостоятельно предлагают почитать самые "злободневные" советы по ее эксплуатации, не торопитесь закрывать окно с этой справкой;
  • различные FAQ (ответы на часто задаваемые вопросы), которые можно найти в Интернете. Вполне достаточно, например, в поисковой системе Hndex набрать в окне запроса название программы, а затем "в найден ном" найти "описание".

Не пугайтесь англоязычных источников. Иногда достаточно перевести пару строк, в которых объясняется, как устранить проблему, чтобы заставить ра ботать программу.


В чем заключается процесс настройки программ ( игр )?

Практически любая программа (в том числе игровая) нуждается в предвари тельной настройке, без которой она либо вообще не будет работать, либо результаты работы могут оказаться не совсем такими, как ожидает пользователь.

Часть настроек осуществляется при инсталляции программы — указывается рабочий каталог программы, на рабочем столе и в меню Пуск создаются все необходимые ярлыки и т. д. Иногда при этом сразу указываются каталоги для временных файлов, для сохранения проектов и прочее.

Программы могут хранить свои настройки в двух видах — в виде ключей системного реестра и в виде текстового файла с расширением INI .

Несмотря на то, что использование для сохранения настроек INI -файлов является несколько архаичным, этот способ обладает рядом преимуществ.

  • Файл INI , в отличие от системного реестра, легко отредактировать вруч
    ную при помощи редактора Блокнот, причем начинающему пользовате
    лю намного проще разобраться в обычном текстовом файле, чем в реест
    ре со сложной иерархической структурой.
  • В отличие от системного реестра, INI -файл проще заархивировать, а за
    тем и восстановить из резервной копии, что можно использовать в слу
    чаях, когда настройка представляет собой довольно сложный процесс,
    а переустанавливать программу приходится регулярно.
  • При редактировании INI -файла вы меняете настройки только одной
    программы, в то время как при редактировании системного реестра мож
    но также нарушить и настройки самой операционной системы.
  • После удаления программы без применения модуля деинсталляции
    в системном реестре не остается ошибочных ссылок.


Установка дополнительных программ и компонентов операционной системы

В последнее время все чаще встречаются программы, которые для своей нормальной работы требуют установки дополнительных компонентов операционной системы, а то и целых программ. Причина этого скрывается в том, что эти программы создаются в расчете на самые современные операционные системы ( Windows XP и выше), в то время как пользователи продолжают применять предыдущие версии.

Наиболее часто обновляемый компонент операционной системы — мульти медийные драйверы под названием DirectX . Они успевают устаревать иногда даже раньше, чем выходит в свет очередная версия операционной системы. Так, например, произошло с Windows XP . В нее интегрированы драйверы DirectX версии 8.1, тогда как почти все современные игровые программы требуют для своей работы версию не ниже 9.0. Именно поэтому на компакт-дисках очень часто встречается дистрибутив драйверов DirectX , чтобы поль зователь, независимо от версии установленной у него операционной системы, мог играть именно в ту игру, которая находится на компакт-диске.

Естественно, что после установки новейшей версии DirectX , например 9.0 или выше, больше не понадобится их устанавливать, особенно если игра требует установки для своей работы более старой версии (8.1 и ниже).

Стоит отметить одну особенность дистрибутива DirectX . Он распространяет ся в двух вариантах. Первый из них предназначен для простого обновления всех предыдущих версий, а вот второй перед обновлением сначала удаляет все старые файлы, которые были установлены до него, а уже затем копирует на их место новые версии этих же самых файлов. Таким образом, достигается полное отсутствие конфликтов версий файлов от разных пакетов DirectX , но здесь можно попасть в неприятную ситуацию. Например, если у вас была установлена версия 9.0 и вы случайно запустили инсталляцию одной из старых версий, то вам остается только уповать на то, чтобы дистрибутив был именно первого типа и после проверки версии DirectX установка будет за вершена. Во втором случае версия 9.0 будет удалена и на ее место записана та самая версия, к которой и принадлежит дистрибутив. Поэтому будьте чрезвычайно внимательны при установке игровых программ. Второй тип дистрибутива DirectX можно узнать по приставке REDIST , которая обычно имеется в имени дистрибутива.

Второй по счету компонент операционной системы, который регулярно тре бует обновления, — это Internet Explorer . Так, например, Norton System - Works для работы требует версию не ниже 6.0, которая "по умолчанию" ус танавливается только вместе с Windows XP , в то время как во всех предыдущих версиях требуется предварительно установить его.

Некоторые программы, как правило, те, которые разработаны компанией Microsoft , самостоятельно определяют необходимость установки обновлений и самостоятельно же их и устанавливают. Яркий пример — пакет Microsoft Office XP.


Перенос программ на другой компьютер

Многим пользователям интересен вопрос переноса программ на другой компьютер. Конечно, намного проще найти дистрибутив программы и уста новить его, но иногда это связано с излишними сложностями, например с вводом идентичных настроек. Из-за этого очень часто практикуют обычное копирование по локальной сети или при помощи дополнительного винче стера (компакт-диска).

На практике могут встретиться программы следующих типов:

  • программы, которые используют для хранения своих настроек один INI - файл — в этом случае при копировании рабочего каталога программы с компьютера на компьютер сохранятся все ее настройки;
  • программы, которые используют для хранения настроек несколько INI - файлов — чаще всего встречается ситуация, когда отдельный файл может отвечать за одни функции программы, в то время как другой файл может отвечать за совершенно другие. Например, в программе Total Commander отдельный INI -файл отвечает за настройки FTP -соединений. При копи ровании программы на другой компьютер все настройки обычно сохра няются, но только если программа не использует для своей работы также еще и ключи системного реестра;
  • программы, которые используют для хранения настроек системный ре естр, — в этом случае возможны два варианта. В первом случае вы не можете скопировать программу на другой компьютер, т. к. она жестко "привязана" к ключам реестра, а во втором случае при первом запуске программы все на стройки будут приведены к первоначальным значениям, устанавливаемым "по умолчанию" (яркий пример — почтовая программа The Bat !);
  • программы, которые используют для хранения настроек как системный ре естр, так и INI -файлы, — в этом случае копирование программы на другой компьютер может привести к непредсказуемым последствиям. Все зависит от того, какие из настроек и для чего программа использует. Если, например, ключи реестра нужны для определения, зарегистрирована ли программа, то на другом компьютере она потребует повторной регистрации.

Следует учитывать, что нередко INI -файлы с настройками программы со держатся в рабочем каталоге Windows (например, Opera сохраняет свои на стройки в файле opera . ini ). Иногда достаточно переместить их в рабочий каталог самой программы, но встречаются случаи, когда приходится сохранять расположение файлов настройки, для чего следует на другом компьютере скопировать их в то же каталог, в каком они находились на первом компьютере. То же самое относится и к другим дополнительным модулям (файлам), которые "по умолчанию" копируются в рабочий каталог Windows , но вполне могут использоваться и из рабочего каталога самой программы.


" Обнуление " настроек программ

Иногда возникает необходимость "обнуления" настроек программы, чтобы начать ее настройку "с нуля".

Намного проще "обнулить" настройки программы, если все они хранятся в INI -файле. Для этого достаточно удалить соответствующий файл, после

чего программа создаст новый файл с настройками "по умолчанию". Правда, некоторые программы не могут этого делать, и их приходится переустанав ливать или вручную копировать нужный файл из дистрибутива в рабочий каталог программы.

Стоит отметить, что нередко помогает простая переустановка программы "поверх" старой копии. При этом сохраняются все пользовательские файлы, а настроечные файлы затираются.


Особенности программ ( игр ) под MS - DOS

Практически все программы, работающие в среде MS - DOS , используют принтеры "по умолчанию", поэтому для них очень важно, какой принтер установлен "первым". Главное, чтобы это был принтер, поддерживающий печать из окна эмуляции MS - DOS .

Любые программы, использующие звуковую плату, а это преимущественно игровые программы, требуют после установки ручную настройку. При этом вы указываете все параметры, которые используются звуковой платой, — прерывание, каналы DMA и т. д. Конечно, существуют программы, в кото рых имеется функция AutoDetect , но это скорее исключение, чем правило.


Глава 12. Удаление программ и игр

  • Удаление программ и игр
  • FAQ (ответы на часто задаваемые вопросы)


Удаление программ и игр

Как вы удаляете программы, которые вам больше не нужны? Просто поме щаете в Корзину рабочий каталог программы, а следом и ярлыки с рабочего стола и из меню Пуск? А после этого удивляетесь появлению разнообразных ошибок, возникающих, например, при установке более новых версий этой программы? Давайте разберемся в этом вопросе более подробно.

Удаление программ (в том числе игр) во всех версиях операционных систем Windows представляет собой удаление программных файлов, которые были установлены в процессе инсталляции, удаление всех автоматически создан ных ярлыков и ключей в системном реестре. Тонкости деинсталляции (так часто называют процесс удаления) зависят от конкретной программы и мо гут сильно отличаться.

Для корректного удаления программ (в том числе игровых) требуется наличие так называемого модуля деинсталляции, который последовательно уда ляет как файлы, так и ссылки на них в системном реестре, а также ярлыки, которые были созданы при установке программы. Здесь имеется один ню анс — все файлы, созданные самим пользователем уже после окончания ин сталляции, как правило, не удаляются. Конечно, некоторые программы имеют достаточно "продвинутые" деинсталляторы, предлагающие вам пол ностью удалить каталог, в котором были размещены файлы программы, но это скорее исключение, чем правило. Следует отметить, что данный модуль должен устанавливаться вместе с программой, в противном случае система будет пытаться применить стандартные средства удаления.

При отсутствии деинсталлятора или одного из файлов, необходимых для его работы, можно воспользоваться деинсталлятором стороннего поставщика, например, Norton CleanSweep компании Symantec . Правда, и здесь имеется один, но немаловажный фактор — англоязычный интерфейс этих программ сильно затрудняет использование их рядовым пользователем.

В большинстве случаев процесс деинсталляции программ (игр) выглядит следующим образом:

  • открываете в меню Пуск раздел, принадлежащий программе, которая подлежит удалению, например, Пуск | Программы | K - Lite Codec Pack .
  • Если программа имеет собственный деинсталлятор, тогда в этом разделе должен находиться файл под названием Uninstall K - Lite Codec Pack . Ес тественно, что этот пункт может иметь несколько иное название, напри мер, Удаление программы, но он должен там присутствовать; ? если вы не можете найти ярлык, запускающий программу деинсталля ции, тогда можно прибегнуть к одному из нижеследующих способов:
    • откройте каталог, в котором содержатся файлы программы, и найдите
      файл под названием UNWISE . EXE или UNINSTALL . EXE . Это и есть
      программа деинсталляции, при этом называться она может немного
      по-другому, хотя, как правило, в названии обязательно присутствует
      приставка " UN ";
    • откройте Панель управления и запустите ярлык Установка и удаление
      программ. Найдите в открывшемся списке нужную программу и на жмите кнопку Заменить/Удалить. При этом запустится деинсталлятор, который идет в комплекте с программой, а за отсутствием такового — применяются стандартные средства удаления программ;
  • как уже упоминалось, пользовательские файлы при деинсталляции не уда ляются, в основном, потому, что программа-деинсталлятор работает со гласно LOG -файлу, создаваемому при установке программы. Поэтому по окончании деинсталляции рекомендуется найти рабочий каталог профам- мы и вручную удалить его. Чтобы узнать расположение этого каталога, щелкните правой кнопкой мыши по ярлыку программы (еще до деинстал ляции) и в свойствах посмотрите, где располагается запускаемый файл. Стоит отметить, что упомянутый LOG -файл может размещаться в неожи данных местах, например, в корневом каталоге или рабочем каталоге Windows . При этом установка другой программы, использующей этот же путь для записи списка установленных файлов, приведет к его перезаписи и, как правило, невозможности удаления той программы, которая бы ла установлена первой.
  • Нередко LOG -файл помещается в каталоге TEMP вместе с временными файлами и при первой же очистке жесткого диска удаляется;
  • после деинсталляции обязательно откройте Панель управления, с которой запустите ярлык Установка и удаление программ. Довольно часто бывает так, что запись уже удаленной программы остается в списке установлен ных программ, поэтому вам придется либо запустить повторно деинстал ляцию, причем вам должны уже предложить удалить ошибочную запись из реестра, либо вручную редактировать системный реестр. Запустите утилиту REGEDIT и зайдите в следующую ветвь реестра: HKEY _ LOCAL _ MACHINE \ SOFTWARE \ MICROSOFT \ WINDOWS \ CunBntVersion \ Uninstall . Здесь вы можете удалить любой из пунктов списка установленных программ, даже тех, которые еще установлены на компьютере. Правда, если вы это сделаете, программа может после перезагрузки операционной сис темы не запуститься и придется ее переустановить;
  • при деинсталляции могут возникнуть ошибки из-за ошибки в реестре, отсут ствия одного или нескольких файлов, подлежащих удалению, и т. п. Это требует применения либо ручной корректировки системного реестра, либо использования специальных программ деинсталляции/очистки реестра.

Практически все проблемы, связанные с удалением программ, можно пере числить следующим образом:

  • программа деинсталляции требует указать путь к LOG -файлу (может иметь название INSTALL . LOG ), при этом по умолчанию указывается либо корневой каталог, либо рабочий каталог Windows . Скорее всего, этот файл уже удален.
  • В данной ситуации вам может помочь переустановка данной программы в тот же каталог, после чего уже можно беспрепятственно удалить его. При отсутствии дистрибутива программы вам остается только лишь уда лить ее рабочий каталог и попытаться вручную удалить из системного реестра ссылки на нее. Хотя и здесь существует немаловажный нюанс. Те программы, которые так жестко привязаны к текстовым файлам, очень часто не делают ссылок в реестре или делают крайне небольшое их количество;
  • программа деинсталляции требует указать путь к дистрибутиву програм мы, при этом иногда недостаточно указать каталог, размещенный где-то на жестком диске, а потребуется воспользоваться компакт-диском, с ко торого была произведена ее установка.
  • Далеко не всегда удается удалить программу даже после установки компакт-диска, с которого вы ее устанавливали. Дело в том, что подав ляющая часть программ устанавливается с пиратских дисков, а програм ма-деинсталлятор требует от вас указать путь к лицензионному диску, на котором, как можно предположить, содержатся некие файлы или метки, которые очень "важны" для программы-деинсталлятора.
  • В этом случае вам может помочь только приобретение хотя бы "точной копии лицензионного диска", или же придется вручную очищать компьютер от остатков программы. Наиболее яркий пример — Prompt 98, ко торый, несмотря на все свои достоинства, никак не хотел нормально уда ляться, пока не был поменян на новую, более "сговорчивую" версию;
  • программа деинсталляции спрашивает, удалять ли файлы, при этом указы вается путь к ним. В этом случае рекомендуется оставлять все файлы, ко торые находятся в рабочем каталоге Windows или в одном из его подкаталогов. Те же файлы, что размешены в рабочем каталоге самой программы, можно смело удалять, ведь его (имеется в виду рабочий каталог) также впоследствии стоит удалить, в противном случае после удаления самих файлов останутся теперь уже ошибочные записи в системном

Приведу список программ, которые можно использовать для управления процессом деинсталляции и очистки системного реестра после некоррект ного удаления любых программ:

  • Norton Clean Sweep, http://www.symantec.com/;
  • Norton Uninstall/Norton Uninstall Deluxe, http://www.symantec.com/;
  • Ashampoo Uninstaller, http://www.ashampoo.com/;
  • Ontrack EasyUninstall, http://www.ontrack.com/;
  • McAffee Uninstaller, http://www.mcafee.com/.

Примечание
Никогда не полагайтесь на функции автоматической очистки жесткого диска или системного реестра . Помимо удаления , например игровой программы , деинсталлятор вполне может удалить и половину ценной информации , которая оказалась по ряду причин связанной с удаляемой программой . Например , в рабочем каталоге программы могут находиться ярлыки файлов с ценной для вас информацией .

Существует еще целый ряд программ-очистителей, которые в той или иной мере обладают следующими возможностями:

  • корректная деинсталляция возможна только тех программ, которые уста
    новлены уже после самой программы-деинсталлятара, т. к. в противном
    случае ни одна из программ не сможет восстановить исходные значения
    ключей реестра, а простое удаление ссылки может привести к сбоям
    в работе операционной системы;
  • определение неиспользуемых DLL -файлов, расположенных в рабочем
    каталоге Windows . При этом некоторые (например, Clean System
    Directory ) ищут связи файлов не только в файлах с расширением ЕХЕ,
    DLL , OCX , но и в документах, файлах HTML и т. п.;
  • поиск и удаление ошибочных ключей системного реестра.


FAQ ( ответы на часто задаваемые вопросы )

Вопрос: Хотел удалить ненужные компоненты Windows 2000/ XP , но при за пуске ярлыка Установка и удаление программ не смог найти полного списка программ, которые устанавливаются вместе с операционной системой, как это было раньше, в Windows 98. Как их удалить?

Ответ: Найдите файл SYSOC . INF , который должен располагаться в рабочем каталоге Windows в подкаталоге INF , и откройте его любым текстовым ре дактором. Удалите везде слово HIDE (возможно, оно будет написано строчными буквами), при этом можно воспользоваться автоматической заменой. После сохранения изменений вновь откройте Панель управления | Установка и удаление программ | Компоненты Windows , где вы и найдете теперь уже все установленные программы.


Глава 13. Работа с файлами и каталогами

  • Файловая система
  • Типы файлов и каталогов
  • Файловые менеджеры
  • Поиск файлов и каталогов
  • Куда девается свободное место на диске?
  • Удаление файлов и каталогов
  • Архивация данных и программы сжатия
  • Восстановление файлов и каталогов
  • FAQ (ответы на часто задаваемые вопросы)


Файловая система

Чтобы упростить работу с дисками, их поверхность разбивается на кластеры, которые, в зависимости от используемой файловой системы и объема диска, могут иметь разный объем. От размера кластера зачастую зависит эффек тивность работы ПК.

В настоящее время используются файловые системы FAT 16 (для записи ад реса размещения файлов используется 16 бит), FAT 32 (32 бита) и NTFS .

Если вы используете файловую систему NTFS , будьте готовы к тому, что некоторые каталоги, особенно те, в которых находится много мелких фай лов (например, каталог SYSTEM в рабочем каталоге Windows ), будут откры ваться с некоторой задержкой. Дело в том, что время от времени операци онная система обновляет метку последнего доступа к файлам, а во время просмотра большого количества файлов содержимое LOG -файла, в котором содержится информация о проведенных операциях, сохраняется на жесткий диск, что приводит к замедлению работы ПК.

Чтобы отключить функцию обновления метки, следует внести в системный реестр некоторые изменения:

  • запустите редактор реестра;
  • найдите строку: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem;
  • создайте новый параметр DWORD ;
  • имя параметра должно быть NtfsDisableLastAccessUpdate ;
  • значение этого параметра должно быть равно 1 (единица);
  • перезагрузите компьютер.

Как уже упоминалось в главе 8, файловая система является неотъемлемой частью операционной системы.

Основой файловой системы является диск или любой раздел на диске, вы деленный в отдельный логический диск. Каждый диск имеет собственное уникальное название или, как чаще всего говорят, — имя.

Имя диска — буквенное обозначение от А до Z , позволяющее организовать все диски, установленные в компьютере, в единую систему. Имя диска зада ется раз и навсегда, что позволяет избежать конфликта из-за вдруг изме нившегося пути к файлам и каталогам. Считается, что флоппи-дисковод всегда имеет имя А:, второй флоппи-дисковод — букву в = , а все остальные, начиная с с-., отданы в распоряжение жестким дискам, приводам CD - ROM и другим устройствам, подключаемым к шинам SCSI , IDE , USB . Иногда термин "имя диска" путают с термином "метка тома", что не совсем верно, т. к. метка тома является дополнительным идентификатором любого диска, который создается во время форматирования диска, в то время как имя дис ка зависит от типа подключаемого устройства (дисковод, жесткий диск) и способа его подключения.

Другими словами, метка тома является логическим идентификатором, кото рый в любое время можно изменить без какого-либо ущерба для работы компьютера, а имя диска является физическим идентификатором, при из менении которого могут появиться сбои в работе компьютера. Хотя и здесь можно сделать несколько отступлений:

  • как правило, жесткий диск или раздел, с которого происходит загрузка Windows , в любом случае становится диском С:, даже если физически этот диск подключен как второе или третье (четвертое) устройство. Это справедливо для всех версий операционных'систем Windows , кроме ХР. В ней используется несколько другой подход к обозначению дис ков — диски получают имена согласно их физическому подключению, т. е. жесткий диск, подключенный как Primary / Master , будет всегда пер вым (диск С:), даже если загрузка осуществляется с диска Secondary / Master . Такой подход помогает избежать путаницы;
  • для любых устройств со сменными носителями информации, таких как приводы CD - ROM , Iomega ZIP , имя диска может изменяться без особых проблем, т. к. все программы, запускаемые с них, обычно используют "те кущий диск", так что если имя диска меняется с D : на Е:, никаких особых проблем не возникает. Хотя если вы запускаете программы, например, с компакт-диска при помощи ярлыков, тогда будьте готовы, что каждый раз при смене имени диска вам придется изменять их свойства, прописы вая новый путь к программе. От этого недостатка избавлена операционная система Windows XP , где имена дисков назначаются согласно тому, в ка ком порядке они появились в системе, т. е. при подключении нового диска его имя будет состоять из буквы, следующей за буквой привода;
  • если новый подключаемый диск разбит на два и более логических диска, то вам следует обратить внимание на следующую особенность. В операционной системе сначала отображаются все активные разделы всех под ключенных дисков, а уже затем отображаются все остальные разделы в той последовательности, в которой они идут. Так, например, если ранее подключенный диск был разбит на два диска, а подключаемый диск име ет всего один раздел, то в системе эти диски получат следующие имена — активный раздел первого диска получит букву с : , активный раздел второго диска получит букву D :, а уже второй раздел первого диска получит букву Е:. Это может вызвать путаницу, которая может привести либо к случай ному удалению файлов "не с того диска", либо к нарушению работы всех программ, расположенных на втором разделе первого диска, т. к. все ярлы ки будут указывать на диск d : , на котором этих программ просто-напросто нет. Недостаток устранен в операционной системе Windows XP , где все диски получают имена в порядке их подключения к системе;
  • чтобы уменьшить вероятность появления сбоев в работе компьютера, ка ждому из логических дисков рекомендуется задать уникальную метку то ма, которая может предотвратить случайную потерю данных после изме нения структуры имен всех дисков.

Самой маленькой единицей измерения информации в компьютере является файл.

Файл — это совокупность связанных друг с другом записей на носителе, рассматриваемых операционной системой и программами как единое целое. Каждый файл имеет идентификационное имя, расширение и путь доступа к нему. При записи файла ему задаются определенные атрибуты. Это размер, дата создания и изменения, а также такие атрибуты, как:

  • "системный" — атрибут указывает на то, что файл является системным. Наличие этого атрибута в операционных системах Windows может блоки ровать удаление файла, а также его изменение и перемещение в другой каталог, что необходимо для безотказной работы компьютера. Особенно высокий приоритет атрибут имеет в операционных системах Windows 2000/ XP . Иногда для системных файлов даже нельзя изменить атрибуты;
  • "скрытый" — атрибут позволяет прятать некоторые файлы, которые, по мнению пользователя или программ (операционной системы), не должны ни изменяться, ни удаляться, ни перемещаться в другие каталоги. Обыч но используется в паре с предыдущим атрибутом (для системных файлов) или отдельно (для всех других файлов). Иногда использование этого ат рибута приводит к появлению сбоев в работе некоторых программ, кото рые просто-напросто не могут обнаружить файл с атрибутом "скрытый";
  • "архивный" — этот атрибут не имеет особого смысла, он указывает на то, что файл готов к архивации;
  • "только для чтения" — этот атрибут позволяет защитить файл от случай ного или намеренного изменения или удаления, хотя он, конечно, не да ет стопроцентной защиты. Если файл имеет атрибут "только для чтения", то практически любые из существующих программ откажутся сохранять Исклю чением являются все файловые менеджеры, которые сделаны "по образу и подобию" Norton Commander ' a — в них, конечно, будет выведено до полнительное предупреждение, что файл доступен только для чтения, но записать изменения все равно позволят, так что будьте внимательны!

Имя файла — идентификатор файла, состоящий из определенного числа символов на латинском или национальном языке (в том числе цифр). Ограничение на количество символов в имени файла накладывает используемая операционная система.

В операционных системах Windows имя файла может состоять из 255 симво лов как латинского, так и национального алфавита, можно использовать цифры и служебные символы. При этом следует также учитывать следую щие ограничения:

  • среди служебных символов некоторые использовать нельзя. Это — </>, <\>, <:>, <*>, <?>, <">, <<>, <>>, <|>. При попытке ввода этих симво лов система выдаст предупреждение об ошибке, хотя иногда возникают казусы, когда она все-таки "принимает" имя, содержащее один из ука занных символов, после чего файл невозможно ни открыть, ни удалить. Ситуация исправляется при помощи таких программ, как Scan Disk , Norton Disk Doctor и им подобных. Проблема устранена в Windows XP , где запрещенные символы вы просто-напросто не сможете ввести в окно запроса имени файла, либо они автоматически удаляются при вводе имени из буфера обмена;
  • нельзя использовать такие имена файлов, как CON , PRN , NUL , AUX , LPTl , LPT2, LPT 3, LPT 4, COMl , COM2, COM3, COM4, CLOCKS . Эти имена соответствуют именам стандартных аппаратных ресурсов компью тера. Запрет на имена задан, в основном, для совместимости со старыми программами, которые могут неверно среагировать на подобное имя файла и вызвать сбой в работе компьютера;
  • допускается использовать в имени файла пробелы, но некоторые про граммы не совсем корректно обрабатывают их. Это относится в первую очередь к старому программному обеспечению, разработанному для рабо ты в MS - DOS . Подобные ситуации можно "обойти", используя вместо пробела символ подчеркивания <_>. Если вы хотите найти файл, в име ни которого содержатся пробелы, придется взять фразу в кавычки, что позволит избежать проблем с поиском;
  • стоит отметить, что операционная система при подсчете суммарного коли чества символов в имени файла "захватывает" еще и все символы, имеющиеся в пути к каждому файлу. Поэтому если файл располагается в ката логе с очень длинным именем, то длина его имени может оказаться ограниченной. Всего допускается до 260 символов в "полном имени" файла, содержащем как непосредственно его имя, так и все символы пути к нему; операционная система не различает прописные и заглавные символы. Поэтому имена, например, text . txt и ТЕХТ.ТХТ, с точки зрения операци онной системы, совершенно одинаковы;
  • для совместимости с операционными системами MS - DOS и Windows З.хх имя файла состоит из двух частей: "стандартной", используемой также в MS - DOS , и "расширенной", используемой в Windows , начиная с версии 95. Во всех версиях MS - DOS принята так называемая система 8.3, при кото рой имя файла состоит из восьми символов, а расширение из трех сим волов. Если файл создан в Windows , то имя для MS - DOS ("псевдоним") генерируется автоматически. При этом следует иметь в виду, что при на личии файлов с одинаковым псевдонимом используются только шесть первых символов, а последние два меняются на знак <~> и номер файла (например, ADMINI ~1. TXT ). Если файлов со схожими псевдонимами очень много, оставляются только первые две буквы, а остальные шесть символов генерируются. Также стоит отметить, что в MS - DOS крайне не рекомендуется использовать русские символы, корректно отображаться они будут только в окне эмуляции, а в "чистом" MS - DOS , как правило, их нельзя будет ни открыть, ни удалить, ни даже скопировать.

Расширение файла — последовательность символов на латинском или нацио нальном языке, предназначенная для идентификации типа файла. В качест ве стандарта было принято, что расширение всегда состоит только из латин ских символов или цифр, а длина его составляет три символа, хотя операционные системы Windows позволяют использовать большее количество символов, например, четыре. Для совместимости с устаревшими опера ционными системами класса MS - DOS и Windows З.хх следует все-таки при держиваться общепринятых стандартов, тем более что MS - DOS часто используется в качестве основы загрузочных дисков для установки и восста новления других операционных систем.

Путь доступа к файлу — идентификатор, содержащий имя диска и название каталога, в котором содержится файл.

Каталог — это специальный файл, в теле которого содержатся записи, ука зывающие на файлы и подкаталоги, логически находящиеся в данном каталоге. Физическое же размещение файлов никак не связано с их логическим расположением в каталогах и подкаталогах. Во всех IBM -совместимых компьютерах структура каталогов имеет иерархическую структуру, т. е. каждый каталог может содержать в себе еще один или несколько каталогов, которые могут как содержать файлы, так и быть пустыми. Требования к имени ката логов такие же, как и к файлам.

Аналогичными являются термины "директория" и "папка". Первый термин является полным аналогом термина "каталог", а второй термин имеет не сколько расширенный смысл. Например, папкой может считаться любая совокупность служебных ярлыков, которая физически не выделена в отдельный каталог, хотя в операционной системе отображается в виде отдель ной папки. Яркий пример — панель управления.

Требования к имени каталогов точно такие же, как и для файлов, — как под Windows , так и под MS - DOS .

Существует несколько терминов, используемых совместно с термином "каталог". Это такие термины, как "корневой", "текущий", "родительский", "ра бочий", "подкаталог".

Корневой каталог — фактически это и есть диск (раздел), так как корневой каталог содержит в себе абсолютно все пользовательские файлы, начиная от файлов, которые создаются операционной системой при установке, заканчивая различными файлами, которые создаются пользователем в процессе работы на компьютере. Его название может состоять из 11 символов латин ского или национального начертания, а также из цифр и любых допустимых символов. Чтобы избежать проблем с работой старых программ, рекоменду ется задавать имя корневого каталога латинскими буквами и не использо вать русские символы. Стоит также отметить, что имя корневого каталога и метка тома — это одно и то же. Имя задается либо при форматировании диска, либо в любой другой момент (в свойствах диска).

Текущий каталог — каталог, который в настоящий момент используется. Как только вы открываете какой-либо другой каталог, ен тут же становится текущим. При этом следует иметь в виду, что в MS - DOS (даже в окне эму ляции) при запуске программ из текущего каталога не обязательно указы вать полный путь к запускаемому файлу, а в случае использования несколь ких каталогов путь указывать следует только для тех, которые не являются текущими. Именно поэтому иногда рекомендуют для облегчения обработки группы файлов скопировать их в один каталог. Стоит отметить или даже напомнить, что для свободной работы с разными каталогами так же, как и с текущим каталогом, следует пользоваться переменной path , которая указывает, где, помимо текущего каталога, нужно искать файлы и программы. В операционной системе Windows "по умолчанию" поиск ведется, например, в каталоге C :\ WINDOWS и его подкаталогах, поэтому иногда достаточно скопировать туда часто запускаемые файлы, например архиваторы, чтобы к ним имелся доступ из любого каталога.

Подкаталог — каталог, находящийся в другом каталоге. Этот термин не мо жет быть применен к каталогам, расположенным в корневом каталоге, т. к. он имеет наиболее высокий уровень. Благодаря развитой системе подката логов вся файловая система на дисках, используемых в IBM -совместимых компьютерах, напоминает иерархическое дерево. Каждый из подкаталогов может иметь любое количество подкаталогов более низкого уровня и т. д. Подкаталоги нужны, например, для разделения типов файлов, что облегчает их поиск и использование. Яркий пример — каталог Мои документы, в ко тором содержатся подкаталоги Мои видеозаписи, Моя музыка, Мои рисунки. Для описания структуры дисков также используется термин "дерево ка талогов ". Родительский каталог — каталог, в котором содержится текущий каталог.

Рабочий каталог — каталог, который используется для размещения про граммных и временных файлов строго определенной программы или группы программ. Иногда в настройках программы следует принудительно задать рабочий каталог, в противном случае вы не сможете ее запустить или ис пользовать некоторые ее функции. Нельзя путать рабочий каталог с ката логом для временных файлов, т. к. в нем программных файлов нет и быть не может.

Помимо ситуаций, описанных ранее, каталоги имеют еще целый ряд ограничений:

  • корневой каталог может содержать только 512 файлов с короткими име нами. Это ограничение осталось от MS - DOS . Именно по этой причине стала применяться система каталогов, т. к. любой другой каталог имеет свойство "растягивания", в результате чего каждый каталог может содер жать столько файлов, сколько вместится на диск.
  • Стоит отметить, что данное утверждение справедливо для жестких дис ков, в то время как для тех же гибких дисков максимальное количество файлов в корневом каталоге ограничено числом 224. В операционной системе Windows ситуация усугубляется еще и тем, что в ней используются длинные имена, которые могут еще больше ограничить максимальное количество файлов. Как уже упоминалось ранее, важно не столько само количество файлов, сколько суммарная длина имен файлов, поэтому чем больше в корневом каталоге файлов с длинными именами, тем меньшее их количество поместится в него;
  • если при копировании вы не указали явно каталог, в который следует копировать файл, то он копируется в корневой каталог указанного диска.


Типы файлов и каталогов

Помимо рассмотренных выше разновидностей каталогов, они также еще делятся на следующие виды:

  • каталог для временных файлов — в операционной системе Windows , независимо от версии, под временные файлы отводится каталог C :\ WINDOWS \ TEMP , хотя от MS - DOS остался "стандарт" на иное его размещение ( C :\ TEMP ), которое, кстати, позволяет избежать немалого количества проблем с работой старых программ. Вы, в принципе, можете задать любой другой каталог для размещения временных файлов, но по давляющая часть программ все равно будет использовать прежний ката лог с именем TEMP ;
  • рабочий каталог операционной системы — этот каталог стоит "в стороне" от всех остальных каталогов, т. к. в нем располагаются практически все системные файлы, необходимые для работы операционной системы. В него нельзя помещать свои, пользовательские файлы, кроме программ ных файлов, используемых в MS - DOS (точнее, в окне эмуляции MS - DOS ). Это могут быть и архиваторы, и программы для просмотра различных типов файлов, и т. п. В этом случае вам не придется задавать путь к этим файлам в переменной path . "По умолчанию" для рабочего кат&чога Windows задается одноименное имя, хотя вы можете задать любое при установке операционной системы. При этом не рекомендуется использовать как слишком длинные имена, так и имена, состоящие из русских символов;
  • каталог Program Files — в этом каталоге помещаются программные файлы всех программ, которые устанавливаются автоматически с операционной системой, и тех программ, которые устанавливает сам пользователь. По сле деинсталляции программ именно здесь следует искать рабочие ката логи удаленных программ для их ручного удаления;
  • каталог Мои документы — в этом каталоге "по умолчанию" сохраняются почти все файлы, начиная от текстовых, созданных в Microsoft Word , за канчивая видео- или аудиофайлами, созданными в профессиональных редакторах. Вы можете или использовать имя каталога "по умолчанию", или задать любое другое имя.

В операционной системе Windows XP появилась возможность задать тип для любой папки, например, папка с видео или аудио. При просмотре содержи мого данной папки будут использоваться соответствующие виды. Например, если вы зададите тип Фотоальбом, при открытии этого каталога автоматически будет выбран вид Диафильм. Здесь намеренно не упоминался термин "каталог", т. к. операционная система Windows XP еще больше, нежели все предыдущие версии, отдаляет понятие папки от привычного всем термина. В ней используется большое количество "виртуальных" папок, которые нельзя назвать каталогами, потому что их физически на диске просто- напросто не существует или же они располагаются в совершенно иных мес тах, чем может показаться на первый взгляд. Это усложняет восстановление файлов после краха системы, зато упрощает работу с компьютером.

Если говорить о типах файлов, то их существует целое множество, что вносит в эксплуатацию компьютера великое множество проблем.

Мы уже привыкли, что при нажатии клавиши < ENTER > по какому-нибудь файлу запускается определенная программа, которая может просматривать и редактировать именно этот тип файлов. При этом мы даже не задумываемся, почему открывается именно эта программа, а не какая-нибудь другая. Яркий пример — программы для работы с текстовыми редакторами Microsoft Word и WordPad , которые могут быть использованы для просмотра и редак

тирования файлов с расширением DOC , но "по умолчанию", естественно, если установлен пакет Microsoft Office , будет запущен именно Microsoft Word . Давайте разберемся почему.

Вы, скорее всего, не раз замечали, что каждый файл на жестком диске или на любом сменном носителе, когда открываешь содержимое диска (катало га) в Проводнике, имеет определенный внешний вид. Конечно, можно за менить вид значка файла, но это изменение затронет все файлы, которые имеют точно такое же расширение, как у того, для которого вы решили вне сти изменение. Исключение составляют, наверное, только исполняемые файлы, которые способны содержать ярлык в своем теле, но об этом мы поговорим чуть позже. Именно расширение файла позволяет отнести его к тому или иному типу файлов.

Любой тип файлов требует специальной программы для работы с ним. Часть файлов имеет встроенную поддержку в самой операционной системе, причем чем старше версия операционной системы, с тем большим количе ством типов файлов она может работать без установки дополнительного программного обеспечения. Другая часть файлов требует для работы с ними установки программного обеспечения.

Если задать неверное расширение файлу, то при попытке запуска этого файла при "не той" программе может возникнуть серьезный сбой в работе операционной системы.

Структура любого файла должна позволять определить, в каком формате записана в нем информация, т. е. в его составе должен находиться заголо вок, который как раз и играет роль своеобразного "информатора". Самый распространенный тип файлов, который не требует установки про граммного обеспечения для запуска, — это запускаемые файлы с расшире ниями СОМ и ЕХЕ. Они бывают нескольких видов. Один из них предна значен для запуска только в MS - DOS , в результате чего запуск такого файла может вызвать сбой в работе Windows -подобных систем. Второй вид предна значен исключительно для использования в Windows , поэтому в MS - DOS они выдают соответствующее предупреждение. Третий тип может работать в любой операционной системе.

Командный файл — это простой текстовый файл с расширением ВАТ или CMD (для Windows 2000/ XP ), содержимое которого придерживается опреде ленного синтаксиса. Чтобы выполнить командный файл, достаточно ввести в командную строку его имя.

Существует еще целый ряд "стандартных" расширений:

  • SYS — системный файл, содержащий драйвер какого-нибудь устройства;
  • ТХТ — текстовой файл, созданный любым текстовым редактором;
  • DOC — текстовой файл, созданный в редакторе Microsoft Word либо в других, совместимых с ним, программах;
  • ВАК, OLD — старые копии системных файлов;
  • ARJ , RAR , ZIP — файлы, созданные наиболее распространенными архи ваторами;
  • BMP , JPG , GIF — графические файлы;
  • DBF — база данных;
  • XLS — электронная таблица в формате Microsoft Excel ;
  • DLL — системный файл, содержащий библиотеки подпрограмм;
  • INI — файл инициализации какой-либо программы, например, инстал лятора или наоборот деинсталлятора;
  • HLP — файл помощи;
  • PIF — ярлык на какой-нибудь файл;
  • WAV , MP 3, WMA — звуковой файл;
  • AVI , MPG — файл, содержащий видеоинформацию, и т. д.


Файловые менеджеры

Файловый менеджер — это программа, предназначенная дл'я работы с файла ми и, как можно "догадаться", с каталогами и дисками, в том числе со сменными носителями.

Файловые менеджеры берут начало с программ типа Norton Commander , ко торые применялись еще во времена MS - DOS , для того чтобы хоть как-то упростить работу с файлами и катачогами, ведь в те времена не было графиче ского интерфейса, как у Windows , и все команды имели текстовый формат. Да и сегодня подавляющая часть файловых менеджеров, по крайней мере их интерфейс, создается на основе ранее популярного Norton Commander ' a , например, DOS Navigator или FAR .

После установки операционной системы Windows для использования дос тупны два файловых менеджера — Проводник и Мой компьютер. Они обла дают практически одинаковыми возможностями, хотя имеется и часть коренных отличий.

Проводник представляет собой более удобное средство навигации, нежели Мой компьютер, т. к. он состоит из двух окон. Левое отображает иерархическое дерево дисков и каталогов, а в правом окне отображается содержимое дисков и каталогов.

Сегодня имеют большую популярность и такие файловые менеджеры, как Total Commander и FAR . Первый удобен тем, что имеет оконный интерфейс, такой же, как и у всех остальных программ Windows . Если же гово

рить о FAR ' e , то он обладает тем же сине-белым интерфейсом, что и Norton Commander .

Файловый менеджер FAR вы можете найти на сайте http :// www . rarlab . com /, I a Total Commander — на http :// www . ghisler . com /.

Теперь немного об особенностях современных файловых менеджеров. С развитием операционной системы Windows развивалась и файловая сис тема. Длинные имена постепенно стали привычнее, чем короткие, поэтому такие файловые менеджеры, как традиционный NC , а также его клоны VC , ! DN , FC , уже перестали удовлетворять требованиям пользователя. Дело I в том, что при копировании и перемещении файлов при помощи этих ме- \ неджеров длинные имена "теряются", а остаются те псевдонимы, которые используются для отображения имен в окне MS - DOS .


Поиск файлов и каталогов

Структура каталогов и файлов на современном мультимедийном компьюте ре может быть очень сложной и составлять десятки тысяч файлов. Возможно, у вас все файлы аккуратно размещены по отдельным каталогам, что об легчает поиск нужного вам в данный момент, но иногда количество файлов, . да и каталогов достигает такого огромного количества (особенно если диск очень большой), что ручной поиск оказывается делом непомерно сложным. В такой ситуации можно использовать, как вы уже наверное догадались, функции автоматического поиска, встроенные как в саму операционную систему, так и во все файловые менеджеры — от Norton Commander ' a до самого современного Total Commander ' a и им подобных программ. Для более эффективного поиска можно применять технику задания имени или даже расширения по маске. Так, например, символ <*> обозначает лю бое имя файла или его расширение. То есть все файлы на диске будут обо значаться, как "*.*". Чаще всего этот символ применяют для поиска, напри мер, всех файлов с расширением TXT , DOC , JPG и т. п. Помимо этого используется еще один символ <?>, который обозначает одну (и только од- \ ну) любую букву в имени файла или в его расширении. Если в имени файла i вам не известны две буквы, следующие подряд, то и таких вот символов нужно будет указать также два и т. д.


Куда девается свободное место на диске ?

В операционных системах Windows ME и Windows XP свободное простран ство часто попусту "съедается" регулярно сохраняемой информацией для восстановления. Здесь следует придерживаться принципа — хранить только самое последнее состояние операционной системы, тогда как все остальные можно спокойно удалить. Исключение может составить ситуация, когда вы постоянно экспериментируете с новыми программами, но в этом случае приходится делать выбор между свободным пространством и стабильностью работы операционной системы.

Несколько уменьшить проблему свободного пространства можно путем применения программ сжатия данных "на лету". Например, функцией, встроенной в файловую систему NTFS , которая позволяет уменьшить объ ем, занимаемый файлами, за счет более эффективного распределения по кластерам. Иногда при сжатии средствами самой операционной системы может возникнуть ошибка, в сообщении которой будет говориться, что яко бы файловая система не поддерживает сжатие, хотя используется файловая система NTFS . Причиной чаще всего является размер кластера больше, чем 4096 байт. В этом случае у вас имеется два варианта: отформатировать диск, причем принудительно задать размер кластера, например, командой

FORMAT <DRIVE>: /FS:NTFS /A:4096

или попробовать преобразовать диск при помощи программы Partition Magic v 8.0, в которой имеется функция изменения размера кластеров. В по следнем случае можно даже не сохранять важные данные на другой диск, хотя утверждение действительно только при использовании лицензионной версии программы, т. к. неизвестно чего "наломали" хакеры и как будет работать именно эта функция. При использовании пиратских программ лучше все-таки самые важные файлы сохранять на другом диски.

Размер кластера играет большую роль в эффективности использования объема диска, что можно увидеть на таком примере. Возьмем две емкости объемом по два литра каждая. В сумме у нас получается четыре литра. Попро буйте налить в них любую жидкость общим объемом три литра. Что у нас получается? Одна из емкостей получается наполненной наполовину. В нее мы уже не сможем налить какую-нибудь другую жидкость. То же самое происходит и с кластерами. Частично заполненный кластер уже не может быть использован для хранения других файлов, т. е. он попусту пропа дает. Таких кластеров на диске может быть до 50%, что приводит к потере до 30—50% общего объема диска на такие вот "пустые" области. Чтобы хотя бы немного смягчить эту проблему, нужно регулярно производить дефрагментацию диска.


Удаление файлов и каталогов

Операционная система Windows устроена таким образом, что "по умолча нию" все удаленные файлы и каталоги помещаются в специальный каталог, из которого можно эти файлы и каталоги удалить окончательно либо вос становить их. Каталог для этих "псевдоудаленных" файлов и каталогов назы вается Корзина, хотя вы можете задать и любое другое название, т. к. это всего лишь логический идентификатор. На самом же деле каталог имеет строго определенное название ( RECYCLER или RECYCLED ) и располага ется он в корне каждого диска. Получается, что логически Корзина — это один каталог, а физически на каждом диске имеется свой каталог для временного хранения удаляемых файлов.

Естественно, что существует возможность удаления "мимо" Корзины. Зачем это нужно? Да. например, если вы уверены, что файлы вам в любом случае не понадобятся. Хотя здесь имеется один, но немаловажный нюанс. Восстановить удаленные таким образом файлы вы сможете только при помощи специальных утилит. Нажмите клавишу < SHIFT > перед тем, как перетаски вать что-либо в Корзину, и вы удалите это "что-либо" без участия корзины. Вы также можете не использовать функцию Drag & Drop — вы можете просто выделить необходимые элементы и нажать < SHIFT >+< DEL > (обе клавиши вместе) — эффект будет тот же.

Сразу же стоит отметить, что практически все проблемы, связанные с удалением как файлов, так и каталогов, связаны с особенностями работы фай ловых менеджеров Проводник и Мой компьютер. Именно поэтому сегодня так популярны файловые менеджеры, подобные "старому доброму Norton Commander ' y ", например, Windows Commander или FAR .

Наиболее распространенные причины, из-за которых не удается удалить файл или каталог:

  • файл или каталог используется в данный момент одной из запущенных программ или самой операционной системой. Такая ситуация часто воз никает при попытке:
    • удаления каталога или файла, используемого запущенной в данный момент программой. Ситуация часто встречается, когда программа сворачивается в ярлык, находящийся возле системных часов. В этом случае следует закрыть все программы, находящиеся в памяти компь ютера, после чего повторить попытку. При этом можно воспользо ваться окном Диспетчера задач Windows , которое вызывается нажатием клавиш < CTRL >+< ALT >+< DEL >;
    • удаления всех файлов из каталога временных файлов — в этом случае дождитесь завершения работы всех программ, а еще лучше, прежде чем удалять временные файлы, перезагрузите компьютер;
    • удаления рабочего каталога одной из программ после ее деинсталля ции — иногда при деинсталляции от программ остаются модули, за гружаемые при запуске системы. Далеко не все деинсталляторы спо собны принудительно выгружать такие модули из памяти, поэтому они остаются на диске. Такая ситуация встречается не так уж и редко, это можно исправить программами вроде PrcView , позволяющими удалять из памяти процессы, которые вы только пожелаете. Операци онные системы Windows 2000/XP обладают встроенными средствами управления ресурсами. После удаления процесса, соответствующего программе, рабочий каталог которой вы хотите удалить, можно повто рить попытку;
  • при использовании файловых менеджеров Проводник и Мой компьютер, когда включен режим отображения Как веб-страница, в определенные' моменты вы не можете удалить файл, хотя ни одной программой он, на первый взгляд, не занят. Причина проблемы в особенностях этого режи ма работы. Дело в том, что когда вы помечаете файл, в центральной час ти рисуется его миниатюрное изображение. Чем больше файл, тем мед леннее это происходит. Естественно, что в этот момент файл недоступен ни для удаления, ни для перемещения;
  • в Windows XP удаление каталога может оказаться неудачным из-за сис темного файла с именем Thumbs . db , который содержит в себе данные о созданных ранее миниатюрных изображениях всех мультимедийных файлов, находящихся в данном каталоге. Если вы открыли данный ката лог в Проводнике, то файл оказывается загруженным в память и его, ес тественно, нельзя удалить. В этом случае следует закрыть Проводник и воспользоваться другим файловым менеджером, например Мой компью тер, или же при использовании Проводника удалять этот каталог, не от крывая его. Можно, в принципе, воспользоваться еще одним способом. Следует выбрать отображения в виде списка, при котором указанный файл не используется, затем временно перейти в другой каталог, чтобы файл в памяти был заменен другим файлом, но уже из другого каталога, а затем беспрепятственно удалить нужный каталог;
  • удалению файлов могут препятствовать программы архивации данных "на лету", например ZIP Magic 2000 или ZIP Folder . В моменты, когда файл сжимается или разжимается, он недоступен для удаления или перемеще ния. Особенно заметно это на слабых конфигурациях.


Архивация данных и программы сжатия

Программы-архиваторы можно разделить на три категории.

  1. 1. Программы, используемые для сжатия исполняемых файлов, причем все файлы, которые прошли сжатие, свободно запускаются, но изменение их содержимого, например русификация, возможны только после их разар- хивации.
  2. 2. Программы, используемые для сжатия мультимедийных файлов, причем можно после сжатия эти файлы свободно использовать, хотя, как прави ло, при сжатии изменяется их формат (внутренняя структура), а иногда и ассоциируемая с ними программа, что может привести к проблемам с за пуском.
  3. 3. Программы, используемые для сжатия любых видов файлов и каталогов, причем в основном использование сжатых файлов возможно только по сле разархивации. Хотя имеются программы, которые "видят" некоторые типы архивов как самые обычные каталоги, но они имеют ряд неприят ных нюансов, например, сильно нагружают центральный процессор, что исключает их использование на "слабых машинах".

Принцип работы архиваторов основан на поиске в файле "избыточной" ин формации и последующем ее кодировании с целью получения минималь ного объема. Самым известным методом архивации файлов является сжатие последовательностей одинаковых символов. Например, внутри вашего файла находятся последовательности байтов, которые часто повторяются. Вместо того, чтобы хранить каждый байт, фиксируется количество повторяемых символов и их позиция. Например, архивируемый файл занимает 15 байт и состоит из следующих символов:

В В В В В LLLLLAAAAA

В шестнадцатеричной системе

42 42 42 42 42 4С 4С 4С 4С 4С 41 41 41 41 41

Архиватор может представить этот файл в следующем виде (шестнадцате-ричном):

01 05 42 06 05 4С 0А 05 41

Это значит: с первой позиции пять раз повторяется символ "В", с позиции 6 пять раз повторяется символ " L " и с позиции 11 пять раз повторяется сим вол "А". Для хранения файла в такой форме потребуется всего 9 байт, что на 6 байт меньше исходного.

Описанный метод является простым и очень эффективным способом сжа тия файлов. Однако он не обеспечивает большой экономии объема, если обрабатываемый текст содержит небольшое количество последовательностей повторяющихся символов.

Более изощренный метод сжатия данных, используемый в том или ином виде практически любым архиватором, — это так называемый оптимальный префиксный код и, в частности, кодирование символами переменной длины (алгоритм Хаффмана).

Код переменной длины позволяет записывать наиболее часто встречающиеся символы и группы символов всего лишь несколькими битами, в то время как редкие символы и фразы будут записаны более длинными битовыми строками. Например, в любом английском тексте буква Е встречается чаще, чем Z , а X и Q относятся к наименее встречающимся. Таким образом, ис пользуя специальную таблицу соответствия, можно закодировать каждую букву Е меньшим числом битов и использовать более длинный код для бо лее редких букв. Популярные архиваторы ARJ , РАК, PKZIP работают на основе алгоритма Лемпела-Зива. Эти архиваторы классифицируются как адаптивные словарные кодировщики, в которых текстовые строки заменяются указателями на идентичные им строки, встречающиеся ранее в тексте. Например, все слова какой- нибудь книги могут быть представлены в виде номеров страниц и номеров строк некоторого словаря. Важнейшей отличительной чертой этого алгоритма является использование грамматического разбора предшествующего текста с расположением его на фразы, которые записываются в словарь. Указатели позволяют сделать ссылки на любую фразу в окне установленного размера, предшествующего текущей фразе. Если соответствие найдено, текущая фраза заменяется указателем на своего предыдущего двойника.

При архивации, как и при компрессировании, степень сжатия файлов силь но зависит от формата файла. Графические файлы, типа TIF и GIF , уже за ранее компрессированы (хотя существует разновидность формата TIFF и без компрессии), и здесь даже самый лучший архиватор мало чего найдет для упаковки. Совсем другая картина наблюдается при архивации текстовых файлов, файлов PostScript , файлов BMP и им подобных.


Восстановление файлов и каталогов

Наиболее важное правило, которое следует знать при .восстановлении фай лов, — это то, что вы фактически восстанавливаете не сам файл, а доступ к нему. То есть сам файл в большинстве случаев находится на диске в цело сти и сохранности, только вот вы не можете его ни прочитать, ни скопиро вать, т. к. отсутствует служебная информация, указывающая на то, где рас полагается этот файл, и на то, какими характеристиками он обладает, например, размером. То же самое относится и к каталогам.

Если вы потеряли файл при работе в Windows 2000/ XP , обратите внимание на то, что рабочий стол у каждого пользователя свой и при копировании на него файлов можно получить эффект их пропажи, если войти в систему под другим именем.

Любые повреждения делятся на физические и логические. С первыми все понятно — либо работает, либо нет, зато вот со второй разновидностью следует разобраться как следует.

Самый первый сектор занят главной загрузочной записью ( MBR , Master Boot Record ), которая представляет собой программу, заведующую загрузкой опе рационной системы после передачи ей управления BIOS . Эта запись стан дартна и легко восстановима, например, командой fdisk / mbr .

В конце сектора располагается таблица разделов жесткого диска, в ней содержатся данные о размере, местоположении и назначении разделов. По стандарту их не может быть больше четырех. Нарушение структуры в этой области грозит потерей всех или части разделов. Восстановление воз можно при ручном или программном поиске начальных структур

Файловая система FAT состоит из следующих компонентов: Boot Sector , две копии таблицы FAT , расположенные одна за другой, корневой каталог и область данных.

Нарушение структуры одной из FAT -таблиц не критично, т. к. она может быть восстановлена путем дублирования целой копии на место поврежден ной. Если же повреждения коснулись обеих копий, то это уже проблема. Единственное, что может при этом спасти, так это специальные программы, способные искать файлы по остаткам обеих FAT -таблиц.

Корневой каталог является основным и содержит все ссылки на каталоги сле дующего уровня, а также на файлы, находящиеся в нем. Его повреждение со провождается появлением странных директорий и файлов. Вероятность восстановления данных при их искажении в нем велика, однако логическая структура директорий, а также многие файлы могут быть потеряны безвозвратно.

Далее располагается область данных, где кроме них находятся еще и ката логи следующего уровня. Их повреждения локальны и при желании легко излечиваются стандартными средствами вроде NDD .


FAQ ( ответы на часто задаваемые вопросы )

Вопрос: Удалил файл, но в Корзине его не обнаружил, что делать?

Ответ: Файл, скорее всего, был очень большим и не поместился в Корзину. "По умолчанию" под Корзину отводится только 10% всего объема жесткого диска, что и приводит к подобным ситуациям. Возможно, вы (или кто-то другой) включили стирание без предупреждения, т. е. минуя Корзину, таких файлов. Все эти функции настраиваются в свойствах этой самой Корзины.

Вопрос: Мне нужно восстановить удаленный ранее файл, можно ли продол жать работу на компьютере или лучше всего это сделать сразу?

Ответ: Лучше всего прекратить работу всех приложений и операционной системы сразу же после того, как пришла в голову мысль о том, что зря удалили один или несколько файлов. Сделать это лучше клавишей RESET на системном бло ке, чтобы ни программы, ни сама операционная система не могли записать на его место другие данные. Вся специфика операционных систем Windows состо ит в том, что файл подкачки постоянно перезаписывается, что постепенно приводит к уменьшению вероятности восстановления данных. Сюда же относятся и все временные файлы, например те, которые создаются при редактировании текстовых файлов в программе Microsoft Word .

Вопрос: Что нужно сделать, чтобы нельзя было восстановить файлы после удаления?

Ответ: Наиболее простой способ — это воспользоваться функцией программы Norton Speed Disk "очищать свободное пространство". После дефрагментации файлов вся оставшаяся незадействованной поверхность будет "забита нулями".

Если подходить к этому вопросу более серьезно, то следует воспользоваться такими утилитами, как Norton Wipelnfo , которые созданы для безвозврат ного удаления всех файлов и каталогов, указанных вами.

Вопрос: Архив с ценной информацией оказался поврежденным. Можно ли как-то восстановить его?

Ответ: Если архив сжат программой RAR или WinRAR , попробуйте вос пользоваться функцией Восстановление поврежденного архива. Если архив имеет формат ZIP , то попробуйте воспользоваться утилитой PKZIPFIX , входящей в состав дистрибутива данного архиватора.

Вопрос: Случайно удалил не тот раздел на диске. Можно его как-то восста новить?

Ответ: Главное правило — ни в коем случае не пытайтесь создать на его месте новый раздел, т. к. программа FDISK при просчете свободного пространства всегда записывает в первый сектор каждой дорожки код F 6, что приводит к потере данных в этих секторах.

Воспользуйтесь программами вроде TIRAMISU , GetDataBack , EasyRecovery . Можно, конечно, попытаться восстановить данные вручную, но это требует квалификации и времени.

Вопрос: Какой файловый менеджер все-таки лучше — TotaJ Commander или FAR ?

Ответ: Оба упомянутых менеджера хороши, но каждый приспособлен для строго определенных задач. Так, например, FAR удобно использовать для работы с такими программами, которые требуют для работы запуска окна эмуляции MS - DOS . При работе в FAR ситуация облегчается тем, что он уже работает в окне эмуляции MS - DOS , в то время как при работе в Total Commander придется запускать отдельное окно. Это дает большое преимущество FAR ' y , т. к. имеется возможность посмотреть результаты работы программы, в то время как отдельное окно в Total Commander ' e после завершения про граммы автоматически закроется. С другой стороны, Total Commander дает наглядное представление о работе Windows -подобного интерфейса, пользователю нет необходимости переучиваться.

FAR обладает встроенным редактором текста, который может работать с различными кодировками, в то время как Total Commander может исполь зовать только внешние программы, например, блокнот, да и функции по перекодировке у него бедноватые.

Обратите также внимание еще и на следующие менеджеры:

  • Frigate — http://www.winfrigate.com/;
  • WinNavigator — http://www.wnsoft.com/.

Они также имеют некоторые весьма приятные отличительные особенности, которые возможно именно вам и пригодятся в повседневной практике.


Глава 14. Работа с офисными программами

  • Какие программы относятся к офисным?
  • Особенности настройки офисных программ
  • Особенности работы с текстовыми файлами
  • Проблемы при работе с принтером
  • FAQ (ответы на часто задаваемые вопросы)


Какие программы относятся к офисным ?

Чтобы понять, какие программы можно отнести к разряду офисных, доста точно себе представить, чем занимались в офисах до появления в них ком пьютеров. Печатные машинки, линейки, карандаши, огромные стопки бу маги. Все это использовалось до тех пор, пока на рабочий стол практически каждого работника не был установлен персональный компьютер.

Отсюда можно сделать вывод о том, что офисные программы предназначе ны для работы как с текстом, так и с графикой. Набор и печать разнообраз ных текстов, бланков, наброски эскизов, проектов, дизайн и многое другое. Сегодня компьютер используется почти в любой сфере — от набора и печати бухгалтерских бланков до верстки сложнейших рекламных щитов, газет и журналов.


Особенности настройки офисных программ

По большому счету практически все проблемы, связанные с офисными программами, идут от некорректной установки или работы установленных в системе шрифтов. Все шрифты можно разделить на системные и пользовательские. Первый тип в основном используется для отображения всевоз можных меню самой операционной системы, а второй тип в основном используется для расширения возможностей программ для работы с тексто выми файлами, хотя и программы для работы с графическими файлами также нередко используют шрифты, например Adobe Photoshop .


Особенности работы с текстовыми файлами

т. к. используется всего один файл, ну а с другой стороны, для выбора опре деленной кодировки используется целая система псевдонимов, например, Times New Roman Cyr , O = Times New Roman ,204. Старые же программы уме ют работать только с именами файлов, из-за чего русские символы могут отображаться в виде псевдографики, т. к. выбрана неверная кодовая страни ца. Для исправления ситуации можно применить специально обработанный шрифт, у которого таблица с кириллицей перемещена в начало файла, но этот подход работает не всегда, да и найти такие шрифты сложно.

Нередко возникает проблема с некорректным отображением символов в Блокноте. После установки какой-нибудь программы, часто драйверов принтера, отображение текста вместо стандартного шрифта может осущест вляться, например, наклонным шрифтом. Проблема усугубляется тем, что подобное явление наблюдается и в других программах, например в окне терминала удаленного доступа к сети.

Чтобы вручную исправить ситуацию, найдите в системном реестре раздел

HKEY_LOCAL_MACHINE\config\0001\display\settings

В нем найдите параметр fixedfon . fon , который "по умолчанию" должен быть равен vgafix . fon , и укажите любой шрифт, установленный в системе, хотя лучше, если вы будете использовать только шрифты с расширением FON , т. к. шрифты TTF работают не всегда. Перезагрузите компьютер для применения изменений.

В указанном выше разделе можно изменить практически любые системные шрифты, но следует соблюдать осторожность. Стоит отметить, что для со вместимости со старыми программами вся информация из этого раздела системного реестра вносится также и в файл SYSTEM . INI в раздел BOOT . Имейте это в виду при редактировании реестра.


Проблемы при работе с принтером

Практически все офисные программы имеют возможность работы с принтером, и это, в принципе, вполне естественно, потому что любая работа с тек стом, например, в итоге предполагает его вывод на бумагу. Если говорить о графике, то и ее при первой же возможности выводят на бумажный или иной носитель, например на пленку или же на компакт-диск. На практике проблемы с печатью встречаются чаще, чем проблемы с программным обес печением, поэтому-то мы и выделили их в отдельную часть главы.

Принтер не печатает

Если вы только что купили принтер и подключили его к компьютеру, то, естественно, он печатать сразу же не будет. В первую очередь следует под ключить его к разъему на компьютере, который соответствует разъему на принтере, т. е. если принтер USB , то и подключать его следует к USB , и наоборот, если он предназначен для работы с параллельным портом, то и подключать его надо именно к параллельному порту.

Стоит отметить, что сегодня постепенно уходят с рынка принтеры, использующие для своей работы LPT -порт, т. к. USB -устройства намного проще настраиваются, да и подключать их к системному блоку можно, не выклю чая компьютер. Сегодня также имеется возможность подключения принтера LPT к разъему USB через специальный переходник.

По идее, если принтер подключен к системному блоку правильно и включен в сеть, то после перезагрузки компьютера система должна определить его наличие. Если же этого не происходит, следует проверить режимы рабо ты порта, через который вы его подключили, возможно, он вообще отклю чен. Не раз мне встречались материнские платы, у которых "по умолчанию" отключен порт USB . Это относится к достаточно старым компьютерам на базе процессоров Pentium / Pentium II , когда устройства USB были редкостью и производители вводили поддержку этой шины "на всякий случай" и не более того.

Теперь немного подробнее о режимах работы "принтерного" порта. О шине USB , в принципе, говорить ничего не нужно, т. к. это полностью Plug and Play -шина и никаких настроек, кроме установки драйверов, для нее де лать не нужно. А вот порт LPT (его чаще называют парамельныи порт), тре бует к себе особого внимания, что вызвано возможностью выбора несколь ких режимов его работы.

  1. 1. SPP ( Standard Parallel Port ) — наиболее простой режим работы парал лельного порта, при котором используется только однонаправленная пе редача данных (от компьютера к принтеру). Его иногда называют режи мом Normal . Этот режим часто используется для работы матричных принтеров, для которых он, в общем-то, и создавался.
  2. 2. EPP ( Enhanced Parallel Port ) — расширенный режим параллельного пор та, при котором данные могут поступать как от компьютера к принтеру, так и наоборот. Режим порта может применяться практически для любых устройств, которые требуют двустороннего обмена данными с компьюте ром, но для принтеров он не используется.
  3. 3. ЕСР ( Extended Capability Port ) — расширенный режим параллельного порта, при котором используются каналы передачи данных без участия процессора ( DMA ), а также возможности аппаратного сжатия передавае мых данных. Это позволяет не только увеличить скорость вывода данных на печать, но и разгружает процессор, позволяя во время печати зани маться другими операциями. Режим практически всегда используется для работы струйных и лазерных принтеров. Для струйных принтеров этот режим важен в первую очередь тем, что появляется возможность пере давать в компьютер данные о расходе чернил, а для лазерных появляется не менее хорошая возможность управления его внутренними параметра ми. Таким образом, например, можно включить в принтере поддержку кириллицы, изменить шрифты, используемые "по умолчанию" при печа ти в MS - DOS , и т. д.

Если операционная система установлена при включенном режиме SPP , ко торый "по умолчанию" включен практически на любых, даже самых современных материнских платах, то для изменения его на ЕСР или ЕРР может потребоваться небольшая, но необходимая манипуляция. Удалите драйвер поддержки порта LPT из Диспетчера устройств, перезагрузите компьютер, после чего зайдите в программу CMOS Setup Utility и установите требуемый режим порта. Оптимальный вариант ЕРР+ЕСР, когда операционная система автоматически определяет необходимый режим. После того как система за грузится, система Plug and Play автоматически установит новый порт.

Как только вы включили и настроили работу порта, можно устанавливать драйверы для принтера. Здесь следует отметить, что все неиспользуемые драйверы лучше всего заранее удалить, чтобы в дальнейшем не возникало никаких конфликтов. Драйвер, который вы устанавливаете, следует пометить как используемый по умолчанию, в таком случае, даже при наличии других установленных принтеров, печать из MS - DOS будет проходить кор ректно, да и в Windows -приложениях не придется каждый раз вручную вы бирать нужный принтер.

Если принтер упорно не хочет печатать, быстро проверить его можно таким образом:

  • распечатайте тестовую страницу, которая вызывается нажатием кнопок на самом принтере. Какие именно кнопки и как следует их нажимать, можно прочитать в инструкции, прилагаемой к принтеру. Чаще всего весь секрет состоит в том, чтобы, удерживая одну из кнопок на принтере, включить его питание, хотя иногда могут встретиться и отдельные кноп ки, специально предназначенные для теста, например, как у принтеров Samsung ML 1210/1250. Если принтер отпечатал тест нормально, следует продолжить поиски в системном блоке;
  • распечатайте пробную страницу, используя встроенные функции драйве ра. Если принтер не печатает, тогда проблема заключается в отсутствии контакта между принтером и системным блоком, проверьте его. Если же тест прошел нормально, то проблема, значит, заключается в программе, которая отказывается печатать.

Нередко можно наблюдать некорректные изменения, вносимые драйвером принтера в работу операционной системы. В этом случае остается только обновить драйвер или, наоборот, использовать одну из старых версий, ка кую именно — покажет практика. Принтеры — это одно из тех немногих устройств, для которых обновление драйверов крайне не рекомендуется.

Принтер печатает , но с искажениями

Сразу стоит отметить, что если принтер начал печатать с искажениями, то, значит, он нуждается в техническом обслуживании. Любой механизм, будь то автомобиль или принтер, требует профилактического обслуживания, в противном случае можете быть уверены в том, что по истечении опреде ленного срока начнется повышенный износ деталей, что, в конце концов, приводит к преждевременной поломке принтера и, соответственно, замене дорогостоящих узлов.

С другой стороны, следует определить, что именно вы называете искаже ниями. Если под искажениями подразумевается некорректное отображение русских символов или вывод на печать совершенно не тех шрифтов, кото рые задумывались, то вам следует обратить внимание на используемое про граммное обеспечение. Если же искажения представляют собой полосы, пятна и другие артефакты на печатаемом изображении, тогда уже следует нести принтер в сервис-центр.

Напоследок стоит отметить, что с различными моделями принтеров часто связано не малое количество различных сбоев и неполадок. В помощь вам может прийти только Интернет, в котором в различных форумах и конференциях обсуждаются подобные вопросы. Это, наверное, самый универсаль ный ответ на вопрос: "А что делать, если не могу настроить принтер?"

Особенности матричных принтеров

У некоторых принтеров, особенно это относится к старым моделям матричных принтеров Epson , опасно крутить ручку подмотки бумаги при выклю ченном (!) принтере. Дело в том, что принтер должен знать, где находится передний край загруженного листа, и, в зависимости от его положения, включает на пути листа разнообразные направляющие ролики или защелки. Поэтому, если его обмануть, он может защелкнуть ролик до того, как лист его пройдет; бумага упрется в ролик, помнется, и, в лучшем случае, придет ся вытаскивать мятый лист из принтера. А в худшем — выйдут из строя датчик конца листа, печатающая головка, каретка, механизм подачи бумаги, некоторые детали корпуса.

Тем более не рекомендуется крутить эту ручку при включенном принтере. Ко всем вышеописанным последствиям добавится еще несколько, а именно: выход из строя шестеренок, двигателя подачи бумаги и, естественно, самой ручки. Из всего сказанного следует, что вставлять бумагу в принтер следует только по инструкции, а двигать ее или выгружать из принтера можно только с помощью штатных средств, каковыми являются кнопочки на пульте.

Особенности струйных принтеров

Струйные принтеры используют в качестве носителя специальные быстро сохнущие чернила. Каждая модель струйного принтера обладает целым рядом уникальных характеристик, таких как размер сопел печатающей голов ки и скорость движения бумаги. Именно под эти параметры подбирается соответствующий состав чернил и именно отсюда пошло мнение о том, что существуют совместимые и несовместимые расходные материалы.

Подавляющая часть домашних принтеров является струйными. Дело в том, что их цена, как минимум, раза в три ниже цены самых дешевых лазерных принтеров, а о матричных и говорить не приходится. Новые матричные принтеры стоят раза в два дороже струйных принтеров, а их эксплуатационные характеристики, например уровень издаваемого шума, сводят удоволь ствие от их использования к минимуму.

Конечно, стоимость каждой отпечатанной копии на струйном принтере ока зывается на порядок выше, чем копия на лазерном принтере, зато в домаш них условиях просто неоценима возможность цветной печати, даже вплоть до фотографического качества.

И самый немаловажный фактор, благодаря которому струйные принтеры все больше и больше заполоняют рынок домашних принтеров, — это возможность неоднократной заправки картриджей. При этом стоимость отпе чатанной копии падает в десятки раз. Естественно, что картридж может выйти из строя во время первой же заправки, но это зависит в основном от того, насколько много у вас практики. Обычно картридж удается заправить не менее 2—3 раз, а некоторые умельцы доводят эту цифру до 8—10 раз и более.

Особенности лазерных принтеров

Лазерные принтеры используют в качестве красителя специальный порошок (тонер). Каждая модель принтера обладает целым рядом уникальных харак теристик, одни из которых: температура печки и скорость движения бумаги. Именно под эти параметры подбирается соответствующий состав тонера, и именно отсюда пошло мнение о том, что существуют совместимые и несо вместимые расходные материалы.

Если вы заправите картридж тонером несовместимой марки, возможны следующие проблемы:

  • тонер плохо переходит на фоторецептор, на котором формируется изо
    бражение, и текст получается бледным;
  • тонер состоит из слишком крупных гранул, чем положено для данного
    принтера, в результате чего разрешение печати будет намного ниже, чем
    при нормальном тонере;
  • тонер имеет слишком высокую температуру плавления, в результате чего плохо прилипает к бумаге и при любом прикосновении изображение размазывается по бумаге. Здесь имеется еще один неприятный нюанс. Часть тонера остается внутри принтера и прилипает к резиновым валикам, которые постепенно разъедаются, и к ним начинает прилипать бу мага. Помимо этого происходят и другие изменения, которые, по боль шому счету, приводят к поломке принтера.

Для долгой бессбойной работы лазерного принтера нужно применять только бумагу, плотность которой не Ниже 60 г/м 2 . Низкокачественная бумага мо жет быстро вывести принтер из строя. Еще один момент связан с печатью на типографских бланках, если вы постоянно используете бумагу с нанесен ным на обратной стороне изображением, имейте в виду, что под воздейст вием высокой температуры она может размазываться и даже осыпаться с бумаги.

Расходные материалы для принтеров

Очень много проблем связано с расходными материалами, а точнее с картриджами, в которых содержится краситель, переносимый при печати на бумагу.

Помимо оригинальных картриджей, на рынке расходных материалов пред ставлены так называемые неоригинальные, или совместимые картриджи. Это продукция компаний, не имеющих собственного производства принтеров, а занимающихся выпуском исключительно расходных материалов. По сравнению с оригинальными картриджами, картриджи этих производителей от личаются низкой ценой и позволяют значительно (более чем в два раза) снизить стоимость печати одной страницы. При этом качество печати при работе с совместимым картриджем зачастую остается на уровне результатов, получаемых при использовании оригинального картриджа. Все это вместе делает совместимые расходные материалы очень привлекательными для использования в офисе и дома. Причем низкий уровень цен главным образом объясняется тем, что производители совместимых расходных материалов не пытаются за счет их продажи окупить стоимость производства принтеров. Нередко покупатели обращают внимание на то, что принтер часто стоит немного дороже, чем картридж для него.


FAQ ( ответы на часто задаваемые вопросы )

Вопрос: Загрязнилось стекло сканера, отчего на сканированных рисунках появились разнообразные артефакты. Как можно очистить стекло?

Ответ: Стекло сканера можно почистить любым средством для очистки стекол, например "Мистер Мускул". Только имейте в виду, что тряпка, которой вы трете стекло, не должна приводить к появлению царапин, лучше всего использовать что-нибудь вроде замши или специальные очистительные сал фетки.

Вопрос: При печати из Microsoft Word вместо букв печатаются квадратики. Что это может быть и как от этого избавиться?

Ответ: Самый простой способ — это обновить версию пакета Microsoft Office до версии 2000 или ХР (последняя версия откажется устанавливаться в Windows 95).

Если вы все-таки хотите решить проблему без переустановки программы, можно воспользоваться следующими рекомендациями:

  • обновите драйвер для принтера, возможно, проблема заключается в том, что все шрифты, которые печатаются некорректно, подменяются драйвером на другие, в которых таблица с поддержкой кириллицы либо смеще на, либо отсутствует;
  • переключить принтер в режим печати, когда абсолютно все символы пе
    чатаются как графика;
  • найдите в системном реестре строку: HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Word\<MMH принтера >
  • и внесите новую переменную Flags со значением 8192;
  • ? найдите в системном реестре раздел Font substitution , где для всех
    шрифтов, что некорректно работают, задайте параметры:
    Font,0 = Font, 204
    Font,204=Font, 204
    Для Windows 95 аналогичную операцию можно проделать в файле WIN . INI ;
  • найдите шрифт с тем же написанием (названием), в котором таблица
    поддержки кириллицы будет находиться где положено, или же конверти
    руйте имеющийся шрифт при помощи программы TTFCONV .

Вопрос: При печати из Microsoft Word сдвигаются таблицы. Что можно сде лать?

Ответ: Наиболее простой вариант — обновите версию пакета Microsoft Office до версии 2000 или ХР. Если вы все-таки хотите использовать Microsoft Office 97, тогда следует обновить его последовательно пакетами обновления SP 1, SP 2 и SP 3, или же следуйте дальнейшим рекомендациям. В настройках Microsoft Word включите опцию Использовать параметры принтера при разметке документа. Также попробуйте работу в режиме со вместимости с Word 6.0/95 или в режиме Печатать текст как графику. В случае использования принтера Epson (матричного) в установках принтера выключите режим " condensed ". Вопрос: При печати часть изображения пропадает либо лист не распечатывается до конца. Как исправить ситуацию?

Ответ: Причина проблемы кроется в недостатке памяти в самом принтере. Добавьте ее либо используйте меньшее разрешение для печати.

Вопрос: Принтер Epson LX -300 не работает под Windows 95. Что можно сде лать?

Ответ: Обновите "прошивку" принтера или отключите от разъема контакты 14 и 17 на разъеме компьютера. Они соответствуют сигналам AFXT и SLCTIN .

Вопрос: Не могу сохранить изменения в файле, каждый раз приходится со хранять документ под другим именем. Из-за чего это могло произойти?

Ответ: Во-первых, проверьте атрибуты документа, флажок напротив "только для чтения" должен быть снят. Во-вторых, убедитесь, что этот файл не открыт никакой другой программой или на каком-нибудь другом компьютере в локальной сети. Если эти варианты отпадают и файл все равно открывает ся в режиме "только для чтения", тогда, скорее всего, вы стали жертвой мак ровируса. Воспользуйтесь антивирусным сканером.

Вопрос: При заправке картриджа для лазерного принтера просыпал тонер на одежду, как его лучше очистить?

Ответ: Ни в коем случае не смывайте его горячей водой, он тогда въестся в ткань еще сильнее. Смывать тонер можно только холодной водой. Если тонер попал на ковровое покрытие или линолеум, то, не откладывая в долгий ящик, тут же уберите порошок пылесосом. Если этого не сделать, то потом грязь можно будет убрать только вместе с ковром.

Вопрос: Почему при работе с копирами часто ощущается запах озона?

Ответ: Тот, кто работал с копирами, часто ощущал запах озона. Ошибочно мнение, что это хороший запах или полезный. Когда летом в лесу или в по ле после дождя Вы видите радугу и чувствуете запах озона — это действительно полезно, так как там выделение озона составляет 10 3 степени. Ко пировальный аппарат выделяет 10 6 степени, а то и больше, порядок цифр не столь важен, важно, что на несколько порядков больше, чем необходимо человеку. Озон Оз — это сильнейший окислитель. При длительном нахождении в непроветриваемом помещении, где долго работают на копировальной технике, человек получает большую порцию О3. Происходит сильноеокисление клеток, а значит, все процессы в организме ускоряются, главный из которых — это СТАРЕНИЕ. Симптомы: чувство усталости, сонливости, разбитости.

В копировальной технике для уменьшения вредности предусмотрен озоно вый фильтр. Поэтому меняйте его своевременно. Для копиров нужна про филактика после каждых 3000 копий.

Вопрос: Можно ли как-то увеличить скорость вывода на печать?

Ответ: "По умолчанию" в операционной системе Windows используется фо новая печать, при этом все данные, посланные на печать, сначала записы ваются в файл, а уже после этого последовательно выдаются на печать. Благодаря этому появляется возможность выполнять другие операции в программе, из которой активизирована печать. Можно в свойствах прин тера отключить эту функцию, но при этом работа программы будет на время печати заблокирована.

Вопрос: При печати из Microsoft Word появились искажения. Может переус тановить программу или дело намного серьезней?

Ответ: Сначала распечатайте пробную страницу, если все нормально, зна чит, сам принтер исправен и надо искать причину проблемы в компьютере. Чтобы выяснить, какая именно программа дает сбой, попробуйте распеча тать тот же самый текст из других программ, например, WordPad или Note pad . Также попробуйте распечатать из Microsoft Word другой документ, луч ше только что набранный, возможно, прежний документ поврежден.

Вопрос: При запуске Microsoft Excel часто появляется сообщение о наруше нии зашиты. Что можно сделать?

Ответ: Найдите и удалите файл с именем EXCEL . XLB .

Вопрос: Можно ли изменить шрифты, используемые в окне эмуляции MS - DOS ?

Ответ: Название шрифта можно поменять в системном реестре при помощи

КЛЮЧа HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\MS- DOS Emulation.

Вопрос: В английской версии Adobe Photoshop v 5.0 невозможно использо вать русские символы в именах файлов, т. к. вместо них отображаются зако рючки. Можно ли это как-то исправить?

Ответ: Найдите в системном реестре ключ hkey _ local _ machine

\ System \ Currentcontroiset \ controi \ Nis \ codepage и измените следующие параметры:

"1250"=" cp _1251 . nls " "12 51"="ср_12 51. nls " "12 52"=" cp _12 51. nls "

После этого могут нормально заработать с русскими шрифтами и некоторые другие англоязычные программы.


Глава 15. Мультимедийные функции компьютера

  • Мультимедийные функции компьютера
  • Воспроизведение звука
  • Обработка звука
  • Воспроизведение видеоизображения
  • Воспроизведение компакт-дисков
  • Особенности настройки мультимедийного ПК
  • FAQ (ответы на часто задаваемые вопросы)


Мультимедийные функции компьютера

Сначала давайте разберемся, что представляют собой мультимедийные про граммы, какими особенностями они обладают по сравнению, например, с офисными программами.

Наверное, еще немало пользователей помнит те времена, когда "самым кру тым" процессором был Pentium (без номеров, т. е. первый). Именно тогда впервые появился термин "мультимедийный компьютер". Это означало, что на компьютере установлены такие устройства, как проигрыватель компакт- дисков и звуковая плата, позволяющие прослушивать музыкальные компакт- диски (так называемые аудиодиски). В качестве дополнительной услуги предполагалось хранение компьютерных данных на тех же самых дисках, которые поначалу изготавливались исключительно на заводе, и только отно сительно недавно обычные пользователи получили возможность самостоя тельно записывать как компьютерные, так и аудиодиски.

Из вышесказанного можно сделать вывод: все мультимедийные программы активно используют в своей работе:

  • проигрыватель компакт-дисков. Существует несколько типов приводов:
    • CD - ROM — позволяет проигрывать компакт-диски, предназначенные для бытовых проигрывателей компакт-дисков, копировать их содер жимое на жесткий диск и считывать информацию с так называемых компьютерных дисков, на которые может быть записана практически любая информация: от музыки в МРЗ-формате до игровых программ. Записывать на диски и стирать информацию с компакт-дисков все приводы CD - ROM не могут. И еще одно ограничение — невозмож ность работы с DVD -дисками;
    • CD - RW — пишущий привод CD - ROM , позволяющий не только считывать информацию с любых компакт-дисков, но еще и записывать на них данные. Современные приводы способны записать аудиодиск, компьютерный диск с данными, а также смешанные диски, содержа щие как звуковые дорожки, так и компьютерные данные. Для записи используются так называемые "болванки" (чистые компакт-диски). На диски заводского изготовления и те диски, на которые запись уже была произведена, записать что-либо уже не получится, хотя существуют специальные перезаписываемые диски. Более подробно этот во прос мы рассмотрим немного позже;
    • DVD - ROM — фактически это обычный "читающий" CD - ROM , но только с возможностью проигрывания DVD -дисков (также возможно копирование на жесткий диск). Все остальные функции практически идентичны первому типу приводов. Записывать ни обычные компакт- диски, ни DVD -диски они не могут.
  • Существуют также комбинированные приводы, например, CD - RW + DVD - ROM . Многие пользователи считают, что, купив такой аппарат, они смогут записывать даже DVD -диски, но это не так. Для DVD в таких приводах реализована только лишь функция чтения (копирования на же сткий диск);
  • звуковая плата — компонент любого мультимедийного компьютера, ко торый позволяет воспроизводить и записывать музыкальные файлы. По мимо всего этого на всех звуковых платах имеется разъем для подключе ния игрового джойстика или его модификаций (руля, штурвала и т. п.), который также применяется для подключения любых синтезаторов музы ки, использующих формат музыкальных файлов MIDI . Звуковые платы также имеют несколько модификаций:
    • интегрированные звуковые платы — фактически, это не звуковая плата, а часть материнской платы, занимающаяся обработкой звука;
    • звуковые платы, выполненные в виде платы расширения — такие зву ковые платы представляют собой полноценные устройства для обра ботки звука. Это выражается в меньшей нагрузке на центральный процессор при работе, а также в большем количестве и лучшей реали зации различных звуковых эффектов вроде реверберации, эффекта зала, пещеры и т. п., что особенно заметно в игровых программах;
    • внешние звуковые платы — как ни странно, существуют и такие. Все они, как правило, подключаются к шине USB и предназначены для тех ПК, на которых не имеется интегрированной звуковой платы, а свободных слотов для подключения платы расширения нет. Такая ситуация, например, может возникнуть у владельца старенького ноут бука или владельца материнской платы всего с двумя слотами расши рения (кроме слота AGP , естественно), один из которых занят сетевой платой, а второй — SCSI -контроллером сканера. Такая ситуация часто встречается в офисах.

В последнее время особенно заметно поднялась производительность персональных компьютеров, поэтому домашний компьютер помимо всего прочего активно стали использовать для просмотра видеофайлов: фильмов, клипов, домашних записей, так что функции современного мультимедийного ком пьютера немного расширились. В качестве дополнения появилась функция воспроизведения и записи видео, поэтому к компьютеру часто подключают такие устройства, как тюнер, позволяющий обойтись без телевизора и радиоприемника, платы для записи видеоизображения в компьютер и воспроизведения его с возможностью вывода на внешний источник (телевизор или видеомагнитофон). Зачастую функцией захвата видео обладают тюнеры, но качество их работы обычно оставляет желать лучшего, поэтому для профес сиональной работы с видео используются специализированные платы.

Вот и разобрались с тем, какие устройства используются при работе так называемых мультимедийных программ. Естественно, не обязательно должны использоваться все перечисленные компоненты ПК. Чтобы вам было проще понять суть вопроса, еще раз перечислим отличительные черты мультимедийных программ:

  • запись, обработка, воспроизведение звука;
  • запись, обработка, воспроизведение видео;
  • воспроизведение, запись компакт-дисков.


Воспроизведение звука

Для воспроизведения звука на персональном компьютере требуется, как минимум, наличие звуковой платы и акустических колонок или наушников. Естественно, что звуковая плата должна функционировать без сбоев и не должна вызывать зависаний компьютера.

Все распространенные сегодня версии Windows могут воспроизводить звуко вые файлы в формате WAV и МРЗ. Существует некоторое количество других стандартов на сжатие, например OGG , MP + и т. д. Зачастую для воспроиз ведения большинства имеющихся в природе форматов звуковых файлов достаточно установить программу вроде Winamp как можно более новой версии.

В качестве акустической системы можно использовать как компьютерные колонки, так и любой музыкальный центр. При этом придется вам приобре сти специальный переходник с разъема mini - jack (стерео) на разъем, кото рый используется на вашем центре, например типа "тюльпан".


Обработка звука

Под обработкой звука следует понимать любое изменение звукового файла, при котором изменяется качество, громкость и другие параметры его звуча ния. Наиболее распространенным типом обработки является кодирование файлов в формате МРЗ, при этом оригинальный файл сжимается в несколько

воспроизведения. Рассмотрим все немного подробнее.

Обработка звука разделяется на два типа:

  • "неискажающая" обработка — включает в себя все формы монтажа: вы резку, вклейку, наложение, копирование, перемещение;
  • "искажающая" обработка — включает в себя операции, изменяющие форму и структуру сигнала: смешивание, усиление, фильтрацию, модуля цию и т. п. При этом следует иметь в виду, что этот тип обработки может вносить непоправимые искажения в сигнал.

Нужно отметить, что все цифровые вычисления осуществляются по сетке — чем выше разрядность звукового файла, тем выше точность вычислений (меньше осуществляется округлений), но в любом случае полностью устра нить округление значений невозможно. Таков принцип работы цифрового оборудования. Для того чтобы уменьшить искажения, в профессиональных звуковых студиях используют 32-разрядный или хотя бы 24-разрядный звук, в то время как для любительской практики вполне достаточно 16- разрядного звука.

Несмотря на то, что качество сигнала неизбежно, хоть и незначительно, ухудшается при любой "искажающей" цифровой обрабо/гке, некоторые операции при определенных условиях являются полностью и однозначно обра тимыми. Например, усиление сигнала по амплитуде в три раза заключается в умножении каждого отсчета на три. Если эта операция выполнялась с фиксированной точкой и при этом не возникло переполнения (т. е. звук не зашкаливал), с помощью деления на три потом можно будет вернуть все отсчеты в исходное состояние, тем самым полностью восстановив первона чальное состояние сигнала. И в то же время, после умножения каждый от счет окажется увеличенным точно в три раза, поэтому ошибка относительно исходного аналогового сигнала, внесенная до этого, также увеличится в среднем в три раза, тем самым еще больше ухудшив общее качество сигнала.


Воспроизведение видеоизображения

Для воспроизведения видеоизображения на компьютере должен быть уста новлен драйвер поддержки данного формата кодирования, будь то MPEG 4 или DVD . Часто для установки поддержки того или иного формата кодиро вания вполне достаточно установить определенную программу, например для просмотра DVD устанавливают программу WinDVD .

Наиболее распространены форматы VCD (который имеет модификацию SVCD ), а также MPEG , в свою очередь имеющий множество версий — это DivX , XviD и т. д.

Вывод видеоизображения на обычный телевизор

Видеоплаты стали комплектоваться устройством TV - OUT , позволяющим вывести изображение на экран обычного телевизора, начиная с появления GeForce 2 MX . Это частично связано с нарастанием популярности формата MPEG 4.

Основной проблемой при подключении компьютера к телевизору является то, что в большинстве случаев видеоплаты с TV - OUT оснащены разъемом формата S - Video , а не привычным RCA ("тюльпан"). Хотя иногда встречает ся наличие обоих разъемов. В большинстве случаев при несовпадении разъ емов на видеоплате и на телевизоре рекомендуется пользоваться готовыми переходниками.

При подключении компьютера к телевизору обязательно следует отключить и то, и другое, а также отключить телевизионную антенну, что позволит вам обезопасить устройства от поломки в результате разницы потенциачов, ко торая может достигать 100 вольт.

При длине кабеля до 5 метров можно воспользоваться обычным экраниро ванным кабелем, используемым для бытовой аудио/видео техники. При большем расстоянии рекомендуется использовать коаксиальный кабель.


Воспроизведение компакт - дисков

Привод CD - ROM является прямым наследником бытовых проигрывателей компакт-дисков, поэтому первый его задачей является возможность воспро изведения тех же самых аудиодисков, что используются в бытовых аппара тах. К сожалению, основная масса производителей в последнее время мало уделяет внимания поддержке дисков с записью звука, возможно, полагая, что они уходят в прошлое.

Для воспроизведения компакт-дисков различных форматов требуется под держка как от самого привода, так и от программного обеспечения (опера ционной системы). Все версии операционной системы Windows имеют встроенные драйверы для приводов CD - ROM , поэтому с воспроизведением компакт-дисков особых проблем не должно возникать. Другое дело, операционная система MS - DOS , в которой для поддержки привода требуется загрузить специальный драйвер.

Термин " CD - ROM " произошел от фразы " Compact Disk Read Only Memory ", т. е. компакт-диск, предназначенный только для чтения. Фактически, это ответ на многочисленные вопросы: "А можно ли записать на мой музыкаль ный диск другую музыку?", "Если все-таки можно, то как?" и т. п. Ответ очень прост: на компакт-диски, купленные в магазине, т. е. изготовленные Промышленным способом, записать что-либо нельзя.

Несмотря на то, что производители компакт-дисков заявляют, что данные на них могут храниться от 70 до 200 лет, еще никто не видел столь долго вечного диска. В основном, срок использования отдельного взятого диска ограничен такими факторами, как появление царапин и потертостей на по верхности, обращенной к считывающей головке привода, а также появление царапин из-за влияния окружающей среды.

Для самостоятельной записи компакт-дисков применяются специальные "болванки", которые изготавливаются по технологии немного отличной от обычной, но об этом мы поговорим чуть позже.

Различают технологические диски ( OEM ) и "болванки", самостоятельно за писанные пользователем. Они очень сильно отличаются как применяемым материалом, так и в некоторой степени структурой материала, что влияет на качество чтения. Считается, что технологические диски обычно считывают- ся на более высоких скоростях, чем те диски, которые записаны пользовате лем. В основном это связано с тем, что приводы разработаны в расчете именно на первый тип дисков, а поддержка "самописаных" дисков появи лась уже позже, с распространением пишущих приводов. Очень часто ста рые приводы CD - ROM , особенно со скоростью чтения ниже 24х, крайне плохо читают второй тип дисков.

Скорость воспроизведения ( копирования )

Практически единственным параметром "читающего" привода CD - ROM яв ляется скорость вращения дисков, которая обозначается условно как 24х, 40х, 52х. Мало кто знает, что же на самом деле означают эти загадочные цифры.

В качестве условной единицы принята скорость вращения обычного аудио- диска в бытовых проигрывателях. Это по большей части необходимо для совместимости как раз с аудио компакт-дисками, т. к. для компьютерных дисков кратность скорости не играет большой роли. Скорость передачи данных при "единичной" скорости равна 150 Кбит/с, скорость передачи при этом вычисляется умножением на указанный рядом с символом "х" множи телем. Например, привод 52х имеет скорость передачи данных 7600 Кбит/с.

Самый главный секрет приводов CD - ROM заключается в том, что указан ная в маркировке модели скорость является пиковой. То есть она может быть достигнута только в тех случаях, когда компакт-диск не имеет царапин на поверхности, при его производстве были соблюдены все технические усло вия, а механизм привода (в частности, оптика) не загрязнен. Как видите, все условия соблюсти крайне тяжело, особенно в наше время, когда большая часть предлагаемых нам дисков является ни много ни мало пиратскими, т. е. произведенными кустарными способами обычно далекими от совер шенства. Поэтому в большинстве случаев компакт-диск вращается с куда меньшей скоростью, чем можно предположить, исходя из названия привода. В реальной практике скорость вращения диска постоянно меняет ся в зависимости от качества записи, наличия пятен или царапин — как только появляется ошибка при чтении данных, автоматически дается ко манда на снижение скорости вращения. При скорости вращения более 16х начинают сказываться физические параметры диска: неравномерность тол- шины, геометрический эксцентриситет, что вызывает не только повышен ный уровень шума, но и увеличение количества ошибок. Многие приводы восстанавливают значение скорости только после смены диска.

Еще один момент, сильно влияющий на текущую скорость вращения дис ка _ неравномерность записи данных на поверхности диска. На внешней стороне диска секторы с данными располагаются на большем расстоянии, чем на внутренней его стороне, поэтому при считывании информации вначале диск вращается медленнее, а затем скорость вращения увеличивается. Это делается в основном, чтобы сделать незаметным для пользователя раз ницу в скорости считывания информации из разных точек диска. На прак тике же реальная скорость считывания постепенно падает, что легко можно заметить по счетчику времени, указывающему на время оставшееся, например, до окончания процесса копирования, которое периодически может увеличиваться.

Существует ряд программ, позволяющих практически вручную управлять скоростью вращения компакт-дисков, что дает, во-первых, возможность уменьшить уровень шума, издаваемый при работе CD - ROM . Во-вторых, по зволяет прочитать "трудные" диски, которые плохо читаются на максимальных скоростях. И в-третьих, сильно увеличивает срок службы привода, т. к. при этом его механика меньше изнашивается и уменьшается вероятность разрыва компакт-дисков, на которых имеются трещины. Наиболее популяр ны такие программы, как CD Slow или Nero Drive Speed , которая входит в комплект программного пакета Ahead Nero .

Автоматический запуск программ

Секрет автоматического запуска программ с компакт-диска хранится в ма леньком файле под названием AUTORUN . INF , который размещается в корневом каталоге диска и позволяет выполнять целый ряд действий:

  • установка для диска указанного ярлыка, что позволяет сделать диск от личным от других;
  • запуск любой программы, что позволяет при установке диска в привод открывать удобную оболочку, облегчающую установку программ или просмотр всех файлов, находящихся на данном компакт-диске. Например, на компакт-диске с фильмом может предлагаться установка про грамм, необходимых для просмотра данного формата, а также автомати ческий запуск просмотра.

Простейший вариант файла AUTORUN . INF может выглядеть следующим образом:

[Autorun]
      icon=icon.ico
      open=autorun.exe

При написании файла его структура должна придерживаться следующих правил.

Во-первых, перед всеми параметрами должна присутствовать строка [ Autorun ].

В качестве параметров могут быть следующие команды:

  • Open — командная строка, автоматически выполняемая при вставке дис ка или при выборе в контекстном меню диска пункта Автозапуск. Например:

Open = Autorun . exe ИЛИ Open = Notepad . exe List . txt ;

  • Icon — полные путь, имя файла со значком и номер значка в нем. Формат: icon = fiie . exe , n , где fiie . exe — полные путь и имя файла со значком, an — номер (отсчет начинается с нуля) значка в файле;
  • Shell \ name — описание дополнительного пункта контекстного меню дис ка. Формат:
  • ShelI \ mname = mtext
    • Shell\ mname \ Command = cmdline , где mname — ИМЯ Пункта Меню, ratext — текст Пункта меню, cmdline —
  • командная строка, выполняющаяся при выборе этого пункта меню.
  • Если параметр sheii \...\ command указан без параметра sheii \..., то в меню будет выведен либо системный текст, либо имя пункта меню.

Файлы Autorun . inf могут работать не только на компакт-дисках, но и на дискетах и других типах съемных накопителей. Для этого надо с помощью любой программы тонкой настройки Windows включить автозапуск со съем ных дисков.

Временно отменить автозапуск можно несколькими способами:

  • перед установкой компакт-диска в привод нажмите одну из клавиш < Shift > на клавиатуре и удерживайте ее нажатой до тех пор, пока лоток привода не закроется и лампочка на приводе не перестанет моргать. Честно говоря, такой способ не всегда работает, по крайней мере, в Window 98 SE , поэтому, если вам очень нужно избежать автозапуска, используйте второй способ;
  • установите компакт-диск, пока операционная система еще не загрузи лась, но в этом случае следует быть осторожным, т. к. почти все при воды автоматически закрывают лоток в момент определения устройств, подключенных к контроллеру IDE , т. е. в самом начале запуска компью тера, а некоторые модели закрывают его еще и при каждом обращении операционной системы. При этом вы можете просто не успеть устано вить диск в лоток, и при закрытии он будет "закушен", что вполне может привести к появлению на нем серьезной царапины.

Можно, конечно, вообще отключить автоматический запуск компакт- дисков, но при этом некоторые игровые программы не будут работать.

Если вы желаете отключить автозапуск компакт-дисков, это можно сделать, изменив следующий ключ в системном реестре:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CDRom

Параметр Autorun должен иметь значение о при отключенной функции ав тозапуска или значение 1 при включенной функции. На автозагрузку влия ют также следующие два ключа :

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\ Explorer NoDriveTypeAutoRun = 0x00000095

HKEY_USERS\.DEFAULT\Software\Microsof t:\Windows\CurrentVersion\Policies\ Explorer NoDriveTypeAutoRun = 0x00000095

Их корректное значение должно быть равно 0x00000095.

Копирование аудиодисков на жесткий диск

Для копирования музыки с аудиодисков требуется привод, поддерживающий режим чтения RAW Sectors ("сырых" секторов) и специальная программа, так называемый grabber (все-таки подобное копирование нельзя считать законным, т. к. способствует распространению пиратских копий). Такая программа считывает "сырые" сектора, вырезает из них "чистые" аудиоданные и записывает их на жесткий диск в формате WAV . Из-за незна чительных различий в протоколах и форматах команд некоторые приводы могут не работать с рядом программ. В этом случае остается подбирать ту программу, которая будет нормально копировать звук именно с вашей мо делью.

Вышесказанное говорит о том, что простое копирование файлов с аудио- диска не даст никакого эффекта, якобы скопированная музыка не будет проигрываться.

Большая часть программ (например, Audiograbber ) копируют музыку с дис ка, минуя звуковую плату, что позволяет избежать искажений, вносимых цифро-аналоговым преобразователем.

В списке большинства "грабберов" имеются следующие возможности:

  • нормализация звука — при этом уровень громкости звука приводится к одному определенному уровню, например, 98%;
  • поддержка онлайновой базы данных — при этом достаточно подключиться к сети Интернет, чтобы названия треков были введены автоматически. Естественно, что данный компакт-диск должен иметься в специальной ба зе данных, при этом имеется один маленький нюанс. В этой базе содер жатся описания только лишь лицензионных дисков, а для пиратских дис ков там места не нашлось (кстати, по вполне естественным причинам);
  • кодирование музыкальных файлов — при этом кодировать можно как встроенными кодеками, такими как WMA или МРЗ, так и внешними, например, OGG .

Запись компакт - дисков

Компакт-диски, предназначенные для записи, имеют название CD - R ( CD - Recordable , записываемый CD ) или CD - RW .

Чтобы успешно записывать компакт-диски, следует понять некоторые осо бенности функционирования приводов CD - RW , а также получить понятие ряда терминов, что мы сейчас и сделаем.

Любой пишущий привод позволяет записывать компакт-диски за счет ис пользования в нем лазера повышенной мощности. Именно поэтому "чи тающие" приводы не могут записывать диски — электроника и оптика у них не предназначены для работы с лазером повышенной мощности. При своей работе CD - RW как бы выжигает на диске канавки, которые соответствуют логической единице (незатронутые лазером места играют роль логических нулей), что позволяет на "компьютерном языке" записывать информацию. Для записи звуковой информации используются отдельные дорожки, так называемые треки (от английского слова Track ). Компьютерные данные записы ваются в виде непрерывного массива. Запись всегда начинается от внутрен него края диска, поэтому возникновение трещины на прижимном кольце быстро приводит к фактической невозможности считывания информации с диска, т. к. в первую очередь теряется вся служебная информация. Чистые компакт-диски, предназначенные для самостоятельной записи, очень часто называют "болванками", что, в общем-то, соответствует исти не — при производстве болванкой считается заготовка, после обработки ко торой и получается изделие.

Процесс записи можно разделить на несколько этапов:

  • запись непосредственно данных;
  • запись метки начала записи ( Lead - in ) и метки конца записи ( Lead - Out );
  • запись таблицы содержания сессии (ТОС-таблица, Table of Contents , фак тически аналог FAT -таблицы жесткого диска). Этот процесс называется "финализацией" компакт-диска. После "финализации" все данные, рас положенные на диске, становятся доступными для чтения. Если в момент записи ТОС-таблицы прервать запись (например, если "моргнет" свет), то можно считать и диск, и данные безнадежно утерянными;
  • по окончании записи всей информации диск "закрывается", т. е. выпол няется так называемая фиксация диска, после чего запись на него стано вится невозможной даже в том случае, если на нем имеется свободное место. Естественно, можно не "закрывать" диск, оставив при этом возможность записи, но при этом некоторые старые приводы и бытовые проигрыватели не смогут считать с него информацию.

В случае, когда данные на диск записываются в несколько приемов, счита ется, что диск является мулытшсессионным , при этом диск может использо ваться после записи каждой сессии. Впоследствии, когда дописывается еще одна или несколько сессий, меняется служебная метка, указывающая на более новую версию ТОС-таблицы, содержащую ссылки на все данные. Если речь идет о аудиодисках, то в них ТОС-таблица записывается в начале диска и изменению уже не подлежит, поэтому многие бытовые проигрыватели способны прочитать только те треки, которые были записаны за первый се анс записи. Компьютерный привод без проблем читает все треки, т. к. в нем используются другие методы поиска служебной информации. При записи компакт-дисков возможно применение следующих методов:

  • Track At Once — этот режим записи позволяет записывать диск за несколько сеансов. Записанный таким образом аудиодиск можно будет прочитать на бытовом проигрывателе только после "фиксации". При этом между дорожками, записанными в разные сеансы, будет пауза;
  • Disk At Once ( DAO ) — это режим записи, когда диск записывается за один сеанс. При этом сначала на диск записывается метка, обозначаю щая начало записи ( Lead - in ), затем записываются непосредственно дан ные, а уже в конце записи — метка, которая обозначает конец записи ( Lead - Out ). Этот метод рекомендуется применять для изготовления матрицы, которая впоследствии будет использоваться, например, для тиражирова ния дисков. При записи аудиодисков в этом режиме исчезают паузы между треками (дорожками);
  • MultiSession — режим записи, позволяющий добавлять новую информа цию к ранее записанной. Таких сессий на одном диске может быть мно жество. Каждая сессия будет содержать запись начала ( Lead - in ), затем непосредственно данные и финальную информацию о сессии ( Lead - Out ). При записи в режиме мультисессии, информация о структуре предыду щих записей копируется в новую сессию и может быть изменена. Таким образом, при записи можно стереть ссылки на информацию, записанную ранее. С одной стороны, это возможность "стирания" данных с компакт- диска, но физически они продолжают оставаться на нем, т. к. уничтожа ются только ссылки на них. У данного режима записи существует опре деленный недостаток — отделяя одну сессию от другой, каждый раз теря ется около 13,5 Мб (на запись ТОС-таблицы, содержащей ссылки на вновь записанную информацию). Соответственно, чем больше сессий записано на диске, тем больше теряется места. Кроме того, некоторые модели CD - ROM не могут считывать диски, записанные в этом режиме, а другие имеют ограничение на число видимых ими сессий.

Объем компакт - дисков

Существует три распространенных стандарта на объем компакт-дисков:

  • 650 Мбайт (74 мин) — морально устаревший стандарт, не позволяющий записать многие современные игры. Некоторые производители указыва ют объем на дисках 680 Мбайт, что не совсем верно. В компьютерном "мире" принято считать, что в одном килобайте 1024 байт, а не 1000. Именно во втором случае получается эта нескромная цифра 680. Доказа тельством сказанного является неизменный объем диска в минутах, кото рый в любом случае остается равным 74 минутам;
  • 700 Мбайт (80 мин) — наиболее распространенный стандарт, поддержи ваемый не только компьютерными приводами, но и бытовыми проигры вателями компакт-дисков. Поначалу качество хранения информации на таких дисках было не очень хорошее, но на сегодняшний день абсолютно никакой разницы между 650- и 700-мегабайтными дисками по качеству записи нет;
  • 800 Мбайт (90 мин) — довольно мало распространенный стандарт дис ков, т. к. он требует поддержки от привода специальной технологии, по зволяющей запись в области, обычно используемой для хранения слу жебной информации. Обычно такие диски не совместимы ни со старыми компьютерными приводами (даже CD - RW ), ни с бытовыми проигрыва телями, хотя, конечно, встречаются исключения. Хранить ценную ин формацию на таких дисках можно только в том случае, если записывае мый объем не превышает 700 Мбайт.

Скорость записи компакт - дисков

Немаловажной при записи компакт-дисков является скорость вращения диска. Так же, как и в случае с воспроизведением компакт-дисков, за еди ницу принимается скорость вращения обычного аудио компакт-диска.

Сегодня существуют пишущие приводы, позволяющие производить запись до 52х, что, на мой взгляд, является избыточным. Диапазон скоростей записи может быть:

1х, 2х, 4х, 6х, 8х, Юх, 12х, 16х, 20х, 22х, 24х, 26х, 28х, 32х, 40х, 52х.

Некоторые современные модели приводов не имеют возможности записи, например, на скорости ниже 4х, что в принципе уже не является ограниче нием, т. к. наиболее распространены сегодня "болванки", рассчитанные на скорость записи 16—32х.

Следует иметь в виду, что при увеличении скорости записи прямо пропор ционально возрастает вероятность появления ошибок при записи и появле ния участков, которые впоследствии с трудом можно будет считать даже на этом же приводе, не говоря о других.

При записи аудиодисков рекомендуется выбирать скорость записи не более 8х, что увеличит шансы нормального воспроизведения на бытовых проигрывателях. Более высокие скорости могут привести к различным искажениям, например, в местах, где система защиты от опустошения буфера временно прекращала за пись. Наивысшее качество звучания и наибольшую долговечность для аудио- дисков можно гарантировать только при записи на скорости 1х. При записи компьютерных данных особые рекомендации дать сложно, главное здесь придерживаться рекомендаций производителя "болванок" и не превышать скорости, указанной на диске, а лучше держать скорость записи в районе 16—32х.

Форматы записи компакт - дисков

Существует несколько форматов записи, позволяющих хранить на одних и тех же дисках как звуковую информацию, так и компьютерные данные, а также свободно комбинировать их.

Основополагающим форматом является стандарт CDDA , который использу ется для записи аудиодисков, предназначенных для проигрывания в быто вых проигрывателях или компьютерных приводах CD - ROM . Иногда этот стандарт называют " Red Book " ("красная книга"). Такое название произошло от цвета обложки книжки, в которой он был описан.

Все остальные форматы записи, которые используются для хранения ком пьютерных данных, являются производными от CDDA и, по традиции, имеют названия — " Yellow Book " ("желтая книга"), " Green Book " ("зеленая книга"), " Orange Book " ("оранжевая книга"), " White Book " ("белая книга"), " Blue Book " ("синяя книга").

Практически все форматы относятся скорее не к записи диска в целом, а к формату отдельных дорожек, что позволяет создавать диски, содержащие дорожки различных форматов (такой режим записи называется Mix Mode ). Естественно, что для работы с такими комбинированными дисками требуется привод, поддерживающий каждый из примененных форматов по отдельности.

Какие " болванки " покупать ?

Существует две разновидности "болванок".

  1. 1. Brand - Name — они выпускаются с уже нанесенным на поверхность логотипом производителя и полиграфической вставкой. Надписи на них можно наносить только специальным маркером или фломастером. Обычный маркер слишком долго сохнет, что может привести к размазы ванию надписи в результате эффекта центробежной силы во время вра щения диска. Такие диски обычно пакуются в пластиковые коробки, за тянутые защитной пластиковой пленкой. Десять дисков обычно собираются в коробку.
  2. 2. OEM — это так называемые диски для производства. Такие диски на внешней поверхности не имеют никаких надписей или рисунков, т. к. они предназначены для печати графики и текста при помощи специальных CD -принтеров. Обычно OEM -диски упакованы в стопки (тубы) или в стопки на осях. Огромный недостаток второй разновидности — повы шенная опасность повреждения информационного слоя, т. к. у brand - name - дисков внешняя поверхность защищена слоем краски, чего нет у ОЕМ- дисков. Иногда доходит до того, что небольшая царапина на внешней по верхности диска приводит к осыпанию всего информационного слоя.

На каждой "болванке" обозначается, для какой скорости записи она предна значена. При этом существуют как универсальные диски, рассчитанные на запись при скоростях от 1х до 40х, так и "узкоспециализированные", напри мер 8—16х. Очень часто запись может вестись на скоростях выше указанной скорости на диске. Этого делать крайне не рекомендуется, т. к. в этом слу чае резко увеличиваются шансы появления сбоев, если не при записи, так при последующей эксплуатации.


Особенности настройки мультимедийного ПК

Характерной особенностью любых мультимедийных программ является счи тывание большого объема последовательной информации с накопителя. Сразу же всплывает в памяти проблема фрагментации файлов, но и помимо нее существует немалое число нюансов, вызывающих проблемы при работе мультимедийных программ.

В первую очередь следует отметить, что при работе со звуковыми и, особен но, с видеофайлами требуется регулярно проводить полную дефрагментацию жесткого диска. Это позволит устранить "подергивание" изображения, "заи кание" звука и все подобные проблемы.

Наиболее важным обстоятельством во всей настройке компьютера для работы с мультимедийными программами является хорошая оптимизация скорости работы операционной системы с жестким диском или другим носителем, т. к. именно только это в основном и "тормозит" работу всего компьютера в це лом. Оперативная память и центральный процессор, также активно участ вующие в процессе обработки данных, работают намного быстрее любого жесткого диска, и им приходится ожидать, когда же, наконец, будет считан или записан следующий пакет информации.

Настройка " железа "

Особое внимание при оптимизации работы жесткого диска нужно обратить на следующие моменты:

  • запустите программу CMOS Setup Utility ( BIOS Setup ) и проверьте со стояние параметров:
    • 32- Bit Disk Access — функция должна быть включена ( Enabled ). Вклю чает 32-битный доступ к жесткому диску, ускоряющий его работу;
    • IDE Buffer for DOS & Windows — данная функция должна быть вклю чена ( Enabled ). Она включает специальный буфер упреждающего чте ния и отложенной записи, что увеличивает пропускную способность IDE -каналов, преимущественно используемых на домашних компью терах;
    • IDE Burst Mode — функция должна быть включена ( Enabled ). Она включает полноценную поддержку буфера данных расположенного на любом современном жестком диске;
    • IDE HDD Block Mode Sectors — параметр должен иметь значение HDD MAX или похожее по смыслу (например, просто МАХ). Позво ляет неплохо поднять производительность за счет одновременной пе редачи нескольких пакетов информации за один раз.

Также должны быть включены все параметры, имеющие в своем названии термин UDMA или похожий по смыслу (например, просто DMA ). Это по зволит включить специальную схему на материнской плате, позволяющую передавать данные без участия центрального процессора. При этом ему вполне достаточно активировать процесс, например копирования, после чего все данные будут проходить через так называемые каналы DMA . Есте ственно, что все устройства должны поддерживать работу в этом режиме, в противном случае выигрыша от использования этого режима работы не будет — это относится как к жесткому диску, так и к приводу CD - ROM .

Есть несколько особенностей работы устройств с поддержкой режима DMA (чаще называют этот режим как UDMA — Ultra DMA ).

  1. 1. Устройства, поддерживающие работу в DMA -режиме, должны быть под ключены отдельно от устройств, не поддерживающих ее. Если вы, на пример, подключите к одному соединительному шлейфу современный жесткий диск и старый CD - ROM , не поддерживающий работу с DMA , тогда ваш винчестер будет работать с такой же скоростью, как и CD - ROM (речь идет о скорости передачи данных по кабелю). Подключите все устройства без поддержки DMA ко второму каналу IDE , а все те уст ройства, которые нормально работают с DMA , к первому каналу. Это по зволит использовать все потенциальные возможности того же жесткого диска, хотя не решит проблему медленной работы старых устройств.
  2. 2. Для полноценной поддержкп работы каналов DMA в операционной сис теме вы должны совершить одно из нижеописанных действии:
    • если вы используете операционную систему семейства Window 9 x , тогда запустите ярлык Система из Панели управления. После этого в свойствах каждого дискового устройства и привода CD - ROM / CD - RW и т. п. укажите, что следует использовать каналы DMA , после чего пе резагрузите систему. Если одно из устройств все-таки не поддерживает этот режим работы, вы получите как минимум нестабильно работаю щий компьютер, а то и вообще не сможете загрузить операционную систему, поэтому будьте осторожны и не экспериментируйте без необ ходимости;
    • для поддержки современных стандартов UDMA 100 и UDMA 133 сле дует использовать специальные 80-жильные соединительные кабели. Если вы подключите устройство (например, жесткий диск) при помо щи обычного 40-жильного кабеля, то максимальная скорость передачи будет не более, чем 33 Мбит/с, т. е. будет использоваться уже мораль но устаревший режим UDMA 33;
    • если вы используете операционную систему Windows 2000/ XP , то, скорее всего, DMA -каналы уже подключены, но никогда не мешает в этом еще раз убедиться, открыв вкладку Диспетчер устройств и про смотрев Свойства контроллера IDE АТА/АТАРГ (как первого, так и второго);
    • особенностью Windows 2000 является некорректная работа с некото рыми чипсетами производства Intel , что проявляется в невозможности включения поддержки DMA , что решается.

Убедиться в том, что какое-либо устройство действительно поддерживает работу с каналами DMA , можно, остановив на время загрузку компьютера в момент, когда на экране монитора появляется таблица с краткими характеристиками компьютера. Она появляется обычно перед началом загрузки операционной системы. Для того чтобы вы могли внимательно изучить ее, придется воспользоваться клавишей < Pause / Break >.

Конечно, оптимизацией дисковой подсистемы можно добиться многого, но ничто так не повышает производительность мультимедийных программ, как большой объем оперативной памяти. Сегодня можно рекомендовать объем не менее 256 Мбайт, а лучше 512 Мбайт или даже 1 Гбайт. В последнем слу чае вам не придется прибегать ко всем перечисленным ниже способам оп тимизации, т. к. все они направлены на улучшение работы виртуальной па мяти (файла подкачки, который расположен на жестком диске). Здесь же вы имеете возможность отключить ее использование, что не только увеличит производительность ПК, но и освободит дополнительное место на диске. Стоит отметить, что тактовая частота центрального процессора особой роли не играет, если вы используете компьютер для прослушивания звуковых файлов или же для просмотра видеоизображения. Даже компьютер на базе процессора Celeron 433 вполне способен справиться с фильмом в формате MPEG 4 высокого качества. Здесь присутствует только один нюанс — чем выше тактовая частота процессора, тем вам меньше придется думать об оп тимизации работы операционной системы и программ.

Если же вы профессионально занимаетесь обработкой звука или видеоизоб ражения, тогда вам наверняка следует выбирать процессор с тактовой часто той повыше, т. к. это позволит сократить время, например просчета проекта или применения какого-нибудь эффекта, в общем, сделает вашу работу бо лее приятной.

Настройка операционной системы

После того как все аппаратные возможности оптимизации работы жесткого диска включены, можно приступить к настройке программного обеспече ния, в том числе и операционной системы. Сразу стоит отметить, что опе рационные системы семейства Windows NT , как правило, не нуждаются в дополнительной настройке, особенно это относится к Windows XP , кото рая даже на компьютерах со средней конфигурацией показывает намного лучшие результаты работы любых мультимедийных программ, чем, напри мер, Windows 98. Хотя из каждого правила существует ряд исключений, по этому мы рассмотрим все возможные варианты.

Для операционных систем семейства Windows 9 x наиболее интересна про грамма под названием CacheMan , которая позволяет оптимизировать размер виртуальной памяти и всевозможные буферы под аппаратную конфигура цию вашего компьютера. Ни для кого ведь не секрет, что любая версия Windows устанавливается с усредненными значениями всех параметров.

По поводу оптимизаторов оперативной памяти хотелось бы сказать следующее: все они время от времени блокируют обращение к оперативной памяти либо сильно уменьшают скорость работы с ней, что отрицательно сказыва ется на работе любых мультимедийных программ. Особенно нежелательно при этом использование программ, "на лету" сжимающих информацию в оперативной памяти ( ZIP Memory ).

Отдельное слово следует сказать о совместимости мультимедийных про грамм почти с любыми антивирусными мониторами, которые иногда делают невозможной работу с видеоизображением или звуком. Конечно, они по зволяют защитить компьютер от деструктивного воздействия вирусов, но в данном случае лучше их хотя бы временно отключать. Особой "нелюбо вью" отличается программа Kaspersky Anti - Virus версии 4.0 и выше (возможно из-за того, что она рассчитана на работу на мощных ПК, а не на средних конфигурациях, как зачастую можно наблюдать).


FAQ ( ответы на часто задаваемые вопросы )

Вопрос: Не работает автозапуск для привода CD - ROM , хотя раньше работал. Тем более что проверил, автозапуск в свойствах привода включен. Что делать?

Ответ: Иногда такое встречается и "лечится" ручным редактированием системного реестра. При этом нужно сначала удалить нижеследующий ключ, перезагрузить ПК, а затем вновь его создать. Речь идет о ключе

[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Policie s\ Explorer] С параметром "NoDriveTypeAutoRun"=hex:95, 00,00, 00

Если у вас имеется какая-нибудь программа для тонкой настройки системы, тогда возможно проще будет воспользоваться именно этой программой.

Вопрос: Перезагрузил компьютер в режиме эмуляции MS - DOS , после чего пропали привод CD - ROM и курсор, хотя при зафузке с компакт-диска (Реаниматора) они не пропадают. В чем дело?

Ответ: Чтобы в режиме MS - DOS (не в окне эмуляции) включить поддержку привода CD - ROM и манипулятора мышь, следует загрузить соответствующие драйверы. Когда вы загружаетесь с зафузочного компакт-диска, там, в файлах конфигурации, уже имеется ссылка на подобные драйверы, поэтому после зафузки все устройства доступны, а когда вы зЪфужаете компьютер в режиме эмуляции MS - DOS , требуется ручной запуск этих драйверов. Если вам часто приходится работать в среде MS - DOS и вам нужно загру жаться именно с жесткого диска, а не загрузочной дискеты или же компакт-диска, тогда внесите изменения в файл DOSSTART . BAT , который использу ется системой для запуска всех драйверов, необходимых для работы в среде MS - DOS . Естественно, что файлы драйверов должны находиться в доступ ном месте на жестком диске, в противном случае они не будут зафужены в память компьютера.

Стоит отметить, что файл DOSSTART . BAT находится в рабочем каталоге Windows .

Вопрос: Записывая очередной компакт-диск, обратил внимание, что потра ченное на его запись время значительно больше обычного. Может быть, привод перегрелся?

Ответ: Причина, скорее всего, в том, что в процессе записи часто опусто шался буфер записи, из-за чего система снижала скорость записи. Такое может произойти из-за запуска "тяжелых" программ во время записи, например, таких как Adobe Photoshop и ему подобных. Если такая ситуация повторяется часто, попробуйте отключить от шлейфа, к которому подклю чен пишущий привод, другие устройства, особенно если они не поддержи вают работу с DMA -каналами. И старайтесь не зафужать свой компьютер во время записи компакт-дисков.


Глава 16. Работа в сети Интернет

  • Что такое Интернет и для чего он нужен?
  • Как подключиться к Интернету?
  • Как работает Интернет?
  • Модемное соединение с Интернетом
  • Что такое электронная почта?
  • Что нужно для работы с Web-сайтами?
  • Соединение двух компьютеров посредством модема
  • Опасности, подстерегающие нас в Интернете
  • FAQ (ответы на часто задаваемые вопросы)


Что такое Интернет и для чего он нужен ?

Интернет — это глобальная сеть, объединяющая офомное количество ком пьютеров по всему земному шару. Наиболее интересная особенность Ин тернета — независимо от физического расположения компьютеров, доступ к ним осуществляется абсолютно одинаково. Единственное ограничение — чем дальше находится компьютер, который вас интересует, тем дольше может происходить соединение из-за большого числа промежуточных узлов, через которые проходят сигналы. Стоит также отметить, что это не всегда верно, потому что скорость передачи данных не обязательно зависит от того, насколько удалены друг от друга компьютеры (об этом поговорим чуть позже).

Самое главное преимущество глобальной сети Интернет — возможность удаленного доступа к другим компьютерам. Это дает возможность получения доступа к разным базам данных и т. д. Если говорить о предоставляемых сетью Интернет услугах более подробно, то их можно разделить на следую щие виды:

  • доступ к различным базам данных посредством так называемых Web - сайтов, что позволяет получать, например, информацию о продукции, предоставляемой тем или иным производителем. Любой Web -сайт пред ставляет собой набор текстовых файлов с целым рядом служебных ко манд, вставленных между абзацами, которые позволяют украсить внеш ний вид сайта, увеличить функциональные возможности до широких пределов, например, добавить функции перехода с одной страницы на другую, скачивания файлов и прочее;
  • возможность пересылки электронных сообщений с одного компьютера на другой или даже на целый ряд компьютеров сразу. Причем можно пе ресылать не только текстовые сообщения, но и различные файлы, на пример документы, картинки и программы;
  • доступ к удаленным дискам, что позволяет копировать различные файлы и даже каталоги на свой компьютер.


Как подключиться к Интернету ?

Чтобы начать работу в глобальной сети Интернет, нужно купить и подключить к своему компьютеру оборудование для связи с провайдером ( Internet Service Provider , ISP ) — так называется организация или частное лицо, пре доставляющее услуги по доступу к сети Интернет. Второй шаг — это заключение договора на предоставление соответствующих услуг. В большинстве случаев даже рекомендуется начинать именно со второго шага, т. к. провай деры зачастую сами предлагают установку оборудования и его настройку. В таком случае вы, скорее всего, получите именно такую модель того же модема, который будет хорошо работать с модемом, установленным на ком пьютере провайдера.

Наиболее распространенными являются два типа подключения к сети Ин тернет:

  • коммутируемое соединение посредством модема или спутниковой тарелки — это временно существующий канал связи с сетью Интернет, который организуется на время работы в сети;
  • постоянное соединение посредством выделенной линии или той же спутниковой тарелки — главное отличие данного типа подключения — это наличие постоянного доступа к ресурсам сети Интернет.

Сразу стоит отметить, что существует несколько видов оплаты услуг про вайдера.

  • "Повремянка" — вы платите только за время, проведенное в сети незави симо от того, что вы делаете, читаете ли новости или качаете файлы.
  • "Повремянка плюс трафик" — вы платите за время, проведенное в сети, и плюс к этому оплачиваете каждый полученный (иногда и отправленный) мегабайт, что в итоге может оказаться более выгодным, если, например, вы проводите приличное количество времени за чтением новостей, не отключаясь от сети.
  • "Абонентская плата" — вы платите фиксированную сумму, в которую за частую входит строго определенный трафик, по исчерпании которого ка ждый мегабайт оплачивается отдельно.

Трафик — это объем данных (как правило, исчисляется в мегабайтах), кото рый ваш компьютер получил из сети Интернет. Некоторые провайдеры включают в трафик и объем данных, исходящий из вашего компьютера. Об ратите внимание на то, что этот термин очень широко применяется в раз личных форумах и конференциях на данную тему (Интернет и прочее). Иногда под термином "трафик" подразумевается сам поток данных, а не его объем, например, "трафик неустойчивый".


Как работает Интернет ?

Работа сети Интернет основана на тех же принципах, что и работа любой локальной сети, но с небольшими изменениями, точнее нововведениями.

Как и в любой другой сети, при подключении к сети Интернет каждый компь ютер получает собственный уникальный IP - adpec , который позволяет отправ лять каждый запрос именно на тот компьютер, которому он был адресован. Если компьютер подключен к сети Интернет постоянно, то он получает статический IP -адрес, а вот с компьютерами, которые используют коммутируемое соединение, ситуация несколько иная. Как известно, IP -адрес имеет форму ХХХ.ХХХ.ХХХ.ХХХ, где XXX — число от 0 до 254. В итоге получается впечат ляющее количество уникальных IP -адресов. Все эти адреса поделены на опре деленные группы (диапазоны), которые распределены между провайдерами, т. е. каждый провайдер получает в свое распоряжение строго определенный диапа зон адресов, например, от 192.168.109.0 до 192.168.110.254. Все адреса указан ного диапазона провайдер может назначать компьютерам, которые при по мощи его оборудования соединяются с Интернетом. Один IP -адрес автоматически назначается самому провайдеру, а все остальные доступны для использования. Таким образом, ваш компьютер независимо от способа подключения может получить адрес только из диапазона, используемого вашим провайдером.

При коммутируемом соединении каждому компьютеру назначается IP -адрес из того диапазона, который выбрал провайдер (используется не весь доступный диапазон, а только часть его). Причем каждый раз при подключении, например, ваш компьютер может получить совершенно другой IP -адрес, т. к. прежний может быть занят другим компьютером, который подключил ся к Интернету раньше вас. Это динамический IP -адрес. Если вы подключе ны к сети посредством выделенной линии, то вам будет дан статический IP - адрес.

Примечание Если ваш компьютер подключен не только к сети Интернет , но и к локальной сети , то IP - адреса компьютеров локальной сети должны находиться в диапазо не , разрешенном или , точнее сказать , принятом для использования в локаль ных сетях . В противном же случае возможно появление конфликтов из - за обращения к компьютеру в Интернете с таким же IP - адресом , что и у одного из компьютеров в локальной сети . Подробнее об этом в главе 17.

Для обращения к компьютеру достаточно набрать в окне запроса его IP - адрес, но это не очень удобно, т. к. компьютеров в Интернете огромное ко личество и запомнить адреса всех интересующих просто невозможно, да и ошибиться при вводе нетрудно. Чтобы избежать трудностей, применяется так называемая система доменных имен. Это позволяет избавиться от необходимости запоминать сложные комбинации цифр, используя кодовое имя для каждого сайта. Естественно, доменное имя также является уникальным идентифика тором, как и IP -адрес. Для автоматического перевода доменного имени в IP -адрес (ведь компьютеры по-прежнему продолжают использовать в сво ей работе только цифры) используют специальные серверы имен ( DNS , Domain Name Server ).

Вы можете сделать из своего компьютера очень быстрый DNS -сервер. Для этого в рабочем каталоге Windows следует создать текстовый файл с именем HOSTS без расширения и внести в него список наиболее часто посещаемых вами Web -страниц. При этом следует придерживаться правила — файл дол жен состоять из двух столбцов (левый содержит доменное имя, а правый — соответствующий IP -адрес). При работе в сети Интернет браузер в первую очередь будет обращаться к этому файлу и только после того, как он не найдет в списке запрошенного доменного имени, подключится к настояще му DNS -серверу, который естественно требует значительно больше времени для определения IP -адреса запрошенной страницы.

Вполне естественно, что помимо дополнительного оборудования для работы в сети Интернет требуется наличие определенного программного обеспече ния. Для работы в сети разработан и применяется целый ряд стандартов, которые позволяют более-менее упорядочить функции^ удаленного доступа, что сильно упрощает процесс работы в сети. Например, все Web -сайты соз даются на основе протокола HTTP , который предполагает только просмотр этих сайтов и скачивание файлов, вы при этом даже случайно не можете повредить содержимое сайта. Другие протоколы, например FTP , предполагают двусторонний обмен данными, что позволяет вам (и не только) создавать, удалять, перемещать файлы на удаленных компьютерах. Все эти протоколы доступны любому пользователю, только нужно установить соответствующее им программное обеспечение. Операционные системы Windows большую часть из существующих протоколов поддерживают без установки дополнительных программ .


Модемное соединение с Интернетом

Модем — устройство, подключаемое к компьютеру для передачи и приема сигналов по телефонным линиям. При передаче сигнала модем преобразует цифровой сигнал, полученный от компьютера, в аналоговую форму, после чего передает его по линии. При приеме сигнала модем выполняет обратное преобразование.

Для подключения к сети Интернет посредством обычного модема вам потребуется как минимум доступная телефонная точка, непосредственно компьютер с модемом и определенное количество телефонного кабеля, необходимого для подключения всего этого в единую цепь. В дальнейшем получившееся соединение можно использовать не только для подключения к Интернету но и к другим модемам для организации сетевых игр и обмена файлами между компьютерами, но без выхода в Интернет. Для физического соединения модема с телефонной линией необходимо установить специаль ные розетки, которые используются в кнопочных телефонных аппаратах. Их чаще всего называют "евророзетками", более официальное название разъема — RJ -11.

Примечание Обратите внимание на то , что во время работы в сети Интернет ваш телефон не будет работать . Со стороны вызывающего абонента будут звучать сигналы " занято ", поэтому , если вам приходится работать в Интернете часто и подолгу , подумайте о выделенной линии .

В компьютере для подключения модема должен быть свободный слот расширения в случае установки внутреннего модема или свободный разъем по следовательного или USB -порта в случае использования внешнего модема. На современных компьютерах обычно имеется один или два встроенных последовательных порта (каждый в виде 9-контактного разъема), которые расположены на задней панели системного блока. А вот портов USB может быть от двух (как минимум) до шести в зависимости от типа материнской платы.

На практике процесс работы в сети Интернет посредством модема выглядит вот так. Модем набирает номер телефона, указанный провайдером в догово ре. К телефонной точке, соответствующей набираемому номеру, (со сторо ны провайдера) подключен компьютер. Его называют сервером. Он обраба тывает все поступающие с вашего компьютера запросы и далее отправляет их на другой компьютер, который дает ответ, соответствующий запросу, ли бо отправляет запрос дальше. В конце концов, запрос достигает своего адре сата и назад отсылается пакет запрошенных данных. Сервер провайдера преобразует ответ в понятный для вашего компьютера вид и отсылает его вам. Во время прохождения пакет данных может быть несколько раз преоб разован из одного формата в другой в зависимости от типа сервера, через который эти данные проходят. Естественно, что процесс занимает всего несколько секунд, поэтому довольно сложно представить себе, что в процессе просмотра очередного Web -сайта участвует несколько десятков, а то и сотен компьютеров.

Примечание Для дозвона к провайдеру используется утилита Dial - Up Networking ( DUN ), которая не только может быть обновлена , но и заменена другими програм мами , например , MDialer или EDialer и другими , имеющими общее название " звонилки ".

Стоит отметить, что в вашем городе может быть несколько провайдеров, которые также могут предоставлять несколько различных видов услуг. Так, например, услуги по регистрации электронного ящика могут быть платными или бесплатными, скорость связи с компьютером провайдера может нахо диться в очень широких пределах в зависимости от применяемого им обо рудования.

Если после набора номера компьютер провайдера свободен и работает нор мально, тогда выводится запрос имени пользователя и пароля доступа. По сле проверки обоих параметров по специальной базе, хранящейся на ком пьютере провайдера, происходит непосредственно подключение к сети Интернет.

Операционные системы Windows предлагают "запомнить" пароль для удаленного соединения, чтобы в следующий раз вам не пришлось набирать его заново. Никогда не соглашайтесь с подобными предложениями, т. к. в этом случае ваши пароли становятся доступными для любого, кто получит доступ к вашему компьютеру или диску. Дело в том, что все пароли хранятся в та ких файлах, как PWL (для Windows 9 x ) и SAM (для Windows NT ), которые очень легко расшифровываются при помощи программ вроде PWL Tools .

Подключение модема к телефонной линии

Возможны две схемы подключения модема к телефонной сети. Первая предполагает подключение модема параллельно другим устройствам, таким как телефон, АОН и т. п. Вторая схема предполагает подключение телефона и других устройств через модем. Рассмотрим их более подробно.

В первом случае устройства, подключенные параллельно модему, во время работы в Интернете вносят в линию немалое количество помех, особенно факсы и АОН'ы, что увеличивает количество сбоев при передаче данных и соответственно уменьшает скорость их передачи.

Примеч ание Наибольшее влияние на качество соединения оказывают определители номе ра , которые сильно " подсаживают " телефонную линию . Также немалое влияние на модем могут оказать стоящий рядом работающий факс , источник беспере бойного питания и другие устройства , излучающие электромагнитные поля ( все устройства , имеющие в составе один или несколько трансформаторов ).

Второй способ, который часто называют "подключение через модем", явля ется более оптимальным, т. к. во время работы в Интернете устройства, подключенные к линии (кроме модема), отключаются от нее и поэтому фи зически не могут вносить помехи.

Вы, скорее всего, не раз обращали внимание на то, что на модеме два оди наковых разъема, которые подписаны LINE и PHONE (или IN и OUT ).

Первый разъем используется для подключения модема непосредственно к телефонной линии, а вот второй предназначен для подключения телефона и других устройств, подключаемых к телефонной линии. Специальное реле, которое имеется в каждом модеме, перед набором номера отключает все устройства от линии, чтобы они не вносили помехи во время работы в Ин тернете.

Чтобы получить максимально качественное соединение, следует осущест вить хотя бы часть нижеследующих операций:

  • телефонный кабель от распределительного щитка (в подъезде) до розетки лучше всего заменить. Дело в том, что строители в шутку либо в силу привычки (кабель дома нужен больше) используют для прокладки теле фонных линий как можно более короткие куски кабеля, который приходится местами соединять. И как уже стало традиционным у нас в России, все соединения выполняются путем скрутки, причем иногда проклады ваются куски кабеля из разного материала (алюминий, медь). Постепен ное окисление места соединения приводит к увеличению уровня помех, оказываемых на все проходящие сигналы.

Если избежать соединений не удается, то для обеспечения качественной связи их следует тщательно пропаять. А вообще самый лучший вари ант — это витая пара. Из всех вариантов она позволит создать наиболее стабильное соединение;

  • откройте телефонные розетки и удалите из них все конденсаторы. Их применяли во времена аналоговых АТС для предотвращения выгорания контактов на самой АТС в момент, когда вы поднимаете трубку телефо на, в то время как на ваш номер поступает вызов и соответственно повышенное напряжение питания. На современных АТС эти конденсаторы утратили свое значение и являются не более чем дополнительным источ ником помех;
  • телефонный провод должен подключаться, в первую очередь, к модему, а уже после него ко всем остальным устройствам (телефонному аппарату, АОН и т. д.), поэтому измените разводку телефонного кабеля внутри по мещения с учетом этих требований.

Примечание Обратите внимание на то , что со временем кабельная сеть деградирует из - за внешних воздействий и возможных повреждений , нанесенных во время про кладки и монтажа кабеля . В результате уменьшается сопротивление изоляции , окисляются оголенные или плохо изолированные соединения (" скрутки ") и т . д . Физические дефекты также могут вызвать изменение электрических свойств кабеля .

Настройка модемного соединения

Естественно, что для нормальной работы в сети Интернет нужно установить драйвер для модема. При этом следует учитывать, что некоторые, особенно старые, модемы не имеют поддержки систем автоматического определения Plug and Play , это относится в первую очередь к модемам, подключаемым к шине ISA . В этом случае приходится пользоваться Мастером установки оборудования.

Стоит отметить, что в отличие от других типов устройств, модем для своей работы требует наличия свободного последовательного порта. Это своеоб разный рудимент, оставшийся со времен, когда все модемы использовали последовательный порт для передачи данных в компьютер. Современные модемы, подключаемые к шинам PCI и USB , уже не используют последова тельный порт для своей работы, хотя эмулируют его работу (это необходимо для совместимости со старыми программами). Поэтому вы можете даже отключить последовательные порты для уменьшения вероятности аппаратных конфликтов, модем у вас будет работать без проблем. Внешние модемы, подключаемые к последовательному порту, по-прежнему используют его, поэтому следует позаботиться, чтобы другие устройства не занимали требуе мый СОМ-порт или ресурсы, используемые данным портом.

Перед установкой драйвера достаточно установить модем в слот расширения или же подключить его к соответствующему внешнему порту и включить его питание. Все модемы, подключаемые к шине USB , питаются от нее.

После установки драйвера можно приступать к настройке соединения с провайдером.

В процессе настройки модемного соединения вы должны будете ввести сле дующие параметры:

  • тип набора — на выбор предлагается тоновый и импульсный набор. Пер вый из них можно применять только в тех случаях, если телефон, под ключенный к вашей телефонной точке, использует этот тип набора номера. Если же тоновый набор вашей телефонной точкой не поддержи вается, то вам нужно пользоваться вторым типом (импульсным набором). Стоит отметить, что, если импульсный набор будет работать на любых линиях, даже с поддержкой тонового набора, то выбор первого варианта может привести к невозможности набора номера;
  • код города и регион (страну), в дальнейшем эти данные использоваться не будут;
  • название соединения, при этом совершенно неважно, как вы его назовете;
  • номер телефона, который должен быть указан в договоре с провайдером. Стоит отметить, что если телефонов несколько, как это бывает в неболь ших городах, то на каждый номер придется создавать отдельное соедине ние, в противном случае придется изменять номер вручную. Не доверяйте как провайдеру, так и знакомым, которые утверждают, что якобы только один телефон позволяет работать с сетью Интернет на максимально возможной скорости. Проверьте это утверждение сами; D имя пользователя, которое вы выбрали при заключении договора с провайдером. Это так называемый "логин", и вовсе не обязательно, чтобы он соответствовал вашему имени или фамилии. Обычно логин состоит из латинских символов, при этом могут использоваться как прописные, так и заглавные буквы;
  • пароль для доступа в Интернет, который вы выбрали при заключении договора с провайдером;
  • тип сервера, указывается провайдером; О IP -адрес, указывается провайдером;
  • иные настройки, всегда указываются провайдером.

Соединение через выделенную линию

Выделенная линия связи ( Dedicated Line , Leased Line ) — линия связи, закреп ленная за источником и приемником информации. При использовании вы деленной линии ваш компьютер получает статический IP -адрес, который не может быть использован никакими другими компьютерами.

Выделенные линии обычно используют для подключения к сети Интернет локальных сетей, а не отдельных компьютеров, т. к. стоимость их использо вания достаточно высока.

Имеется два основных типа подключения: через АТС и минуя АТС.

Преимущества выделенной линии по сравнению с обычным коммутируе мым соединением:

  • высокая скорость работы;
  • высокая надежность соединения;
  • круглосуточное подключение;
  • постоянно свободный телефон;
  • отсутствие тарификации на время, проведенное в сети Интернет, учиты вается только трафик. Соединение осуществляется через обычную сетевую плату. По сути, это ло кальная сеть с провайдером и через него со всем Интернетом.

Соединение может осуществляться через медную пару, такую же, как и телефон, но в этом случае требуется наличие свободной "пары" поблизости от вашего дома, т. е. вы должны будете выкупить еще одну телефонную точку, только вот подключать ее вы будете не к АТС, а к провайдеру. Этот способ имеет ограничение на максимальное отдаление от провайдера (обычно около 5 километров).

Основная проблема при построении выделенной линии на базе медной па ры — это отсутствие предварительной информации об эксплуатационных параметрах будущей линии связи. Основными параметрами являются электрическое и волновое сопротивление линии. От величины электрического сопротивления зависит тип модема, который следует применять. Чем выше сопротивление, тем дороже обойдется вам модем.

Существует еще один способ соединения. Как известно, любой телефонный аппарат соединен с телефонной станцией (АТС) посредством витой пары медного кабеля. Обычно используется часть пропускной способности кана ла связи между двумя телефонами или же модемами, остальная же часть по сути дела "пустует", что позволяет использовать ее для параллельной переда чи цифровых сигнатов. При этом скорость соединения достигается еще и тем, что необходимости в преобразовании цифрового сигнала в аналоговый сигнал и обратно нет, что, в общем-то, позволяет не только увеличить про пускную способность телефонной линии, но и пар&члельно использовать линию для обычных телефонных разговоров.


Что такое электронная почта ?

Электронная почта ( Electronic Mail , e - mail ) — сетевая служба; позволяющая пользователям обмениваться сообщениями или документами без примене ния бумажных носителей. На сегодняшний день это основное средство об щения в сети Интернет.

Электронная почта преимущественно используется для общения между ча стными лицами и организациями. Сегодня практически любой бизнес в некоторой степени привязан к электронной почте. Например, прайс-листы на продукцию практически на 100% пересылаются именно при помощи Ин тернета. Зачастую сотрудники одной и той же организации используют для общения электронную почту, особенно когда они располагаются в разных офисах.

Во-первых, это экономия на расходных материалах, т. к. нет нужды распе чатывать прайс-листы, различные текстовые и графические файлы. Таким образом, можно вести длительную разработку одного проекта, обмениваться образцами и т. п.

Во-вторых, это возможность получения бесплатной прессы в электронном виде и даже заказ различных файлов, например, драйверов. Это очень удобно, т. к. связь с провайдером обычно оказывается на порядок более скоро стной и устойчивой, чем с сервером, на котором находится интересующий вас файл.

По сравнению с обычной почтой, электронная почта имеет преимущества, например, скорость.

Что нужно для работы с электронной почтой ?

Для работы с электронной почтой нужно иметь, в первую очередь, электронный адрес, зарегистрированный на ваше имя. Именно используя этот адрес можно писать вам электронные письма. Как правило, регистрация электронного адреса входит в услуги, предоставляемые провайдером, хотя вы можете создать электронный ящик и на таких независимых почтовых серверах, как MAIL . RU . Для получения доступа к электронным сообщениям необходимо знать имя пользователя и непосредственно пароль доступа, без которого невозможно даже прочитать сообщения, а уж удалить их не удастся и подавно. Этот же адрес обычно указывается в каждом письме, чтобы адресат мог вам ответить.

Электронный адрес имеет следующий формат — NAME @ SERVER , где NAME — это имя пользователя, обычно оно соответствует имени, указы ваемому в окне запроса пароля доступа к электронному ящику. Слово SERVER — это название почтового сервера, на котором зарегистрирован ваш электронный адрес (там находятся все адресованные вам сообщения). Знак <@> обычно называется "собака" и служит для разделения имени пользователя и названия почтового сервера.

Стоит отметить, что в качестве названия почтового сервера может указы ваться как его IP -адрес, так и его доменное имя. Имя пользователя никак не может повторяться в пределах одного почтового сервера. Для управления электронными сообщениями требуется установить на ком пьютер специальную программу (почтовый клиент), которая позволит как писать новые, так и просматривать полученные, написанные ранее или от правленные сообщения. Среди наиболее часто используемых программ можно отметить Outlook Express и The Bat !. Первая из них устанавливается вместе с операционной системой Windows , а вторая является неплохим кон курентом, обладающим рядом расширенных функций.

Получение и отправка электронных сообщений осуществляется при помощи сервера, на котором зарегистрирован ваш электронный адрес, хотя вы мо жете использовать, например, для отправки сообщений любой другой почтовый сервер, который, на ваш взгляд, работает быстрее, хотя здесь имеется ряд нюансов. Например, некоторые из провайдеров позволяют пользоваться услугами своего почтового сервера только тем пользователям, которые поль зуются его услугами, в то время как остальные запросы будут просто- напросто игнорироваться.

Получение электронной почты

Для приема электронных сообщений достаточно знать три вещи: электрон ный адрес, имя пользователя и пароль доступа. Название почтового сервера, как правило, соответствует второй части названия электронного адреса.

При получении электронной почты почтовая программа связывается с РОР- сервером (от Post Office Protocol Server ), в процессе чего сверяется пароль доступа к каталогу с сообщениями. При копировании сообщений на ло кальный компьютер пользователя можно как удалять их оригиналы в каталоге сервера, так и оставлять их на случай повторного получения, например, с другого компьютера.

Отправка электронной почты

Для отправки электронных сообщений достаточно знать две вещи: элек тронный адрес адресата и название почтового сервера, который позволил бы отправить ваше послание. Чаще всего достаточно воспользоваться сервером провайдера, который предоставляет вам доступ в Интернет. В таком случае в графе " SMTP -сервер" следует указать имя сервера (его можно уточнить у провайдера) при первичной настройке почтового клиента.

Стоит отметить, что в теле электронного сообщения помимо самого текста обычно содержится ряд служебной информации. Это дата написания и от правки, название программы, при помощи которой создано сообщение, IP -адрес отправителя и самого SMTP -сервера и т. д.

Если электронного адреса, по которому вы пытаетесь ртправить сообщение, не существует, тогда SMTP -сервер при помощи утилиты Mailer - Daemon отправит его обратно по вашему электронному адресу, который автоматически добавляется к телу каждого сообщения. При этом утилита указывает причи ну, по которой его передача оказалась невозможной, например, размер ящика адресата оказался превышен или же сервер, на котором должен рас полагаться нужный ящик, временно недоступен. Здесь возможны два вари анта. Либо электронного адреса действительно не существует, либо почто вый сервер, на котором зарегистрирован этот адрес, временно недоступен. Во втором случае стоит попробовать отослать сообщение повторно.

Безопасная работа с электронной почтой

Электронная почта не только позволяет значительно упростить ведение бизнеса, но и представляет большую опасность для него. Дело в том, что Интернет нередко используется для передачи конфиденциальной информа ции. Тем более что никто не мешает одному из сотрудников именно вашей организации отсылать секретные данные о разработках новейшего рецепта самогона на электронный адрес вашего конкурента. Отсюда правило номер один — для обеспечения безопасности нужно "фильтровать" не только вхо дящую, но и исходящую почту.

Две другие проблемы связанные с электронной почтой — это спам и вирусы. О них мы поговорим немного позже. Для большей безопасности никогда не настраивайте программы чтения электронной почты на автоматический просмотр/сохранение файлов. Вни мательно следите за типом присоединенных файлов. Не забывайте, что под расширение отведено целых 255 символов (в Windows ), поэтому можно не обратить внимания на расширение файла вроде photo . jpg 200 пробеловехе. С виду файл является изображением, а на самом деле это запускаемый файл и, скорее всего, он заражен вирусом.

Примечание Основные методы внедрения " троянских коней " основаны на невнимательности или любопытстве .


Что нужно для работы с Web - сайтами ?

При подключении к сети Интернет на том компьютере, который подключа ется и является, по сути, клиентом сети, запускается так называемый брау зер ( browser ). В операционной системе Windows независимо от версии используется в качестве браузера программа Internet Explorer , хотя сегодня существует еще целый ряд подобных программ. Это Opera , Netscape Navigator и еще некоторое количество менее популярных, но не менее функцио нальных программ.

При помощи браузера вы подаете в сеть Интернет запрос, например, на от крытие той или иной Web -страницы (к примеру, http :// www . yandex . ru ). При этом вам достаточно ввести в специальном окне кодовое имя открываемой страницы, а уже программа самостоятельно формирует запрос и отправляет его на компьютер, через который вы подключились к сети Интернет.

Работа с Web - сайтами в режиме Online

Перед началом работы в сети Интернет браузер нуждается в небольшой на стройке. Так, например, при открытии Internet Explorer "по умолчанию" пы тается открыть страницу технической поддержки компании Microsoft или иную установленную либо вами самостоятельно, либо одной из установлен ных ранее программ. Это занимает и время, и трафик, поэтому лучше всего эту функцию отключить, чтобы при открытии нового окна Internet Explorer запускался бы, используя "чистый бланк".

Чтобы уменьшить трафик и в то же время ускорить открытие Web -страниц, нужно в Свойствах обозревателя отключить отображение картинок, воспро изведение звуков и видео, а также запретить анимацию. Включить отобра- ** ? жение рисунков можно в любой момент. Стоит отметить, что часть рисун ков представляет обычную рекламу.

Наиболее часто встречающаяся проблема при посещении Web -сайтов — это различие кодировок, в частности проблема касается в первую очередь рус ских символов. .

Проблема может заключаться как в браузере, который вы используете, так и в самом сервере, на котором содержится открываемый вами сайт. Обычно браузер открывает страницу согласно рекомендациям сервера, но и здесь имеется одна небольшая, но весьма зловредная проблема. В языке программирования, на котором пишутся почти все Web -сайты, имеется специальная команда, которая позволяет указать, в какой же именно кодировке написана вызываемая страница. Эта команда имеет максимальный приоритет при вы боре кодировки браузером по сравнению с рекомендациями сервера. В этом случае может возникнуть ситуация, когда сервер уже перекодировал текст в соответствии с запросом, а браузер, обнаружив команду, прямо указываю щую на тип кодировки, осуществляет повторную перекодировку, в результате чего может получиться совершенно нечитаемый текст. Причем стандартными средствами этот "кавардак" с текстом уже не исправишь. Остается только со хранить страницу на диск и удалить команду (для кодировки Win -1251):

< МЕТА HTTP-EQUIV="CONTENT-TYPE" CONTENT="TEXT/HTML; CHARSET=WINDOWS- 1251 ">, после чего можно просматривать страницу в нормальном режиме.

Работа с Web - сайтами в режиме Offline

Существует целый ряд программ, позволяющих заранее скачивать целые Web -сайты на жесткий диск, чтобы можно было в дальнейшем их изучать уже без подключения к сети Интернет (в так называемом режиме offline ). Эти программы в основном так и называются — offline -браузер (читается как "оффлайн", вне линии связи). Один из самых ярких представителей — это WebCopier , также можно отметить программу Offline Explorer .


Соединение двух компьютеров посредством модема

Во-первых, следует отметить, что для качественного соединения следует иметь два очень качественных модема, желательно внешних подключаемых к СОМ-порту, т. к. только они в последнее время могут дать гарантию полной аппаратной обработки сигналов в отличие от внутренних и внешних модемов, подключаемых к шине USB .

Во-вторых, желательно, чтобы АТС была цифровой, что позволит вам играть в более сложные игры, нежели с линией старого типа.

В-третьих, следует иметь в виду то, что никакие крутые "прибамбасы" не смогут заменить ту телефонную линию, которая досталась нам/вам в на следство от прадедушек со всеми ее окислившимися скрутками, исклеванной птицами изоляцией и другими не менее экзотическими дефектами. Это, в общем-то, может сыграть основную роль во всей суете вокруг настройки модемного соединения.

Для организации модемного соединения необходимо установить следующие сетевые компоненты (предварительно запустите значок Сеть в Панели управления):

П Клиент для сетей Microsoft — компонент позволяет организовать удален ный доступ к ресурсам компьютера. Он находится в меню Клиент | Microsoft . После того как вы нажмете кнопку ОК, данный компонент должен появиться в списке, причем вы должны еще раз нажать кнопку ОК, после чего уже начнется непосредственно установка. Следует отме тить, что для корректной установки потребуется указать путь к дистрибу тиву операционной системы (кроме Windows ME и Windows XP ). Стоит отметить, что данный компонент зачастую устанавливается автоматиче ски при установке операционной системы;

П Служба доступа к файлам и принтерам сети Microsoft — его устанавлива ют в тех случаях, когда ресурсы компьютера (например, принтер) будут использоваться другими ПК, подключенными к локальной сети. Его можно установить из меню Служба окна, которое открывается при нажа тии кнопки Добавить;

? Протокол IPX / SPX — он находится в меню Протоколы | Microsoft . После того как вы нажмете кнопку ОК, данный протокол должен появиться в списке, причем вы должны еще раз нажать кнопку ОК, после чего уже начнется непосредственно установка. Следует отметить, что для коррект ной установки потребуется указать путь к дистрибутиву операционной системы (кроме Windows ME и Windows XP ).

После осуществления вышеуказанных операций перезагрузите компьютер, и на рабочем столе должен появиться ярлык Сетевое окружение, означаю щий, что все сделано правильно.

Также следует установить еще и следующие компоненты: Hyper Terminal , Сервер удаленного доступа и Удаленный доступ к сети. Все они станут дос тупными, если запустить значок Установка и удаление программ, выбрать вкладку Установка Windows и в разделе Связь установить галочки напротив соответствующих пунктов. После установки, которая, кстати, потребует указать путь к дистрибутиву Windows , следует перезагрузить компьютер, после чего можно приступать к следующему этапу настройки.

Примечание Следует отметить , что вышеописанные настройки должны быть произведены на обоих компьютерах , которые впоследствии планируется подключать друг к другу .

Следующий шаг — настройка непосредственно модемного соединения. От крываем окно Удаленный доступ к сети и в меню, расположенном в верхней части окна, выбираем пункт Соединения | Сервер удаленного доступа. В от крывшемся окне следует поставить галочку напротив пункта Разрешить удаленные подключения. Далее во вкладке Тип сервера следует указать РРР: Интернет, Windows NT Server , Windows 98 вместо Default и снять галочки напротив пунктов Программное сжатие данных и Требуется зашифрованный пароль. После принятия всех изменений (кнопка ОК) на Панели задач (она же Task Bar ) появится картинка, изображающая компьютер на ладони.

На втором компьютере следует создать Удаленное соединение выше описан ным способом, указав номер телефона, по которому расположен компьютер с запущенным сервером удаленного соединения. На первой вкладке не за будьте убрать галочку напротив пункта Использовать код страны и параметры связи. На второй вкладке проверьте, чтобы тип сервера был указан как РРР: Интернет, Windows NT Server , Windows 98. Также следует поставить галочку напротив строки Войти в сеть и выбрать все допустимые протоколы. После этого можно нажать кнопку ОК и звонить на компьютер с запущен ным сервером удаленного доступа.

После окончания процесса соединения на Панели задач должен появиться значок, сигнализирующий об успешном соединении, после чего можно запускать сетевые игры или обращаться к ресурсам удаленного компьютера. Следует отметить, что вам будут доступны только те ресурсы, для которых разрешен удаленный доступ.


Опасности , подстерегающие нас в Интернете

Вопрос безопасности в сети Интернет весьма обширен. Любое ваше дейст вие можно использовать против вас. Скачиваете ли вы файлы, заполняете форму или же просто открываете Web -страницу.

Интересная особенность операционных систем семейства Windows — как только вы подключаетесь к глобальной сети Интернет, вы становитесь ее частью и все ресурсы вашего компьютера становятся доступными для уда ленного доступа, если, конечно, вы не применяете специальные средства защиты.

Для того чтобы четко представить себе всю опасность выхода в Интернет, вспомните о такой немаловажной функции операционной системы Windows — это функция Windows Update . Данная функция позволяет в ав томатическом режиме, фактически незаметно для вас, обновлять (заменять) системные файлы на их более новые версии, а также устанавливать какие- либо новые компоненты. Чем это грозит? Вы теряете на этом "незаметном" трафике свои деньги, потому что необходимость обновления для начала сле дует доказать. Существует немало фактов, когда после обновления помимо "полезных" функций появляются неустранимые сбои в работе компьютера. Другой вариант — если официально в операционной системе имеется функ ция, которая даже не спрашивает пользователя о необходимости скачивания файлов из сети, то никто не мешает использовать эту "точку входа" для за качки на ваш компьютер "троянского коня", который сначала перешлет всю ценную информацию с вашего компьютера, а затем отформатирует жесткий диск для удаления следов своей деятельности. Все это подтверждает тот факт, что в той же Windows XP примерно 30% трафика специально резерви руется для передачи служебной информации (какой?).

Обязательно следите за новостями и устанавливайте все "заплатки" на операционную систему, которые позволят уменьшить вероятность попадания на компьютер каких-либо "троянских коней".

Анонимные письма и спам

Для чего нужно отправлять анонимные письма? Например, для того, чтобы обругать своего начальника, который сутками донимает вас бесполезной работой, которую, в принципе, и делать-то не надо, а он вас заставляет. Для того, чтобы закидать ящик недруга тысячами писем со ссылками на порно сайты. Для того, чтобы "закинуть" кому-нибудь компьютерный вирус, чтобы тот украл для вас все пароли. Это список можно продолжать до бесконечно сти, итог один — анонимность нам нужна в тех случаях, когда мы не хотим, чтобы адресат узнал, кто же так его не любит. Конечно, догадаться он мо жет, зато веских доказательств у него не будет, да и сами рассылки, особенно компьютерных вирусов, нельзя назвать законными.

С первого взгляда для отсылки анонимного письма достаточно указать "ле вый" адрес при настройке почтовой программы, но на самом же деле все намного сложнее.

Во-первых, любые действия, которые осуществляет какой-нибудь сервер, подлежат записи в специальный файл отчета, который в свою очередь мо жет "рассказать" все и про вас, и про то, как вы "троянского коня" "впарива ли" и т. д.

Во-вторых, в теле письма помимо электронного адреса указывается еще и IP -адрес, что позволяет быстро определить, с какого сервера было отослано определенное письмо.

Против спама лучше всего использовать специальные фильтры, которые все письма, внесенные в "черный" список, удаляют прямо на сервере провайде ра, что позволяет не только избежать приема письма с вирусом, но и уменьшить трафик.

Спам не только раздражает, но и отнимает время, а также занимает трафик, за который придется платить вам, а не тем, кто отослал вам письмо. Спам может даже вызывать перегрузку почтового сервера. Спам выгоден провайдерам.

Хакерские атаки

Хакер — это лицо, совершающее различного рода незаконные действия:

  • несанкционированное проникновение в чужие компьютерные сети и по лучение из них информации;
  • незаконное снятие защиты с программных продуктов и их копирование;
  • создание и распространение компьютерных вирусов и т. п.

Нас больше интересуют два пункта — первый и последний, т. к. именно они могут доставить немало хлопот пользователям.

Если хакеру вдруг потребуется найти в сети компьютер с ресурсами, доступ ными для общего пользования, например, принтером или каталогом на дис ке, то ему вполне достаточно воспользоваться программой, сканирующей указанный диапазон как раз на наличие подобных ресурсов. Ситуация об легчается тем, что каждому провайдеру дается строго определенный диапа зон адресов, что позволяет ускорить поиск жертв, например, в городе, где проживает хакер. Следует иметь в виду, что любая система защиты всего лишь усложняет процесс пользования информацией.

Также стоит отметить, что с самого появления операционных систем ком пании Microsoft в них имелись так называемые недокументированные воз можности. То есть сама компания Microsoft открыто заявляла только часть возможностей, которые (как можно предположить) тщательно тестировалась ими. Остальная же часть возможностей, которая согласно нашему предпо ложению еще не прошла достаточной проверки, просто умалчивалась, что позволяло хитроумным хакерам все-таки находить их и использовать в сво их целях. Вообще убрать программный код, отвечающий за недокументиро ванные команды, очень сложно, т. к. пришлось бы переписывать операци онную систему заново, поэтому для устранения различных "нюансов" постоянно выпускаются так называемые "заплатки", частично заменяющие программный код только отдельных компонентов Windows . Тем более что эти недокументированными возможностями могут воспользоваться сами программисты компании Microsoft , ведь им известны все "дырки" и в системах безопасности, да и просто в отдельных модулях программ.

Как крадут информацию ?

Первый метод является самым простым и безнадежно распространенным. Это простое подглядывание за человеком, набирающим пароль. Даже не обладая очень хорошей памятью, за три-четыре подглядывания или даже наглого рассматривания можно по движению пальцев рук определить па роль длиной до десяти символов. При этом периодически встречаются такие умники, которые просто-напросто записывают пароль на листок бумаги, после чего подкладывают его под клавиатуру либо приклеивают на монитор или системный блок.

В качестве борьбы с подглядыванием стали применять скрытие пароля звез дочками или другими бесполезными символами. Это не остановило любо знательных хакеров, которые придумали целый ряд программ, которые по зволяют очень быстро и главное достоверно "вытаскивать" пароли из-под звездочек.

Второй метод состоит в перехвате пакетов данных, содержащих пароль. Суще ствует немалое количество программ для перехвата пакетов с данными, кото рые получили общее название "снифферы". Существуют модификации программ для работы как в локальной сети, так и в глобальной сети Интернет.

Третий метод — использование так называемого "троянского коня". Это в первую очередь клавиатурные шпионы (наиболее яркий представитель — HOOKDUMP ), которые позволяют считывать нажатия клавиш прямо из оперативной памяти и записывать их в файл, который впоследствии также еще может быть автоматически переслан по заранее заданному электронно му адресу.

Как защитить компьютер от кражи ценной информации ?

Если к вашему компьютеру время от времени имеют доступ сомнительные лица, то вам следует в первую очередь защитить свой компьютер от несанк ционированного доступа в ваше отсутствие. Для этого при помощи специальной опции в BIOS нужно установить пароль на запуск компьютера, без знания которого никто кроме вас не сможет загрузить компьютер даже с загрузочной дискеты или компакт-диска.

Не помешает установить пароль также и на запуск операционной системы, что особо актуально при использовании операционных систем Windows 2000/ XP , которые в отличие от Windows 9 x обладают достаточно развитыми средствами разграничения доступа.

Каждый раз, когда вы задаете пароль на какой-либо ресурс, например дос туп к диску или каталогу, следует использовать уникальный пароль, кото рый должен состоять не менее чем из восьми символов, среди которых должны быть как прописные, так и заглавные буквы, а также цифры и специальные символы. По возможности следует регулярно менять все пароли доступа на тот случай, если злоумышленник уже успел узнать/украсть один из паролей. Если вы подозреваете, что ваш компьютер кто-то разбирал, например, доставал жесткий диск, следует сразу же заменить все пароли в на дежде на то, что целью злоумышленника были именно они, а не какая-то другая информация.

Ни в коем случае никогда не записывайте пароль на бумагу и подобные носи тели, например, на крышке стола. Если таковая необходимость все же имеет ся, обязательно храните все записи в надежном месте (например, сейфе).

Никогда и ни при каких обстоятельствах не вводите какие-либо пароли на чужих компьютерах, ведь никто не может дать гарантии, что на одном из них не установлен клавиатурный шпион. Особенно не следует этого делать, если вас об этом очень просят.

Существует несколько вариантов защиты от несанкционированного доступа. Один из них — это доступ по паролю. В самом простом случае для доступа вам требуется ввести некую комбинацию символов, которая в процессе вво да отображается на экране монитора. Такой подход устарел, т. к. велик шанс, что пароль подсмотрят или даже отсканируют при помощи специаль ного оборудования, хотя по-прежнему применяется при установке лицензи онного программного обеспечения. Программы, имеющие более продвину тую защиту, отображают вводимый пароль звездочками (например, пароль на удаленный доступ в Интернет) или не отображают его вовсе (например, терминальное окно входа в Интернет). В большинстве случаев к паролю прилагается имя пользователя, что, во-первых, позволяет разграничить воз можности разных пользователей в зависимости от их статуса, во-вторых, позволяет усложнить подбор пароля путем ввода случайных комбинаций символов, ведь теперь требуется знать еще и имя пользователя, хотя, как показывает практика, это вовсе не проблема.

Теперь рассмотрим, как же проверяется правильность введенного пароля. Если вы хотите подключиться к удаленному компьютеру, тогда введенный пароль вместе с именем пользователя пересылается на этот самый удален ный компьютер для его проверки. Здесь имеется масса нюансов, сильно об легчающих жизнь хакерам. Так, например, протоколы TELNET , FTP , POP 3, IMAP используют пересылку пароля в незашифрованном виде, поэтому дос таточно перехватить пакет данных с паролем и прочитать его без всякого дополнительного программного обеспечения, требуется только знать струк туру пакета (где именно записывается пароль).

Чтобы усложнить кражу пароля, в последнее время все чаще применяют различные системы шифрования, когда перед отсылкой пароля пакет дан ных шифруется, когда же он принимается на удаленном компьютере, осу ществляется обратный процесс. Но и здесь имеется немаловажный фак тор — никто ведь не мешает воспользоваться программой расшифровки также и хакеру, которому достаточно перехватить пакет с данными и подож дать, пока программа расшифровки доведет дело до конца. Конечно, для шифрования применяются различные ключи, без которых процесс расшиф ровки может превратиться в многодневный кошмар, но опять-таки здесь речь идет только лишь о времени, которое необходимо на взлом шифра.

Существуют еще более сложные алгоритмы защиты, но все они представляют собой "творение человека", а как говорится, "человек создал — человек сломал", т. к. все они позволяют только усложнить процесс взлома, но ни как не предотвратить его. В большинстве случаев подобная защита создается от так называемых "ламеров", что возомнили себя суперкрутыми хакерами и ломают, что ни попадя.


FAQ ( ответы на часто задаваемые вопросы )

Вопрос: Что такое сервер? Почему этот термин очень часто применяется к разным компьютерам?

Ответ: Сервер — это компьютер, подключенный к сети (локальной или гло бальной), который предоставляет доступ к ресурсам, находящимся на нем, вплоть до управления ими. Роль сервера может играть программа. В сети Интернет различают несколько типов серверов. Наиболее важными являются: П WWW -серверы — предназначены для предоставления доступа к содержимому баз данных, которые оформлены, например, в виде Web -сайта. Особенностью этих серверов является то, что они работают в основном с протоколами HTTP и FTP ;

  • серверы электронной почты, позволяющие принимать и отправлять электронные сообщения с одного компьютера на другой. Особенностью этих серверов является то, что они работают в основном с протоколами SMTP и РОРЗ (иногда IMAP 4);
  • серверы FTP , предназначенные для обмена файлами. Внешне они выгля дят как обычные диски с сетевым доступом, на которых расположены ка талоги и файлы, доступные каждому пользователю; П серверы общения в реальном времени (так называемые чаты); ? серверы, обеспечивающие работу 1Р-телефонии; О серверы, реализующие трансляцию радио и видео в Интернете. Вопрос: Что такое прокси-сервер?

Ответ: Прокси-сервер — это компьютер, который выполняет функции "посто янного фильтра" для исходящих и поступающих на ваш компьютер пакетов данных. В его функции входит "прикрытие" вашего компьютера от возможных хакерских атак, хотя и сами хакеры используют прокси для скрытия своего реального местонахождения, т. к. система анонимных запросов реализована именно на них. Большая часть прокси-серверов обладает функцией кэширо вания всех проходящих через них данных, т. е. если вы однажды запросили определенный файл, то в последующем его открытие произойдет значительно быстрее, потому что его копия будет храниться на прокси. Роль прокси-сервера ( Proxy Server ) может выполнять как компьютер про вайдера, так и любой другой компьютер, расположенный в любой точке земного шара.

Вопрос: Что такое шлюз?

Ответ: Шлюз — это компьютер или программа, который передает протоколы одного типа сети в сеть другого типа, динамически преобразуя их. Напри мер, подключение вашего компьютера к сети Интернет происходит посред ством шлюза, установленного на компьютере провайдера.

Вопрос: Модем постоянно соединяется на разных скоростях, хотя провайдер говорит о том, что его оборудование позволяет работать со скоростью до 33,6 Кбит/с. Может, мой модем неисправен?

Ответ: Во-первых, скорость соединения и скорость передачи данных — это не одно и то же. Во вторых, провайдер указывает максимально возможную скорость передачи данных через его оборудование. Но давайте по порядку.

В свойствах соединения указывается та скорость, на которой соединился ваш модем с модемом провайдера. Как правило, реальная скорость передачи данных при работе в сети Интернет значительно меньше указанной, т. к. пакеты данных проходят через разные серверы, которые могут работать как быстрее, так и медленнее того сервера, который установлен у провайдера. Тем более, что при открытии разных Web -сайтов данные проходят через разное количество серверов, что просто не может не сказаться на том, с ка кой средней скоростью эти данные попадут на ваш компьютер. Тот факт, что в течение дня скорость соединения даже с провайдером может меняться, говорит о том, что на реальную скорость влияет множество факторов, например, затухание сигнала или переходные помехи. Практически каждый из нас хотя бы однажды слышал во время своего телефонного разговора другой телефонный разговор. Это и есть переходные помехи. Подобные помехи ухудшают распознавание аналогового сигнала.

Наличие у провайдера даже самого современного цифрового оборудования не дает никакой гарантии, что вы сможете использовать его возможности полностью. Дело в том, что даже при условии наличия цифровой АТС мы продолжаем использовать те телефонные линии, которые были проложены еще во времена, когда наши дедушки и бабушки, будучи молодыми, изощрялись в попытках построить коммунистическое общество.

Вопрос: Модем не распознает сигнал "занято" в телефонной линии и продолжает набор номера. Что можно сделать?

Ответ: "По умолчанию" при установке драйверов для большинства модемов может устанавливаться совместимость с телефонными линиями США, которые отличаются от российских линий в первую очередь форматом сигнала "занято". Для того чтобы исправить ситуацию, необходимо в свойствах драй веров выбрать страну Россия или любую другую, если наша страна отсутст вует в списке. В случае необходимости обновите "прошивку" модема, чтобы в нем появилась поддержка российских линий.

Вопрос: При загрузке операционной системы предлагается подключиться к сети Интернет. Как можно убрать эту функцию?

Ответ: По идее, операционная система не может сама по себе пытаться выйти в Интернет, поэтому вам следует уделить немного внимания тому, какие программы загружаются автоматически с операционной системой. Попробуйте найти и удалить программу Windows Critical Update Notification , иногда пытается звонить именно она.

Возможно, ваш компьютер заражен вирусом, поэтому не пренебрегайте ре гулярной проверкой жесткого диска антивирусным сканером. Вопрос: При запуске Internet Explorer на экран монитора выводится ошибка, после чего программа закрывается. Что делать?

Ответ: Скорее всего, поврежден один из служебных файлов программы. По пробуйте выполнить следующие действия:

  • переустановите Internet Explorer , при этом выберите выборочную уста новку и установите галочку напротив всех компонентов, что позволит увеличить шансы восстановления поврежденного файла;
  • удалите Internet Explorer при помощи, например, программы IEradicator , после чего установите его заново;
  • переустановите операционную систему "поверх" или воспользуйтесь функцией "отката" в Windows XP . Возможно, проблема заключается в каком-нибудь модуле, интегрируемом в оболочку Internet Explorer ' a , например программы закачки файлов. По пробуйте удалить или хотя бы переустановить все программы, которые подключают свои модули к нему. Это могут быть программы закачки файлов, блокирования рекламы и всплывающих окон и т. п.
  • Если у вас нет возможности переустанавливать программу и операционную систему, можно воспользоваться альтернативными браузерами, например Opera .

Вопрос: В районе установили новую цифровую АТС, но связь с провайдером только хуже стала. Почему так произошло?

Ответ: При замене АТС практически всегда оставляют старые телефонные кабели, которые сами по себе вносят большое количество шумов, треска и других подобных помех. Цифровое оборудование более требовательно к ка честву линии, чем старое аналоговое, поэтому такая замена в основном облегчает работу самим работникам АТС и предоставляет дополнительные услуги вроде тонового набора, определителя номера и т. п. А на качество модемного соединения это вполне может оказать только отрицательное воз действие.

Вопрос: Как проверить качество телефонной линии, подходит ли оно для работы в сети Интернет?

Ответ: Некоторые модемы, например ZyXEL U 336 или USR Courier V . Everything , имеют встроенные средства диагностики телефонной линии, в остальных случаях придется воспользоваться программами, которые обыч но измеряют реально проходящий по сети трафик, рисуют кривую потока данных (на тот случай, если связь регулярно теряет скорость) и т. п.

Вопрос: Что представляет собой SMTP -сервер?

Ответ: Любые SMTP -серверы (от Simple Mail Transfer Protocol ) используют ся для отправки электронных сообщений. В его функции входит определе ние IP -адреса компьютера, которому адресовано отправляемое сообщение и непосредственно сама отправка.

Вопрос: Что такое UART ?

Ответ: UART ( Universal Asynchronous Receiver / Transmitter ) — микросхема уни версального асинхронного приемопередатчика. В этой микросхеме происхо дит преобразование сигналов, исходящих и входящих в компьютер через модем. Развитие модемов почти неразрывно связано с совершенствованием данной микросхемы, в современных ПК используется UART серии 16550А и ее модификаций. Следует отметить, что во всех программных модемах (так называемых win - и soft -модемах) она отсутствует, причем ее наличие эмули руется программно.

Вопрос: Что такое FIFO ?

Ответ: FIFO ( First In First Out Buffer ) — специальный буфер, через который осуществляется обмен данными с модемом. Размер буфера составляет 16 байт для микросхемы 16550А. Если быть более точным, то 16550А содер жит два буфера типа FIFO — на прием и на передачу. Когда происходит прием данных, микросхема генерирует прерывания. Данная операция устанавливает уровень заполнения буфера, при котором будет выработано пре рывание. Буфер играет очень важную роль при высоких скоростях обмена и при работе в многозадачных операционных системах. Для обеспечения ка чественной связи важно правильно управлять буфером, и здесь возможны следующие варианты:

  • О— прерывание выработается, когда в буфере находится 0 байт, прерывания будут вырабатываться при поступлении каждого байта и не будут помещаться в буфер, что равносильно его отключению;
  • 1 — прерывание выработается, когда в FIFO будет находиться 1 байт;
  • 4 — прерывание выработается, когда в FIFO будет находиться 4 байта;
  • 8 — прерывание выработается, когда в FIFO будет находиться 8 байт;
  • 14 — прерывание выработается, когда в FIFO будет находиться 14 байт.

Особое значение имеют правильные установки для FIFO при приеме дан ных (наилучшие результаты обычно получаются при значениях 8 или 14),

если говорить о передаче, то, как правило, их устанавливают такими, чтобы генерация прерыванием осуществлялась через 14 или 16 байт.

Вопрос: По электронной почте получил сообщение с вложенным файлом, но его имя отображается в виде непонятных "закорючек". Из-за этого его

нельзя ни открыть, ни сохранить на диске в виде отдельного файла. Что

можно сделать?

Ответ: Сначала сохраните это письмо в виде отдельного файла. Затем при

помощи файлового менеджера вроде FAR или Total Commander откройте

его редактирование И найдите строку вроде Content - Disposition : attachment ,- Шепате=имя файла, измените имя на любое другое и сохра ните изменения. Теперь все должно работать нормально. Вопрос: Что такое Интернет-карта, как ей пользоваться? Ответ: Интернет-карта — это подобие телефонной карты, используемой для работы в сети Интернет. Когда вы покупаете карту, под защитным слоем (примерно таким же, как на лотереях) содержится имя пользователя и пароль для доступа к сети. На карте также имеется номер лицевого счета, чтобы вы могли в любое время уточнить, какой остаток имеется на нем и сколько еще времени в Интернете вы сможете провести, используя имеющуюся карту.

Вопрос: Можно ли подключиться к сети Интернет через мобильный теле фон?

Ответ: Да, если провайдер мобильной связи имеет такую услугу. В этом слу чае вам необходимо написать заявление, чтобы вам включили соответст вующую услугу. "По умолчанию", естественно, эта функция отключена. Некоторые провайдеры работают даже без пароля доступа, например МТС.


Глава 17. Работа в локальной сети

  • Работа в локальной сети
  • Что такое локальная сеть?
  • Конфигурация локальной сети
  • Что нужно для работы в локальной сети?
  • Подключение компьютеров к локальной сети
  • Настройка компьютеров в локальной сети
  • Проверка работоспособности локальной сети
  • Соединение двух компьютеров без сетевых плат
  • Организация общего доступа в Интернет
  • FAQ (ответы на часто задаваемые вопросы)


Работа в локальной сети

Если вы хоть раз в жизни посещали какой-нибудь игровой клуб, то пре красно знаете, насколько захватывающими могут быть сетевые поединки, например в Half Life или какой-нибудь другой игре, даже такой устаревшей с виду, как Quake . Ведь одно дело проходить лабиринт по заранее созданной и практически неизменной схеме, а другое — непредсказуемость поведения "противника". В последнее время все чаще даже в домашних условиях мож но наблюдать наличие более одного компьютера (например, когда два брата никак не могут ужиться за одним ПК). Поэтому тема, которую мы рассмот рим в данной главе, вполне актуальна — ведь даже в домашних условиях можно создать локальную сеть, а то и протянуть ее между несколькими подъездами одного дома.


Что такое локальная сеть ?

Локальная сеть ( Local Area Network , LAN ) — группа персональных компьюте ров или периферийных устройств, которые объединены между собой высокоскоростным каналом передачи цифровых данных в пределах одного или нескольких близлежащих зданий. Также встречается термин "локальная вычислительная сеть"(ЛВС).

Основное назначение любых видов компьютерных сетей — организация со вместного доступа к ресурсам любого из компьютеров, подключенного к данной сети. Прежде всего, это совместный доступ к данным и програм мам. Это когда данные или программы, находящиеся на одном из компью теров сети (файловом сервере), могут использоваться на любом из подклю ченных к нему компьютеров. Так происходит, например, при использовании сетевой бухгалтерской программы, когда работники, которые имеют доступ к сети, могут вносить изменения в единую базу данных. Для организации постоянной связи между компьютерами локальной сети их объединяют в рабочие группы.

Рабочая группа — это группа лиц (например, сотрудников организации), кото рые занимаются одним проектом. Современные локальные сети направлены, услови ях рабочей группой можно назвать группу компьютеров, которые, например, заняты обработкой одной сетевой игры. Компьютеры каждой рабочей груп пы составляют отдельный сегмент.

Сегмент локальной сети — часть сетевого кабеля, ограниченная маршрути заторами, повторителями, терминаторами и другими дополнительными уст ройствами.

В отдельную группу можно отнести серверы печати с подключенными к ним несколькими обычными принтерами, которые при этом приобретают сетевые возможности и могут работать по сети вне зависимости от наличия под держки в них этого режима работы. Обычно серверы печати имеют LPT - разъемы. Такие серверы используются в очень крупных организациях, в до машних же условиях вполне достаточно иметь один принтер на компьютере, подключенном к локальной сети, чтобы к нему имели доступ все компьюте ры рабочей группы.

Все вышесказанное можно выразить единым термином — "совместный дос туп к ресурсам".

Помимо уже рассмотренных преимуществ, имеется еще одно и весьма немаловажное. Благодаря наличию постоянной связи между компьютерами появляется возможность удаленного администрирования, когда, сидя за одним компьютером, можно следить за работой всех остальных компьютеров, под ключенных к локальной сети — например, включен ли конкретный компь ютер, какие программы на нем запущены и прочее.

Именно отсюда произошел термин "системный администратор" — это чело век, отвечающий за работу всей локальной сети и управляющий режимами совместного доступа к ресурсам сети (другими словами, управляющий сис темной политикой).

Примечание Самое главное преимущество локальной сети — это возможность сэкономить . Покупка одного принтера , сканера , модема и других устройств соизмерима по цене с покупкой сетевого оборудования . Например , можно купить один очень большой жесткий диск и хранить на нем фильмы , музыку и другие объемные файлы .


Конфигурация локальной сети

Конфигурация локальной сети — метод соединения компьютеров между со бой. Иногда встречается термин "топология сети". Чаще всего используется один из трех основных типов соединения.

  1. 1. Шина — все компьютеры как бы построены в одну линию, т. е. от одного кабеля имеются отводы к каждому из компьютеров сети, причем концы кабеля являются незамкнутыми. Чаще всего такая схема применяется для соединения нескольких компьютеров, установленных в одном помеще нии, для чего применяется тонкий или толстый коаксиальный кабель. Наиболее яркий недостаток этой топологии — при любом обрыве в кабеле теряется связь между всеми компьютерами.
  2. Данная топология используется для сетей типа Ethernet , когда все ком пьютеры сети подключены друг к другу параллельно с последовательным включением в основную магистраль, а концы магистрали закрыты "тер минаторами". Если к сетевой плате уже подключен Т-образный разъем, тогда кабель может быть подключен к нему при помощи BNC -разъема ( Bayonet Nut Connector ).
  3. При использовании этой топологии следует учитывать, что подключение новых компьютеров может потребовать полной реорганизации сети.
  4. 2. Кольцо — все компьютеры, как и в предыдущем случае, соединены между собой при помощи одного кабеля, концы которого соединены между со бой. Эта схема в основном используется для создания сетей IBM Token Ring . Теперь любой разрыв кабеля уже не приводит к потере связи между компьютерами. Для соединения нескольких колец используются специ альные устройства.
  5. 3. Звезда — каждый компьютер сети отдельным кабелем подключен к од ному ПК, который играет роль файлового сервера. Наиболее распростра ненная схема — локальная сеть создается на основе "витой пары" с при менением концентратора. Обрыв в кабеле приводит к потере контакта только с одним компьютером или же сегментом сети, но для создания сети по данной топологии необходимо наличие специального распреде лителя (соединение компьютеров между собой полностью параллельное).

В зависимости от размеров локальной сети, расположения компьютеров и их роли в данной сети может встретиться комбинированная схема подклю чения.

Прежде чем закупать сетевое оборудование, следует внимательно изучить условия, в которых будет эксплуатироваться локальная сеть, чтобы точно вычислить как длину кабеля, необходимую для ее создания, так и пропуск ную способность, от чего зависит тип применяемого кабеля и необходи мость покупки дополнительных устройств. Лучше даже на бумаге отобразить схему будущей сети со всеми ее параметрами — длиной сегментов, распо ложением компьютеров и т. д.

Исходя из физического месторасположения каждого компьютера, следует составить подробный план прокладки кабеля с учетом архитектурных осо бенностей комнаты, таких как углы, выступы, изгибы (вы ведь не собирае тесь кидать провод посредине комнаты, ведь он прокладывается надолго). Следует отметить, что общая длина кабеля (от компьютера к компьютеру) не должна превышать 100 м, в противном же случае вам придется использовать устройство, усиливающее сигнал, так называемый "репитер" (повтори тель), который в свою очередь позволяет создавать сети любой длины.

Стоит отметить, что цена всего комплекта обычно складывается из следую щих компонентов:

  • кабель, необходимый для покрытия расстояния между компьютерами и всеми дополнительными устройствами ( hub , switch , repeater ) плюс 20-30 см на каждое соединение дополнительно, чтобы осталась возможность передвигать системный блок или тот же hub , если в этом возникнет необхо димость;
  • разъемы на каждом конце кабеля, как со стороны компьютеров, так и со стороны дополнительных устройств ( hub , switch , repeater );
  • крепеж для кабеля, который может представлять собой или пластиковые короба, или обычные "загогулины" с гвоздиками;
  • специальный обжимный инструмент, без которого, скорее всего, вам не удастся получить стабильно работающую локальную сеть. Можно, конеч но, обойтись и плоскогубцами, но в этом случае вам придется очень по стараться, чтобы качество обжатия получилось достаточным.

При прокладке сети следует придерживаться того правила, что кабель дол жен быть хорошо защищен от любых внешних воздействий (каблуки, жи вотные, атмосферные осадки), что обычно достигается при укладке его в специальный пластиковый кожух. При прокладке кабеля вне помещения следует иметь в виду, что крайне не рекомендуется, чтобы кабель провисал под собственным весом, т. е. при прокладке кабеля, например, с крыши од ного дома на другую следует использовать стальную проволоку. В то же время при прокладке кабеля на улице следует иметь в виду, что зимой из-за разницы температур при сильном натяжении может произойти разрыв. Стоит отметить, что за счет некоторого провисания кабеля при перекидыва нии его, например, с крыши одного здания на крышу другого здания, его длину при расчетах следует увеличить примерно в 1,5 раза.

Прежде чем закреплять разъемы на концах кабеля, обратите внимание на особенности его прокладки. Например, если придется протягивать кабель через высверленные где-то отверстия, то лучше сначала его протянуть, а уже затем устанавливать разъемы, в противном же случае придется расширять отверстия.


Что нужно для работы в локальной сети ?

Любая локальная вычислительная сеть состоит из трех обязательных компо нентов:

  • средства коммуникации, которые включают в себя также и каналы пере дачи данных (например, кабель "витая пара");
  • компьютеры, соединенные каналом передачи данных;
  • сетевое программное обеспечение.

Средства коммуникации могут включать следующие устройства (в зависимо сти от конфигурации сети):

  • сетевая плата — представляет собой PCI -плату (сегодня еще можно встретить также ISA -платы), которая устанавливается в любой свободный слот материнской платы. Практически все современные сетевые платы поддерживают технологию Plug and Play , что позволяет достаточно быст ро настроить сетевое соединение. Со стороны задней панели системного блока после установки сетевой платы имеется специальный разъем, позволяющий подключить компьютер к локальной сети, при этом вид разъема должен соответствовать типу применяемой конфигурации сети, в противном случае вам придется использовать дополнительные устрой ства для сопряжения компьютеров;
  • соединительный кабель — встречается несколько типов кабелей, приме няемых для организации локальной сети:
    • тонкий коаксиальный кабель — по внешнему виду он похож на ан тенный кабель, но обладает несколько иными техническими характе ристиками. Его волновое сопротивление составляет 50 Ом. Он позво ляет создавать сети не более чем 110 м длиной со скоростью передачи данных до 10 Мбит/с;
    • толстый коаксиальный кабель — так же, как и предыдущий тип, от обычного антенного кабеля отличается техническими характеристика ми. Волновое сопротивление составляет 75 Ом. Он позволяет созда вать сети до 200 м длиной с той же скоростью, что и предыдущий тип (до 10 Мбит/с);
    • кабель "витая пара" — состоит из четырех пар проводников, перепле тенных между собой специальным образом (в сумме восемь провод ников). Самое большое отличие локальной сети, построенной на базе "витой пары", — это более высокая скорость передачи данных (до 100 Мбит/с). В простейшем случае "витая пара" представляет собой неэкранированный двужильный телефонный кабель, правда, качество связи при этом будет неважное;
    • оптический кабель (оптоволокно) — используется для передачи дан ных на большие расстояния и с большой скоростью (до 1 Гбит/с). В домашних условиях такой тип кабеля не используется в основном из-за высокой цены;
  • дополнительные устройства, позволяющие создавать сложные локальные сети, которые не только могут обладать очень высокой скоростью передачи данных, но и немалой степенью зашиты от перегрузки, несанкцио нированного доступа и т. п. Например:
    • Bridge (мост) — устройство сопряжения локальных сетей. Позволяет всем компьютерам одной локальной сети свободно работать с компьютерами другой локальной сети;
    • Hub (концентратор) — устройство, соединяющее параллельно компьютеры в локальной сети. Также оно играет роль повторителя, препят ствующего затуханию сигнала, что позволяет увеличить максимальную общую длину кабеля между компьютерами;
    • Repeater (повторитель) — устройство, позволяющее избежать затуха ния сигнала при очень большой длине соединительных кабелей. Роль повторителя может играть специально настроенный компьютер. Обычно это устройство устанавливается в середине линии связи, что бы обеспечить устойчивую двустороннюю связь. Бывают как пассив ные, так и активные повторители, а также преобразующие повторите ли, которые применяются для соединения, например, "витой пары" с оптоволокном;
    • Router (маршрутизатор) — устройство, используемое для организации крупных локальных сетей. Оно позволяет направлять пакеты данных строго к определенным (заранее зарегистрированным) IP -адресам, что, например, позволяет избежать перехвата пакетов с данными и ис ключить "утечку" информации. Роль маршрутизатора может играть специально настроенный компьютер;
    • Switch (переключатель) — устройство, переключающее линию связи между всеми компьютерами, причем этот делается в реальном време ни, что позволяет устранить снижение производительности из-за встречных потоков данных. Также оно играет роль повторителя, пре пятствующего затуханию сигнала.


Подключение компьютеров к локальной сети

Соединения коаксиального кабеля выполняются с помощью специальных разъемов BNC ( Bayonet Nut Connector ) и Т-образных разъемов. Для соеди нения двух компьютеров в сеть необходим один отрезок кабеля, для трех — два отрезка и т. д. Разъем BNC закрепляется на конце коаксиального кабе ля, а затем с помощью Т-образного разъема, к которому прикрепляется BNC -разъем, кабель присоединяется к сетевой плате. Свободный контакт Т-образного разъема может быть использован для подключения коаксиаль ного кабеля, идущего на следующий сетевой компьютер. В случае, если на данном компьютере сеть заканчивается, на свободный контакт надевается "терминатор" — специальное сопротивление-заглушка в 50 Ом. Терминаторы нужны для того, чтобы гасить отраженную от концов кабеля электромагнитную волну.

Удалите внешнюю изоляцию с коаксиального кабеля примерно на 1,5 см, после чего аккуратно расплетите экран и удалите внутренний изоляционный слой, чтобы открыть доступ к центральной жиле. Аккуратно, чтобы не по гнуть центр&чьную жилу, наденьте BNC -разъем, после чего его следует обжать специальным инструментом или хотя бы плоскогубцами (в последнем случае качество обжима намного хуже). Наденьте разъем на заранее под ключенный к материнской плате Т-образный разъем и поверните по часо вой стрелке, чтобы зафиксировать соединение.

Кабель "витая пара" подключается к компьютеру и дополнительным устрой ствам при помощи разъема, известного под маркировкой RJ -45. В витой па ре задействованы две пары — это всего четыре провода, хотя в разъеме при сутствует восемь контактов. Это сделано специально для совместимости с одним из малораспространенных стандартов. Для подключения компьюте ров используются контакты 1, 2, 3, 6, тогда как другие, например 4 и 5, мо гут быть использованы для подключения телефонов.

Разъем RJ -45 состоит из вилки (ее надевают на кабель) и розетки, расположенной на сетевой плате. Для подсоединения разъема к кабелю необходимо взять его защелкой от себя, местом, куда вставляют кабель вниз. В этом случае контакты окажутся прямо перед вами и будут нумероваться слева напра во — от 1 до 8. Следует отметить, что если вы неправильно подключите разъем к кабелю (перепутаете разводку), можно его просто выбросить, т. к. "обжим" осуществляется "раз и навсегда".

Кабель витой пары имеет восемь проводников, объединенных в четыре па ры, покрытых изоляцией различного цвета. Сначала следует снять с кабеля полтора сантиметра верхнего изолирующего слоя, для чего можно использо вать обычный нож, но лучше специальное лезвие, которое входит в ком плект обжимного инструмента. После этой операции станут доступными восемь проводников, которые следует выстроить в последовательности, ука занной в табл. 17.1 (при подключении ПК через концентратор или другое подобное устройство).

Далее следует обрезать и выровнять концы проводников, чтобы они были равны друг другу, после чего аккуратно вставить их в разъем таким образом, чтобы контакты были повернуты от вас и направлены вверх. Если все про водники (проверяем визуально) попали "куда положено", вставляем разъем в обжимной инструмент и сильно сжимаем его. Следует отметить, что ис пользование обычных плоскогубцев сильно снижает шансы получения каче ственного контакта в разъеме.

При необходимости качество обжимки (на наличие так называемых "мерт вых" контактов) можно проверить обычным тестером в режиме омметра.

Таблица 17.1. Разводка восьмижильного кабеля при подключении через концентратор

Разъем со стороны компьютера | Цвет провода | Разъем со стороны концентратора
1 | бело-зеленый | 1
2 | зеленый | 2
3 | бело-оранжевый | 3
4 | синий | 4
5 | бело-синий | 5
6 | оранжевый | 6
7 | бело-коричневый | 7
8 | коричневый | 8

Иногда используют несколько другую разводку, которая, в общем-то, является полным аналогом предыдущей (см. табл. 17.2). Следует иметь в виду, что для всей сети обязательно следует использовать только один тип разводки.

Таблица 17.2. Еще одна разводка восьмижильного кабеля при подключении через концентратор

Разъем со стороны компьютера | Цвет провода | Разъем со стороны концентратора
1 | бело-оранжевый | 1
2 | оранжевый | 2
3 | бело-зеленый | 3
4 | синий | 4
5 | бело-синий | 5
6 | зеленый | 6
7 | бело-коричневый | 7
8 | коричневый | 8

Для четырехжильного кабеля разводка будет выглядеть несколько иначе (см. табл. 17.3).

Таблица 17.3. Разводка четырехжильного кабеля при подключении через концентратор

Разъем со стороны компьютера | Цвет провода | Разъем со стороны концентратора
1 | бело-оранжевый | 1
2 | оранжевый | 2
3 | бело-синий | 3
6 | синий | 6

Если вы хотите подключить всего два компьютера при помощи "витой па ры", можно обойтись без концентратора и других подобных устройств (при условии, что оба ПК находятся на расстоянии не более 100 м друг от друга). Для этого применяется так называемая "перекрестная" разводка ( cross - over ). Ее иногда называют соединением "точка-точка".

Чтобы понять, для чего именно создается перекрестное подключение, нужно знать, как соотносятся контакты и сигналы (см. табл. 17.4).

Таблица 17.4. Разводка сигналов на разъеме кабеля " витая пара "

Номер контакта | Обозначение сигнала | Расшифровка обозначения
1 | ТХ+ | сигнал передачи данных
2 | тх- | второй провод передачи данных
3 | RX+ | сигнал приема данных
6 | RX- | второй провод приема данных

Если вы используете концентратор или иное подобное устройство, соедине ние всех контактов передачи данных со всеми контактами приема данных на других разъемах осуществляется внутри этого устройства. Если же вы хотите подключить компьютер к другому компьютеру напрямую, потребуется изменить разводку на разъеме таким образом, чтобы контакты передачи данных с одной стороны всегда были соединены с контактами приема дан ных на другой стороне. Отсюда получается, что разводка будет выглядеть несколько иначе, нежели при использовании концентратора (см. табл. 17.5).

Таблица 17.5. Разводка кабеля при прямом подключении компьютеров

Разъем со стороны одного компьютера | Цвет провода | Разъем со стороны другого компьютера | Цвет провода (второй вариант)
1 | бело-зеленый | 3 | бело-оранжевый
2 | зеленый | 6 | оранжевый
3 | бело-оранжевый | 1 | бело-зеленый
4 | синий | 4 | синий
5 | бело-синий | 5 | бело-синий
6 | оранжевый | 2 | зеленый
7 | бело-коричневый | 7 | бело-коричневый
8 | коричневый | 8 | коричневый


Настройка компьютеров в локальной сети

Сразу же после установки сетевой платы в компьютер следует установить драйверы, которые, как правило, поставляются на гибких дисках. При ука зании пути, где они находятся, следует указывать дисковод А:.

Иногда можно встретить рекомендации, что любая настройка сетевой платы должна осуществляться только после ее физического подключения к локальной сети и при наличии хотя бы одного включенного компьютера, так же подключенного к ней, чтобы сразу же проверить правильность установки всех необходимых компонентов, но это не всегда возможно.

После настройки драйверов следует подключить кабель, соединяющий ком пьютер с локальной сетью. Обратите внимание на зеленый индикатор, который находится рядом с разъемом (под названием " Link "). Если он заго релся зеленым цветом, тогда физическая связь установлена и можно при ступать к настройке сетевых протоколов, в противном случае вам следует проверить, включены ли дополнительные устройства ( hub , switch ) и надежно ли закреплены разъемы на кабеле.

Сетевой протокол — язык общения компьютеров по локальной сети. Благо даря ему появляется возможность подключения к единой сети компьютеров с разными версиями Windows . В большинстве случаев сетевой протокол ра ботает следующим образом: все данные, которые подлежат передаче по сети, разрезаются на отдельные пакеты, которые в свою очередь помимо полез ных данных содержат еще служебную информацию. Под служебной информацией подразумевается: имя компьютера, откуда отослан пакет, имя ком пьютера, куда он послан, и контрольная сумма, которая позволяет проверить целостность приходящих данных. Благодаря пакетной передаче данных появляется возможность двустороннего обмена данными между двумя и более компьютерами, что особенно полезно в игровых программах. Есте ственно, что при этом скорость передачи данных немного снижается, т. к. любая локальная сеть имеет ограниченную пропускную способность.

Примечание Обратите внимание на то , что при передаче данных по сети также передается целый ряд служебной информации , которая занимает определенный объем . В результате , весь переданный по сети массив оказывается на порядок более объемным , нежели " чистый " массив данных . Это нужно учитывать , например , при расчете необходимой пропускной способности создаваемой сети .

Настройка локальной сети в Windows 9 x

Сразу следует отметить, что в качестве основы для описания процесса на стройки мы будем рассматривать операционную систему Windows 98 SE . Остальные версии могут в чем-то различаться, но принцип везде остается одним.

После установки сетевой платы в компьютер и настройки драйверов автома тически создается подключение к локальной сети с некоторыми средними настройками. Для тонкой настройки локальной сети запустите значок Сеть в Панели управления. После этого в открывшемся окне вы сможете найти все установленные сетевые компоненты. Это в первую очередь драйверы сетевой платы, а также компоненты Семейный вход в систему, Клиент для сетей Microsoft , поддержка протокола TCP/IP для вашей сетевой платы, в чем вы можете убедиться, изучив название данного пункта — в нем долж но содержаться название сетевой платы. Если у вас имеется модем, тогда вы увидите еще и поддержку протокола TCP/IP для вашего модема, при этом рядом с названием протокола пишется фраза Контроллер удаленного доступа. который как раз и используется для организации доступа к сети Интернет, а также в иных случаях, когда требуется удаленный доступ к другим компь ютерам. Рассмотрим установленные компоненты поподробнее:

  • Семейный вход в систему — в основном предназначен для организации, как можно догадаться, домашней сети. Как правило, используется крайне редко и его можно безболезненно удалить;
  • Клиент для сетей Microsoft — компонент позволяет организовать удален ный доступ к ресурсам компьютера;
  • Протокол TCP/IP (Transmission Control Protocol/ Internet Protocol) — это основа любой компьютерной сети. Для бесперебойной работы локальной сети, особенно при наличии более 2—3 компьютеров, следует его немного настроить. Пометьте его в списке и нажмите кнопку Свойства, после чего во вкладке IP -адрес поставьте галочку в пункте Указать IP - адрес явным образом, введите любой адрес, состоящий из цифр от 0 до 254,а также маску подсети в виде 255.255.255.0. При этом следует иметь в ви ду, что компьютеры, подключенные к одной локальной сети, должны иметь одну и ту же маску, тогда как IP -адрес у каждого компьютера дол жен быть оригинальным, например, адрес может иметь следующий вид: 192.168.x.х, где х — это цифра от 0 до 254. Оптимальным вариантом явля ется следующая последовательность— 192.168.0.1, 192.168.0.2 и т.д., это поможет вам в дальнейшем просто добавлять к сети дополнительные компьютеры, например, когда к вашей домашней сети хочет подклю читься еще одна сеть из другого подъезда/квартиры.

Примечание Никогда не используйте IP - адрес 127.0.0.1, т . к . при обращении к нему вы фак тически обращаетесь к своему компьютеру . Это так называемый " адрес - петля ".

Стоит также отметить, что в некоторых источниках рекомендуется ис пользовать несколько другой формат IP -адреса, а именно — 169.254.х.х. В принципе можно использовать любой IP -адрес, если локальная сеть не имеет подключения к сети Интернет, естественно, кроме описанного выше исключения;

  • Контроллер удаленного доступа — этот компонент необходим для органи зации удаленного доступа к компьютеру провайдера или к другому ком пьютеру, когда, например, вы хотите поиграть в сетевую игру через мо дем.

Для нормальной работы локальной сети рекомендуется установить еще и следующие компоненты (для этого следует нажать кнопку Добавить и в поя вившемся окне выбрать необходимый компонент):

  • Протокол IPX / SPX — он находится в меню Протоколы | Microsoft . После того, как вы нажмете кнопку ОК, данный протокол должен появиться в списке, причем вы должны еще раз нажать кнопку ОК, после чего уже начнется непосредственно установка. Следует отметить, что для коррект ной установки потребуется указать путь к дистрибутиву операционной системы (кроме Windows ME и Windows XP ). После установки протокола его следует немного настроить. Пометьте его в списке и нажмите кнопку Свойства. В открывшемся окне в подраз деле NetBIOS снимите галочку напротив пункта Запустить поддержку NetBIOS протоколом IPX / SPX . Если галочка серая, то ничего менять не нужно;
  • Протокол NetBEUI — протокол находится в том же списке, что и преды дущий. Его рекомендуется устанавливать во всех случаях нестабильной работы сети;
  • Служба доступа к файлам и принтерам сети Microsoft — его устанавлива ют в тех случаях, когда ресурсы компьютера (например, принтер) будут использоваться другими ПК, подключенными к локальной сети. Его можно установить из меню Служба окна, которое открывается при нажа тии кнопки Добавить. Если вы его не установите, тогда ни один компью тер не сможет прочитать содержимое ваших дисков, не сможет печатать на принтере, подключенном к вашему компьютеру — это можно исполь зовать для защиты от несанкционированного доступа.
  • После установки службы ее следует немного настроить. Пометьте ее в списке и нажмите кнопку Свойства. В открывшемся окне установите галочку напротив пункта Быстрый вход в разделе Параметры входа в сеть, это позволит быстрее загружаться операционной системе. Ставить галочку напротив пункта Входить в домен Windows NT в разделе Вход в сеть и задавать имя домена не нужно. Если вы установили компоненту Клиент для сетей Microsoft , то эта служба установится автоматически. В дальнейшем, нажатием кнопки Доступ к файлам и принтерам, можно разрешать и блокировать доступ к файлам и принтерам, подключенным к вашему ПК.

Все остальные протоколы и службы, которые могут присутствовать в спи ске, можно удалить, т. к. они для работы в локальной сети обычно не ис пользуются и будут замедлять загрузку компьютера, а также занимать оперативную память.

В том же окне имеется еще меню — Способ входа в систему, которое позво ляет выбрать в данном случае три варианта: Семейный вход в систему, Клиент для сетей Microsoft и Обычный вход в Windows . В большинстве слу чаев следует выбирать третий вариант, т. к. при этом вы будете избавлены от необходимости ввода пароля при запуске операционной системы.

По окончании настройки сетевых компонентов следует перезагрузить ком пьютер, затем вновь запустить значок Сеть в Панели управления, после чего открыть вкладку Идентификация, где ввести имя компьютера, название рабочей группы и описание компьютера. В большинстве случаев первый и по следний пункты могут совпадать, т. е. в обоих окошках можно ввести одно и то же имя. При вводе имени компьютера и названия рабочей группы следу ет придерживаться правил — символы должны принадлежать только к латинскому алфавиту или цифрам, т. к. кириллица — это враг номер один для локальной сети (вам практически обеспечена головная боль из-за проблем с ее настройкой и эксплуатацией). В большинстве случаев название рабочей группы можно оставить "по умолчанию", т. е. WORKGROUP или сократить его до WORK , причем на всех компьютерах в локальной сети обязательно должны быть указаны различные имена компьютеров и одно название рабо чей группы.

Обратите внимание также на третью вкладку — Управление доступом, со держимое которой позволяет либо разрешить свободный доступ к ресурсам компьютера всем участникам локальной сети, либо ограничить доступ некоторых компьютеров, при этом для описания компьютеров со свободным доступом используются их сетевые имена.

Чтобы проверить наличие связи с другими компьютерами, достаточно за пустить ярлык Пуск | Найти | Компьютер и набрать имя любого компьютера из числа тех, что подключены к локальной сети и на данный момент вклю чены. Выключенный ПК, естественно, будет недоступен даже при исправно функционирующей сети.

Для включения свободного доступа к своим дискам или к отдельным ката логам или файлам следует нажать на выбранном ресурсе правой кнопкой мыши и в выпадающем меню выбрать пункт Доступ. Здесь вы можете от крыть или закрыть по вашему желанию доступ к любому из дис ков/каталогов/файлов, при этом сам доступ может быть как полным (с воз можностью, например, удаления файлов на удаленном компьютере), так и "только для чтения" или с доступом по паролю. При помощи этих простых средств можно довольно успешно администрировать локальную сеть, так, на пример, на сервере (основном компьютере) можно отдать в свободный доступ только определенный каталог (с фильмами), что позволит спасти системные файлы операционной системы от их "случайного" удаления и т. п.

Настройка локальной сети в Windows 2000/ XP

В качестве примера мы будем рассматривать операционную систему Windows XP , но стоит отметить, что многие рассматриваемые функции имеются в Windows 2000. Тем более, что Windows 2000 довольно редко ис пользуется в домашних условиях из-за немалой ее специфики.

Так же, как и в Windows 9 x , после установки сетевой платы в компьютер и настройки драйверов автоматически создается подключение к локальной сети с некоторыми средними настройками. "По умолчанию" устанавливаются следующие компоненты:

  • Клиент для сетей Microsoft — этот компонент необходим для организации удаленного доступа к сетевым ресурсам;
  • Служба доступа к файлам и принтерам сетей Microsoft — без комментариев;
  • Протокол Интернета (TCP/IP) — как и в случае с Windows 9 x , в свойст вах протокола можно выбрать как автоматическое определение IP -адреса, так и установить его вручную.

Стоит отметить, что установленные компоненты можно просмотреть, запус тив ярлык Пуск | Подключения | Отобразить все подключения. После этого щелкнуть правой кнопкой мыши по значку Подключение по локальной сети и выбрать в меню пункт Свойства.

Помимо имеющихся протоколов, следует также установить IPX / SPX / NetBIOS -совместимый транспортный протокол из вкладки Установить | Протокол.

В свойствах протокола TCP/IP введите постоянный IP -адрес, который дол жен быть того же формата, что и в случае с Windows 9 x , нажмите кнопку Дополнительно и в открывшемся окне произведите следующие настройки. В первой вкладке, которая называется Параметры IP , можно ввести IP -адрес шлюза, через который вы можете подключиться к Интернету. Следующую вкладку ( DNS ) можно пропустить, далее следует вкладка под названием WINS , в которой следует отключить Просмотр LMHOSTS , ставим галочку на пункте Отключить NetBIOS через TCP/IP. После внесения всех измене ний, которые следует подтвердить нажатием кнопки ОК (но ни в коем слу чае не Отмена), компьютер надо перезагрузить, чтобы все изменения вступили в силу.

Запустите Мастер настройки сети, который можно найти по пути Пуск | Стандартные | Связь, при помощи которого закончите настройку локальной сети, а это означает следующее — ввести тип подключения, имя, описание компьютера и название рабочей группы.


Проверка работоспособности локальной сети

Быстро проверить качество работы только что настроенной локальной сети можно при помощи утилиты под названием PING , которая работает по принципу измерения времени прохождения сигнала от компьютера, на ко тором она была запущена до любого указанного компьютера (указывается его IP -адрес). Если после какого-нибудь адреса время ответа удаленного компьютера резко увеличилось по сравнению с теми результатами, что дава ли остальные компьютеры, то значит, вы обнаружили "узкое место" в сети, которое в дальнейшем может стать причиной проблем со связью.


Соединение двух компьютеров без сетевых плат

Если вы не имеете возможности или желания приобрести сетевые платы и кабель, но подключить один компьютер к другому очень нужно, можно вос пользоваться так называемым прямым соединением.

Прямое соединение — соединение компьютеров при помощи кабеля, соеди няющего последовательные или параллельные порты двух компьютеров и не требующее для своей организации дополнительного аппаратного и про граммного обеспечения. Поддержка прямого соединения имеется в любой из версий операционной системы Windows .

В основном прямое подключение используется для организации доступа к жесткому диску ноутбука (или другого настольного компьютера), когда требуется скопировать большой объем данных, или для запуска игровых программ в сетевом режиме. Стоит отметить, что немало игр поддерживает работу в режиме прямого соединения.

При прямом соединении один из компьютеров назначается ведущим, а другой — ведомым. С ведущего компьютера можно получить доступ ко всем дискам и каталогам ведомого компьютера. Стоит отметить, что управление передачей данных возможно только с ведущего ПК, т. е. при этом образуется связь с односторонним управлением.

Единственный недостаток этого способа соединения — низкая скорость пе редачи данных. Так для последовательного порта она составляет максимум 115200 бит/с, что явно недостаточно для эффективной работы, напри мер, для организации доступа к базе данных бухгалтерской программы 1С-Бухгалтерия. Естественно, что при таком соединении можно подключать в сеть только два компьютера.

Как уже отмечалось, для организации прямого подключения нет необходи мости в установке дополнительного программного обеспечения, т. к. для этого используется программа, входящая в комплект операционной систе мы. В Windows 9х программу эту можно найти в меню Пуск | Программы | Стандартные | Связь | Прямое кабельное соединение. Стоит отметить, что данная программа "по умолчанию" не устанавливается, поэтому вам придется сделать это самостоятельно. В Windows XP прямое соединение можно настроить при помощи мастера настройки сети.

Естественно, что для успешного соединения потребуется установка на ком пьютерах одинаковых сетевых протоколов и компонента, разрешающего общий доступ ко всем файлам и принтерам.


Организация общего доступа в Интернет

Если у вас дома имеется выделенная линия и несколько компьютеров, объе диненных в локальную сеть, то вам просто необходимо установить компо нент Общий доступ к подключению Интернета, что позволит всем участни кам локальной сети иметь доступ к глобальной сети, хотя этот компонент будет полезен также и при наличии обычного модемного соединения.

Рассмотрим, как настраивается общий доступ к подключению Интернета в семействе Windows 9 x :

  • запустите значок Установка и удаление программ, выберите вкладку Установка Windows . В открывшемся списке найдите пункт Средства Интернета, войдите в него нажатием кнопки Состав. Установите галочку напротив требуемого компонента, после чего нужно дважды нажать кнопку ОК и, указав путь к дистрибутиву Windows , дождаться, пока все необходимые файлы не будут скопированы в системный каталог;
  • после установки автоматически (даже без перезагрузки компьютера) за пустится Мастер общего доступа к подключению Интернет. Нажмите кнопку Далее для начала настройки или Отмена для закрытия мастера, если вы хотите продолжить настройку в следующий раз;
  • выберите способ подключения к сети Интернет, который вы используете, после чего нажмите кнопку Далее. В случае выбора второго пункта будет предложено выбрать устройство, через которое компьютер подключен к сети Интернет;
  • вставьте отформатированный гибкий диск в дисковод а= и нажмите кнопку Далее, после чего вам будет предложено записать на него инфор мацию, которая необходима для настройки остальных компьютеров ло кальной сети. Вы можете отменить создание дискеты и сразу же перейти к последнему окну мастера;
  • перезагрузите компьютер. Созданную ранее дискету можно использовать для настройки всех компьютеров, подключенных к локальной сети.

Общий доступ к подключению Интернет работает следующим образом. Когда один из компьютеров в локальной сети выполняет запрос к Интернету, его частный IP -адрес передается компьютеру, обеспечивающему подключе ние. Последний преобразует этот частный IP -адрес в свой IP -адрес и отправляет запрос в Интернет. При получении результатов компьютер, обеспечи вающий подключение, выполняет обратное преобразование IP -адреса и отправляет ответ компьютеру сети, который подал этот запрос.

Единственный компьютер домашней сети, видимый из Интернета (то есть имеющий прямое подключение), — это компьютер, обеспечивающий под ключение. Остальные компьютеры домашней сети подключаются к Интернету через этот компьютер. Они не подключены к Интернету напрямую.

Перед запуском мастера установки на одном из компьютеров локальной се ти убедитесь, что выполнены следующие требования:

  • на компьютере установлена операционная система Windows ;
  • на компьютере установлена и подключена к локальной сети сетевая плата;
  • на компьютере установлена поддержка протокола TCP/IP;
  • на компьютере установлен браузер (следует отметить, что Internet Explorer устанавливается "по умолчанию" при установке операционной системы Windows );
  • компьютер, обеспечивающий подключение к Интернету, имеет подклю чение как к Интернету, так и к локальной сети.

Для настройки компьютера установите ранее созданную дискету в дисковод, введите команду a :\ icsciset . exe в окне Выполнить и нажмите кнопку ОК.

В операционных системах Windows 2000/ХР следует воспользоваться масте ром настройки сети. В Windows XP SPl при создании шлюза для общего доступа в Интернет не обходимо указывать IP -адрес только 192.168.0.1, иначе работать система не будет, такова уж особенность упомянутого обновления.


FAQ ( ответы на часто задаваемые вопросы )

Вопрос: После установки сетевой платы компьютер стал медленно загру жаться. Можно ли это устранить при помощи настроек, или неисправна се тевая плата?

Ответ: При сохранении всех настроек сетевой платы "по умолчанию" каж дый раз при включении компьютер пытается соединиться со специальным сервером, который должен присвоить ему уникальный IP -адрес. Если такого сервера нет в локальной сети (называется он DHCP -сервер), тогда следует компьютеру задать постоянный IP -адрес, который должен быть уникальным для каждого компьютера.

DHCP ( Dynamic Host Configuration Protocol ) — протокол динамической на стройки ЭВМ. Термин " DHCP - Server " обозначает службу, которая выдает из определенного диапазона адресов статический IP -адрес компьютеру.

Вопрос: Вот вы пишите, что витая пара состоит из четырех пар проводни ков, и в то же время упоминаете об обычном телефонном кабеле. Как это понимать?

Ответ: Если подходить к вопросу организации локальной сети на профес сиональном уровне, то стоит отметить, что существует несколько видов кабеля "витая пара". Он бывает одножильный и многожильный, экранирован ный и неэкранированный. Для обозначения экранированного кабеля используется аббревиатура STP ( Shielded Twisted Pair ), а для неэкранирован- ного кабеля — UTP ( Unshielded Twisted Pair ). При этом неэкранированный кабель подразделяется на уровни ( Level I , Level 2) или же классы (А, В, С) в зависимости от диапазона частот, который используется для передачи данных (см. табл. 17.6).

Таблица 17.6. Классификация неэкранированного кабеля типа " витая пара "

Полоса частот, МГц | Категория(уровень) | Класс
до 0,1 | 1 | А
до 1 | 2 | В
до 10 | 3 | С
до 20 | 4 | _
до 100 | 5 | D
до 200 | 6 | Е
до 600 | 7 | F

По большому счету, кабель UTP изначально предназначался для телефонных линий, поэтому для локальных сетей, использующих высокую скорость пере дачи данных, он мало подходит. Также "витая пара" может быть как восьми-, так и четырехжильной, причем для наиболее распространенных стандартов в любом случае используются только четыре жилы, в то время как остав шиеся четыре используются только ради совместимости с менее распростра ненными стандартами. Этот факт позволяет вполне успешно использовать даже не совсем верно "обжатые" соединительные кабели.

Стоит отметить, что для организации локальной сети со скоростью передачи данных до 10 Мбит/с достаточно использовать кабель 3-й категории, в то время как для более скоростных линий (до 100 Мбит/с) следует применять уже кабель не менее, чем 5-й категории.

Экранированный кабель ( STP ) также имеет несколько модификаций:

  • ScTP — кабель, в котором каждая отдельная пара заключена в отдельный
    экран;
  • FTP — кабель, в котором "витые пары" заключены в общий экран;
  • PiMF — кабель, в котором каждая отдельная пара заключена в отдельный
    экран, причем все пары заключены еще и в общий экран.

Если продолжать тему про "упрощенные" "витые пары", то стоит упомянуть также и такие термины, как "полевка" и "лапша".

Полевка — два скрученных между собой провода (обычно стальных) в жесткой полиэтиленовой изоляции черного цвета. Применяется для прокладки телефонных сетей вне помещения (по столбам).

Лапша — телефонный кабель, используемый для прокладки линии внутри зданий. Представляет собой два проводника, соединенных параллельно друг с другом при помощи полиэтиленовой изоляции.

Вопрос: Часто можно встретить термины вроде 10 Base 2, lOBaseT и т. п. Что они обозначают?

Ответ: Этими терминами обозначают различные типы Ethernet . В частности цифра 10 обозначает скорость передачи сигнала 10 МГц, " Base " является со кращением от " Baseband " (также еще встречается слово " Broad " — от " Broadband "). Последняя секция изначально предназначалась для отображе ния максимальной длины каждого кабельного сегмента сети в сотнях метров (без применения повторителей), но этот стандарт был несколько изменен с введением терминов lOBaseT — сеть, построенная на основе "витой пары", и lOBaseF — сеть, построенная на основе оптоволокна.

10 Base 2 — сеть Ethernet , предназначенная для передачи данных со скоро стью до 10 Мбит/с. Используется тонкий коаксиальный кабель, максимальная длина сегмента сети — 185 метров. Можно также встретить названия Thinnet или тонкий Ethernet .

10 Base 5 — сеть Ethernet , предназначенная для передачи данных со скоро стью до 10 Мбит/с. Используется толстый коаксиальный кабель, макси мальная длина сегмента сети — 500 метров. Можно также встретить названия Yellow Ethernet или толстый Ethernet .

lOBaseT — сеть Ethernet , предназначенная для передачи данных со скоро стью до 10 Мбит/с на базе кабеля "витая пара" категории 3, 4, 5 с использова нием повторителей. Обычно применяется топология "звезда". Это наиболее распространенный тип сети. Максимальная длина сегмента сети 100—150 м в зависимости от качества кабеля.

100BaseT — это термин, объединяющий несколько стандартов передачи данных со скоростью до 100 Мбит/с. Они отличаются друг от друга характе ристиками сигнала, требованиями к кабелю, форматами передачи данных. Например, 100 BaseT 4 — это сеть Ethernet , предназначенная для передачи данных со скоростью до 100 Мбит/с на базе кабеля "витая пара", причем используются все четыре пары кабеля.

Вопрос: Если я буду использовать повторители, то смогу ли я создать ло кальную сеть, например, длиной в несколько километров, и смогу ли при этом подключить к ней сколько угодно компьютеров?

Ответ: К сожалению, существует целая масса ограничений, препятствующих этому. Так, например, при соединении "точка-точка" два "повторителя" счи таются за один "удлиняющий повторитель", причем на пути между двумя любыми компьютерами не может быть более двух "удлиняющих повторите лей", к любому из которых нельзя подключать другие компьютеры.

Существует одно правило, при соблюдении которого можно создать доста точно сложную по иерархии локальную сеть — это правило 5—4—3. При использовании "повторителей" можно использовать не более пяти сегментов сети, причем только к трем из них можно подключать компьютеры. Естест венно, что для пяти сегментов можно применять только четыре "повторите ля". То есть пять сегментов, соединенных четырьмя "повторителями", могут соединять не более, чем три компьютера (группы компьютеров). Следует иметь в виду, что такие устройства, как концентраторы, также играют роль повторителей.

Если говорить об отдельных стандартах, тогда следует отметить, что:

  • стандарт lOBaseT имеет ограничение на максимальное количество ком пьютеров в 30 устройств (без применения "повторителя") и минимальным расстоянием не менее 50 см между Т-разъемами;
  • стандарт 10 Base 5 имеет ограничение на максимальное количество ком пьютеров в 100 устройств (без применения "повторителя") и минималь ным расстоянием не менее 2,5 метров между подключениями.

Вопрос: Можно ли соединить две локальные сети, построенные на основе разных стандартов, например, одна создана на базе коаксиального кабеля, а другая — на базе "витой пары".

Ответ: В принципе это возможно, но только при условии соблюдения огра ничений обоих стандартов. Для этого вы можете использовать маршрутиза торы, повторители и другие подобные устройства, имеющие соответствую щие разъемы (обоих стандартов).

Вопрос: Мне сказали, что нужно обязательно заземлять сеть, построенную на базе коаксиального кабеля, в противном случае она не будет работать, но сеть уже почти год функционирует без проблем (без заземления). Как это объяснить?

Ответ: Обязательному заземлению подлежит только сеть, построенная на базе толстого коаксиального кабеля. Если вы применяете тонкий кабель, то его можно и не заземлять, хотя иногда заземление позволяет улучшить ста бильность работы сети. При этом следует отметить, что заземление нужно подключать со стороны одного из "терминаторов" и ни в коем случае не с обеих сторон и не где-нибудь в середине, что может привести к полной потере связи между компьютерами. Также следует иметь в виду, что некоторые устройства, например повторители, автоматически заземляют подклю ченный к ним конец кабеля, хотя это утверждение нисколько не умаляет необходимости изучения документации на устройство, чтобы убедиться в этом.

Следует отметить, что при прокладке кабеля на улице заземлять его дейст вительно просто необходимо, иначе первый же разряд молнии придется на ваш компьютер.

Вопрос: Компьютер подключен к локальной сети исправным кабелем (про веряли на другом компьютере), но не могу настроить подключение к другим компьютерам. Что можно сделать, чтобы исправить ситуацию?

Ответ: Во-первых, выясните, правильно ли установлены драйверы для сете вой платы и нет ли аппаратного конфликта с другим оборудованием. Если все нормально, то вашим следующим шагом должна быть переустановка всех необходимых сетевых протоколов (возможно, вы забыли что-то устано вить). При этом обязательно еще раз проверьте IP -адрес, возможно, он со ответствует IP -адресу другого компьютера в сети, который был включен раньше. В этом случае задайте компьютеру уникальный адрес.

Если все настройки сетевой платы и сетевых протоколов в порядке, про верьте название рабочей группы (оно должно соответствовать названию ра бочей группы на всех остальных компьютерах). Если вы используете вход в сеть Клиент для сетей Microsoft , тогда вам следует перезагрузить компью тер и обязательно нажать клавишу < ENTER >, а не < ESC >, как это делают некоторые пользователи. Если вы забыли пароль, наберите другое имя, которое еще ни разу не было использовано на этом компьютере, введите новый пароль и нажмите клавишу < ENTER >.

Вопрос: Можно ли подключить друг к другу два концентратора, чтобы со единить две локальные сети в одну?

Ответ: Да, конечно, можно. Для этого используется та же "перекрестная" разводка, что и при подключении двух компьютеров без концентратора. Стоит отметить, что можно воспользоваться переключателем PC / HUB , если таковой имеется на концентраторе. В этом случае разводка остается преж ней ("прямой").

Вопрос: Светодиоды на сетевой плате лихорадочно мигают. Связи нет. Что делать?

Ответ: В большинстве случаев во всем виновато заземление. Отключите его, после чего все должно наладиться.

Вопрос: Купил разъемы RJ -45 и только потом обратил внимание на то, что у них всего шесть контактов. Что теперь делать?

Ответ: Честно говоря, термин "разъем RJ -45" применяется не всегда оправданно. Сама по себе аббревиатура " RJ " ( Registered Jack ) используется для идентификации кабельной разводки — каждый тип разводки по идее имеет собственное обозначение вроде RJllC , RG 14 C или R . J 45 S . Всего существует четыре разновидности разъемов, которые используются для создания ло кальных сетей на базе "витой пары". Это "обычный" восьмиконтактный разъем, разъем с восемью контактами и ключом, шестиконтактный разъем и шестиконтактный модифицированный разъем. Третий и четвертый разъемы имеют названия RJ -11 и RJ -12, поэтому вас просто "надули" при покупке.


Глава 18. Компьютерные вирусы

  • Понятие компьютерного вируса
  • Понятие антивирусной программы
  • Как происходит заражение компьютера вирусом?
  • Настолько ли страшны компьютерные вирусы?
  • Борьба с компьютерными вирусами на практике


Понятие компьютерного вируса

Компьютерный вирус — это фрагмент исполняемого кода, который копирует себя в другую программу, модифицируя ее при этом.

Здесь стоит отметить, что, в первую очередь, это обычная программа, прав да, предназначенная не для удовлетворения потребностей пользователя, а наоборот, призванная уничтожить ценную информацию, испортить "досуг" различными сбоями операционной системы и программного обеспечения, нанести материальный ущерб и т. п.

Наиболее характерные черты компьютерных вирусов:

  • самостоятельное копирование из каталога в каталог или из файла в файл, что обычно называется "самовоспроизведением". Это позволяет вирусам выживать в условиях постоянной смены программного обеспечения (за раженную программу пользователь может удалить и на этом "жизнь" ви руса закончится). Тем более, что наличие копии вируса в каждой папке повышает шанс его копирования на другой компьютер;
  • маскировка под полезные программы или режим невидимости, при кото ром вы даже не подозреваете, что компьютер заражен (при нажатии ком бинации клавиш < CTRL >+< ALT >+< DEL > запущенные вирусом файлы не отображаются).

Естественно, что не все программы, которые самостоятельно копируют некоторые файлы в различные каталоги и создают видимость, что ничего не происходит, можно считать компьютерными вирусами.

Существует несколько критериев, позволяющих классифицировать компью терные вирусы, — это поддерживаемая операционная система, способ зара жения, алгоритмы работы, деструктивные возможности.

По операционным системам компьютерные вирусы можно подразделить на:

  • вирусы, работающие в среде MS - DOS , — весьма устаревшая категория вирусов, которая еще может в отдельных случаях быть опасной, напри мер для Windows 9 x или MS - DOS , но в операционных системах Windows NT они просто не могут быть запущены по вполне естествен ным причинам;
  • вирусы, работающие в среде Windows 9 x , — наиболее широко распро страненная категория вирусов, по сей день представляющая большую опасность;
  • вирусы, работающие в среде Windows NT , — наиболее "продвинутые" ви русы, т. к. некоторые особенности работы операционных систем данного семейства по своей сути сами по себе защищают компьютер от воздейст вия вирусов, например блокируется прямой доступ к управлению аппа ратными ресурсами.

По алгоритму заражения все многообразие компьютерных вирусов разделя ют на следующие категории:

  • файловые вирусы заражают программные файлы с такими расширениями, как COM , EXE , DLL , SYS , DRV , VXD . Файловые вирусы могут заражать файлы практически любой операционной системы независимо от ее версии. Отдельной категорией стоят вирусы, которые заражают документы, соз данные при помощи пакета программ Microsoft Office , это так называе мые макровирусы;
  • загрузочные вирусы, или как их еще называют boot -вирусы (бутовые), ко торые заражают загрузочные области дискет и жестких дисков, точнее ту их часть, что не используется системными файлами. Такие вирусы зара жают практически все дискеты, которые используются на зараженном компьютере.
  • Особенность загрузочных вирусов состоит в том, что они загружаются в память компьютера еще до запуска операционной системы, а значит, до запуска антивируса, что несколько затрудняет своевременное их обна ружение, особенно, если программа для "ловли вирусов" при запуске компьютера не проверяет оперативную память. Еще одним нюансом загрузочных вирусов является то, что в операционных системах типа Windows многие из них не способны к заражению других дисков;
  • загрузочно-файловые вирусы обладают возможностью заражения как раз личных файлов, так и загрузочной области дисков. При этом заражение может произойти даже при простом обращении к зараженному диску или при запуске зараженного файла;
  • сетевые вирусы — эта категория вирусов способна самостоятельно пере давать свой программный код всем компьютерам, подключенным к ло кальной сети. Часто эту категорию вирусов называют червями;
  • "троянские кони" — эта категория вирусов, как правило, никогда не за ражает файлы или загрузочную область диска, а просто прописывает себя в автозагрузку и ждет, когда же вы введете некий пароль, чтобы отправить его создателю вируса. Такие программы предназначены, в основном, для кражи ценной информации.

Способы заражения могут быть совершенно разными. Например, вирус ак тивируется при запуске операционной системы и остается в оперативной памяти до завершения работы компьютера, при этом заражаются все файлы и диски, к которым обращается система во время своей работы. Или другой вариант — после первого запуска вирус "прописывает" себя в автозагрузку и после каждой загрузки операционной системы в память компьютера копи руется программный код вируса. Вариантов может быть великое множество, поэтому все их мы рассматривать не будем.

В принципе, если в подробностях изучать разновидности компьютерных вирусов, то можно посвятить этому целую книгу, но в данном случае нас интересует в первую очередь то, как можно от них избавиться.


Понятие антивирусной программы

Антивирусная программа — это программа, которая предотвращает зараже ние ПК компьютерными вирусами и позволяет устранить последствия зара жения.

Вполне естественно, что раз существуют компьютерные вирусы, то сущест вуют и антивирусные программы, позволяющие эти самые вирусы удалять с компьютера, а иногда даже спасать поврежденную информацию. Чтобы предотвратить возможность "заражения" компьютера, обычно используются антивирусные программы, которые можно подразделить на два основных вида:

  • антивирусный сканер — эта категория позволяет проверять файлы и ката логи, содержащиеся на жестком диске или на любом сменном носителе, на наличие в них программного кода, характерного для того или иного компьютерного вируса (не секрет, что вирусы "прикрепляют" себя к ис полняемым файлам других программ). При этом вы можете запустить проверку в любое удобное для вас время;
  • антивирусный монитор — данная категория предназначена для постоян ного контроля всех запускаемых программ и копируемых (перемещае мых, удаляемых, открываемых) файлов. Как правило, антивирусный мо нитор запускается вместе с операционной системой и контролирует все процессы, выполняемые в оперативной памяти. В качестве дополнитель ной услуги монитор может проверять файлы на жестком диске, если на компьютере в течение определенного времени не осуществляется ника ких работ. При этом работа компьютера несколько замедляется, а то и вообще становится очень медленной. Здесь все зависит от того, какие по размеру файлы используются. Особенно замедление работы заметно на играх.

На сегодняшний день наиболее популярными являются антивирусные про граммы:

  • AVP или Антивирус Касперского, официальный сайт http :// www . kaspersky . ru /;
  • Dr . Web , созданная специалистами компании "Диалог-Наука" http :// www . dials . ru /;
  • Symantec Norton Antivirus, http://www.symantec.com/.

Каждый вирус (без исключения) имеет в своем "теле" характерный только для него программный код, который, как правило, не похож ни на одну "полезную" программу или утилиту. Именно эта часть кода содержится в специальном файле антивирусной программы, который обычно называет ся антивирусной базой.

Помимо антивирусных программ, в лечении компьютерных вирусов могут помочь такие программы, как Process Viewer , позволяющие не только уви деть абсолютно все программы, запущенные на данном компьютере, но и удалить любую программу из оперативной памяти, принудительно прервав ее выполнение. Этим самым вы можете остановить выполнение компьютер ного вируса, позволив антивирусной программе вылечить или удалить все зараженные файлы (обычно один или несколько файлов не доступны для лечения из-за того, что они используются запущенными программами).


Как происходит заражение компьютера вирусом ?

На этот вопрос можно дать очень простой ответ: "Всему виной Интернет". Так или иначе компьютерные вирусы попадают на компьютер пользователя посредством так называемой глобальной сети — либо вместе с электронным письмом, либо когда сам пользователь скачивает некоторый файл, содер жащий вирус, и потом запускает его на своем компьютере или несет на дискете на компьютер друга, коллеги.

Давайте разберемся подробнее, как же на самом деле все происходит и чего следует в первую очередь опасаться.

Вариант первый — зараженная дискета. При этом заражение может проис ходить как при открытии содержимого дискеты (например, вирус VBS . Redlof ), так и при открытии файла, например, зараженного макровирусом. Дискеты все реже используются в качестве загрузочных, но вариант заражения в момент загрузки с дискеты нельзя полностью исключить, т. к. забытая дискета в дисководе в момент запуска компьютера несет в себе потенциальную опасность. Если на ней имеется загрузочный вирус, тогда он загружается в память компьютера при первом же обращении к ней, при этом он может успеть заразить зафузочную область жесткого диска. То же самое относится и к жестким дискам, подключаемым к компьютеру, а также компакт-дискам. Наиболее полную защиту от подобной ситуации дают анти вирусные мониторы, блокирующие доступ к зараженному диску или файлу. Вариант второй — электронная почта. При этом заражение может происхо дить либо при запуске файла, вложенного в письмо и содержащего про- фаммный код вируса, либо при просмотре письма, когда вирус запускается автоматически, используя так называемые "дыры" (ошибки в программе), позволяющие подобный запуск. Самую большую гарантию безопасности при этом могут дать антивирусные мониторы или специальные модули, специализирующиеся на проверке поступающей почты.

Вариант третий — скачивание файлов. При этом практически любой скаченный вами файл может быть заражен компьютерным вирусом, поэтому прежде чем любой из них использовать (распаковывать, запускать), следует проверить их антивирусным сканером, хотя в большинстве случаев можно положиться на программу-монитор.


Настолько ли страшны компьютерные вирусы ?

Вирусы запускаются сами по себе

Нет, это не совсем верно. Для активизации вируса требуется запустить ту или иную программу. В операционных системах семейства Windows , незави симо от версии, для всех файлов назначена строго определенная программа или действие, выполняемое одним из служебных модулей самой операци онной системы. При просмотре того или иного файла автоматически запус кается назначенная программа, но для пользователя это происходит как бы незаметно (он ведь просто хочет почитать текст), поэтому для него создается впечатление, что вирус можно запустить самостоятельно, тогда, когда он сам запускает его вместе с программой-просмотрщиком.

Вирусы позволяют выкрасть ценную информацию

Да, действительно, существует категория компьютерных вирусов, предна значенных для кражи ценной информации. Обычно этим занимаются "тро янские кони". Наиболее часто воруют различные пароли, например, доступа к сети Интернет, pin -коды и др., т. е. все то, что может причинить вам ма териальный ущерб.

"Троянские кони", ворующие ценную информацию, могут либо отправлять ее на чей-нибудь электронный ящик — это становится возможным в случае подключения вашего компьютера к сети Интернет, либо сохранять всю информацию в текстовый или иного формата файл. Следует иметь в виду, что второй вариант говорит о том, что человеку, заразившему ваш компью тер "троянским конем", обязательно нужно будет получить доступ к вашему компьютеру, чтобы скопировать этот файл. Доступ к компьютеру возможен либо локальный (например, в ваше отсутствие), либо по локальной сети, если таковая имеется.

Отдельной категорией стоят так называемые клавиатурные шпионы. Они не только могут привести к утечке паролей и кодов, но и вообще всей инфор мации, которую вы вводите в компьютер при помощи клавиатуры.

Вирусы способны испортить компоненты компьютера

Да, действительно, существует категория вирусов, способных привести в негодность один или сразу несколько компонентов компьютера, напри мер, материнскую плату. Такое стало возможным после того, как стали применять так называемую FLASH -память, которая позволяет при помощи обычных программ изменять ее содержимое. При этом запись в микросхему FLASH -памяти не программного кода, а случайного "мусора", приводит к невозможности использования данного оборудования. Наиболее ярким примером подобных вирусов является WinCIH или его бблее опасный пото мок I . Worm . Magistr .

Вирусы приводят к потере информации

Да, действительно, существует ряд вирусов, приводящих в негодность, на пример, все файлы с расширением DOC , TXT (вирус под названием KLEZ . H ). Также существует ряд вирусов, уничтожающих файловую систему, что приводит к потере абсолютно всех файлов на диске. Правда, следует иметь в виду, что в большинстве случаев все-таки имеется возможность вос становления информации. Дело в том, что физически стереть информацию с целого жесткого диска объемом хотя бы 1 Гбайт довольно не просто, по этому большая часть вирусов уничтожает ссылки на всю информацию, а не сами данные. Иногда вполне достаточно воспользоваться программой UNERASE или UNDELETE , чтобы восстановить большую часть данных.


Борьба с компьютерными вирусами на практике

Самое главное правило — как только компьютер начал выдавать не появ ляющиеся ранее ошибки, обязательно проверьте все файлы на жестком диске антивирусным сканером. Возможно, проблема связана с повреждением какого-нибудь системного файла, но в любом случае нельзя пренебрегать определенными мерами безопасности.

Если вы регулярно и особенно подолгу работаете в сети Интернет, тогда вам следует установить на свой компьютер антивирусный монитор, который будет "фильтровать" все поступающие на ваш компьютер данные.

Если у вас нет доступа ни к сети Интернет, ни к какой-либо локальной се ти, тогда вам будет вполне достаточно регулярно пользоваться антивирус ным сканером, а самое главное, проверять им все поступающие на компью тер данные с дискет или же компакт-дисков и других носителей.

Если вы обнаружили или подозреваете, что ваш компьютер заражен компь ютерным вирусом, ваши действия должны быть следующими:

  • сохраните наиболее важную информацию на сменных носителях. Даже если эти файлы также окажутся зараженными, можно будет потом, не торопясь, "вылечить" их, а пока что вас должна волновать операционная система. Лучше всего все это делать после загрузки компьютера с загру зочного диска, обязательно созданного на незараженном компьютере;
  • проверьте жесткий диск антивирусной программой, при этом антивирус ные базы должны быть как можно более новыми;
  • при обнаружении зараженного файла попытайтесь "вылечить" его, если же это не удается, тогда смело удаляйте зараженный файл — лучше зано во установить ту программу, к которой он принадлежит, чем впоследст вии потерять информацию;
  • после удаления компьютерного вируса иногда приходится переустанавли вать операционную систему или некоторые программы;
  • сменные носители после "лечения" или вместо него можно отформати ровать;
  • жесткий диск можно избавить от загрузочного вируса командой fdisk / mbr . При этом предварительно следует загрузиться с "чистого" загрузоч ного диска, на котором имеется программа FDISK . Обратите внимание, что не все вирусы вы сможете удалить с жесткого диска путем формати рования, т. к. при этом совсем не затрагиваются некоторые служебные области, создаваемые при создании на нем разделов.

Для того чтобы убедиться в отсутствии или наличии на своем компьютере "троянских коней", можно запустить редактор системного реестра (команда REGEDIT ) и открыть по очереди следующие ветви:

HKEY_CUKRENT_USER\Software\ Microsoft\Windows\CurrentVersion\Run HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\CurrentVersion\Run HKEY_LOCAL_MACHINE\SOFTWARE\ Microsoft\Windows\CurrentVersion\RunServices HKEY_USERS\.DEFAULT\Software\ Microsoft\Windows\CurrentVersion\Run

Если в одной из низ имеется подозрительный ключ, не относящийся к программам, которые вы устанавливали или которые использует операционная система, тогда вам следует срочно воспользоваться антивирусной программой.

Теперь о практическом использовании антивирусных программ. Самое главное правило — следует использовать только новые антивирусные базы. После установки программы с компакт-диска обязательно проверьте, какого числа было произведено последнее обновление. Например, для программы Kaspersky Anti - Virus это можно сделать, выбрав пункт меню Справка | О Программе. Дата последнего обновления должна быть не позже, чем 30 дней назад, потому что за этот период обычно успевает появиться немалое количество новых вирусов, против которых "старый" антивирус бесси лен. Обновление базы для описываемой программы можно найти на интер нет-сайте http :// www . kaspersky . ru . Обратите внимание на то, что антивирус с устаревшей базой может даже способствовать распространению вирусов, т. к. у пользователя в таком случае создается ложное представление о безо пасности. Нельзя забывать и о возможности защиты от макровирусов, встроенных в программы пакета Microsoft Office .

При установке антивирусной программы, как правило, предлагается уста навливать как сканер, так и монитор, поэтому отдельно остановимся на особенностях работы антивирусного монитора. Дело в том, что до того мо мента как, например, открываемый файл будет проверен на наличие в нем вирусов, доступ к нему блокируется. Зачастую создается впечатление, что компьютер завис, но это не так. К сожалению, одновременное использова ние антивирусного монитора и сложных игровых программ, использующих большое количество графических текстур, приводит к снижению произво дительности компьютера из-за периодической блокировки файлов. Такова плата за антивирусную безопасность. В этом случае следует перед запуском игры завершать работу монитора.

Единственно, что остается добавить, если на вашем компьютере установлен модем, то наличие установленного антивирусного монитора обязательно. В остальных же случаях можно ограничиться установкой антивирусного сканера и периодической профилактической проверкой жесткого диска. И главное, помните, что антивирусная программа с устаревшей базой не способна обнаружить и удалить новые виды вирусов.


Глава 19. Зависания операционной системы

  • Зависания операционной системы
  • Несоблюдение режимов работы компонентов
  • Некорректная настройка BIOS
  • Удалены (повреждены) системные файлы
  • Ошибки файловой системы
  • Ошибки в системном реестре
  • Воздействие компьютерных вирусов
  • Аварийная загрузка операционной системы
  • Проблемы при выключении компьютера


Зависания операционной системы

Тема, которую мы будем рассматривать в данной главе, на мой взгляд, явля ется самой животрепещущей, да к тому же еще и самой спорной. Попробуй те ответить на вопросы: "Что такое зависание?", "Чем отличается зависание от других видов сбоев, например от резкого замедления работы ПК?" Поду мали над ответом? Запросто могу поспорить, что большинство из читателей четко не могут представить себе, что это такое — зависание. Вот отсюда и рождаются различные термины, например, "сглючил" или "программа зава лилась". Попробуем разобраться все-таки, что такое зависание и чем оно может нам грозить.

Зависание — это такое состояние компьютера (или операционной системы), когда он (она) перестает отвечать на запросы пользователя, такие как нажа тие клавиш как на клавиатуре, так и на других устройствах ввода (мышь, сканер, цифровая фотокамера и т. д.). Причин этому может быть великое множество, поэтому начнем данную главу традиционно с классификации причин зависаний.

Наиболее чреватая последствиями причина зависаний — нарушение темпе ратурных и иных режимов работы компонентов компьютера. При этом вы рискуете не только потерять ценную информацию, но и получить "головную боль" из-за поломки одного из компонентов компьютера. Стоит отметить, что многие компании, занимающиеся продажей компьютеров, не принима ют сгоревшие комплектующие, на которых в свою очередь имеются следы перегрева. Например, на центральные процессоры, а также модули опера тивной памяти, приклеивают наклейки, которые от высокой температуры съеживаются, выдавая тем самым причину поломки. Заменить подобную наклейку достаточно сложно, т. к., во-первых, попробуйте найти такую же наклейку, во-вторых, попробуйте восстановить все надписи на ней, которые были на оригинале. В этих надписях "скрываются" данные о сроках гарантии и т. д.

К первой категории можно также отнести "естественное старение" компо нентов, если они, как говорят некоторые пользователи, после Ю лет бес сбойной работы стали ни с того ни с сего работать плохо. Комментировать эту ситуацию не рискнул бы даже самый прожженный специалист по ре монту, т. к. эти слова не пропустила бы даже самая лояльная цензура.

Вторая по частоте распространения причина плохой работы компьютеров — это некорректные установки в программе CMOS Setup Utility , а если говорить попроще, то в BIOS компьютера. В большинстве случаев эти настрой ки никто не трогает, что зачастую позволяет, конечно, добиться нормальной работы компьютера, но это вовсе не дает гарантии того, что настройки "по умолчанию" будут хорошо совместимы со всем установленным оборудованием. Например, при загрузке параметров из пункта вроде Load Optimized Default на некоторых материнских платах включаются нестандартные режи мы работы шины PCI или AGP , в которых имеющийся жесткий диск или видеоплата могут давать сбой. Выявить подобный эффект не так-то просто, потому что сбои могут появляться через несколько часов работы и только в строго определенных программах, что усложняет их диагностику. Тем бо лее что в BIOS обычно имеется неплохой набор параметров, предназначен ных для ручного или автоматического распределения ресурсов независимо от операционной системы.

Третья причина, которая достаточно часто встречается, если пользователь ПК, мягко говоря, начинающий, да любопытный, — это удаление, некор ректное изменение или перемещение системных файлов. Честно говоря, зависанием состояние компьютера, которое "достигается" после порчи сис темных файлов, сложно назвать, но все-таки и этот вариант нельзя исклю чать, если у вас компьютер стал плохо работать. Иногда в результате повре ждения системного файла операционная система на самом деле способна зависать в процессе загрузки даже без вывода каких-либо сообщений.

Четвертая причина зависаний, практически, сама собой вытекает из преды дущей, что иногда может привести к неправильной диагностике неполадки. Здесь речь идет об ошибках в файловой системе жесткого диска. В этом случае может возникнуть такая ситуация, при которой системный файл работоспособен, но операционная система не может найти его, пользуясь дан ными, взятыми из таблицы размещения файлов.

Пятая причина зависаний заключается в особенностях некоторых компо нентов компьютера, которые, в силу своей невысокой цены, могут обладать целым рядом весьма неприятных особенностей. Так, например, некоторые приводы CD - ROM не поддерживают работу с DMA -каналами, что стало сегодня практически стандартом. Это приводит к тому, что попытки вклю чить этот режим могут привести к сбоям при обращении к такому приводу. В качестве "последней пули" в данной ситуации стоит отметить, что практи чески все виды пакетов драйверов для материнских плат автоматически включают режимы DMA для всех устройств, работающих на шине IDE . И только операционная система Windows XP в некотором роде защищена от подобной ситуации, т. к. в ней по умолчанию для приводов CD - ROM ис пользуется устаревший, зато более надежный режим РЮ4.

Шестая причина связана с ошибками в системном реестре. Обратите внимание, что в этом случае не идет речь о повреждении файлов системного реестра, что приводит к невозможности его загрузки. Речь идет о появлении некорректных ссылок в реестре, которые могут приводить к замедлению работу компьютера, невозможности запуска некоторых программ, а в неко торых случаях к периодическим зависаниям.

И последняя, наверное самая непонятная для пользователей причина зави саний, — это деструктивное воздействие компьютерных вирусов. Очень многие пользователи делают круглые глаза, когда начинаешь им рассказы вать про то, как вирусы "палят" материнские платы, очищают от "мусора" жесткие диски Но от реальности никуда не денешься, поэтому и этот фак тор приходится учитывать, тем более, что проблемой может стать не столько компьютерный вирус, как сама антивирусная программа, с первого взгляда предназначенная как раз для уменьшения вероятности появления сбоев в работе компьютера.


Несоблюдение режимов работы компонентов

Под несоблюдением режимов работы компонентов компьютера следует по нимать все ниже перечисленные пункты:

  • некачественное охлаждение компонентов компьютера, в частности, про цессора, видеоплаты, модулей оперативной памяти, жесткого диска, а иногда блока питания системного блока. Все это может приводить как к периодическим зависаниям во время работы, так и к поломке компо нентов, подвергавшихся перегреву;
  • нестабильное электропитание компонентов компьютера. Причиной зави саний могут быть как колебания в электросети, так и нестабильная рабо та блока питания системного блока, который в свою очередь может так работать из-за серьезного перегрева или же из-за превышения потреб ляемой мощности. Хотя здесь нельзя исключать возможность производ ственного брака, особенно, если ваш компьютер новый;
  • разгон, как отдельных компонентов, так и всего компьютера в целом. Подобное заявление вы, наверное, уже слышали неоднократно. И дейст вительно, разгон не только уменьшает срок эксплуатации разогнанных компонентов, но и приводит к различным сбоям в работе компьютера. Тем более, что любому разгону обычно сопутствует повышенное выделе ние тепла, увеличение напряжения питания для отдельных компонентов выше номинального. Не применяйте разгон, если вы не желаете полу чить вместо компьютера груду "сгоревшего" железа, т. к. подобные экс перименты требуют немалой хотя бы теоретической базы знаний;
  • постоянная вибрация, вызванная одним из вентиляторов системного блока либо некачественным креплением материнской платы, жесткого диска, привода для чтения компакт-дисков. Модульная конструкция IBM -совместимых компьютеров в таком случае подвергается постоянной опасности пропадания контакта в любом из разъемов. В некоторой сте пени увеличению уровня вибрации способствуют тонкие стенки дешевых компьютерных корпусов, что особенно заметно, если на компьютере не установлены привод CD - ROM и флоппи-дисковод, придающие ему, в случае наличия последних, некоторую жесткость;
  • засорение вентиляционных отверстий пылью, которая от постоянного нагрева прикипает к поверхности радиатора и лопастей вентиляторов, препятствуя, таким образом, нормальному охлаждению центрального процессора и блока питания.

Для профилактики сбоев по причине несоблюдения режимов работы ком понентов ПК можно посоветовать придерживаться следующих рекомендаций. Применяйте для питания компьютера (хотя бы системного блока) источник бесперебойного питания, который позволит избежать скачков напряжения и неожиданного отключения. Также к этому стоит добавить, что при покупке компьютера следует выбирать блок питания с мощностью не менее 300 Вт и в достаточно большом корпусе, который обеспечит более качественное охлаждение компонентов компьютера. Тем более, что подмечена статистика — чем дороже стоит корпус, тем толще металл, из которого он собран, что в свою очередь уменьшает уровень вибрации при работе компьютера. Дорогие корпуса, в дополнение ко всему прочему, имеют более качественные блоки питания, в чем можно убедиться, визуально сравнив его с блоком питания из любого дешевого корпуса. Небольшие размеры транс форматора или конденсаторов "выдают" низкое качество блока питания.

В качестве профилактики можно посоветовать регулярную очистку внутрен ностей компьютера при помощи обыкновенного пылесоса со щелевой на садкой. Если вы не имеете доступ внутрь системного блока, можно ограни читься вытяжкой пыли только из блока питания, который, в общем-то, как раз и является основным ее накопителем. Главное — не включайте пылесос на полную мощность.

Обратите внимание на то, что при несоблюдении минимально необходимых режимов работы компонентов компьютера вы не сможете никакими переус тановками или же тонкими настройками добиться стабильной работы ПК.


Некорректная настройка BIOS

Современный пользователь настолько избалован графической оболочкой Windows , что, попав в программу CMOS Setup Utility , позволяющую изме нять настройки BIOS , начинает удивленно хлопать глазами и спрашивать самого себя: "А куда я попал?" Если вы относитесь к этой категории пользо вателей, вам нет смысла вообще браться за настройку компьютера. Во всех остальных случаях вам придется поднабрать немного терпения и внимательно изучить многочисленные разделы данной программы. Достаточно просто это можно сделать, изучив материалы книги "Секреты BIOS".


Удалены ( повреждены ) системные файлы

Если вы умудрились удалить один или несколько системных файлов при работе в операционной системе, что особенно просто сделать в Windows 9х, вы этого никак не заметите, пока не перезагрузите компьютер. Как только одна из программ запросит перезагрузку или же вы сами захотите сделать это, "небо над вами померкнет". При этом спасти вас смогут две вещи: программа восстановления удаленных файлов или переустановка операци онной системы, что в случае с Windows 2000/ XP равнозначно полной потере всех установленных программ (в Windows 9 x имеется возможность установки операционной системы "поверх").

С другой стороны, не только "криворукость" самого пользователя может привести к повреждению или удалению системных файлов. При установке некоторых программ часть системных файлов может подвергаться замене якобы на более новые версии. Для чего это делается, не известно, хотя можно предположить, что данная программа не способна нормально рабо тать со стандартным файлом, поэтому он заменяется на модифицированную версию, которая, однако, может работать некорректно со всеми остальными программами. В реальной практике такой подход встречается нередко, по этому в той же Windows XP на этот случай имеется программа, блокирую щая попытки заменить все жизненно важные системные файлы. С другой стороны, некоторые программы при удалении "уносят" с собой некоторые системные файлы. Так, например, известная программа редактирования звуковых файлов Sound Forge (по крайней мере, версии 4.5), когда ее деин сталлируешь, предлагает удалить один важный компонент, без которого не будет работать звуковая плата. Хорошо еще, что у подавляющей части про грамм имеется функция предупреждения при удалении файлов с расшире нием DLL , SYS и проч., а также при удалении файлов из рабочего каталога Windows (подробнее в главе 12).

Другой не менее важный фактор, который может повлиять на состояние файлов, — это стабильность электропитания в момент совершения таких операций, как, например, дефрагментация. Стоит только компьютеру не ожиданно перезагрузиться в момент перемещения системного файла, как можете быть почти уверены, что после перезагрузки он окажется повреж денным или вообще будет отсутствовать. Теперь о возможности восстановления. В большинстве случаев вполне дос таточно воспользоваться старой, но от этого не менее актуальной програм мой UNERASE , которую можно найти на многих загрузочных компакт- дисках (так называемых реаниматорах). Аналог этой программы UNDELETE выполняет те же функции, что и сама UNERASE , так что большой разницы в том, что именно вы будете использовать, нет.

Если вы используете файловую систему FAT любой модификации, тогда проблем с восстановлением файлов у вас не должно возникнуть. Вам будет достаточно найти и запустить программу UNERASE , предварительно загру зившись с загрузочного диска. Если же вы используете файловую систему NTFS (также любой модификации), тогда вам придется сильно потрудиться, чтобы получить доступ к разделу с информацией. Здесь возможны два варианта. Первый заключается в подключении жесткого диска к другому компьютеру с установленной операционной системой, которая "понимает" имею щуюся файловую систему. Второй вариант более сложен в финансовом плане, т. к. вам придется прикупить специальный загрузочный диск, кото рый организует доступ к NTFS -разделам из среды MS - DOS , хотя такой диск при наличии времени да способностей можно сделать и самому.

Некоторые из системных файлов, по крайней мере те, которые находятся в рабочем каталоге Windows , можно восстановить простым копированием из дистрибутива, но здесь следует иметь в виду, что чаСть файлов находится в сжатом виде. В основном для распаковки файлов дистрибутива использу ются программы, находящиеся в самом каталоге дистрибутива, например, программа EXTRACT в Windows 98 SE . Например, при использовании упо мянутой программы командная строка будет выглядеть вот таким образом:

A:\EXTRACT /A /L С :WINDOWS\SYSTEM Z:\WIN98\win98_21.cab FILENAME,

где ключ а позволяет просмотреть все архивы дистрибутива за один проход. Ключ l и последующий за ним путь указывают путь, куда следует распако вать требуемый файл. Следующий далее путь, начинающийся с символа z , обозначает букву, назначенную приводу CD - ROM , где следует искать дист рибутив, a filename — это имя файла, который требуется найти и распако вать. Следует иметь в виду то, что в системе MS - DOS обязательно нужно указывать абсолютный путь ко всем файлам и каталогам (с использованием буквы диска), а вместе с именем файла указывать и его расширение. Стоит отметить, что указывать имя архива как в примере необязательно, потому что первый ключ "заставляет" программу EXTRACT просматривать все ар хивы дистрибутива.

Для операционных систем Windows 2000/ХР имеется возможность воспользоваться консолью восстановления, которая позволяет при помощи относи тельно небольшого набора команд автоматически восстановить системные файлы. Единственно, что вам потребуется при этом, так это компакт-диск с дистрибутивом.

Если имеется возможность загрузки операционной систему хотя бы в безо пасном режиме, можно воспользоваться заранее созданной точкой отката (для Windows ME и ХР). Делается это следующим способом:

  • запустите программу Пуск | Программы | Стандартные | Служебные | Восстановление системы;
  • выберите пункт Восстановление системы и нажмите Далее;
  • на появившемся календаре укажите дату точки отката, которую, как вы считаете, следует использовать, после чего нажмите Далее;
  • ответьте положительно на предложение закрыть все активные приложе ния, что необходимо для нормального перезапуска системы в режиме восстановления;
  • нажмите ОК, после чего компьютер перезагрузится, в процессе чего сис темные файлы будут восстановлены;
  • сразу же после восстановления вы можете отменить все внесенные изме нения (вернуть те настройки, которые были до активизации функции восстановления). Для этого опять запустите программу Восстановление системы, где имеется пункт Отмена восстановления. Это необходимо на случай, если восстановление было неудачным.

Практически единственной рекомендацией для профилактики подобных ошибок для вас может стать следующее правило — если вы не уверены в том, что файл можно удалить, не удаляйте его. Проверьте его атрибуты, если установлен атрибут "только для чтения", "скрытый" или "системный", — это почти наверняка системный файл, его нельзя ни в коем случае ни удалять, ни изменять, ни перемещать в другие каталоги. Также посмотрите на размер файла — если он незначителен, просто сделайте этот файл скрытым, чтобы он не "мешал вашему взору", когда вы занимаетесь навигацией по многочислен ным каталогам. А вот если файл занимает на диске более 10 Мбайт, в таком случае следует обратить внимание на дату его создания, что позволит хотя бы примерно определить, какой программой он создан, возможно, это вы испробовали новую версию графического редактора и забыли удалить временно созданный файл. Рекомендуется обратить особое внимание на те файлы, которые расположены в корневом каталоге жесткого диска.

Системные файлы Windows 9 x

В операционных системах Windows 9 x системных файлов, особенно расположенных в корневом каталоге жесткого диска, имеется довольно большое количество, поэтому вам следует знать их "в лицо", чтобы случайно не уда лить какие-либо при удалении "мусора". Некоторые из системных файлов можно редактировать, но не стоит этого делать, если вы не имеете достаточного опыта в работе с компьютерами.

Если один из системных файлов недоступен или поврежден, компьютер прекратит процесс загрузки и выдаст на экран монитора соответствующее сообщение. Обычно сообщение об ошибке несет небольшое количество по лезной информации, из чего следует, что вам придется "поломать голову" над причиной сбоя. В русских версиях операционных систем сообщения об ошибках могут выводиться в русской кодировке, или, как еще говорят, в кириллице, а так как для нормального отображения символов на русском языке требуется предварительная загрузка специального драйвера, экран монитора может оказаться испещрен непонятными "крякозяблами". Единст венное успокоение в данной ситуации в том, что имя файла, который стал причиной сбоя, в любом случае будет написано латинскими символами, которые, в свою очередь, нормально отображаются без всяких дополнительных драйверов.

Ниже приведен список файлов, на которые следует обратить внимание при очистке жесткого диска от "мусора".

AUTOEXEC . BAT — конфигурационный файл, доставшийся в наследство от MS - DOS . Содержит команды, которые должны быть выполнены до старта 32-битной (основной) части операционной системы. Его удаление может повлиять только лишь на работу программ, использующих его для своей инициализации, например, ключа защиты, т. к. в этом случае в память ком пьютера загружается стандартный набор тех программ-, которые необходимы для нормальной работы Windows (подробнее об этом в главе 9). Этот файл можно редактировать по своему усмотрению, но некорректные записи в нем могут вызвать зависание компьютера на этапе загрузки или во время его ра боты. Стоит отметить, что в Windows ME этот файл вообще игнорируется.

AUTOEXEC . DOS — резервная копия файла AUTOEXEC . BAT , принадлежавшего к установленной ранее копии Windows . Используется, когда в загрузочном меню была выбрана загрузка предыдущей версии операционной системы. Если вы никогда не пользуетесь этой функцией, тогда этот файл можно спокойно удалить, хотя можно и оставить, сделав его "скрытым", т. к. он занимает немного места на диске.

CONFIG . SYS — конфигурационный файл, так же как и предыдущий, ос тавшийся от MS - DOS . Используется для загрузки 16-битных драйверов, ис пользуемых, например, для работы старого оборудования. Этот файл можно редактировать, но некорректные записи в нем могут вызвать зависание ком пьютера на этапе загрузки или во время его работы. Стоит отметить, что в Windows ME этот файл вообще игнорируется.

CONFIG . DOS — конфигурационный файл, принадлежащий ранее установ ленной версии Windows . Как и файл AUTOEXEC . DOS , востребуется только в том случае, когда выбирается пункт Previous version of MS - DOS загрузоч ного меню. Его можно удалить, но только в том случае, если вы не пользуе тесь данным режимом загрузки.

COMMAND . COM — командный процессор (другими словами интерпретатор). Этот файл отвечает за выполнение команд MS - DOS , всех пакетных файлов с расширением ВАТ, загрузку в память компьютера программ MS - DOS . Необ ходим для запуска всех версий Windows 9 x , кроме Windows ME . Редактировать, удалять или перемещать его нельзя, в противном случае операционная система не загрузится.

COMMAND . DOS — командный процессор, принадлежащий предыдущей версии операционной системы. Используется только в случае, когда вы вы бираете загрузку предыдущей операционной системы в зафузочном меню.

IO . SYS — ядро операционной системы MS - DOS , входящей в состав Win dows 9х. При удалении или изменении этого файла загрузка становится невозможной. Этот файл располагается в загрузочном секторе, поэтому его восстановление осуществляется не обычным копированием, а командой SYS А: С:, причем в этот момент на дискете, установленной в дисковод А:, должны содержаться необходимые системные файлы, такие как непосредст венно сам IO . SYS , так и MSDOS . SYS , C 0 MMAND . COM , т. е. она должна быть зафузочной. Версия файла должна обязательно соответствовать версии установленной операционной системы.

IO . DOS — как и во всех предыдущих случаях, файл с этим расширением относится к предыдущей версии операционной системы.

MSDOS . SYS — конфигурационный файл операционной системы Windows , который обрабатывается в первую очередь. В нем содержатся параметры, необходимые при начальной стадии старта системы. При его отсутствии все необходимые параметры берутся из файла IO . SYS , но в этом случае зафузка будет возможна только в режиме командной строки. Правила редактирования этого файла рассмотрены в главе 9.

MSDOS . DOS — конфигурационный файл, принадлежащий предыдущей версии операционной системы.

LOGO . SYS — стартовый логотип Windows . При отсутствии этого файла, на чиная с Windows 98, используется логотип, "зашитый" в файле IO . SYS . Так как структура его напоминает обыкновенный графический файл с расширением BMP , можно менять логотип по своему усмотрению (подробнее смот рите в главе 9).

BOOTLOG . TXT — протокол зафузки операционной системы. Создается в случае, если выбирается режим зафузки " Logged " (в загрузочном меню). Он используется для выявления причины сбоев, приводящих к невозможно сти загрузки (подробнее смотрите в разделе Аварийный запуск этой главы).

BOOTLOG . PRV — протокол предыдущей зафузки операционной системы, а также последнего выключения компьютера. Как и предыдущий файл, нужен только лишь для диагностики проблем.

DETLOG . TXT — протокол процесса обнаружения оборудования, он создается при установке Windows , а также при выборе пункта Установка оборудования Панели управления, и служит для выявления причин зависаний на стадии инсталляции или же установки нового оборудования.

DETLOG . OLD — протокол предыдущего процесса обнаружения оборудова ния, он фактически является всего лишь старой версией предыдущего файла.

OEMLOG . TXT — протокол установки операционной системы в режиме OEM ( Original Equipment Manufactured ), т. е. при установке на новый жест кий диск.

SETUPLOG . TXT — протокол хода установки операционной системы, ис пользуется в случаях переустановки "поверх", чтобы не задавать пользовате лю тех же вопросов, что и при первой установке.

SUHDLOG . DAT — этот файл содержит копию загрузочных записей Master Boot Record и Partition Boot Record , существовавших до и после установки операционной системы. Он используется для восстановления главного за- фузочного сектора при удалении Windows посредством программы Установка и удаление программ, но только если это было предусмотрено во время об новления Windows .

SYSTEM .1ST — копия части системного реестра, которая отвечает за уста новленное оборудование. Этот файл можно использовать для восстановле ния поврежденного системного реестра.

SCANDISK . LOG — протокол работы программы ScanDisk . Используется только в справочных целях, для выяснения проделанной программой сканирования работы. Его создание можно отключить, выбрав в окне программы вкладку Дополнительно и установив галочку напротив пункта Не вести протокол.

CVT . LOG — протокол работы программы Drive Converter , которая предназначена для конвертирования FAT 16 в FAT 32. Используется для выяснения причин сбоев при конвертировании.

VIDEOROM . BIN — полная копия микросхемы BIOS видеоплаты, интегри рованной в материнскую плату. Используется для поддержки нескольких мониторов, так что когда вы устанавливаете вторую видеоплату в компью тер, инициализация первой происходит путем обращения уже не к самой микросхеме BIOS , а к этому файлу. Если вы удалите этот файл, то поддерж ка двух мониторов пропадет до тех пор, пока вы его не восстановите. Стоит обратить внимание, что при обновлении версии BIOS видеоплаты следует старую копию файла удалить. Тот же смысл несет в себе другой файл под названием OEMROM . BIN .

W 98 UNDO . DAT — архив файлов предыдущей версии операционной систе мы. Файл используется для "отката" версии Windows посредством програм мы Установка и удаление программ.

W 98 UNDO . INI — файл сценария "отката" версии операционной системы. Создается при обновлении версии Windows .

Системные файлы Windows 2000/ ХР

Для операционных систем Windows 2000/ХР набор системных файлов отли чается от набора файлов для семейства Windows 9 x . Так же, как и в преды дущем случае, нельзя эти файлы удалять или изменять (последнее могут вы полнять только пользователи, имеющие опыт работы на компьютере, да и то это относится не ко всем файлам).

Если один из системных файлов недоступен или поврежден, компьютер прекратит процесс загрузки и выдаст на экран монитора соответствующее сообщение. Зачастую сообщение об ошибке имеет достаточно объемный текст, поэтому вам придется либо воспользоваться англо-русским словарем, либо предварительно изучить английский язык, чтобы наиболее полно по нять суть проблемы. В русских версиях операционных систем сообщения об ошибках могут выводиться в русской кодировке или, как еще говорят, в кириллице, а так как для нормального отображения символов на русском языке требуется предварительная загрузка специального драйвера, экран монитора может оказаться испещрен непонятными "крякозяблами". Единственное ус покоение в данной ситуации в том, что имя файла, который стал причиной сбоя, в любом случае будет написано латинскими символами, которые в свою очередь нормально отображаются без всяких дополнительных драйверов.

Ниже приведен список файлов, на которые следует обратить внимание при очистке жесткого диска от "мусора".

NTLDR — этот файл необходим для загрузки операционной системы, он находится в зафузочном секторе жесткого диска. После инициализации этот файл позволяет уже загружать и инициализировать все остальные сис темные файлы. Файл имеет атрибут "только для чтения" и "скрытый", изме нять эти атрибуты не рекомендуется, на что следует обратить внимание при пакетном изменении атрибутов.

BOOT . INI — этот файл используется для организации загрузочного меню, в котором вы можете выбрать вариант загрузки в случае установки нескольких операционных систем. Он имеет атрибут "только для чтения". Имеется воз можность редактирования этого файла, о чем подробно рассказано в главе 9.

BOOTSECT . DOS — этот файл позволяет запускать любые операционные системы, отличные от Windows NT , например, Windows 98. Он имеет атри бут "скрытый", эти атрибуты изменять крайне не рекомендуется, на что сле дует обратить внимание при пакетном изменении атрибутов.

NTDETECT . COM — этот файл используется для генерации списка исполь зуемого оборудования и проверки его на совместимость. Он имеет атрибуты "скрытый" и "только для чтения", изменять эти атрибуты крайне не рекомендуется, на что следует обратить внимание при пакетном изменении атрибутов. Именно из-за особенностей работы этого файла в Windows 2000/ХР могут использоваться только те устройства, которые были включены до запуска операционной системы. Все остальные не могут быть инициализиро ваны автоматически (за исключением устройств, подключаемых к шине USB ), что чаще всего пользователи замечают на примере внешних модемов, для инициализации которых приходится перезагружать компьютер либо обновлять сведения об установленном оборудовании, но делать это приходится "вручную".

NTBOOTDD . SYS — этот файл используется для загрузки операционной системы с диска, подключенного к контроллеру SCSI .

Все вышеописанные файлы расположены в корневом каталоге того жест кого диска, с которого осуществляется загрузка операционной системы. Хотя если быть точным, то эти файлы располагаются в первом активном разделе диска, в то время как сама по себе загрузка может производиться и с другого жесткого диска. Все нижеследующие файлы располагаются в рабо чем каталоге Windows , но, несмотря на их внешнюю защищенность от "кри вых рук" пользователя, все-таки следует знать, какие файлы нельзя трогать ни в коем случае.

NTOSKRNL . EXE — ядро операционной системы семейства Windows NT , это аналог файла KERNEL . DLL для Windows 9 x .

HALL.DLL — библиотека Hardware Abstraction Layer.


Ошибки файловой системы

Файловая система, как уже упоминалось ранее, является частью операцион ной системы, и ошибки в ее работе напрямую сказываются на стабильности работы ПК. Наиболее часто встречаемая ошибка — это неверное отображе ние информации об имеющемся свободном пространстве на диске. Это характерно в первую очередь для дисков, отформатированных в файловой сис теме FAT 32.

Ошибки файловой системы можно подразделить на следующие категории:

  • ошибки, возникающие по вине программного обеспечения, в том числе самой операционной системы, — это некорректная запись имен файлов, их "потеря" и т. д.;
  • ошибки, возникающие по вине аппаратного обеспечения, — чаще всего проблема связана с некорректной работой электроники жесткого диска в результате разгона компьютера или перегрева.

Исправляются ошибки файловой системы встроенными средствами опера ционной системы, а точнее программой Scan Disk , хотя можно пользоваться и программным обеспечением сторонних производителей, например, про граммой Norton Disk Doctor .


Ошибки в системном реестре

В простейшем случае, когда операционная система нормально загружается, но не работают некоторые программы (функции), можно воспользоваться программой типа Norton WinDoctor или RegCleaner . Первая программа позволяет не только удалять ключи системного реестра, но и вносить в него поправки, например, если требуемый файл найден, но расположен в другом каталоге. Сами представьте, что может рано или поздно произойти — стоит только вместо нужного файла "подставить" похожий, как вы уже рискуете получить вместо одной ряд других, возможно, более опасных ошибок. Вторая программа в основном предназначена для удаления некорректных клю чей из системного реестра. Обратите внимание на то, что практически лю бые из подобных "очистителей" реестра имеют функции возврата старых ключей, так что вы, в крайнем случае, можете загрузить операционную сис тему в безопасном режиме и восстановить все удаленные ключи.

Примечание Если вы хотите избежать переустановки операционной системы , ни в коем слу чае не полагайтесь на функции автоматической очистки реестра . Любые изме нения должны производиться только под вашим непосредственным контролем .

Если при загрузке компьютера постоянно выдается сообщение о найденной ошибке в реестре, после чего якобы он восстанавливается, компьютер пере загружается, после чего все начинается заново, проверьте работу оператив ной памяти. Скорее всего, все неполадки связаны с ее нестабильной рабо той, хотя возможен и другой вариант — резервная копия системного реестра, предназначенная для восстановления, повреждена, из-за чего и возникла такая ситуация. После перезагрузки ошибка вновь находится и запускается программа восстановления реестра, которая, естественно, использует поврежденную копию.

Стоит отметить, что вышеописанная ситуация характерна только для Windows 9 x . В этом случае следует совершить следующую последователь ность операций:

  • запустите компьютер в режиме MS - DOS при помощи загрузочного диска или из загрузочного меню;
  • запустите любой файловый менеджер ( Norton Commander , Volkov Commander или DOS Navigator ) и удалите из рабочего каталога Windows файлы с названием SYSTEM . DAT и USER . DAT ;
  • откройте каталог SYSBCKUP , который находится в рабочем каталоге Windows , и найдите в нем набор файлов с названием RBXXX . CAB , где XXX — номер файла от 000 до 004. Дело в том, что все операционные системы Windows 9 x регулярно автоматически сохраняют резервные файлов, которые постепенно заменяются, начиная с самого старого по дате создания. Ориентироваться вам придется только по времени и дате создания файла, т. к. после записи последнего файла все они перезапи сываются с самого начала, т. е. начиная с номера 000. Причем системный реестр, который удаляется при восстановлении, автоматически пакуется в файл с названием RBBAD . CAB ;
  • удалите последнюю (по дате и времени создания) резервную копию;
  • запустите программу SCAN REG из дистрибутива операционной системы, которую также можно найти в каталоге COMMAND , расположенного в рабочем каталоге Windows . Именно она используется для восстановления реестра, причем вы можете воспользоваться следующими ключами запуска:
    • BACKUP — резервное копирование реестра и файлов состояния сис темы;
    • RESTORE — восстановление реестра из резервной копии;
    • FIX — устранение повреждений реестра.

Пример использования программы — SCANREG / RESTORE .

Если ни одна из резервных копий реестра не помогает восстановить нормальную работу операционной системы, придется ее "переустановить, хотя еще имеется шанс воспользоваться файлом SYSTEM . DAT , расположенным в корневом каталоге диска, на котором установлена операционная система. Он создается установкой Windows и позволяет восстановить хотя бы изна чальные установки, когда система загружается нормально, правда, при этом придется переустановить все вплоть до драйверов. Это поможет быстро вос становить работоспособную систему только в том случае, если все систем ные файлы, необходимые для ее загрузки, не повреждены и находятся в тех каталогах, в которых они и должны находиться. Увеличить шансы восстановления в таком случае можно предварительной проверкой жесткого диска программой вроде ScanDisk , которая позволяет устранить все ошибки, свя занные с размещением файлов и каталогов. Но и в этом случае можно предположить, что в результате, например, нестабильно работающей опера тивной памяти, подобные исправления могут навсегда испортить структуру файловой системы и привести к потере информации.

Кстати, вы можете изменить количество сохраняемых резервных копий. Сделать это можно, отредактировав файл SCANREG . INI , который находит ся в рабочем каталоге Windows . Найдите в нем строку с параметром MaxBackupCopies =5 и измените число на любое в диапазоне от 1 до 99. Если на вашем компьютере установлен маленький жесткий диск, будьте осторож ны с установкой большого числа резервных копий, т. к. могут начаться про блемы из-за нехватки свободного места.


Воздействие компьютерных вирусов

Эта проблема достаточно подробно рассмотрена в главе 18, полностью по священной компьютерным вирусам.


Аварийная загрузка операционной системы

Абсолютно все версии Windows (как 9х, так и NT ) позволяют воспользоваться так называемым безопасным режимом загрузки, который позволяет ис править ошибки в настройках программ, приведших к невозможности нор мальной загрузки, так и в силу необходимости выполнять минимум операций, таких как распечатка текстов, поиск и копирование на сменные носители документов и прочее.

Загрузка операционной системы в безопасном режиме может понадобиться в таких, например, случаях, как некорректная работа новой версии драйве ра, из-за чего стала невозможна нормальная загрузка, или наоборот, невоз можности установки драйверов в обычном режиме, что характерно для операционной системы Windows 2000.

При загрузке в безопасном режиме в память компьютера загружается тот минимум драйверов, который необходим для запуска графической обо лочки. Естественно, что компьютер в этом режиме работать будет очень медленно.

Как показывает практика, удобнее работать с файлом BOOTLOG . TXT при помощи программы BootLog Analizer ( http :// www . vision 4. dial . pipex . com /). Она покажет, на каком этапе запуска Windows происходит сбой.


Проблемы при выключении компьютера

Как ни странно, но вполне нормально работающий компьютер может давать сбой именно при завершении его работы. Это может выглядеть, как отсутст вие заставки, предлагающей наконец-то нажать кнопку выключения пита ния, как элементарное зависание на этапе выгрузки графической оболочки, как переход в спящий режим. Все эти признаки рано или поздно встреча ются пользователям и зачастую ведут к подозрению на физическую неисправность компонентов компьютера, но это вовсе не так. Попробуем разо браться, в чем может заключаться проблема выключения ПК.

Проблемы при выключении компьютера можно решить следующим образом:

  • запустите программу MSCONFIG , во вкладке Общие | Дополнительно отметьте галочку Запретить быстрое завершение работы. Иногда помогаетвыключение этой галочки, что наоборот разрешает так называемое бы строе выключение, что в большинстве случаев позволяет ускорить выключение компьютера. Информацию об этом режиме в достаточно под робном виде можно найти на сайте Microsoft — http :// support . microsoft . com / support ^/ articles / ql 96/0/08. asp ;
  • в файле конфигурации SYSTEM . INI внесите строку
  • PagingFile=C:\win3 86.swp ( в секции [386Enh]);
  • компания Microsoft выпустила специальный патч, якобы устраняющий проблему с выключением компьютеров с установленной Windows 98. Он имеет название " ShutDown Supplement ";
  • иногда антивирусные программы создают проблемы с выключением. Отключите антивирусный монитор, оставив возможность "ручного" ска нирования;
  • откройте вкладку Свойства Сетевого окружения | Служба доступа к файлам и принтерам и отключите функцию Оповещение LM . В свойствах Клиент для сетей Microsoft выберите Быстрый вход в сеть;
  • проверьте наличие и целостность терминаторов на сетевой плате;
  • переустановите все сетевые компоненты вплоть до драйверов сетевой платы, при этом имейте в виду, что проблемы могут возникнуть из-за не совместимости этой самой платы с другими компонентами компьютера, что делает возможным решение проблемы только путем замены ее на другую модель. Так, например, для всех сетевых плат Realtek , собранных на чипе 8029 AS , для устранения проблемы в Windows 98 SE стоит попро бовать заменить некоторые файлы аналогичными из Windows 98 (4.10.1998). Вот список этих файлов: NDIS . VXD , RTL 8029. SYS , VTDI .386, VIP .386, VTCP .386, VDHCP .386, VNBT .386, VREDIR . VXD , VSERVER . VXD ;
  • удалите файлы заставок, выводимых при завершении работы, — названия файлов: LOGOS . SYS и LOGOW . SYS . Можно попробовать восстановить их, скопировав из дистрибутива на место старых;
  • попробуйте изменить звуковую схему событий, отключив звук, издавае мый при завершении работы, или поменяв его на любой другой;
  • обратите внимание на все настройки, связанные с автоматическим управлением питанием — АРМ и ACPI , нет ли конфликта между на стройками BIOS и самой операционной системой. Более подробно мож но изучить проблему, прочитав страницу на сайте http :// support . microsoft . com / support / kb / articles / Q 136/6/51. asp ;
  • переустановите Windows "поверх" с отключением ACPI (команда setup /р i ) или, наоборот, с включением ACPI (команда setup / p j );
  • после работы с большим количеством сетевых дисков, прежде чем за вершать работу операционной системы, отключите их;
  • иногда проблема вызывается драйвером мыши Genius , в этом случае сле дует или обновить его, или отказаться от использования манипуляторов с этой маркой;
  • удалите все программы, которые создают виртуальные диски, например Virtual CD или Paragon CD Emulator , или хотя бы временно отключите их;
  • внимательно изучите файл BOOTLOG . PRV , возможно, вы найдете при чину. Для этого включите ведение протокола в загрузочном меню и по сле зависания вновь загрузите компьютер, только в режиме MS - DOS , и изучите этот файл:
  • если он заканчивается строкой EndTerminate = KERNEL , тогда компью тер должен выключаться нормально. Для устранения проблемы заме ните файл CONFIGMG . VXD на аналогичный из дистрибутива Windows 98 (не SE );
  • если он заканчивается строкой Terminate = QueryDrivers , то, скорее всего, проблема заключается в каком-нибудь менеджере памяти ( QEMM ) или же в сбойном модуле оперативной памяти;
  • если он заканчивается строкой Terminate = Reset Display , то вся про блема в драйвере видеоплаты. Попробуйте отключить параметр копи рования видео в теневую область оперативной памяти ( SHADOW ) или обновить версию драйвера видеоплаты;
  • если он заканчивается строкой Terminate = RIT , скорее всего, проблема есть со звуковой платой или манипулятором мышь;
  • если он заканчивается строкой Terminate = Win 32, проблема заключает ся в одной из запущенных программ, которые вы не выгрузили перед тем, как завершить работу операционной системы. Имейте в виду, что программа эта может загружаться автоматически при старте компью тера;
  • удалите из автозагрузки драйвер системного динамика (строка wave = speaker . drv В файле SYSTEM . INI );
  • на мощных компьютерах проблема может быть устранена вводом в реест ре В Строку [ HKEY _ LOCAL _ MACHINE \ SOFTWARE \ Microsoft \ CurrentVersion ] параметра " CacheWriteDelay "= dword :000007 dO ;
  • в Windows ME при помощи программы MSCONFIG временно отключите VxD -драйвер NDIS . VXD , возможно, проблему вызывает именно он;
  • обновите версию Detonator ' a или вернитесь к предыдущей версии (имеет ся в виду пакет драйверов для видеоплат nVidia ).


    Глава 2. Диагностические сообщения BIOS

    • Диагностические сообщения BIOS
    • Звуковые сообщения BIOS
      • Звуковые сигналы AWARD BIOS
      • Звуковые сигналы AMI BIOS
      • Звуковые сигналы Phoenix BIOS
    • Текстовые сообщения BIOS


Диагностические сообщения BIOS

Очень многие слышали, что в компьютере есть BIOS (читается как "биос"), что его обновляют, восстанавливают; но что это такое, мало кто понимает, хотя это довольно важно, особенно при самостоятельном поиске причины сбоев и неполадок.

BIOS (от англ. Basic Input / Output System , базовая система ввода/вывода) — это набор программ небольшого размера, в функции которых входят начальное тестирование оборудования и обеспечение взаимодействия компонентов ком пьютера. Программы эти записаны в специальной микросхеме, расположен ной на материнской плате. Все они являются неотъемлемой частью аппарат ного обеспечения и поэтому всегда входят "в комплект" материнской платы. Имеется несколько видов BIOS : системная BIOS , расположенная на мате ринской плате, видео- BIOS , обеспечивающая работу видеоплаты, начиная от первоначального тестирования в момент включения и заканчивая взаи модействием видеоплаты с процессором и другими компонентами ПК, BIOS контроллера SCSI , играющая роль переводчика между интерфейсом SCSI и системной шиной. Из всех вышеперечисленных наиболее важной является системная BIOS , в функции которой входит:

  • тестирование компьютера при включении питания;
  • поиск и подключение других BIOS , расположенных на платах расширения;
  • распределение ресурсов между компонентами компьютера.

При помощи базовой системы ввода/вывода операционная система и при кладные программы работают с аппаратным обеспечением компьютера. Дру гими словами, BIOS — это набор программ, которые переводят понятные пользователю команды Windows на язык, понятный компьютеру. Содержимое BIOS доступно процессору без обращения к дискам, что позволяет компьюте ру работать даже при повреждении дисковой системы. Работа в операционной системе DOS производится с помощью прямого обращения к программам BIOS . Более совершенные операционные системы (в частности, семейство Windows ) имеют собственные функции контроля аппаратного обеспечения компьютера и при своей работе довольно редко используют BIOS .


Звуковые сообщения BIOS

Диагностика сбоев и неполадок при помощи звуковых сигналов была разра ботана и применена еще во времена первых IBM -совместимых компьюте ров. Это позволяло при помощи одного только небольшого динамика, под ключенного к материнской плате, определить неисправное устройство. Естественно, что текстовое сообщение способно нести большее количество информации об имеющейся неисправности, но для его вывода требуется, как минимум, нормально функционирующая система вывода изображения (видеоплата плюс монитор), а также нормально функционирующие опера тивная память и центральный процессор. Для диагностики неисправностей при помощи звуковых сигналов вполне достаточно иметь материнскую плату, к которой подключены блок питания, центральный процессор и систем ный динамик. Даже при наличии сбойных блоков на материнской плате и в ядре процессора диагностика при помощи звука вполне возможна, чего не скажешь о выводе текстовых сообщений на экран монитора.


Звуковые сигналы AWARD BIOS

AWARD BIOS является наиболее известной торговой маркой, поэтому будет вполне достаточно изучить звуковые сигналы, характерные именно для этой BIOS . Несмотря на то, что "в народе" распространено несколько версий, например, v 4.51 G или v 6.0, все они имеют сходные диагностические воз можности, что сделано в основном для вашего же удобства. И даже после приобретения компании Award Software менее известной компанией Phoenix Technologies Ltd ., специалисты последней оставили эти уже ставшие при вычными комбинации сигналов неизменными (табл. 2.1). Кстати, до этого события в Phoenix BIO . S были использованы совершенно другие комбина ции сигналов, которые мы рассмотрим немного позже.

Таблица 2.1. Диагностические сигналы , характерные для большинства версий AWARD BIOS

Комбинация
сигналов
Возможная причина неисправности,
рекомендации по устранению
Сигналов нет
Возможно, неисправен блок питания системного блока или соединительные кабели, соединяющие основные компоненты ПК.
Следует проверить:
1. Подключен ли сетевой шнур к системному блоку.
2. Включен ли выключатель на блоке питания АТХ.
3. Подключен ли блок питания к разъему на материнской плате.
4. Подключена ли кнопка POWER к соответствующему разъему на материнской плате АТХ, иногда важна также полярность подключения.
Сигналов нет
5. Подключен ли системный динамик к соответствующему разъему на материнской плате.
6. Проверьте целостность соединительных кабелей (хотя бы визуально).
7. Временно отключите от соответствующего разъема на мате-
ринской плате кнопку RESET на случай замыкания в ней, что может иметь место особенно в дешевых корпусах
Непрерывный
сигнал
Скорее всего, неисправен блок питания системного блока.
Не рискуйте и лучше всего сразу же отключите питание и замените блок питания, хотя есть шанс, что неполадка имеется в одном из подключенных устройств, например, жестком диске. Попробуйте отключить устройства, кроме центрального процессора и кулера, от материнской платы, после чего включите компьютер (есть вариант, что не хватает мощности блока питания на все
оборудование)
Один короткий
сигнал
Этот сигнал можно услышать при каждом включении компьюте-
ра, когда все компоненты ПК работают нормально
Один короткий
повторяющийся
сигнал
Ошибка регенерации оперативной памяти. Попробуйте переза грузить компьютер при помощи кнопки RESET на системном блоке или на время выключить его. Проверьте установку модулей в слотах, при необходимости вытащите их и установите заново.
"Обнулите" содержимое CMOS-памяти, чтобы исключить влияние некорректных установок в CMOS-памяти
Два коротких
сигнала
Обнаружены какие-то незначительные ошибки. Например, не обнаружен один из дисководов или жестких дисков, параметры которых внесены в CMOS-память. Как правило, одновременно на экране монитора появляется сообщение, предлагающее запустить программу CMOS Setup Utility, чтобы изменить необходимые параметры на заведомо правильные. Проверьте при необходимости правильность подключения соединительных кабелей
Три длинных
сигнала
Ошибка при инициализации контроллера клавиатуры. Перезагрузите ПК при помощи кнопки RESET на системном блоке или вы ключите его на некоторое время. Если неисправность устранить
не удается, скорее всего, придется менять материнскую плату
Один длинный
плюс один ко-
роткий сигнал
Ошибка инициализации оперативной памяти. Проверьте установку модулей в слотах, попробуйте вытащить их и снова вставить.
Если устранить таким образом неисправность не удается, скорее всего, придется заменить модуль на исправный
Один длинный
плюс два ко-
ротких сигнала
Ошибка инициализации видеоплаты. Проверьте установку видеоплаты в слоте расширения (особенно AGP), подключен ли монитор к системному блоку. Если неисправность устранить не удается, скорее всего, придется заменить видеоплату. Если видео
интегрированное и на материнской плате отсутствует AGP-слот, тогда придется заменить материнскую плату либо довольствоваться возможностями устаревшей PCI видеоплаты
Один длинный
плюс три ко-
ротких сигнала
Ошибка инициализации контроллера клавиатуры. Попробуйте
выключить компьютер на некоторое время или перезагрузить его
при помощи кнопки RESET на системном блоке. Проверьте, подключена ли вообще клавиатура к системному блоку, при необходимости проверьте целостность кабеля и качество пайки клавиатурного разъема на материнской плате (особенно на платах AT форм-фактора). Попробуйте подключить заведомо исправную
клавиатуру. Если неполадку устранить не удается, скорее всего,
придется заменить материнскую плату
Один длинный
плюс девять
коротких сиг-
налов
Ошибка чтения данных из микросхемы постоянной памяти (BIOS).
Сначала просто перезагрузите компьютер при помощи кнопки
RESET на системном блоке или на некоторое время выключите его.
Если неисправность не исчезла и на вашей материнской плате используется так называемая технология Dual-BIOS, то восстановите содержимое микросхемы. Для того чтобы узнать, как правильноэто сделать, прочитайте документацию на материнскую плату.
В противном случае для восстановления информации в BIOS вам придется воспользоваться программатором. В случае повторного появления этой ошибки попробуйте заменить аккумулятор, питаюoий микросхему CMOS-памяти, которая является логической частью BIOS (при тестировании программа диагностики POST рассматривает ее как единое целое с основной микросхемой BIOS)
Один длинный
повторяющийся
Ошибка инициализации оперативной памяти. Сначала просто
перезагрузите компьютер при помощи кнопки RESET на систем ном блоке или на некоторое время выключите его. Проверьте
установку модулей в слотах, при необходимости вытащите их и установите заново. "Обнулите" содержимое CMOS-памяти, чтобы отключить какие-нибудь недопустимые параметры, например, чрезмерно повышенную частоту системной шины. Возможно, один из модулей неисправен
Один короткий
повторяющийся
Обнаружена какая-то ошибка в работе блока питания (одно из выдаваемых напряжений не соответствует необходимым требованиям либо отсутствует вообще). Причиной проблемы может оказаться накопившаяся в нем пыль. Проверьте, вращается ли вентилятор, охлаждающий "внутренности" блока питания, при необходимости вскройте блок и очистите от пыли как плату, на которой расположена схема блока питания, так и вентилятор, который не помешает еще и смазать (пусть даже для профилактики)


Звуковые сигналы AMI BIOS

Основное отличие AMI BIOS от AWARD BIOS — это более скромное коли чество опций, предназначенных для тонкой настройки аппаратной части компьютера, но, несмотря на это, диагностические возможности здесь вы держаны на высоком уровне. Неплохой особенностью некоторых версий AMI BIOS является то, что "обнулить" содержимое CMOS -памяти можно нажатием клавиши Insert на клавиатуре до включения питания (далее ее следует удерживать некоторое время после включения ПК). Наиболее часто встречаемые комбинации сигналов (табл. 2.2), особенно те, которые сигнали зируют о серьезной поломке, практически повторяют предыдущую таблицу.

Таблица 2.2. Диагностические сигналы , характерные для большинства версий AMI BIOS

Комбинация сигналов Возможная причина неисправности, рекомендации по устранению
Сигналов нет
Возможно, неисправен блок питания системного блока или соединительные кабели, соединяющие основные компоненты ПК.
Следует проверить:
1. Подключен ли сетевой шнур к системному блоку.
2. Включен ли выключатель на блоке питания АТХ.
3. Подключен ли блок питания к разъему на материнской плате.
4. Подключена ли кнопка POWER к cоответствующему разъему на материнской плате АТХ, иногда важна также полярность подключения.
5. Подключен ли системный динамик к соответствующему разъему на материнской плате.
6. Проверьте целостность соединительных кабелей (хотя бы визуально).
7. Временно отключите от соответствующего разъема на материнской плате кнопку RESET на случай замыкания, что может иметь место особенно в дешевых корпусах
Один короткий сигнал
Этот сигнал можно услышать при каждом включении компьютера, когда все компоненты ПК работают нормально
Один короткий повторяющийся сигнал
Ошибка регенерации оперативной памяти. Попробуйте перезагрузить компьютер при помощи кнопки RESET на системном блоке или на время выключить его. Проверьте установку модулей в слотах, при необходимости вытащите их и установите заново. "Обнулите" содержимое CMOS-памяти, чтобы исключить влияние некорректных установок в BIOS
Два коротких сигнала
Ошибка контроля четности оперативной памяти. Попробуйте перезагрузить компьютер при помощи кнопки RESET на системном блоке или на время выключить его. Если неисправность после этого так и не исчезла, проверьте установку модулей в слотах, при необходимости вытащите их и установите заново. Проверьте, поддерживают ли все установленные модули контроль четности, если нет, то отключите в BIOS соответствующую опцию. Если не удается устранить неполадку, скорее всего, придется заменить модуль на исправный
Три коротких сигнала
Ошибка инициализации первых 64 Кбайт оперативной памяти. Попробуйте перезагрузить компьютер при помощи кнопки RESET на системном блоке или на время выключить его. Также проверьте установку модулей в слотах, при необходимости вытащите их и установите обратно. Если неполадку не удается устранить таким образом, тогда, скорее всего, придется заманить один из модулей на исправный
Четыре коротких сигнала
Ошибка инициализации системного таймера. Перезагрузите ком- пьютер при помощи кнопки RESET на системном блоке или вы- ключите его на время. Можно попробовать "обнулить" содержимое CMOS-памяти при помощи соответствующей этому перемычки на материнской плате. Если неполадка не исчезла после всего этого, скорее всего, придется заменить материнскую плату
Пять коротких сигналов
Ошибка инициализации центрального процессора. Попробуйте выключить компьютер на некоторое время или перезагрузить его при помощи кнопки RESET на системном блоке. "Обнулите" содержимое CMOS-памяти при помощи перемычки на материнской плате, что позволит отключить все недопустимые режимы работы, например, кэш-памяти. Если проблема возникла после установки нового процессора, следует обновить версию BIOS для более корректной поддержки данной модели процессора
Шесть коротких сигналов
Ошибка инициализации контроллера клавиатуры. Попробуйте выключить компьютер на некоторое время или перезагрузить его при помощи кнопки RESET на системном блоке. Проверьте, подключена ли вообще клавиатура к системному блоку, при необходимости проверьте целостность кабеля и качество пайки клавиатурного разъема на материнской плате (особенно на платах AT форм-фактора). Попробуйте подключить заведомо исправную клавиатуру. Если неполадку устранить не удается, скорее всего, придется заменить материнскую плату
сигналов
Семь коротких сигналов
Ошибка инициализации материнской платы. Перезагрузите компьютер при помощи кнопки RESET на системном блоке или выключите его вообще на некоторое время. Возможно, неисправен какой-либо из интегрированных контроллеров (IDE, FDD и т. п.), поэтому при возможности отключите все неиспользуемые блоки при помощи перемычек на материнской плате или (если есть возможность) при помощи соответствующих опций BIOS. Есть шанс, что все будет нормально работать после аппаратного "обнуления" CMOS-памяти
Восемь коротких сигналов
Ошибка инициализации видеопамяти. Перезагрузите компьютер при помощи кнопки RESET на системном блоке или выключите его вообще на некоторое время. Проверьте установку видеоплаты в слоте расширения, при необходимости вытащите ее и установите снова. "Обнулите" содержимое CMOS-памяти, это поможет при установке каких-либо недопустимых параметров, например, при разгоне системной шины, от которой может зависеть частота работы видеопамяти. При необходимости попробуйте установить на модули видеопамяти охлаждающий радиатор. Если таким образом неисправность устранить не удается, скорее всего, придется заменить или видеоплату, или (при такой возможности) модули видеопамяти. В случае когда видеоплата интегрированная, все вышесказанное относится к модулям оперативной памяти, часть которой используется в качестве видеопамяти
Девять коротких сигналов
Обнаружена ошибка при подсчете контрольной суммы содержимого BIOS. Как правило, на экране монитора появляется соответствующая надпись, но если содержимое микросхемы повреждено слишком сильно, тогда система ограничится только звуковыми сигналами. Сначала просто перезагрузите компьютер при помощи кнопки RESET на системном блоке или на некоторое время выключите его. Если неисправность не исчезла и на вашей материнской плате используется так называемая технология Dual- BIOS, то попробуйте восстановить содержимое микросхемы. Для того чтобы узнать, как правильно это сделать, прочитайте документацию на материнскую плату. В противном случае для восстановления информации в BIOS вам придется воспользоваться программатором. В случае повторного появления этой ошибки попробуйте заменить аккумулятор, питающий микросхему CMOS- памяти, которая является логической частью BIOS (при тестировании программа диагностики POST рассматривает ее как единое целое с основной микросхемой BIOS)
Десять коротких сигналов
Ошибка при записи данных в CMOS-память. Сначала просто пе- резагрузите компьютер при помощи кнопки RESET на системном блоке или на некоторое время выключите его. При повторном появлении данной ошибки замените аккумулятор, питающий микросхемы CMOS-памяти, а если это не помогло, то и саму микросхему (если она расположена на специальной панельке, в противном случае придется заменить материнскую плату)
Одиннадцать коротких сигналов
Ошибка инициализации кэш-памяти (как правило, внешней, уста- новленной в слотах расширения на материнской плате). Сначала просто перезагрузите компьютер при помощи кнопки RESET на системном блоке или на некоторое время выключите его. Проверьте установку модулей в слотах, при необходимости вытащите их и установите заново. Если устранить эту неполадку не удается, замените модули на исправные
Один длинный плюс два коротких сигнала
Ошибка инициализации видеоплаты, точнее не удается инициализировать видео-BIOS. Такая ситуация может возникнуть, например, при установке новой видеоплаты н,а очень старую материнскую плату, при этом обычно помогает обновление версии BIOS, для чего следует временно установить старую видеоплату. Также проверьте установку видеоплаты в слоте расширения (особенно AGP), подключен ли монитор к системному блоку. Если неполадку устранить не удается, скорее всего, придется заменить видеоплату. Если видео интегрированное и на материнской плате отсутствует AGP-слот, тогда придется заменить материнскую плату, либо довольствоваться возможностями старой PCI видеоплаты
Один длинный плюс три коротких сигнала или
Один длинный плюс восемь коротких сигналов
Ошибка инициализации видеоплаты. Проверьте установку видео-платы в слоте расширения (особенно AGP), подключен ли монитор к системному блоку. Если неисправность устранить не удается, скорее всего, придется заменить видеоплату. Если видео интегрированное и на материнской плате отсутствует AGP-слот, тогда придется заменить материнскую плату либо довольствоваться возможностями старой PCI видеоплаты


Звуковые сигналы Phoenix BIOS

На сегодняшний день сложно представить ситуацию, когда вам встретится "чистая" версия Phoenix BIOS . Довольно давно в микросхемы с этим лого типом "зашивается" AWARD BIOS версии 6.0, что является показателем того, что эти две компании уже слились воедино. Хотя такой шанс все-таки есть, например, при покупке ноутбука, бывшего в употреблении, т. е. выпущенного пару лет назад. Комбинации звуковых сигналов, которые в этом случае можете услышать, могут привести в ужас опытного специалиста по ремонту компьютеров, т. к. придется очень внимательно слушать и считать, сколько именно раз пропищал системный динамик (табл. 2.3).

Таблица 2.3. Диагностические сигналы , характерные для большинства версий Phoenix BIOS

Комбинация сигналов | Возможная причина неисправности, рекомендации по устранению
1-1-3 | Ошибка записи/чтения данных в/из CMOS-памяти. Сначала просто перезагрузите компьютер при помощи кнопки RESET на систем ном блоке или на некоторое время выключите его. При повторном появлении данной ошибки замените аккумулятор, питающий микросхемы CMOS-памяти, а если это не помогло, то и саму микросхему (если она расположена на специальной панельке, в противном случае придется заменить материнскую плату)
1-1-4 | Обнаружена ошибка при подсчете контрольной суммы содержи- мого BIOS. Как правило, на экране монитора появляется соответ- ствующая надпись, но если содержимое микросхемы повреждено слишком сильно, тогда система ограничится только звуковыми сигналами. Сначала просто перезагрузите компьютер при помощи кнопки RESET на системном блоке или на некоторое время выключите его. Если неисправность не исчезла и на вашей материнской плате используется так называемая технология Dual-BIOS, то попробуйте восстановить содержимое микросхемы. Для того что- бы узнать, как правильно это сделать, прочитайте документацию на вашу материнскую плату. В противном случае для восстанов- ления информации в BIOS вам придется воспользоваться про грамматором. В случае повторного появления этой ошибки по- пробуйте заменить аккумулятор, питающий микросхему CMOS- памяти, которая является логической частью BIOS (при тестировании программа диагностики POST рассматривает ее как единое целое с основной микросхемой BIOS)
1-2-1 | Ошибка инициализации материнской платы. Перезагрузите ком- пьютер при помощи кнопки RESET на системном блоке или выключите его вообще на некоторое время. Возможно, неисправен какой-либо из интегрированных контроллеров (IDE, FDD и т. п.), поэтому при возможности отключите все неиспользуемые блоки при помощи перемычек на материнской плате или (если есть возможность) при помощи соответствующих опций BIOS. Есть шанс, что все будет нормально работать после аппаратного "обнуления" CMOS-памяти
1-2-2 или 1-2-3 | Ошибка инициализации контроллера DMA. Перезагрузите компьютер при помощи кнопки RESET на системном блоке или выключите его вообще на некоторое время. Возможно, причиной неполадки является некорректно работающее устройство, использующее один из каналов DMA, например, звуковая плата. На период диагностики удалите все лишние устройства из системного блока (иногда прихо- дится отключать даже флоппи-дисковод). Если идентифицировать и устранить неполадку не удается, скорее всего, придется заменить материнскую плату
1-3-1 | Ошибка инициализации схемы регенерации оперативной памяти. Перезагрузите компьютер при помощи кнопки RESET на системном блоке или выключите его вообще на некоторое время. "Обнулите" содержимое CMOS-памяти, что позволит отключить недопустимые режимы работы. Если неисправность устранить таким образом не удается, попробуйте заменить модули оперативной памяти, в противном случае придется менять материнскую плату
1-3-3 /1ЛИ 1-3-4 | Ошибка инициализации первых 64 Кбайт оперативной памяти. По- пробуйте перезагрузить компьютер при помощи кнопки RESET на системном блоке или на время выключить его. Такжр проверьте установку модулей в слотах, при необходимости вытащите их и установите обратно. Если неполадку не удается устранить таким образом, тогда, скорее всего, придется заменить один из модулей на исправный
1-4-1 | Ошибка инициализации материнской платы. Перезагрузите компь- ютер при помощи кнопки RESET на системном блоке или выключи- те его вообще на некоторое время. Возможно, неисправен какой- либо из интегрированных контроллеров (IDE, FDD и т. п.), поэтому при возможности отключите все неиспользуемые блоки при помощи перемычек на материнской плате или (если есть возможность) при помощи соответствующих опций BIOS. Есть шанс, что все будет нормально работать после аппаратного "обнуления" CMOS-памяти
-4-2 | Ошибка инициализации оперативной памяти. Сначала просто перезагрузите компьютер при помощи кнопки RESET на системном блоке или на некоторое время выключите его. Проверьте установку модулей в слотах, при необходимости вытащите их и установите заново. "Обнулите" содержимое CMOS-памяти, чтобы отключить какие-нибудь недопустимые параметры, например, чрезмерно повышенную частоту системной шины. Возможно, один из модулей неисправен
-4-3 | Ошибка инициализации системного таймера. Перезагрузите компьютер при помощи кнопки RESET на системном блоке или выключите его на время. Можно попробовать "обнулить" содержимое CMOS-памяти при помощи соответствующей этому перемычки на материнской плате. Если неполадка не исчезла после всего этого, скорее всего, придется заменить материнскую плату
1-4-4 | Ошибка записи/чтения в/из одного из портов ввода/вывода. Перезагрузите компьютер при помощи кнопки RESET на системном блоке или выключите его на время. Возможно, неполадку вызвало периферийное устройство, подключенное к данному порту, поэтому на период диагностики отключите все устройства от системного блока (иногда приходится отключать мышь, подключенную к одному из СОМ-портов, которая конфликтует с модемом)
2-1-1 | Обнаружена ошибка при чтении/записи 0-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-1-2 | Обнаружена ошибка при чтении/записи 1-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-1-3 | Обнаружена ошибка при чтении/записи 2-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-1-4 | Обнаружена ошибка при чтении/записи 3-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-2-1 | Обнаружена ошибка при чтении/записи 4-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-2-2 | Обнаружена ошибка при чтении/записи 5-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-2-3 | Обнаружена ошибка при чтении/записи 6-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-2-4 | Обнаружена ошибка при чтении/записи 7-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-3-1 | Обнаружена ошибка при чтении/записи 8-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-3-2 | Обнаружена ошибка при чтении/записи 9-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-3-3 | Обнаружена ошибка при чтении/записи 10-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-3-4 | Обнаружена ошибка при чтении/записи 11-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-4-1 | Обнаружена ошибка при чтении/записи 12-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-4-2 | Обнаружена ошибка при чтении/записи 13-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-4-3 | Обнаружена ошибка при чтении/записи 14-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
2-4-4 | Обнаружена ошибка при чтении/записи 15-го бита (в шестнадцатеричном представлении) первых 64 Кбайт оперативной памяти
3-1-1 | Ошибка инициализации второго канала DMA. Перезагрузите компьютер при помощи кнопки RESET на системном блоке или выключите его вообще на некоторое время. Возможно, причиной неполадки является некорректно работающее устройство, использующее данный канал, например, звуковая плата. На период диагностики удалите все лишние устройства из системного блока (иногда приходится отключать даже флоппи-дисковод). Если идентифицировать и устранить неполадку не удается, скорее всего, придется заменить материнскую плату
3-1-2 или 3-1-4 | Ошибка инициализации первого канала DMA. Перезагрузите компьютер при помощи кнопки RESET на системном блоке или выключите его вообще на некоторое время. Возможно, причиной неполадки является некорректно работающее устройство, использующее данный канал, например, звуковая плата. На период диагностики удалите все лишние устройства из системного блока (иногда приходится отключать даже флоппи-дисковод). Если идентифицировать и устранить неполадку не удается, скорее всего, придется заменить материнскую плату
3-2-4 | Ошибка инициализации контроллера клавиатуры. Попробуйте вы- ключить компьютер на некоторое время или перезагрузить его при помощи кнопки RESET на системном блоке. Проверьте, подключена ли вообще клавиатура к системному блоку, при необходимости проверьте целостность кабеля и качество пайки клавиатурного разъема на материнской плате (особенно на платах AT форм-фактора). Попробуйте подключить заведомо исправную клавиатуру. Если неполадку устранить не удается, скорее всего, придется заменить материнскую плату
3-3-4 | Ошибка инициализации видеопамяти. Перезагрузите компьютер при помощи кнопки RESET на системном блоке или выключите его вообще на некоторое время. Проверьте установку видеоплаты в слоте расширения, при необходимости вытащите ее и установите снова. "Обнулите" содержимое CMOS-памяти, это поможет при установке каких-либо недопустимых параметров, например, при разгоне системной шины, от которой может зависеть частота работы видеопамяти. При необходимости попробуйте установить на модули видеопамяти охлаждающий радиатор. Если таким образом неис- правность устранить не удается, скорее всего, придется заменить или видеоплату, или (при такой возможности) модули видеопамяти. В случае когда видеоплата интегрированная, все вышесказанное относится к модулям оперативной памяти, часть которой используется в качестве видеопамяти
3-4-1 | Возникли серьезные проблемы при попытке обращения к монитору
3-4-2 | Не удается инициализировать BIOS видеоплаты
4-2-1 | Ошибка инициализации системного таймера. Перезагрузите ком- пьютер при помощи кнопки RESET на системном блоке или выклю- чите его на время. Можно попробовать "обнулить" содержимое CMOS-памяти при помощи соответствующей этому перемычки на материнской плате. Если неполадка не исчезла после всего этого, скорее всего, придется заменить материнскую плату
4-2-2 | Тестирование завершено
4-2-3 | Ошибка инициализации контроллера клавиатуры. Попробуйте вы- ключить компьютер на некоторое время или перезагрузить его при помощи кнопки RESET на системном блоке. Проверьте, подключена ли вообще клавиатура к системному блоку, при необходимости проверьте целостность кабеля и качество пайки клавиатурного разъема на материнской плате (особенно на платах AT форм- фактора). Попробуйте подключить заведомо исправную клавиатуру. Если неполадку устранить не удается, скорее всего, придется заменить материнскую плату
4-2-4 | Критическая ошибка при переходе центрального процессора в за- щищенный режим. Попробуйте выключить компьютер на некоторое время или перезагрузить его при помощи кнопки RESET на системном блоке. "Обнулите" содержимое CMOS-памяти при помощи перемычки на материнской плате, чтобы отключить возможно недопустимые режимы работы. Если проблема возникла после установки нового процессора, обновите версию BIOS для корректной поддержки данной модели процессора. Если неполадку устранить не удается, скорее всего, придется заменить процессор
4-3-1 | Ошибка инициализации оперативной памяти. Сначала просто перезагрузите компьютер при помощи кнопки RESET на системном блоке или на некоторое время выключите его. Проверьте установку модулей в слотах, при необходимости вытащите их и установите заново. "Обнулите" содержимое CMOS-памяти, чтобы отключить какие-нибудь недопустимые параметры, например, чрезмерно повышенную частоту системной шины. Возможно, один из модулей неисправен
4-3-3 | Ошибка инициализации второго таймера
 | Ошибка инициализации системного таймера. Перезагрузите ком- пьютер при помощи кнопки RESET на системном блоке или выклю- чите его на время. Можно попробовать "обнулить" содержимое CMOS-памяти при помощи соответствующей этому перемычки на материнской плате. Если неполадка не исчезла после всего этого, скорее всего, придется заменить материнскую плату
4-4-1 | Ошибка инициализации одного из последовательных портов. Пере- загрузите компьютер при помощи кнопки RESET на системном бло- ке или выключите его на время. Возможно, неполадка вызвана пе- риферийным устройством, подключенным к порту. При необходимости отключите неисправный порт и используйте второй. Если данный вариант недопустим, скорее всего, придется заменить материнскую плату
4-4-2 | Ошибка инициализации параллельного порта. Перезагрузите ком- пьютер при помощи кнопки RESET на системном блоке или выклю- чите его на время. Возможно, неполадка вызвана периферийным устройством, подключенным к порту. "Обнулите" содержимое CMOS-памяти. Если неполадку устранить не удается, тогда исполь- зуйте плату расширения с установленным на ней параллельным портом или замените материнскую плату
4-4-3 | Ошибка инициализации математического сопроцессора. Переза- грузите компьютер при помощи кнопки RESET на системном блоке или выключите его на время. Если неполадка не исчезла, замените сопроцессор. В случае интегрированного сопроцессора, т. е. если компьютер достаточно новый, скорее всего, "придется менять центральный процессор


Текстовые сообщения BIOS

  • 8042 Gate A20 Error
    Не удается проинициализировать контроллер клавиатуры (цифра 8042 обозначает тип микросхемы, обычно используемой для данного контрол лера, А20 обозначает номер адресной линии, которая обычно использует ся для организации работы клавиатуры). Перезагрузите компьютер при помощи кнопки RESET на системном блоке или на некоторое время вы ключите компьютер. Если неисправность после этого не исчезла, скорее всего, придется заменить материнскую плату.
  • Address Line Short
    Обнаружено короткое замыкание одной или нескольких линий адресной шины. Внимательно осмотрите материнскую плату, предварительно сняв с нее все платы расширения и отключив соединительные шлейфы. При необходимости вытащите ее из корпуса, чтобы убедиться, что под ней нет металлических предметов, кусков припоя, которые могут отвалиться от самой же платы при некачественной пайке. Можно попробовать "про пылесосить" материнскую плату обычным пылесосом, чтобы удалить все возможные кусочки припоя (думаю, все-таки лучше таким вот нетради ционным образом "реанимировать" плату, чем менять ее).
  • BIOS ROM Checksum Error — System Halt
    В результате прохождения программы диагностики POST обнаружена ошибка в контрольной сумме содержимого микросхемы BIOS , работа компьютера при этом была остановлена. Если на вашей материнской плате используется так называемая технология Dual - BIOS , то попробуйте восстановить содержимое микросхемы. Для того чтобы узнать, как правильно это сделать, прочитайте документацию на вашу материнскую пла ту. В противном случае для восстановления информации в BIOS вам придется воспользоваться программатором. В случае повторного появле ния этой ошибки попробуйте заменить аккумулятор, питающий микро схему CMOS -памяти, которая является логической частью BIOS (при тестировании программа диагностики POST рассматривает ее как единое целое с основной микросхемой BIOS ). Причиной может послужить дест руктивное воздействие какого-нибудь вируса (например, WinCIH 95 или I . Worm . Magistr ).
  • BIOS Update For Installed CPU Failed
    Возникла ошибка при попытке обновления микрокода центрального процессора, Это может произойти из-за несоответствия версии BIOS ма теринской платы и конкретной модели центрального процессора. При этом попытка BIOS исправить фактически несуществующие ошибки в архитектуре ядра процессора (для чего функция BIOS Update и предна значена) может привести к появлению новых, в том числе и фатальных ошибок. Верните прежнюю версию BIOS либо найдите в Интернете бо лее новую версию, что "прошита" в данный момент, скорее всего, этот недостаток в ней уже исправлен.
  • Bad PnP Serial ID Checksum
    В результате прохождения самодиагностики программой POST была об наружена ошибка в контрольной суммъ идентификатора одного из уст ройств Plug and Play . Проверьте качество установки всех плат расшире ния. Для того чтобы убедиться в качестве контакта, вытащите и вновь установите все платы. Если таким образом не удается устранить появление сообщения, придется заменить "виновное" в этом устройство.
  • Boot Error — Press <F1> To Retry
  • Программа самодиагностики POST не обнаружила ни одного загрузоч ного диска. Запустите программу CMOS Setup Utility и проверьте значе ния всех параметров, относящихся к установленным в компьютере жестким дискам и дисководам. При необходимости проверьте надежность крепления всех соединительных шлейфов и разъемов питания жестких дисков и дисководов.
  • Bus Time-Out NMI At Slot X
    Плата расширения, установленная в слоте расширения номер X , не реа гирует на немаскируемое прерывание в течение длительного времени, кстати, имеющее немалый приоритет среди всех происходящих внутри компьютера процессов. Попробуйте перезагрузить компьютер при помо щи кнопки RESET на системном блоке или на некоторое время выклю чить его. Действительно для шины EISA .
  • Cache Memory Bad
    Ошибка инициализации кэш-памяти. Если на вашем компьютере она выполнена в виде отдельных модулей (кэш-память 3-го уровня), попро буйте поменять модули или хотя бы вытащить их и установить обратно, предварительно очистив от пыли все разъемы. Если кэш-память интегрирована в центральный процессор, тогда вам придется, как минимум, про верить качество его охлаждения (для тех процессоров, которые выполне ны в конструктиве Slot I / A , следует проверять уровень нагрева именно для микросхем кэш-памяти, расположенных на процессорной плате). Если перечисленные меры не дают никакого толка, скорее всего, придет ся менять сам процессор, хотя не исключено, что неполадка исчезнет по сле перезагрузки при помощи кнопки RESET на системном блоке или выключения компьютера на некоторое время.
  • Cache Memory Bad, Do Not Enable Cache
  • Ошибка инициализации кэш-памяти, кэш-память отключена. Если на вашем компьютере она выполнена в виде отдельных модулей (кэш память 3-го уровня), попробуйте поменять модули или хотя бы вытащить их и установить обратно, предварительно очистив от пыли все разъемы. Если кэш-память интегрирована в центральный процессор, тогда вам придется, как минимум, проверить качество его охлаждения (для тех процессоров, которые выполнены в конструктиве Slot I / A , следует проверять уровень нагрева именно для микросхем кэш-памяти, расположен ных на процессорной плате). Если перечисленные меры не дают ника кого толка, скорее всего, придется менять сам процессор, хотя не исключено, что неполадка исчезнет после перезагрузки при помощи кнопки RESET на системном блоке или выключения компьютера на некоторое время.
  • СН-2 Timer Error
    Возникла ошибка при инициализации второго таймера. Данное сообще ние может появиться только в том случае, если на материнской плате установлено два таймера. Попробуйте на некоторое время выключить ком пьютер или перезагрузить его при помощи кнопки RESET на системном блоке. Сообщение может быть вызвано некорректной работой некоторых периферийных устройств, поэтому на время диагностики отключите все "лишнее" от системного блока.
  • CMOS Battery Failed
    Разрядился аккумулятор, питающий микросхему CMOS -памяти (есть ве роятность, что неисправность возникла из-за плохого контакта в цепи питания). Установите новый аккумулятор. При необходимости "прозво ните" пробником все контакты в цепи питания.
  • CMOS Battery Has Failed
  • Разрядился аккумулятор, питающий микросхему CMOS -памяти (есть ве роятность, что неисправность возникла из-за плохого контакта в цепи питания). Установите новый аккумулятор. При необходимости "прозво ните" пробником все контакты в цепи питания.
  • CMOS Battery State Low
    Разрядился аккумулятор, питающий микросхему CMOS -памяти (есть ве роятность, что неисправность возникла из-за плохого контакта в цепи питания). Установите новый аккумулятор. При необходимости "прозво ните" пробником все контакты в цепи питания.
  • CMOS Checksum Bad
    При прохождении самодиагностики программой POST была обнаружена ошибка в контрольной сумме содержимого CMOS -памяти. Скорее всего, неисправность возникла из-за разрядки аккумулятора, питающего микросхему CMOS -памяти. Замените аккумулятор, запустите программу CMOS Setup Utility и затем загрузите оптимальные значения для всех парамет ров. Если ошибку устранить не удалось, проверьте все контакты в цепи питания. Причиной неполадки может послужить деструктивное воздей ствие какого-нибудь вируса (например, WinCIH 95 или l . Worm . Magistr ).
  • CMOS Checksum Error
  • При прохождении самодиагностики программой POST была обнаружена ошибка в контрольной сумме содержимого CMOS -памяти. Скорее всего, неисправность возникла из-за разрядки аккумулятора, питающего микросхему CMOS -памяти. Замените аккумулятор, запустите программу CMOS Setup Utility и затем загрузите оптимальные значения для всех парамет ров. Если ошибку устранить не удалось, проверьте все контакты в цепи питания. Причиной неполадки может послужить деструктивное воздей ствие какого-нибудь вируса (например, WinClH 95 или l . Worm . Magistr ).
  • CMOS Checksum Failure
    При прохождении самодиагностики программой POST была обнаружена ошибка в контрольной сумме содержимого CMOS -памяти. Скорее всего, неисправность возникла из-за разрядки аккумулятора, питающего микро схему CMOS -памяти. Замените аккумулятор, запустите программу CMOS Setup Utility и затем загрузите оптимальные значения для всех парамет ров. Если ошибку устранить не удалось, проверьте все контакты в цепи проверить установку модулей оперативной памяти в слотах. Если модули не поддерживают контроль четности, запустите программу CMOS Setup Utility и отключите все опции, разрешающие подобный контроль. Сооб щение может появляться при проблемах с работой устройств, интегриро ванных в материнскую плату или процессор. В этом случае неисправ ность устраняется заменой либо материнской платы, либо процессора.
  • Press A Key To Reboot
  • Возникла ошибка, при которой невозможна нормальная работа компью тера. Предлагается нажать любую клавишу для перезагрузки. Если данное сообщение появляется регулярно, скорее всего, необходимо заменить плату, при работе которой возникает ошибка.
  • Press Any Key To Continue
    Возникла ошибка, но продолжение работы возможно. Нажмите любую клавишу .
  • Press ESC To Skip Memory Test
    Сообщение появляется на экране монитора в случае, когда опция вроде Quick Power On Self Test находится в отключенном состоянии. Предлага ется с помощью нажатия клавиши < Esc > пропустить тройное тестирование оперативной памяти.
  • Press Fl To Disable NMI, F2 То Reboot
  • Произошел сбой в работе контроллера прерываний. Скорее всего, систе ма не может идентифицировать устройство, подавшее запрос на немаскируемое прерывание. Предлагается либо запретить использование пре рывания NMI неизвестным устройством (клавиша < F 1>) и продолжить работу, либо перезагрузить компьютер (клавиша < F 2>).
  • Press TAB to Show POST Screen
    Некоторые производители заменяют стандартный логотип на собствен ный. После нажатия клавиши TAB вы можете просмотреть оригинальный логотип Phoenix BIOS вместо отображаемого по умолчанию логотипа производителя материнской платы.
  • Primary Boot Device Not Found
    He найден первый загрузочный диск. Данное сообщение появляется только с BIOS , позволяющей установить несколько возможных вариантов загрузки. Например, если в качестве первого загрузочного устройства указан дисковод для гибких дисков, сообщение может появиться при по пытке загрузки со вставленной несистемной дискетой. Запустите про грамму CMOS Setup Utility и установите загрузку сразу с жесткого диска.
  • Primary Input Device Not Found
  • Назначенное первичное устройство ввода информации не обнаружено.
  • Primary Master Hard Disk Fail
    Программа тестирования обнаружила сбой в работе жесткого диска, подключенного к первому каналу IDE ( primary ) и установленного как master - диск. Попробуйте перезагрузить компьютер с помощью кнопки RESET на системном блоке. Если неисправность появилась снова, проверьте со единительный шлейф и разъем питания соответствующего жесткого дис ка. В противном случае потребуется замена винчестера.
  • Primary Slave Hard Disk Fail
    Программа тестирования обнаружила сбой в работе жесткого диска, под ключенного к первому каналу IDE ( primary ) и установленного как slave - диск. Попробуйте перезагрузить компьютер с помощью кнопки RESET на системном блоке. Если неисправность появилась снова, проверьте со единительный шлейф и разъем питания соответствующего жесткого дис ка. В противном случае потребуется замена винчестера. П Primary / Secondary
  • IDE Controller Resource Conflict
    Контроллер IDE пытается использовать уже занятые ресурсы компьюте ра. Чаще всего эта проблема возникает после попытки включить второй канал контроллера после достаточно длительной работы с отключенным каналом. Запустите программу CMOS Setup Utility и включите режим об новления конфигурации устройств. Если неисправность устранить не удалось, выясните, с каким устройством конфликтует контроллер IDE , и произведите для него ручную настройку распределения ресурсов.
  • RAM Parity Error — Checking For Segment
    Произошел серьезный сбой при работе оперативной памяти — ошибка четности. Проверьте, поддерживают ли установленные модули памяти контроль четности. Если нет, то запустите программу CMOS Setup Utility и отключите все опции, относящиеся к данной функции. Если модули памяти поддерживают контроль четности, попробуйте перезагрузить компьютер с помощью кнопки RESET на системном блоке. При повтор ном появлении ошибки, скорее всего, потребуется заменить неисправ ный модуль памяти.
  • Real Time Clock Error
  • Возникла критическая ошибка при работе часов реального времени. Запустите программу CMOS Setup Utility и установите нормальные значе ния даты и времени. Если ошибка появилась вновь, скорее всего, при дется заменить материнскую плату. П Real Time Clock Failure
  • Возникла критическая ошибка при работе часов реального времени. За пустите программу CMOS Setup Utility и установите нормальные значе ния даты и времени. Если ошибка появилась вновь, скорее всего, при дется заменить материнскую плату.
  • Resuming From Disk, Press TAB to Show POST Screen
    Данное сообщение появляется на ноутбуках с Phoenix BIOS , когда поль зователь пытается перезагрузить (выключить) компьютер, находящийся в спящем режиме. После нажатия клавиши <ТаЬ> компьютер переходит в нормальный режим работы, после чего его можно перезагрузить или выключить.
  • SMART Failure Predicted on Primary Master
    Встроенная диагностика жесткого диска, подключенного к первому кана лу IDE в качестве master -диска, говорит о наличии проблем с надежно стью его работы.
  • SMART Failure Predicted on Primary Slave
    Встроенная диагностика жесткого диска, подключенного к первому каналу IDE в качестве slave -диска, говорит о наличии проблем с надежностью его работы.
  • SMART Failure Predicted on Secondary Master
    Встроенная диагностика жесткого диска, подключенного ко второму ка налу IDE в качестве master -диска, говорит о наличии проблем с надеж ностью его работы.
  • SMART Failure Predicted on Secondary Slave
  • Встроенная диагностика жесткого диска, подключенного ко второму ка налу IDE в качестве slave -диска, говорит о наличии проблем с надежно стью его работы.
  • Secondary Master Hard Disk Fail
  • Программа тестирования обнаружила сбой в работе жесткого диска, под ключенного ко второму каналу IDE ( secondary ) и установленного как master -диск. Попробуйте перезагрузить компьютер с помощью кнопки RESET на системном блоке. Если неисправность появилась снова, про верьте соединительный шлейф и разъем питания соответствующего жесткого диска. В противном случае потребуется замена винчестера. )
  • Secondary Slave Hard Disk Fail
    Программа тестирования обнаружила сбой в работе жесткого диска, под ключенного ко второму каналу IDE ( secondary ) и установленного как slave -диск. Попробуйте перезагрузить компьютер с помощью кнопки RESET на системном блоке. Если неисправность появилась снова, про верьте соединительный шлейф и разъем питания соответствующего жесткого диска. В противном случае потребуется замена винчестера. I Serial Port I Resource Conflict
  • Последовательный порт СOМ1 пытается использовать уже занятые дру гими устройствами ресурсы (прерывание, порт ввода/вывода). Запустите программу CMOS Setup Utility и включите режим обновления конфигу рации устройств. Если неисправность устранить не удалось, выясните, с каким устройством конфликтует последовательный порт, и проведите для него ручную настройку распределения ресурсов.
  • Serial Port 2 Resource Conflict
    Последовательный порт COM2 пытается использовать уже занятые дру гими устройствами ресурсы (прерывание, порт ввода/вывода). Запустите программу CMOS Setup Utility и включите режим обновления конфигу рации устройств. Если неисправность устранить не удалось, выясните, с каким устройством конфликтует последовательный порт, и проведите для него ручную настройку распределения ресурсов.
  • Service Processor Not Properly Installed
    Ошибка инициализации контроллера управления сервером.
  • Should Be Empty But EISA Board Found
    При идентификации платы расширения EISA обнаружено несоответствие данных, указанных в BIOS , действительным характеристикам. Запустите профамму EISA Configuration Utility и проверьте значения всех параметров.
  • Should Have EISA Board But Not Found
  • Плата расширения EISA не отвечает на запросы системы. Запустите программу EISA Configuration Utility и проверьте значения всех парамет ров. Если неисправность устранить не удается, скорее всего, придется заменить соответствующую плату расширения.
  • Slot Not Empty
    Обнаружена неизвестная плата расширения на шине EISA . Запустите программу EISA Configuration Utility и установите верные параметры платы.
  • Start Unit Request Failed
    BIOS контроллера SCSI не может отправить команду Start Unit Command одному из устройств, подключенных к контроллеру. В BIOS контроллера следует опцию Send Start Unit Command установить в значение "Выклю чено" ( No ).
  • Software Port NMI Inoperational
    He работает программный порт немаскируемого прерывания NMI . Попробуйте на некоторое время отключить компьютер. Если неисправность уст ранить не удается, скорее всего, придется заменить материнскую плату.
  • Software Port NMI
  • Не работает программный порт немаскируемого прерывания NMI . Попро буйте на некоторое время отключить компьютер. Если неисправность уст ранить не удается, скорее всего, придется заменить материнскую плату.
  • State Battery CMOS Low
    Разрядился аккумулятор, питающий микросхему CMOS -памяти (есть ве роятность, что неисправность возникла из-за плохого контакта в цепи питания). Установите новый аккумулятор. Если сообщение все равно по является, проверьте качество контактов.
  • Static Device Resource Conflict
  • Плата расширения на шине ISA , не поддерживающая стандарт Plug and Play , пытается использовать ресурсы, уже занятые другим устройст вом. В большинстве случаев проблему можно решить только ручной на стройкой режима работы неРпР-платы расширения.
  • Storage Extension Group = ху
    Configuration Error, x Storage Extensions (s) found, configured are у SE(s) Device List: kl, k2
    Обнаружено несоответствие установок Server Menu Storage Extension най денным коммуникационным устройствам, где:
    • SE ( s ) — Storage Extension Units (устройства хранения информации),
      число не соответствует действительности;
    • ху — номер группы;
    • х — число SE ( s ), найденных на коммуникационной шине;
    • у — число SE ( s ). введенных в конфигурацию;
    • к 1, к2 — идентификаторы устройств хранения.
  • System Battery Is Dead
    Разрядился аккумулятор, питающий микросхему CMOS -памяти (есть ве роятность, что неисправность возникла из-за плохого контакта в цепи питания). Установите новый аккумулятор. Если сообщение все равно по является, проверьте качество контактов.
  • System Battery Is Dead — Replace And Run Setup
    Разрядился аккумулятор, питающий микросхему CMOS -памяти (есть ве роятность, что неисправность возникла из-за плохого контакта в цепи питания). Установите новый аккумулятор. Если сообщение все равно по является, проверьте качество контактов.
  • System Cache Error
  • Ошибка инициализации кэш-памяти. Если на вашем компьютере она выполнена в виде отдельных модулей (кэш-память 3-го уровня), попро буйте поменять модули или хотя бы вытащить их и установить обратно, предварительно очистив от пыли все разъемы. Если кэш-память интегри рована в центральный процессор, тогда вам придется, как минимум, про верить качество его охлаждения (для тех процессоров, которые выполне ны в конструктиве Slot I / A , следует проверять уровень нагрева именно для микросхем кэш-памяти, расположенных на процессорной плате). Если перечисленные меры не дают никакого толка, скорее всего, придется менять сам процессор, хотя не исключено, что неполадка исчезнет по сле перезагрузки при помощи кнопки RESET на системном блоке или выключения на некоторое время.
    Checksum Bad - Обнаружена ошибка в контрольной сумме содержимого CMOS -памяти. Скорее всего, неисправность возникла из-за разрядки аккумулятора, питающего микросхему CMOS -памяти. Замените аккумулятор, запустите программу CMOS Setup Utility и установите верные значения всех пара метров. Если ошибку устранить не удалось, перезапишите содержимое BIOS (это возможно только в случае установки Flash -памяти).
  • System Device Resource Conflict
    Плата расширения на шине ISA , не поддерживающая стандарт Plug and Play , пытается использовать ресурсы, уже занятые другим устройст вом. В большинстве случаев проблему можно решить только ручной на стройкой режима работы неРпР-платы расширения.
  • System Halted, (Ctrl-Alt-Del) To Reboot
    Система остановила свою работу. Для перезагрузки компьютера предлагается нажать комбинацию клавиш < Ctrl >+< Alt >+< Del > ("теплый старт"). Сообщение чаще всего возникает при попытке доступа какой-либо про граммы к оборудованию, минуя средства операционной системы. Если операционная система не допускает подобных действий, компьютер пре кращает свою работу с выводом на экран монитора этого сообщения.
  • System RAM Failed At Offset: XXXX
    Ошибка инициализации основной памяти. Попробуйте на некоторое время выключить компьютер и обязательно проверьте качество установки модулей памяти в слотах. Если таким образом неисправность устранить не удается, скорее всего, придется заменить модули памяти.
  • System Time Error
    Ошибка системного таймера.
  • Time-Out Failure During
    Следует проверить наличие и правильность подключения терминаторов на SCSI -шине, а также правильность подключения информационных ка белей. Возможно, одно из устройств SCSI неисправно.
  • Type Display CMOS Mismatch
  • В BIOS неверно указан тип системного монитора. Запустите програм му CMOS Setup Utility и введите правильные характеристики монитора (в старых материнских платах для этого может потребоваться переключе ние соответствующей перемычки).
  • Uncorrectable ECC DRAM Error
    При работе оперативной памяти DRAM возникла серьезная ошибка, ко торая не может быть исправлена системой коррекции ЕСС. Сообщение может возникнуть при серьезных проблемах в работе модулей памяти с поддержкой режима ЕСС (коррекция одиночных ошибок и выявление множественных). Попробуйте на некоторое время выключить компьютер. Если неисправность устранить не удается, скорее всего, придется заме нить модули памяти.
  • Unknown PCI Error
    Возникла неизвестная ошибка при работе устройств на шине PCI . Попробуйте на некоторое время отключить компьютер. Вторым шагом в устранении неисправности можно порекомендовать последовательную замену PCI -плат расширения. Если локализовать проблему не удается, скорее всего, придется заменить материнскую плату.
  • Update Failed
    Обновление информации о конфигурации устройств Plug and Play закон чилось неудачей. Скорее всего, проблема в низком питающем напряже нии микросхемы. Попробуйте заменить аккумулятор. Если это не помогло, ваша материнская плата подлежит замене.
  • Update OK !
    Обновление информации о конфигурации устройств Plug and Play про шло успешно. Сообщение обычно появляется при установке нового оборудования.
  • Wrong Board In Slot
    Установленная плата EISA некорректно отвечает на запросы системы. Запустите программу EISA Configuration Utility и проверьте значения всех параметров. Если неисправность устранить не удается, скорее всего, при дется заменить соответствующую плату.
  • X : Drive Error
    Диск х: не отвечает на запросы системы. В первую очередь проверьте качество подключения соединительного шлейфа и разъема питания. Если все подключено нормально, запустите программу CMOS Setup Utility и проверьте установленные параметры жесткого диска (лучше всего вос пользоваться пунктом HDD Auto Detection ). Иногда ошибка появляется при сбоях в таблице разделов диска. В этом случае достаточно переформатировать диск.
  • X : Drive Failure
    Диск х: не отвечает на запросы системы. В первую очередь проверьте качество подключения соединительного шлейфа и разъема питания. Если все подключено нормально, запустите программу CMOS Setup Utility и проверьте установленные параметры жесткого диска (лучше всего вос пользоваться пунктом HDD Auto Detection ). Иногда ошибка появляется при сбоях в таблице разделов диска. В этом случае достаточно перефор матировать диск.

Некоторые версии BIOS при появлении ошибки выдают на экран монитора сообщение вида:

Error at [code], где code — код ошибки ( табл . 2.4).

Таблица 2.4. Расшифровка кодов ошибок

Код ошибки | Причина ошибки
01 | Причина ошибки не поддается определению
02 | Проблема в блоке питания
1 | Ошибка на материнской плате
2 | Ошибка в оперативной памяти
3 | Ошибка в клавиатуре
4 | Ошибка монохромной видеоплаты (MDA, Hercules)
5 | Ошибка видеоплаты CGA
6 | Ошибка при работе флоппи-дисковода
7 | Ошибка при работе математического сопроцессора
9 | Ошибка при работе параллельного порта LPT1
10 | Ошибка при работе параллельного порта LPT2
11 | Ошибка при работе последовательного порта СОМ1
12 | Ошибка при работе последовательного порта COM2
13 | Ошибка при работе игрового порта (например, расположенного на звуковой плате)
14 | Ошибка при работе принтера
17 | Ошибка при работе жесткого диска
18 | Ошибка при работе какой-либо платы расширения
30 | Ошибка при работе сетевой платы
74 | Ошибка при работе видеоплаты VGA
85 | Ошибка при работе памяти в режиме EMS

Параллельно выводу этих кодов ошибки из системного динамика может вы даваться комбинация звуковых сигналов или на монитор выводиться одно из описанных в середине главы текстовых сообщений.


Глава 20. Подключение новых устройств

  • Подключение новых устройств
  • Подключение нового монитора
  • Подключение нового принтера
  • Подключение нового сканера
  • Замена материнской платы
  • Установка или замена жесткого диска
  • Установка или замена привода CD-ROM
  • Установка или замена видеоплаты
  • Аппаратные конфликты
  • Поиск драйверов для любых устройств
  • Установка драйверов
  • Меры безопасности при подключении устройств
  • FAQ (ответы на часто задаваемые вопросы)


Подключение новых устройств

Перед тем как начать рассмотрение данной темы, давайте попробуем опре делить, какое устройство можно считать новым, а какое не может считаться таковым.

Практически любое устройство, подключаемое к IBM -совместимому ком пьютеру, для нормальной работы требует электрического соединения с электронной схемой, что осуществляется при помощи соответствующих разъемов, а также программную поддержку, которая осуществляется при помощи соответствующего программного обеспечения (так называемых драйверов). Стоит отметить, что некоторые устройства перед подключением к компьютеру требуется подготовить к работе, например, если на нем име ются перемычки, установить их в такое положение, при котором не будет возникать никаких аппаратных конфликтов с уже имеющимися компо нентами.

Под "новым устройством" подразумевается такое устройство, для которого еще не установлены драйверы или которое еще не настроено для бессбой ной работы вместе с остальными компонентами.


Подключение нового монитора

Перед подключением нового монитора к системному блоку рекомендуется сначала перевести видеоплату в режим работы с разрешением 800x600 и частотой обновления 60 Гц. Этот режим поддерживают практически все со временные модели мониторов (15" и выше), поэтому у вас не должно будет возникнуть проблем с потерей синхронизации изображения. В случае с мо нитором 14" разрешение должно быть 640x480, а частота обновления экрана установлена в значение Оптимальная или же Определяется адаптером.

Если вы забыли проделать вышеуказанную операцию, но уже подключили новый монитор, то лучше всего первый запуск системы произвести в безо пасном режиме, при котором используются примерно те же режимы, кото рые ранее рекомендовано было установить. Откройте Панель управления

и запустите ярлык Экран, установите "безопасные" значения разрешения и перезагрузите компьютер. Частоту обновления пока вы не сможете изме нить, т. к. возможность этого появляется только после того, как вы устано вите драйвер монитора. Если у вас нет специализированного драйвера для вашего монитора, в большинстве случаев достаточно установить драйвер под названием Монитор Plug and Play .

При работе с жидкокристаллическими мониторами следует учитывать, что все они оптимизированы под конкретное разрешение экрана, при котором все изображение отображается с максимальной четкостью. Для моделей 15" — это 1024x768, а для 17" моделей — это 1280x1024. Частота обновле ния подбирается опытным путем, потому что при ее увеличении иногда изображение "замыливается".


Подключение нового принтера

Для подключения принтера необходимо наличие в системном блоке порта, через который принтер должен работать, соединительный кабель, а также непосредственно драйвер принтера. Чаще всего используются параллельный порт LPT или шина USB , хотя встречаются принтеры, работающие через последовательный порт СОМ, но это скорее исключение, чем правило.

Параллельный порт может работать в нескольких режимах: SPP , ЕРР и ЕСР. Первый режим используется для матричных принтеров и когда в остальных режимах принтер работает со сбоями. Второй режим принтерами не исполь зуется. Режим ЕСР обычно используется всеми струйными принтерами и частью лазерных принтеров. Струйные принтеры реализуют при помощи него обратную связь с системным блоком, чтобы была возможность отобра жения информации об остатках чернил, а для лазерного принтера этот ре жим может оказаться необходим, например, в том случае, когда его на стройками пользователь управляет при помощи специальной утилиты. Чаще всего так происходит с принтерами, поддерживающими печать в режиме MS - DOS , ведь в них "по умолчанию" зачастую отключена поддержка кирил лицы (русских символов), а при помощи специальной утилиты, которая обычно находится на компакт-диске с драйвером, эта поддержка может быть включена.

Если принтер подключается к параллельному порту сканера, то следует от ключить двустороннюю связь с принтером, используя, например, возмож ности управляющей программы самого принтера, или при помощи соответ ствующей опции BIOS . Стоит напомнить, что при этом вы лишаетесь возможности получения любой информации, касающейся расхода чернил от струйных принтеров (по крайней мере, это относится к принтерам Epson , в которых эта информация получается из чипа, находящегося в картридже).


Подключение нового сканера

Для подключения сканера необходимо наличие в системном блоке порта, через который сканер должен работать, соединительного кабеля, а также непосредственно драйвера сканера. Чаще всего используется шина USB , хотя по сей день встречаются сканеры, работающие через параллельный порт или использующие SCSI -контроллер.

В первом случае следует учитывать, что чаще всего рекомендуется устанав ливать драйвер не сразу же после подключения сканера к системному блоку, а уже после того как установлены необходимые программы, а в частности так называемый TWAIN -драйвер. Зачастую в процессе установки программ ного обеспечения драйвер сканера устанавливается автоматически, напри мер после перезагрузки компьютера.

В случае использования параллельного порта следует учитывать, что совре менные операционные системы, в частности Windows XP , не поддерживают такой способ подключения сканера, поэтому вы наверняка столкнетесь с проблемой подключения. Хотя в Интернете практически для любой модели сканера можно найти драйвер, специально отредактированный для ус пешной работе в Windows XP .

В случае использования для работы сканера шины SCSI следует учитывать, что перед его подключением и настройкой нужно установить драйвер для контроллера данной шины, который устанавливается в любой свободный слот шины PCI (старые контроллеры используют для работы шину ISA ). И только после того как убедитесь в отсутствии аппаратных конфликтов, можно подключать сканер и устанавливать для него драйвер.


Замена материнской платы

Еще на этапе планирования замены материнской платы следует обратить внимание на следующие параметры новой платы:

  • форм-фактор — сегодня практически отпала необходимость в напомина нии о том, что бывают материнские платы AT и АТХ, т. к. последние уже повсеместно вытеснили первые из-за целого ряда преимуществ, напри мер из-за возможности автоматического управления питанием. Но даже среди материнских плат форм-фактора АТХ существует немало модифи каций. Самое главное здесь — это учитывать различия в размерах плат модификаций АТХ, mini - ATX и micro - ATX . Может так получиться, что с виду большой компьютерный корпус просто не способен вместить но вую материнскую плату АТХ, т. к. рассчитан только на последние два форм-фактора. В этом случае вам не избежать замены и корпуса, иначе от идеи замены материнской платы придется отказаться.
    Как можно понять из вышеприведенных рассуждений, самое главное при выборе новой материнской платы — правильно учесть возможности ком пьютерного корпуса. Но и это еще не все. Если платы форм-фактора АТХ могут препятствовать, например, установке привода CD - ROM или устройства Mobile Rack в некоторые из отсеков, то форм-фактор micro -АТХ "порадует" вас небольшим количеством PCI -слотов, что при большом количестве плат расширения вынудит вас отказаться от одной или даже нескольких из них — все зависит от модели выбранной платы. Успокаивает в этой ситуации только то, что в последнее время все чаще в материнские платы интегрируют звуковые и сетевые платы, позволяющие "обойтись" значительно меньшим количеством PCI -слотов, но это все-таки не выход из ситуации, т. к. все платы расширения обычно име ют большие функциональные возможности, чем их интегрированные со братья;
  • наличие интегрированных устройств — обратите внимание на то, что далеко не каждый компьютерный корпус имеет отверстия на задней па нели, например, для интегрированной звуковой или сетевой платы. В случае их наличия вам придется поменять корпус на другой, более подходящий. В другом случае, если вы купили материнскую плату без интеграции, в то время как у вас была так называемая "полная интегра ция" (видео, звук плюс сеть), тогда будьте готовы к тому, что на задней панели корпуса останутся отверстия от интегрированных устройств;
  • наличие поддержки стандартов всех уже имеющихся компонентов, на пример, той же оперативной памяти — очень часто сегодня можно встре тить покупателей, которые хотят купить новую материнскую плату под Pentium 4 и установить на нее "хотя бы временно" процессор Pentium II и модули оперативной памяти РС66. Следует иметь в виду, что новая мате ринская плата должна поддерживать имеющийся центральный процес сор, модули оперативной памяти, а также иметь все необходимые слоты расширения. Конечно, требовать наличия на современной плате слотов ISA сегодня смешно, зато вот при наличии платы, устанавливаемой в слот CNR , не лишним будет убедиться, что на новой плате имеется именно такой разъем, а не AMR или еще какой-нибудь.
Если вы уверены, что новая материнская плата будет установлена в имею щийся корпус без каких-либо проблем, то можете смело приступать к заме не. При этом не забывайте, что удобнее центральный процессор вместе с охлаждающим его кулером и модули оперативной памяти устанавливать на плату еще до ее установки в корпус. Еще удобнее устанавливать материнскую плату, если металлическая панель, которая является для нее фактиче ски подставкой, отсоединяется от основного каркаса, что позволит без осо бых помех установить все необходимые держатели и закрутить все крепежные винты. Если компьютерный корпус не позволяет этого сделать, можно воспользоваться намагниченной отверткой, которая будет препятствовать падению винтов и позволит быстро установить их в нужные от верстия.

Как только материнская плата будет установлена, следует обязательно под ключить к ней все индикаторы и кнопки, расположенные на передней па нели корпуса, не забудьте также и про системный динамик. Обратите вни мание на то, что в случае наличия на плате настроечных перемычек, краткое описание последних можно найти не только в инструкции к плате, но и на ее поверхности. Внимательно изучите места, где нет или мало микросхем и других деталей, там вы обязательно найдете краткую таблицу для той или иной группы перемычек или переключателей. Ориентируясь по ним, можно обойтись даже без инструкции. Если материнская плата настраивается при помощи функций BIOS , тогда это вы сможете сделать впоследствии при первом включении.

Не торопитесь подключать сразу же все платы расширения, жесткий диск и другие устройства. Для начала вполне достаточно установить процессор, мо дули памяти и видеоплату. Включите компьютер и запустите программу CMOS Setup Utility . Сразу же "разгонять" компьютер крайне не рекоменду ется, ведь еще не известна специфика работы новой платы даже в штатных режимах. Это вы сможете сделать уже после того, как будут настроены и проверены все остальные компоненты. Обязательно проверьте состояние всех параметров, имеющихся в BIOS , для большей стабильности работы ма теринской платы в период первоначальной настройки загрузите наиболее безопасные значения параметров, например, при помощи пункта Load Default BIOS или Load Standard BIOS . Для этого можно воспользоваться пе ремычкой Clear CMOS , которая имеется на любой современной материн ской плате. При наличии Soft Menu установите правильные частоты для центрального процессора и системной шины (еще раз напоминаю, что ба ловаться с "разгоном" на этом этапе еще рановато). Если такие параметры, как температура и напряжение питания, что можно проверить при помощи соответствующих опций BIOS , находятся в разумных пределах, можно вы ключать компьютер и подключать жесткий диск, флоппи-дисковод и привод CD - ROM . Все остальные устройства лучше оставить до тех пор, пока не будет настроена операционная система и все рабочие параметры платы не будут еще раз проверены.

Теперь же пора обратить внимание на особенности программной поддержки новой материнской платы. Основой любой материнской платы, как известно, является чипсет, в то время как остальные компоненты играют роль "обвязки", мало влияющей на процесс настройки. Например, интегрирован ные звуковые платы определенной модели могут располагаться на материн ских платах моделей как под процессоры Intel , так и под процессоры AMD . Драйвер поддержки для них устанавливается отдельно от основного чипсета, что позволяет избежать проблем с их настройкой. При установке операционной системы любой версии для поддержки чипсе та обычно устанавливаются некие стандартные драйверы, хотя следует иметь в виду, что чем старше версия операционной системы, тем больше шансов, что будут установлены именно те драйверы, которые необходимы для оптимальной работы компьютера. В случае установки упомянутых "стандартных" драйверов компьютер будет находиться в рабочем состоянии, но скорость его работы будет находиться не на самом высоком уровне. После установки всех необходимых драйверов на плате включаются разные блоки, ускоряю щие работу компьютера (на разных моделях плат естественно могут быть различные блоки подобного назначения, именно поэтому так важна уста новка именно "родных" драйверов). При замене материнской платы может получиться так, что операционная система просто не сможет нормально запуститься, т. к. драйверы старой материнской платы могут работать некорректно с новой платой.

Наилучший вариант при замене материнской платы — это "чистая" переус тановка операционной системы, но это не всегда возмржно, поэтому рас смотрим ситуацию, когда после замены платы требуется запустить ранее установленную систему.

Если вы предварительно не удалили драйверы компонентов материнской платы, то следует в первый раз запускать операционную систему в безопас ном режиме, что позволит вам, используя "стандартные" драйверы, получить доступ к дистрибутиву с "родными" драйверами новой материнской платы. В этом случае следует иметь в виду, что операционные системы Windows 9 x в безопасном режиме не загружают в память драйверы поддержки привода CD - ROM , что может сильно помешать настройке компьютера. Обойти эту проблему можно двумя способами: загрузить драйвер для MS - DOS или, предварительно запустив компьютер с загрузочного компакт- диска или дискеты, скопировать дистрибутив на жесткий диск. Также стоит отметить, что шанс нормального запуска даже в безопасном режиме сильно уменьшается, если чипсет на новой материнской плате произведен другим производителем, например, не Intel , a VIA или SiS . В этом случае может потребоваться доступ к дистрибутиву Windows , где система Plug and Play сможет найти "стандартные" драйверы для нового чипсета. В случае с Windows 9 x придется вновь воспользоваться загрузочным компакт-диском или дискетой, чтобы скопировать дистрибутив на жесткий диск. Если же говорить об операционных системах Windows 2000/ XP , то с вероятностью в 99% вам придется устанавливать все "начисто", т. к. их громко заявленная надежность зачастую мешает подобным экспериментам, в результате чего система выдает критическую ошибку даже при попытке загрузки в безопасном режиме. Если же производители чипсета совпадают, то, скорее всего, проблем с перенастройкой у вас не возникнет, хотя и здесь имеется целый ряд нюансов. Так, например, чипсеты Intel 440 BX / ZX никак не совместимы с чипсетами Intel серии 8хх.

При покупке новой материнской платы обратите внимание на то, что в комплекте с ней обязательно должен быть компакт-диск, на котором имеются все необходимые драйверы. Так, если на плате имеется интегриро ванный звук или видео, то и для них на компакт-диске должны быть драй веры. То же самое относится ко всем остальным интегрированным устройствам. При установке данного компакт-диска в привод CD - ROM обычно автоматически запускается программа установки, которая предлагает установить последовательно все необходимые драйверы. Иногда каждый компо нент выделен в отдельный пункт, в таком случае следует устанавливать драйверы сверху вниз по списку. Некоторые производители самостоятельно подбирают комбинацию драйверов и последовательность их установки, в таком случае все происходит почти автоматически, вам остается только лишь запустить процесс установки.

Если вы случайно потеряли компакт-диск, или он оказался сильно поцарапанным, или даже лопнул в приводе, тогда вам придется найти драйвер для вашей материнской платы в Интернете или на каком-нибудь диске с кол лекцией драйверов, которые не так уж и редко появляются в продаже. Единственное препятствие, с которым вы можете столкнуться при этом, — прежде чем искать что-либо, требуется узнать, что именно вам нужно. Иногда вполне достаточно узнать модель чипсета, и любой драйвер для него будет прекрасно работать с вашей материнской платой. Встречаются ситуа ции, когда очень важно найти драйвер не столько для чипсета, сколько для конкретной модели материнской платы. Это может быть необходимо, если драйверы для платы поставляются единым пакетом, в то время как имеющаяся у вас плата имеет на своем "борту", например, контроллер RAID - массивов, поэтому при установке драйвера без поддержки этого контроллера не позволит им пользоваться, в то время как другие компоненты платы бу дут работать без нареканий.

Для определения модели материнской платы или чипсета можно воспользоваться программой ASTRA , которая способна работать в среде MS - DOS . Производителя чипсета можно узнать после запуска операционной системы хотя бы в безопасном режиме. Запустите ярлык Система из Панели управле ния. Откройте вкладку Устройства (Диспетчер устройств) и изучите все уста новленные драйверы (точнее следует изучать раздел Системные устройства). Если вы найдете хоть какое-то упоминание о компании Intel , тогда почти наверняка ваша плата собрана на базе чипсета Intel . Если упоминается, на пример, название VIA , тогда вы можете смело устанавливать драйверы именно этой компании. В последнее время в Интернете достаточно просто найти и скачать универсальные пакеты драйверов, они устанавливаются практически на любую материнскую плату. Например, для чипсета VIA можно использовать практически любой пакет драйверов VIA 4- in - l . Прав да, при этом вы можете вместо полноценной поддержки "железа" получить великое множество "глюков", но все равно такой способ часто позволяет достичь цели при минимальных затратах времени, да и денежных средств.

Примечание
Для материнских плат с чипсетом Intel можно воспользоваться утилитой Intel Chipset Identification Utility . Для материнских плат с чипсетом VIA можно устано вить любой из доступных пакетов VIA 4- in -1, но следует иметь в виду— в используемой версии этого пакета может не оказаться поддержки вашей мате ринской платы , поэтому постарайтесь найти как можно более новую версию пакета .

Для корректной работы операционной системы для чипсетов Intel , в частности для моделей Intel 430, 440, 8хх (с любыми буквенными обозначениями) необходима установка следующего набора драйверов:

  • USB / AGP Patch — драйверы поддержки шины USB и AGP . Они необхо димы только для Windows 95 ( OSR 2). В старших версиях Windows под держка обоих шин встроена;
  • Intel Chipset Software Installation Utility (другое название INF Update Utility ) — это непосредственно драйверы для чипсета;
  • Intel Application Accelerator Kit — набор средств для ускорения работы системы. Последние версии включают также Intel Ultra ATA Storage Driver . Установка этих драйверов требуется для чипсетов серии Intel 8 xx ;
  • Intel Ultra ATA Storage Driver — устанавливается в случае применения чип сета серии Intel 8 xx и нежелании/невозможности установки предыдущего пакета. При установке автоматически включаются все возможные режимы UDMA для тех устройств, которые, естественно, поддерживают их;
  • ntel Security Driver — включает поддержку аппаратного генератора слу чайных чисел, который имеется на некоторых платах с чипсетом серии Intel 8 xx . При этом следует иметь в виду, что установка данных драйверов не является обязательной.

В случае использования интегрированного звука, видео, модема, сети необходимо также установить драйвер для всех используемых устройств. Все не используемые устройства можно отключить при помощи соответствующей опции в BIOS , что даже рекомендуется, т. к. при этом освобождается часть ресурсов компьютера.

Все указанные драйверы можно найти в Интернете — http :// support . intel . com /.

Настройка чипсетов VIA

Для корректной работы операционной системы для чипсетов VIA требуется установить следующий набор драйверов:

  • Service Pack (VIA 4-in-l) — пакет драйверов для чипсета , включающий в себя : IDE Filter Driver, AGP Driver, VIA INF Driver, IRQ Driver. Явля ется необходимым для любых моделей чипсетов VIA;
  • USB Filter Patch — обычно устанавливается на материнские платы с чипсетами MVP 3 или MVP 4;
  • VIA Bus-Master PCI IDE — драйвер для поддержки режима Bus-Mastering. Обычно рекомендуется при наличии в компьютере установленных диско водов Iomega ZIP ;
  • патч для устранения проблемы со звуковыми платами SB Live !

В случае использования интегрированного звука, видео, модема, сети необ ходимо также установить драйвер для всех используемых устройств. Все неиспользуемые устройства можно отключить при помощи соответствующей опции в BIOS , что даже рекомендуется, т. к. при этом освобождается часть ресурсов компьютера.

Все указанные драйверы можно найти в Интернете — http :// www . viaarena . com /.

Настройка чипсетов SiS

Для корректной работы операционной системы для чипсета SiS требуется установить следующий набор драйверов:

  • Chipset Patches / Utility — непосредственно драйверы для чипсета;
  • IDE Driver & Support — драйвер IDE -контроллера, включающий под держку U DMA ;
  • AGP Driver & Support — драйвер полноценной поддержки шины AGP .

В случае использования интегрированного звука, видео, модема, сети необ ходимо также установить драйвер для всех используемых устройств. Все не используемые устройства можно отключить при помощи соответствующей опции в BIOS , что даже рекомендуется, т. к. при этом освобождается часть ресурсов компьютера.

Следует отметить, что для всех чипсетов SiS 63 x , 73х, 540, 900 обычно ис пользуется один и тот же пакет драйверов для интегрированной сетевой платы, что несколько облегчает их подбор.

Все указанные драйверы можно найти в Интернете на сайте компании Silicon Integrated System Corporation — http :// www . sis . com / support /.

Настройка чипсетов ALi

Для корректной работы операционной системы для чипсетов ALi требуется установить следующий набор драйверов:

  • Integrated Driver — содержит в себе драйверы полноценной поддержки шины AGP ( AGP Driver , AGP Utility ), IDE -контроллера ( IDE Cache Utility , IDE Driver ), USB Driver (предназначен только для Windows 95) и в некоторых случаях драйвер интегрированной звуковой платы. Если по добного пакета вы не найдете, тогда в таком случае следует установить отдельно все упомянутые драйверы. В случае использования Windows 95 OSR 2.0 или OSR 2.5 сначала следует установить патч USBSUPP . EXE и только после него непосредственно сам драйвер USB .

В случае использования интегрированного звука, видео, модема, сети необ ходимо также установить драйвер для всех используемых устройств. Все неиспользуемые устройства можно отключить при помощи соответствующей опции в BIOS , что даже рекомендуется, т. к. при этом освобождается часть ресурсов компьютера.

Все указанные драйверы можно найти в Интернете на сайте компании Acer Laboratories — http :// www . ali . com . tw / eng / support / drivers /.


Установка или замена жесткого диска

С подключением жесткого диска пользователь сталкивается достаточно час то, т. к., по сравнению, например, с компакт-диском, на него помещается больше информации, да и работает он значительно быстрее, чем привод CD - ROM . У многих имеется даже специальный диск, который работает в качестве "дискеты" и никогда не подключен к компьютеру "на постоянно".

При подключении дополнительного диска в первую очередь следует учиты вать, что перемычки на нем (точнее их положение) не должны совпадать с подключенными устройствами, в частности с приводом CD - ROM или ос новным диском. Чаще всего следует предпочесть подключение дополни тельного диска к отдельному кабелю, что возможно, например, после вре менного отключения привода CD - ROM . Это позволит вам избежать проблем с установкой перемычек.

Несмотря на кажущуюся простоту подключения жесткого диска, следует учитывать, что для его полноценной работы требуется установка драйвера. В операционных системах Windows 9 x устанавливаются некие стандартные драйверы, в то время как в Windows 2000/ХР для каждого диска устанавли вается специализированный драйвер, который позволяет получить макси мум производительности.

Стоит отметить, что сразу после подключения жесткого диска, даже гели для него был установлен специализированный драйвер, он не будет работать на максимальной скорости. Для этого требуется перезагрузка компьютера. В операционных системах семейства Windows 9 x , возможно, потребуется вручную включить поддержку каналов DMA , что позволит уменьшить на грузку на центральный процессор, а в итоге также и увеличить суммарную скорость работы системы.

Если предполагается часто отключать жесткий диск, чтобы переносить на нем информацию, то лучше всего сразу же установить устройство Mobile Rack , которое позволит вам обойтись без регулярного "теребления" соедини тельных кабелей, что в итоге может привести к повреждению разъема на кабеле или даже самого жесткого диска.


Установка или замена привода CD - ROM

С приводами CD - ROM обычно связано два вида неполадок: привод не оп ределяется операционной системой или, если определяется, то не читает или плохо читает диски (в случае же с пишущим приводом может встре титься отказ в записи дисков при вполне нормальном их чтении или одно временном отказе всех функций). Все остальные так называемые неполадки (не открывается лоток и т. п.) имеют характер неисправности и требуют ре монта, а не настройки.

Если привод не определился в операционной системе Windows , проверьте перемычки на тыльной стороне привода — на одном шлейфе не должно быть двух устройств, работающих в режиме MASTER или SLAVE . Также проверьте качество соединения всех разъемов (как соединительного шлей фа, так и разъема питания). Если привод подключается к шине SCSI , проверьте, какой ID для него выставлен, он обязательно должен быть уникаль ным и не должен совпадать ни с другими устройствами, ни с самим контроллером SCSI . Также проверьте наличие терминатора.

Еще одна причина отсутствия привода в Windows — это неустановленные или плохо работающие драйверы IDE -контроллера. В этом случае следует установить драйверы для IDE -контроллера либо переустановить операцион ную систему (в том случае, если не удается добиться нормальной работы). В Windows 9 x можно ограничиться только установкой драйверов поддержки приводов в MS - DOS .

Если привод не распознается в MS - DOS , значит, вы не загрузили драйвер поддержки CD - ROM . Для того чтобы загрузить драйвер для привода CD - ROM , следует внести изменения в конфигурационные файлы загрузочной дискеты.

В файле CONFIG . SYS следует внести строку— device = a : \ driver . sys / D : Z , а в файле AUTOEXEC . BAT — a :\ mscdex . exe / d : z . При этом файлы DRIVER . SYS и MSCDEX . EXE должны быть предварительно скопированы на загрузочную дискету, а также следует учитывать один немаловажный фактор. Файл драйвера для привода можно взять практически от любой мо дели CD - ROM , хотя лучше всего пользоваться файлом именно от вашей модели привода. После перезагрузки привод CD - ROM станет доступным при обращении к диску с именем Z :.

Если привод нормально определяется, но диски не читает, то возможны следующие варианты:

  • не вставлен диск или вставлен не той стороной, что особенно актуально
    для тех дисков, которые не имеют защитного покрытия;
  • диск сильно загрязнен, например, вы оставили отпечаток жирными ру
    ками;
  • поверхность диска сильно поцарапана, при этом особенно опасны цара
    пины, расположенные вдоль окружности диска.


Установка или замена видеоплаты

Для корректной работы видеоплаты необходимо установить драйвер, который может обеспечить работу во всех поддерживаемых видеоплатой режи мах. Это разрешение экрана, глубина цвета, дополнительные функции, такие как: видеовыход, поддержка второго монитора и # т. п.

Для видеоплат производства nVidia обычно достаточно установить пакет драйверов под названием Detonator той версии, в которой имеется поддержка данной модели. При этом следует иметь в виду, что постоянно выпуска ются все более новые версии Detonator ' oB , которые, по заявлениям произво дителей, позволяют добиться большей скорости работы видеоплаты с трехмерной графикой. Но иногда это приводит, как ни странно, к сбоям, тем более что программно ускорить работу видео можно только в случае применения упрощенных алгоритмов просчета графики, что не очень хоро шо сказывается на ее качестве. Считается, что для каждой конкретной ви деоплаты стоит подобрать версию пакета драйверов, которая будет работать наилучшим образом, после чего рекомендуется остановиться и больше драйверы не обновлять. Если вы все-таки любите регулярно обновляться, ни в коем случае не удаляйте старую версию Detonator ' a , возможно, вам вскоре придется вернуться к ней.

Для видеоплат производства других производителей обычно устанавливается целый набор драйверов, содержащий как непосредственно драйвер устрой ства, так и целый ряд утилит — от поддержки видеовыхода до настройки цветовой температуры и т. п. Наиболее яркий пример — видеоплаты ATi Radeon , т. к. для поддержки видеовыхода в них требуется установка помимо драйвера отдельной утилиты.

Обратите внимание (это характерно для любых видеоплат), что драйверы, которые устанавливаются автоматически вместе с операционной системой, как правило, не имеют никаких расширенных функций, при этом вы сможете использовать только минимум возможностей видеоплаты. Тем более что в пакете драйверов может быть немалое количество дополнительных программ, которые значительно облегчат вам работу на компьютере. Это могут быть, например, проигрыватели видеофайлов, которые специально оптимизированы для работы с конкретной видеоплатой.


Аппаратные конфликты

Причины появления аппаратных конфликтов

Как ни странно, можно без особых раздумий сказать — проблема в универ сальности современных компьютеров.

Изначально у компьютера IBM AT была всего одна-единственная шина, с помощью которой все устройства подключались к оперативной памяти и процессору (это шина ISA ). Вся архитектура IBM -совместимых компьютеров строилась только на ней, что, в общем-то, было вполне оправданным — в те времена производительность 286-го компьютера была просто изуми тельной по сравнению с другими компьютерами, так что перед производи телями не стояло задачи создавать стандарт с большим "запасом прочности". Тем более, что подобные разработки всегда отрицательно сказывались на конечной стоимости продукта.

Не существовала ранее и система автоматической настройки устройств Plug and Play , поэтому все оборудование приходилось настраивать, в прямом смысле, вручную. Чтобы облегчить работу специалистов по настройке ком пьютеров, практически всем устройствам были назначены строго опреде ленные ресурсы компьютера, которые не могли быть заняты другими уст ройствами, что, в общем-то, не только ускоряло сам процесс окончательной настройки компьютера, но и практически на 100% устраняло возможность возникновения аппаратных конфликтов.

Естественно, что с течением времени производительность любого старого стандарта перестает удовлетворять, что приводит к появлению нового. Более скоростные стандарты либо являются надстройками над более старыми вер сиями, позволяющими преодолеть те ограничения, которые последние име ют, либо имеют совершенно иной способ подключения, который совсем не совместим со старым методом. Вот здесь мы и сталкиваемся с первой проблемой. Для сохранения совместимости со старыми устройствами произво дители вынуждены оставлять как разъемы, так и программы, которые, как мы уже знаем, не поддерживают автоматической настройки.

Примечание В качестве доказательства утверждения , что система автоматической настрой ки Plug and Play является одной из причин появления сбоев , можно привести семейство операционных систем Windows NT . Все они заслуженно считаются очень стабильными , особенно по сравнению с семейством Windows 9 x , хотя в последнее время , а именно с появлением версии Windows 2000, и здесь появились различные нюансы . Одним из основных нововведений в Windows 2000 является поддержка системы Plug and Play . Выводы делайте сами ...

Практически все современные устройства разрабатываются согласно требованиям к возможности их автоматической настройки, поэтому все специфи кации, безусловно, поддерживают технологию Plug and Play . Здесь мы стал киваемся со второй более серьезной проблемой. Старые устройства по- прежнему требуют безоговорочного резервирования строго определенных ресурсов компьютера, тогда как современные устройства вполне способны работать практически с любыми свободными ресурсами ПК. Вполне естест венно, что для нормальной работы всех старых устройств в любом случае будут зарезервированы все необходимые ресурсы, в то же время их стано вится все меньше и меньше, пока не наступает предел, когда даже новые устройства уже не могут нормально распределить между собой оставшееся количество ресурсов.

Но давайте рассмотрим все по порядку.

Распределение ресурсов компьютера

Под старыми устройствами сегодня следует понимать те устройства, кото рые для своей работы, точнее для связи с остальными компонентами ком пьютера, используют шину ISA . Это такие устройства, как последователь ные, параллельный и инфракрасный порты, порты для подключения клавиатуры и мыши, контроллер флоппи-дисковода. Все они используются до сих пор, поэтому избежать аппаратного конфликта иногда сложно.

Аппаратный конфликт — это ситуация, когда несколько устройств одновре менно пытаются получить монопольный доступ к одному и тому же ресурсу компьютера, причем компьютер начинает давать сбои в работе одного или нескольких устройств, а то и вообще зависает без всяких предупреждений или сообщений об ошибке.

Ресурсы компьютера можно разделить на три основных группы: прерывания, каналы DMA и порты ввода/вывода.

Прерывания ( IRQ , Interrupt Request ) представляют собой физические сигна лы, при помощи которых специальный контроллер переключает вычисли тельные мощности центрального процессора от одного устройства к друго му, позволяя, таким образом, одновременно обрабатывать последовательно все поступающие запросы. Различают аппаратные и программные прерыва ния — в данном случае имеется в виду первый тип. Если устройство не подает запрос на выполнение определенных действий, тогда соответствующее ему прерывание не генерируется.

Для работы любого устройства рекомендуется наличие свободного прерыва ния, при этом старое оборудование всегда требует для себя уник&тьного но мера прерывания, в то время как некоторые наиболее современные устрой ства вполне могут обойтись так называемыми разделяемыми прерываниями. Кроме того, ставится условие, чтобы устройства, использующие одно пре рывание, не работали одновременно, хотя и здесь имеется ряд нюансов.

Аппаратные прерывания могут происходить в любой момент, так что никто не застрахован от ситуации, когда два прерывания могут возникнуть одно временно. В этом случае система прибегает к специальной таблице приори тетов, где каждому прерыванию назначен уникальный приоритет.

Как уже говорилось, немалое количество ресурсов резервируется под ис пользование их старым оборудованием, поэтому рекомендуется изучить всю таблицу прерываний (табл. 20.1), которую устанавливает операционная сис тема по умолчанию.

Таблица 20.1. Таблица прерываний , устанавливаемая по умолчанию

Прерывание | Устройство, назначаемое по умолчанию, рекомендации по настройке
IRQO | Прерывание системного таймера, который отвечает за работу ча- сов реального времени. Применяется со времен первых IBM PC и для использования другими устройствами недоступно
IRQ1 | Прерывание клавиатуры. Генерируется при каждом нажатии на клавиши. Для другого использования недоступно
IRQ2 | Сегодня резервируется исключительно ради совместимости со старыми программами. Для другого использования недоступно
IRQ3 | Прерывание назначается по умолчанию последовательному порту COM2. Этим прерыванием пользуются устройства, использующие "парный" порт COM4. Для других устройств это прерывание может стать доступным только после отключения порта в BIOS
IRQ4 | Прерывание назначается по умолчанию последовательному порту С0М1. Этим прерыванием пользуются устройства, использующие "парный" порт COM3. Для других устройств это прерывание может стать доступным только после отключения порта в BIOS
IRQ5 | Прерывание используется звуковыми платами ISA и более новыми PCI. Современные звуковые платы занимают это прерывание ис- ключительно ради совместимости со старыми программами. Пре- рывание доступно для использования другими устройствами, но в этом случае возможны проблемы с запуском старых игр
IRQ6 | Прерывание используется контроллером флоппи-дисковода. Для других устройств это прерывание может стать доступным только после отключения контроллера в BIOS
IRQ7 | Прерывание используется параллельным портом при работе в ре- жимах ЕРР и ЕСР. Для других устройств это прерывание может стать доступным только после отключения порта в BIOS или при выборе режима SPP (Normal)
IRQ8 | Прерывание используется часами реального времени. Для исполь зования другими устройствами невозможно
IRQ9 | Прерывание свободно для использования другими устройствами
IRQ10 | Прерывание свободно для использования другими устройствами
IRQ11 | Прерывание используется шиной USB. Для других устройств это прерывание может стать доступным только после отключения шины в BIOS, т. к. даже при отсутствии подключенных устройств это пре рывание недоступно для использования другими устройствами
IRQ12 | Прерывание используется для мыши PS/2. Для других устройств это прерывание может стать доступным только после отключения порта в BIOS, т. к. даже при отсутствии мыши прерывание резерви руется и недоступно для использования другими устройствами
IRQ13 | Прерывание раньше использовалось для математического сопро цессора, сегодня резервируется ради совместимости со старыми программами. Для использования другими устройствами недос тупно
IRQ14 | Прерывание используется первым каналом контроллера IDE. Для других целей может быть использовано только после отключения канала в BIOS
IRQ15 | Прерывание используется вторым каналом контроллера IDE. Для других целей может быть использовано только после отключения канала в BIOS

Не стоит понимать фразу "это прерывание может стать доступным" буквально, т. к. далеко не все устройства могут занимать выбранное вами прерыва ние. Яркий пример — звуковые платы. Практически все звуковые платы могут работать только либо с IRQ 5, либо IRQ 10, в то время как все остальные для них вполне могут оказаться недоступными.

Для уменьшения вероятности возникновения аппаратных конфликтов реко мендуется придерживаться следующей последовательности установки уст ройств:

? сначала собирается базовая конфигурация — процессор и кулер для него, модуль памяти, видеоплата, жесткий диск и привод CD - ROM ;

О внутренний модем ( PCI или ISA ). Внешний модем подключается к одно му из последовательных портов, поэтому его настройка обычно не вызы вает больших проблем;

  • звуковая плата ( PCI или ISA ). Если звуковая плата интегрированная, то
    гда она настраивается сразу же еще до установки всех остальных устройств;
  • сетевая плата ( PCI или ISA );
  • плата для работы с видеоизображением ( PCI или ISA );
  • контроллер SCSI ( PCI или ISA );
  • все остальные платы.

После установки каждого последующего устройства в компьютер может произойти аппаратный конфликт. При этом может потребоваться изменить порядок установки компонентов, которые уже установлены в вашем компь ютере (то есть потребуется изменить порядок, какое устройство будет уста навливаться первым, какое — вторым, какое — третьим и т. д.). Как пока зывает практика, время от времени встречаются компьютеры, которые нормально работают только в случае строгого соблюдения или указанной выше последовательности сборки или иной, в противном случае добиться стабильной работы бывает крайне сложно.

Несмотря на то, что аппаратные конфликты встречаются нередко, в послед нее время все чаще и чаще причиной сбоев становятся драйверы устройств. Если во времена процессоров Pentium / Pentium II было достаточно устано вить Windows 98 и на этом вся настройка могла быть закончена, то теперь приходится устанавливать разнообразные "патчи", "сервис-паки" и прочее. И далеко не всегда на компакт-диске с драйверами, который идет в ком плекте с каждым устройством, можно найти весь комплект, а то и просто нормально работающий драйвер. В таком случае приходится или мириться с ситуацией, или искать в Интернете другие версии драйверов, которые бу дут работать нормально. Яркий пример — многочисленное поколение драй веров для видеоплат от nVidia , так называемые Detonator ' bi . К тому же если все проблемы начинаются после переустановки операционной системы, стоит предположить, что все-таки виноваты в этом именно драйверы, хотя каждый случай требует отдельного разбирательства.

Устранение аппаратных конфликтов

Перед тем как устанавливать новое устройство, желательно записать или запомнить, какое устройство какой ресурс использует. Это и прерывания, и каналы DMA , а еще и области оперативной памяти, так называемые порты ввода/вывода. Это поможет вам впоследствии относительно быстро восста новить прежнюю конфигурацию, если, например, нужно срочно доделать работу, а времени разбираться с проблемой нет.

Узнать, как в данный момент распределены номера прерываний на вашем ПК, можно, запустив программу Сведения о системе из раздела Служебные программы. Также можно просмотреть список прерываний в Панели управления
операционных систем Windows 9x, выбрав в свойствах Системы пункт Диспетчер устройств. Каждый раз после установки нового устройства или компонента системы, которым требуется прерывание, записывайте номера прерываний и названия устройств, которым эти прерывания назначены. Эти сведения помогут вам в разрешении аппаратных конфликтов.
После того как вы подключили новое устройство, обязательно обратите внимание на то, как изменилось распределение ресурсов. В первую очередь изучите таблицу, что выводится на экран монитора перед началом загрузки операционной системы. Чтобы остановить на время запуск компьютера, можно воспользоваться клавишей <PAUSE>, которая расположена в верхнем правом углу. Чтобы поймать нужный момент, возможно, придется нажать ее несколько раз. В таблице указано, какое устройство какое прерывание занимает. Если вы обнаружите два или более устройств, возле которых стоит одна и та же цифра, скорее всего, одно из этих устройств нормально работать не будет. Особенно важно это, если конфликт связан с видеоплатой, т. к. в таком случае система может вообще не загрузиться.
Для уменьшения вероятности аппаратных конфликтов следует совершить следующие действия:

  • при первом же включении ПК после подключения нового устройства запустите программу CMOS Setup Utility, найдите параметр Reset Configuration или Force Update ESCD, который, скорее всего, находится в разделе PnP/PCI Configuration, и установите его в значение Yes. Выйдите из программы с сохранением изменений. После перезагрузки данные об установленном оборудовании "обнулятся", что приведет к инициализации системы Plug and Play и перераспределению ресурсов компьютера между установленными устройствами. Если этого не сделать, система попытается назначить новому устройству одно из свободных ресурсов, который может оказаться неподходящим для данного устройства;
    помимо вышеописанного параметра, стоит обратить внимание ее на следующие параметры (их можно использовать для устранения аппаратных конфликтов):
    • DMA n Assigned To — этот параметр позволяет назначить любой канал DMA строго определенному устройству, например звуковой плате ISA. Для этого требуется установить его в значение Legacy ISA, в противном случае следует оставить значение PCI/ISA РпР. В последнем случае каналы DMA будут распределяться согласно возможностям системы Plug and Play.
      Параметр может иметь название DMA n Used By ISA. Соответственно этот параметр должен принимать значение либо No/ICU, либо Yes;
    • IRQ n Assigned To — этот параметр позволяет резервировать прерывания подобно предыдущему параметру.
      Параметр может иметь название IRQ n User By ISA с соответствующими ранее описанными значениями;
    • Interrupt Mode — параметр позволяет использовать усовершенствованный контроллер прерываний, реапизующий 24 аппаратных прерывания вместо стандартных 16-ти. Обратите внимание, что если установить Windows при включенном параметре, выключение может привести к серьезным сбоям в работе компьютера, вплоть до невозможности его загрузки. Значение для включения параметра — APIC, для выключения — PIC;
    • PCI IDE IRQ Map To — позволяет освободить прерывание, используемое контроллером IDE (IRQ14 и IRQ15), на материнской плате, в случае, если вы его не используете. При этом значение его должно быть PC AT (ISA). Если вы все-таки используете IDE-контроллер, оставьте значение, которое установлено по умолчанию (чаще всего это PCI IDE IRQ Mapping);
    • PS/2 Mouse Function Control — параметр позволяет освободить прерывание, по умолчанию резервируемое для мыши PS/2 (IRQ12). Для этого значение параметра должно быть Auto или Disable. Если вы используете мышь PS/2, ни в коем случае не отключайте этот параметр;
    • РпР OS Installed — параметр позволяет отдать приоритет в распределении ресурсов операционной системе (значение Yes) или материнской плате (значение No), точнее установленной на ней BIOS. Параметр может иметь название РпР Operating System.
      Обратите внимание, что операционная система Windows NT 4.0 не обладает возможностью автоматического определения устройств, поэтому в BIOS этот параметр должен находиться в выключенном состоянии;
    • Resource Controlled By — параметр позволяет отключить автоматическое распределение ресурсов;
    • USB IRQ — позволяет освободить прерывание, по умолчанию используемое контроллером шины USB (значение Disabled);
  • отключите все неиспользуемые устройства, такие как:
    • последовательные порты. На современных компьютерах они используются крайне редко, особенно COM2, т. к. на платах с интегрированным звуком разъем COM2 вообще не выведен наружу, что позволяет отключить его без особых последствий. Если вы используете внутренний модем, вам следует знать, что внутренние модемы не используют последовательный порт, а эмулируют его наличие, поэтому можно отключить оба порта;
    • параллельный порт. Если у вас нет принтера, подключаемого к нему, тогда его следует отключить;
    • контроллер IDE. Если вы используете только одно устройство IDE, можно отключить второй неиспользуемый канал. При этом можно освободить IRQ14 или IRQ15;
    • контроллер шины PS/2. Если вы используете мышь, подключаемую к СОМ-порту, следует отключить его, освободив тем самым IRQ12.

При подключении новых устройств могут возникать самые разнообразные проблемы, а не только аппаратные конфликты, например система Plug and Play вообще никаким образом не определяет новое устройство, создавая впечатление его неисправности, даже если на другом компьютере оно работало исправно. Такое может случиться или в том случае, если устройство не поддерживает стандарт Plug and Play (например, наиболее старые ISA платы), или если не поступает напряжение питания (например, для устройства необходимо использовать дополнительный источник питания, или разъем недостаточно плотно подключен), или устройство неисправно. В первом случае следует обратиться к документации устройства, выяснить, какие ресурсы устройство должно использовать, после чего зарезервировать их при помощи параметров BIOS. Во втором случае следует проверить качество соединения всех разъемов и наличие напряжения на соответствующих выводах. В третьем случае ответ краток — ищите в срочном порядке гарантийный талон, если таковой имеется, и несите в сервис-центр.
Если какое-либо устройство, например контроллер шины USB, не отключается при помощи параметров BIOS, можно отключить его в Диспетчере устройств Windows, что, в общем-то, практически однозначно первому способу.


Поиск драйверов для любых устройств

Доступ к сети Интернет в последнее время становится все более доступным (прощу прощения за масло масляное, но это действительно так), поэтому поиск драйверов для любых устройств значительно упрощается, хотя все-таки остается один нюанс — стоимость услуг провайдера особенно в маленьких городах продолжает оставаться на высоком уровне. Именно поэтому, прежде чем идти, например, в интернет-клуб или на своем компьютере набирать номер провайдера, следует определиться, что вы хотите найти и где вы собираетесь это искать.
Очень часто выпуском драйверов занимаются как производитель конечного продукта (платы), так и производитель основной микросхемы (чипа), на которой основана вся работа устройства. В том случае, если разработчиком и того, и другого является один и тот же производитель, вам будет достаточно найти только один комплект.
Подключение новых устройств
361
Обычно производители конечного продукта (платы) добавляют к оригинальным драйверам производителя чипа свой интерфейс, различного рода утилиты, настройки и т. п., поэтому применение оригинальных драйверов не всегда оправдано, так как некоторые дополнительные возможности устройства могут быть недоступны. Но здесь кроется и положительный мо-мент _ использованием оригинальных драйверов можно устранить некоторые ошибки, которые возникли как раз из-за нововведений.
Первое место в Интернете, которое следует посетить, — это официальный сайт самого производителя как конечного продукта (платы), так и чипа. Найти адрес этого сайта можно, например, набрав полное имя компании-производителя в любой поисковой системе, иногда добавив фразу "официальный сайт". Следует иметь в виду, что почти все адреса тайваньских компаний имеют вид http://www.company.com.tw/, а всех остальных — http://www.company.com/, хотя зачастую к названию фирмы добавляют еще какую-нибудь фразу или букву (обычно, из-за того, что на момент регистрации доменного имени сайт с нужным названием уже имелся).
Второе место — это так называемые "склады драйверов", на которых можно найти не только официальные версии драйверов, но и исправленные, дополненные (например, русифицированные) версии.
На официальных сайтах производителей не всегда просто найти раздел драйверов, где имеется возможность их выбора и скачивания. В простейшем случае такой раздел будет иметь название DOWNLOAD, DRIVERS, FILES и т. п. В противном случае вам придется посетить разделы с названиями SUPPORT, TECH SUPPORT, PRODUCTS, SERVICE. В последнем случае обычно требуется найти описание конкретной модели устройства, в тексте которого должна быть дана ссылка на скачивание драйвера. В последнее время качество драйверов и даже BIOS значительно снизилось, поэтому не стоит сильно увлекаться обновлением. Основной причиной тому оказалась именно доступность этих самых обновлений. Разработчикам теперь нет необходимости тщательно тестировать новую версию драйвера, а достаточно "выложить" на сайте так называемую бета-версию, а пользователи сами найдут и исправят все ошибки. Так-то оно так, но таких пользователей, которые могут сами совершить такой "подвиг", единицы, а остальным остается надеяться, что в скором времени исправления будут выложены на одном из популярных сайтов. Ситуацию усугубляет то, что каждый производитель пытается выпустить устройство как можно быстрее, что просто не дает времени для тщательного тестирования драйверов. Особенно снижение качества написания драйверов заметно в области BIOS, потому что сегодня ее обновление доступно без помощи специального оборудования и даже без специальной подготовки. При этом часть проблем со стабильностью работы BIOS после обновления можно отнести на "кривору-кость" пользователя.
Перед обновлением драйверов поинтересуйтесь, какие нововведения были произведены по отношению ко всем предыдущим версиям. Если были исправлены какие-нибудь серьезные ошибки, тогда обновляйте. Если были применены новейшие методы вычисления, например текстур, тогда призадумайтесь — а какие проблемы с собой привнесут эти новшества, не придется ли трепетно ожидать исправлений этих супермодных алгоритмов или переустанавливать старые версии драйверов?


Установка драйверов

После того как устройство подключено, все крепежные винты надежно закреплены и крышка системного блока возвращена на прежнее место, можно включать компьютер и устанавливать программное обеспечение, которое необходимо для работы данного устройства. Внешние устройства перед началом настройки требуется подключить как к системному блоку, так и к электросети.
Как правило, к каждому устройству прилагается компакт-диск (или хотя бы дискета), на котором содержится драйвер и обслуживающие программы.
Для уменьшения вероятности неполадок по вине драйверов следует придерживаться следующих рекомендаций:

  • выбирайте продукцию только известных производителей ("брэндов"). Зачастую производители, попадающие в категорию "noname", обращают мало внимания на написание качественных драйверов, хотя это вовсе не означает, что драйверы от "noname" обязательно будут работать нестабильно. Здесь речь идет о статистике, которая, в общем-то, может оказаться необъективной;
  • приобретайте устройства только после их "проверки временем", после чего могут быть выявлены неприятные особенности той или иной модели. Не один десяток раз некоторым пользователям приходилось "кусать локти" только из-за того, что они поторопились купить супермодную новинку, которая оказалась, мягко говоря, не совсем тем, о чем говорилось в рекламе. Хотя и здесь можно "напороться" на другой неприятный фактор — только модель устройства становится популярной, как ее начинают делать все "кому не лень", в результате чего качество продукции резко падает. В настоящий момент это происходит, например, с видеоплатами ATi Radeon;
  • не доверяйте заявлениям даже "брэндов" о совместимости устройства с любой операционной системой, читайте обзоры и статьи, посвященные данной модели, чтобы узнать мнение независимых специалистов или даже просто пользователей;
  • не спешите скачивать из Интернета обновленные драйверы, сначала внимательно изучите, какие изменения в них были внесены. Может так получиться, что они не имеют никаких серьезных нововведений, зато при обновлении можно приобрести целый ряд недоработанных модулей, приводящих к сбоям в работе компьютера.

Стоит отметить, что драйверы распространяются в двух вариантах. Первый вариант представляет собой единый файл с расширением ЕХЕ, при запуске которого автоматически осуществляются все необходимые действия: копирование файлов, создание ярлыков и ссылок в реестре. Второй вариант представляет собой набор файлов, необходимых для работы устройства и файла с расширением INF, где прописан алгоритм действий, необходимых для успешной установки драйвера. В этом случае установкой драйвера "заведует" операционная система. При этом вам следует при запросе на установку драйвера устройства указать каталог, в котором находится необходимый для его работы драйвер, после чего, согласно имеющемуся INF-файлу, операционная система совершит необходимые действия. Естественно, что каталог с драйвером должен быть доступным на протяжении всего процесса установки.
Драйверы выпускаются отдельно для каждой версии операционной системы, что иногда затрудняет переход с одной версии на другую, т. к. для новой версии ОС просто может не оказаться нужного драйвера. Очень часто можно встретить пакеты драйверов, которые предназначены для работы во всех версиях Windows 9x или же Windows 2000/XP. Иногда можно встретить пакеты, содержащие драйверы не только для любых версий Windows, но и для Linux, OS/2 и т. д.
Обратите внимание, что драйверы для всех устройств лучше всего устанавливать еще до начала тонкой настройки операционной системы и до установки программ, т. к. возможные сбои могут потребовать "чистой" переустановки операционной системы и соответственно всех программ.
Обратите внимание: для того чтобы драйверы к старому оборудованию загружались при старте системы и оборудование распознавалось, требуется, чтобы оно было включено на момент включения самого компьютера. Кроме того, не рекомендуется выключать старое оборудование до полного завершения работы компьютера, т. к. это может вызвать зависание операционной системы. Ведь операционная система во время своей работы может подать запрос готовности устройства, а так как отвечать будет некому, система будет "стоять в растерянности" и ожидать ответа. При этом можно попробовать включить оборудование в надежде, что система "отвиснет", но здесь никто, даже компания Microsoft, не даст гарантии стабильной работы ПК после этого (все равно придется перезагрузить компьютер).


Меры безопасности при подключении устройств

Прочитав подзаголовок этой части главы, вы, наверное, с усмешкой подумали: "Да, да, конечно, меня может убить электрическим током. Да откуда он там?!!!" Но не все так просто. Действительно, внутри системного блока нет высокого напряжения, если не считать блок питания, который, в общем-то, пользователю совершенно нет нужды разбирать. Да и на внешних разъемах имеется напряжение не более 12 вольт, но это не должно вас слишком успокаивать. Если вы можете достаточно безопасно ковыряться внутри компьютера, то некоторые его компоненты от неосторожного обращения могут очень быстро и, главное, надежно выйти из строя. Ну и как всегда по порядку.
Самый главный и наиболее часто встречающийся враг любой электроники — это статическое электричество. На коже человека, особенно в холодные сухие дни, может накопиться до нескольких сотен вольт. Этого вполне достаточно, чтобы безнадежно повредить электронную начинку компьютера.
Само по себе статическое электричество не страшно. Большую роль играет разность потенциалов между кончиками ваших пальцев и того места, которого вы касаетесь. Если вы предварительно коснетесь блока питания или неокрашенной части металлического шасси системного блока, то потенциал ваших пальцев станет равным потенциалу заземленного корпуса компьютера. Только в этом случае вы сможете избежать повреждения компьютерной электроники.

Примечание
В современных корпусах АТХ при программном отключении напряжение питания, так называемое дежурное питание, постоянно подается на материнскую плату, поэтому удар статического электричества может вызвать в любой момент самопроизвольное включение компьютера, например, при установке видеоплаты или модуля оперативной памяти. Естественно, что при этом компоненты могут получить повреждение не столько самим статическим электричеством, сколько резким скачком напряжения питания.

Для защиты от воздействия статического электричества можно воспользоваться вот такими рекомендациями:

  • подберите сопротивление в один мегаом. Точная величина не имеет значения — подойдет любое от нескольких сотен килоом до нескольких мегаом. Также не важно, на какую мощность рассчитано это сопротивление. Возьмитесь за один конец сопротивления, а другим коснитесь корпуса компьютера, прежде чем прикасаться к нему непосредственно пальцами. Это позволит медленно сбросить заряд электричества, и вы не почувствуете удара током. Процесс может занять несколько секунд. После чего следует прикоснуться кончиками пальцев к корпусу, чтобы убедиться, что вы полностью разрядились. Это обезопасит не только вас, но и электронику;
  • купите специальный предохранительный браслет. Самые простые из них делаются одноразовыми (из бумаги с прикрепленным проводом). Один конец проводника прикрепляется к корпусу компьютера (для этого концы делаются липкими), а второй — надевается на запястье. В этом случае все накапливающееся во время работы статическое электричество сразу сбрасывается через петлю на запястье;
  • снимите с себя всю синтетическую или шерстяную одежду, которая при движении имеет свойство довольно сильно накапливать статическое электричество.

Если вы отходите от компьютера, то разряжаться следует каждый раз, когда вы вновь собираетесь прикасаться к электронным компонентам компьютера.
Все внешние устройства следует подключать к системному блоку только после его выключения. Исключение составляют только устройства, подключаемые к шине USB, которая изначально была предназначена для "горячего" подключения, то же самое относится и к шине FireWire. Если вы вдруг все-таки "догадались" подключить какое-нибудь устройство, например принтер при включенном компьютере, тогда не удивляйтесь, что после этого параллельный порт перестал работать. Естественно, что на современных компьютерах применяются средства защиты внешних портов от перепадов напряжения, которое возникает в момент подключения, но это не дает 100% гарантии, что электроника выдержит нагрузку.
Прежде чем лезть внутрь системного блока, следует четко представлять себе, что же именно вам следует сделать, чтобы подключенное устройство нормально работало. В противном случае подобное "ковыряние" может привести к поломке компьютера.
При работе внутри системного блока следует помнить, что для подключения практически всех разъемов, установки перемычек или плат расширения не требуется прикладывать больших усилий. В большинстве случаев достаточно силы нажатия, сравнимой с нажатием на клавишу клавиатуры. Если вы чувствуете какое-то сопротивление, сначала вытащите разъем (перемычку, плату), проверьте, совпадают ли все ключи, выводы и отверстия, и только после этого повторите попытку с большим усилием. В противном случае вы можете повредить материнскую плату или подключаемое устройство, к тому же подобное механическое повреждение лишает вас гарантии на него.


FAQ (ответы на часто задаваемые вопросы)

Вопрос: Пытался подключить мышь PS/2 к порту СОМ через переходник, почему-то не получилось. Может быть, переходник неисправен?
Ответ: Манипулятор мышь PS/2 можно подключить к одному из последовательных портов только в том случае, если его электроника поддерживает работу с обоими типами портов. Такой вариант возможен, например, если одна и та же модель мыши выпускается в двух вариантах — с разъемом СОМ и с разъемом PS/2, в то время как все остальные компоненты мыши выпускаются на одной производственной линии. В противном случае никакой переходник вам не поможет, т. к. режимы работы в обоих случаях различаются.
Вопрос: Пытался установить драйвер устройства от Windows 2000 в операционной системе Windows XP, но система отказывается его устанавливать, выдавая при этом сообщение об ошибке (якобы драйвер не предназначен для работы в Windows XP).
Ответ: Попробуйте нижеследующий способ.
Запустите редактор системного реестра и найдите параметр ProductName
В КЛЮЧе HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Windows NTACurrentVersion.
Измените значение с Microsoft windows xp на Microsdft windows 2000.
Установите драйвер, который, в принципе, должен быть уверен, что операционная система является версией Windows 2000, после чего верните значение по умолчанию обратно.
Вопрос: Возле одного из устройств в Диспетчере устройств стоит восклицательный знак. Что он означает?
Ответ: Восклицательный знак указывает на проблему, которая может заключаться в отсутствии установленных драйверов устройства, в наличии аппаратного конфликта или же в отсутствии доступа к устройству. Иногда он означает конфликт драйверов. Ваши действия по устранению проблемы должны согласовываться со сведениями, которые можно почерпнуть из свойств данного устройства.
Вопрос:Не могу установить драйверы для одного из устройств. Что можно сделать?
Ответ: При установке драйверов могут возникнуть проблемы по следующим причинам:

  • из-за слишком длинного пути к каталогу с драйвером или если путь содержит русские символы, например каталог с драйвером находится на рабочем столе. Переместите каталог с драйвером в корневой каталог жесткого диска и задайте имя из латинских символов или цифр, после чего повторите попытку;
  • программа установки и другие необходимые файлы имеют атрибут "только для чтения". Снимите атрибут и повторите попытку;
  • слишком длинный путь к каталогу временных файлов или этот путь содержит русские символы. Особенно актуально это для Windows 2000/XP. Переместите каталог TEMP в корневой каталог, после чего повторите попытку;
  • программа установки запущена из командной строки окна эмуляции MS-DOS.

Это весьма характерно для Windows 2000/XP.
Если все-таки у вас не получается установить драйвер, попробуйте сделать это в безопасном режиме, но при этом имейте в виду, что предварительно следует скопировать драйверы на жесткий диск на случай, если привод CD-ROM будет недоступен, как это происходит в операционных системах Windows 9x.
Вопрос: Хотел самостоятельно переустановить операционную систему, а мне вот сказали, что придется устанавливать еще какие-то драйверы. Разве операционная система сама их не ставит, ведь в ней есть система Plug and Play?
Ответ: Система Plug and Play позволяет автоматически определять, что устройство подключено, после чего предлагается установить для него драйвер. Любая версия Windows имеет определенную базу драйверов, при этом следует иметь в виду, что более новые версии имеют более полную базу, но это не избавляет от необходимости ручной установки драйверов. С одной стороны, операционная система может и определит устройство, да установит для него драйвер, но с другой стороны, "встроенные" драйверы имеют, как правило, весьма "урезанные" функции. Например, видеоплаты GeForce 2 с видеовыходом. В Windows XP имеются драйверы для этих плат, но в них нет поддержки видеовыхода. Другой пример — видеоплата на чипе Intel 740. Операционная система Windows XP автоматически устанавливает для нее драйверы, но в них имеется серьезный недостаток — они не позволяют использовать аппаратное ускорение, что фактически уменьшает производительность компьютера, а то и вообще приводит к невозможности запуска некоторых игровых программ.
Вопрос: После установки Windows 2000 компьютер стал работать медленнее, чем это было в Windows 98. Из-за чего это может быть?
Ответ: Если ваша материнская плата построена на базе чипсета Intel с поддержкой режима UDMA66, вам придется вручную включить этот режим, т. к. по умолчанию он выключен. Для включения режима UDMA66 запустите редактор системного реестра, после чего найдите раздел:
HKEY_LOCAL_MACHINE\System\
CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000
(кроме 0000 могут быть и другие цифры, в зависимости от количества дисков).
Добавьте параметр ЕпаЫетомлбб со значением 1. Перезагрузите компьютер. Установите также флажок DMA в свойствах жесткого диска в диалоге Диспетчер устройств.
Вопрос:Купил материнскую плату с поддержкой USB 2.O. Установил на компьютер Windows ХР, а драйверы для USB 2.0 не хотят устанавливаться, несмотря на любые ухищрения.
Ответ: Причина проблемы в отсутствии в Windows ХР поддержки стандарта USB 2.O. Для устранения данной проблемы установите Service Pack 1 (и выше) либо патч, который должен находиться на компакт-диске с драйверами для материнской платы. В остальных версиях Windows поддержка USB 2.0 реализована полноценно.
Вопрос:Пробовал вручную изменить INF-файл драйвера, но, видимо, сделал ошибку, в результате которой теперь драйвер не устанавливается. Можно как-то исправить ее? Вроде все делал согласно рекомендациям из Интернета.
Ответ: Во-первых, любая информация, взятая из сети Интернет, должна проверяться, сверяться с разными источниками, особенно если она связана с тонкой настройкой операционной системы и системных файлов. Во-вторых, скорее всего, вам придется заново искать и скачивать драйверы, которые вы "препарировали", а в дальнейшем для уменьшения вероятности ошибочного ввода данных можно воспользоваться программой INF-Tool, она позволяет описать процедуру для установки драйвера, какие файлы и куда копировать, какие изменения следует вносить в системный реестр и т. д.
Вопрос:В Windows ХР не получается вручную назначить прерывание одному из устройств, т. к. пункт Автоматическая настройка недоступен для изменений. Что делать?
Ответ: Единственный способ справиться с ситуацией — это отключить параметр в BIOS под названием рпр os installed, что позволит распределять ресурсы только при помощи функций самой BIOS. Хотя имеет смысл отключить поддержку ACPI, после чего переустановить операционную систему (после отключения, скорее всего, ПК не загрузится). В последнем случае имеется еще один минус — компьютер перестанет самостоятельно выключаться.
Вопрос: Попробовал воспроизвести на приводе CD-ROM аудиодиск от музыкального центра, но звука не услышал. Говорят, что нужно подключать колонки к разъему на внешней панели привода. Можно как-то объединить этот разъем со звуковой платой?
Ответ: Для воспроизведения обычных аудиодисков на привод CD-ROM используйте так называемый "шнурок", соединяющий специальный разъем на тыльной стороне привода с соответствующим разъемом на звуковой плате или материнской плате, если звук интегрированный. Если ваш привод достаточно новый, то, скорее всего, он поддерживает режим цифрового воспроизведения. Режим можно включить во вкладке Панель управления | Мультимедиа | Музыкальный компакт-диск.
Вопрос:Не знаю, какой максимальной тактовой частоты можно установить на материнскую плату процессор.
Ответ: В современных материнских платах очень многое зависит от версии BIOS, которая установлена на ней. Например, при помощи обновления запросто можно установить процессор, который не работал бы до этого. Подобную информацию можно найти на сайте производителя материнской платы или конкретной версии BIOS, хотя первое более логично.
Вопрос:При установке новой мощной видеоплаты компьютер стал включаться через раз.
Ответ: Старый блок питания не "тянет" по мощности, попробуйте эту плату на ПК с более мощным блоком питания. Возможно, "накрылись" преобразователи напряжения, которые используются для питания шины AGP.
Вопрос: При включении режима DMA операционная система стала зависать.
Ответ: Для начала убедитесь, что жесткий диск или привод CD-ROM на самом деле поддерживают работу в режиме DMA. Особенно осторожно следует применять этот режим, если на одном соединительном шлейфе "висят" старое и новое устройства.


Глава 3. Диагностические сообщения операционной системы

  • Разновидности сообщений
  • Сообщения MS-DOS.78
  • Сообщения Windows 95/98/ME
  • Сообщения Windows NT/2000/XP101


Разновидности сообщений

  • Все сообщения, которые выдает на экран монитора любая операционная система, можно подразделить на следующие категории:
  • сообщение об ошибке, из-за которой продолжение установки операци
    онной системы невозможно. Обычно предлагается вариант, как именно
    можно устранить данную проблему, после чего можно будет повторить
    установку. Например, устранить эту проблему можно при помощи спе
    циальных ключей, описание которых вы найдете в главе <?, посвященной
    установке операционной системы;
  • сообщение об ошибке, из-за которой загрузка операционной системы не может быть продолжена. Проблема может заключаться в отсутствии или повреждении файлов, необходимых для успешной загрузки, хотя нередко причиной может быть нестабильно работающая оперативная память, особенно, когда речь заходит об ошибке защиты Windows и т. п.;
  • сообщение об ошибке, после которой нормальная работа операционной системы невозможна. Обычно при этом предлагается перезагрузить компьютер. Это такие проблемы, как повреждение системного реестра и т. Очень часто они связаны с нестабильной работой оперативной памяти;
  • сообщение о незначительной ошибке, после которой работа возможна. Обычно при этом предлагается нажать определенную клавишу для продолжения работы. Проблема обычно заключается в отсутствии некоторых файлов, не влияющих на успешную загрузку, причиной может стать не полная установка или удаление как программного обеспечения, так и драйверов устройств;
  • сообщение о невозможности выполнения определенной команды, яв
    ляющейся стандартной для операционной системы. Например, команда
    TIME . Скорее всего, команда была дана с недопустимыми параметрами или для ее выполнения не были соблюдены необходимые условия (на пример, программа не может быть запущена в окне эмуляции MS - DOS );
  • сообщения о невозможности запуска прикладных программ, сигнализи рующие о том, что не соблюдены все условия для их работы (отсутствие необходимого объема оперативной памяти и т. п.);
  • сообщения о невозможности окончания какой-либо команды или при кладной программы. Обычно при этом сообщается, что программа не отвечает на запросы, и предлагается принудительно "снять задачу", закрыв программу без сохранения всех произведенных изменений.

Внешний вид сообщений об ошибках может быть различным. Для операционной системы MS - DOS характерны текстовые сообщения, выводимые на черном фоне, для операционных систем семейства Windows все намного сложнее. Здесь встречаются самые разнообразные формы сообщений: от "синего экрана смерти" до стандартных "окошек", предлагающих получить дополнительную справку о возникшей проблеме.

Иногда операционная система дает серьезный сбой, в результате которого на экране монитора можно увидеть немало ляпсусов. Очень большая коллекция ошибочных сообщений собрана на интернет-сайте http :// vap . org . ru /.

Особенностью некоторых программ, рассчитанных на работу в операционной системе Windows , является то, что в них отсутствует обработчик ошибок, который позволял бы точно идентифицировать ошибки, возникающие процессе работы программы. Роль выдачи сообщений об ошибках берет на бя операционная система. Обычно это выглядит как некое краткое сообщение на английском или русском языке, которое не всегда понятно, араллельно с текстовым сообщением очень часто выдается цифровой код ошибки, по которому якобы вы сможете получить более подробные сведения о возникшей ситуации. Все хорошо, только во встроенной справке indows описание большинства этих ошибок отсутствует.

Существуют, по крайней мере, две программы, содержащих описания кодов ошибок, встречающихся при работе в Windows . Это программы под названием МS Windows Error Messages и WinErrs . Первая содержит коды описания оши- к, вторая помимо этого содержит еще и коды ошибок OLE ( Object Linking d Embedding , связывание и встраивание объектов). Обе программы работают д операционными системами Windows 95/98/ Me / Win 2 K / XP .


Сообщения MS - DOS

С операционной системой MS - DOS , несмотря на многочисленные попытки компании Microsoft , пользователь сталкивается практически каждый раз, гда приходится или переустанавливать "упавшую" операционную систему, и восстанавливать данные с жесткого диска, на котором повреждена таблица размещения данных. Однако все реже в литературе можно встретить описание методов работы в среде DOS , т. к. все повально стали переходить на работу в операционных системах семейства NT .

В данной части главы мы рассмотрим основные типы сообщений, с кото рыми можно встретиться при загрузке с компакт-диска или флоппи-диска.

  • Abort , Retry , Ignore , Fail
    Данное сообщение обычно появляется сразу после другого сообщения, которое сигнализирует об ошибке чтения/записи. Вам предлагается четыре варианта. При нажатии клавиши <А> программа прекратит свою работу и на экран монитора будет выведена строка приглашения MS - DOS примерно такого вида: c :\ windows \ command \, где с:— текущий диск, a \ windows \ command \ — текущий каталог.
    При нажатии клавиши < R > активизируется последняя команда, при вы полнении которой возникла ошибка, что позволяет продолжить выполнение программы. Так следует поступить, если вы устранили причину ошибки (например, вставили дискету в дисковод). В противном случае нажимать эту клавишу бесполезно.
    При нажатии клавиши <1> программа просто игнорирует ошибку и продолжит свою работу. Так следует поступить, когда вы уверены в том, что данное действие не приведет к потере ценной информации (например, ошибка при чтении одного из нескольких файлов нисколько не мешает копированию остальных файлов).
    При нажатии клавиши < F > программа получит команду продолжения операции, но без фиксации факта ошибки. Фактически данная команда заставляет систему, например, заново инициализировать дисковод и про должить чтение с того места, на котором возникла ошибка.
  • Access Denied
    Нет доступа. Такая ситуация возникает, например, если файл имеет ат рибут "только для чтения", а также, если файл зашифрован программны ми средствами или же он поврежден (имеет неверный формат).
  • Active Code Page Not Available From CON Device
    Активная кодовая страница не доступна для использования с устройст вом CON
  • Active Code Page : X
    В настоящий момент активной является кодовая страница X .
  • All Files In Directory Will Be Deleted! Are You Sure (Y/N)?
    Все файлы в текущем каталоге будут удалены! Вы уверены ( да / нет )?
  • Archive Is Not Damaged, Repairing Not Possible
    Архив не поврежден, процедура восстановления прекращена. Обычно сообщение можно увидеть при попытке восстановления архива, созданного программой RAR .
  • Are You Sure ?
    Вы уверены, что хотите продолжить действие (операцию)?
  • Attempt to Remove Current Directory
    Попытка удалить текущий каталог . Подобное сообщение может быть выведено на экран монитора антивирусной программой. Возможно, вы пытаетесь удалить каталог, в котором хранятся временные файлы запущенных программ.
  • Authenticity Verification - Check Error
    Ошибка при подсчете контрольной суммы файла. Такая проверка осуществляется, например, при распаковке архивов, запуске некоторых дист рибутивов и т. п.
  • Bad Command or File Name
    Вы ввели неверную команду или имя файла. Возможно, файл находится в другом каталоге или на другом диске.
  • Bad or Missing Command Interpreter
    He удается найти командный файл C 0 MMAND . COM или он поврежден. Может быть, вы ввели команду, которая выполняется при помощи этого файла, а дискета, с которой вы загружали компьютер, была заменена на другую, несистемную.
  • Bad or Missing Keyboard Definition File
    He удается найти файл, необходимый для нормальной работы клавиату ры, или этот файл поврежден. Возможно, файл находится в другом ката логе или на другом диске.
  • Batch File Missing
    Система не может найти указанный пакетный файл (с расширением ВАТ). При загрузке компьютера обычно запускается файл с именем AUTOEXEC . BAT .
  • CDR 100: Unknown Error
    Возникла неизвестная ошибка при работе привода CD - ROM .
  • CDR 101: Not Ready
    Устройство не готово. Подождите немного и повторите попытку. Если все равно появляется данное сообщение, проверьте наличие диска в при воде и качество его поверхности (возможны царапины в системной об ласти диска).
  • CDR102: EMS Memory No Longer Valid
    Количество расширенной памяти EMS превышает допустимый предел.
  • CDR103: CDROM Not High Sierra or ISO-9660 Format
    Привод CD - ROM не совместим со стандартом ISO -9660.
  • CDR 104: Door Open
    Лоток привода CD - ROM открыт.
  • CRC - Check Error
    Ошибка при проверке целостности данных. Обычно возникает при копи ровании файлов с компакт-диска на жесткий диск или попытке запус тить файл с него.
  • Can Not Find File <NAME>
    Система не может найти файл с названием < NAME >. Возможно, носи тель (диск) поврежден.
  • Cannot CHDIR to Root
    Система не может открыть корневой каталог диска. Возможно, носитель (диск) поврежден или его содержимое изменилось.
  • Cannot Do Binary Reads From a Device
    Система не может считать двоичный файл с устройства. Возможно, носи тель (диск) поврежден.
  • Cannot Find System Files
    He удается найти системные файлы. Возможно, носитель (диск) повреж ден или же его содержимое изменилось.
  • Cannot Load COMMAND, System Halted
    He удается найти командный файл CОMMAND.COM , система остановлена.
  • Cannot LoadHigh Batch File
    He удается загрузить пакетный файл в расширенную память. Возможно, носитель (диск) поврежден или же его содержимое изменилось. Есть ва риант, что неверно работает драйвер расширенной памяти.
  • Cannot Make Directory Entry
    He удается войти в указанный каталог. Возможно, носитель (диск) поврежден или же его содержимое изменилось.
  • Cannot Open Specified Country Information File
    He удается открыть указанный языковой файл. Возможно, носитель (диск) поврежден или же его содержимое изменилось (файл отсутствует).
  • Cannot Share Drives
    Совместное использование дисков в данном случае недопустимо.
  • Cannot Start COMMAND, Exiting
    He удается запустить командный файл C0MMAND.COM.
  • Code Page X Not Prepared For All Devices
    Кодовая страница Х не готова для использования всеми устройствами.
  • Code Page X Not Prepared For System
    Кодовая страница Х не готова к использованию.
  • Code Page Mismatch
    Несоответствие кодовой страницы.
  • Code Page Requested ( X ) Is Not Valid For Given Keyboard Code
    Запрос кодовой страницы X не соответствует клавиатурному коду.
  • Code Page Specified Has Not Been Prepared
    Указанная кодовая страница не готова к использованию.
  • Code Page Specified Is Inconsistent With The Selected Code Page
    Несовпадение кодовых страниц .
  • Command Line Too Long
    Слишком длинная команда. В командной строке MS - DOS введено слиш ком много параметров.
  • Configures a Keyboard For a Specific Language
    Настройка клавиатуры для указанного языка .
  • Copy Is Not Possible
    Не удается скопировать файл. Возможно , носитель ( диск ) поврежден .
  • Could Not Create Destination File
    He удается создать файл. Возможно, носитель
  • Could Not Create Directory
    He удается создать каталог .
  • Could Not Create File In Current Temporary Directory
    He удается создать файл во временном каталоге
  • Could Not Delete File or Directory
    He удается удалить файл или каталог.
  • Current Dive is No Longer Valid
    Указанный диск (дисковод) имеет недопустимые рабочие параметры
  • DOS Memory — Arena Error
    Ошибка в памяти, используемой операционной системой DOS
  • DOS is In Low MemoryDOS
    Операционная система MS - DOS находится в младших адресах памяти.
  • Data Error DOS
    Ошибка в данных.
  • Data Error Reading Device X:DOS
    Ошибка чтения данных с устройства X :.
  • Data Error Writing Device X:
    Ошибка записи данных в устройство X :.
  • Decompression Not Possible
    Декомпрессия файла невозможна .
  • Deleting Will Not Happen
    He удается осуществить удаление файла
  • Disk Boot Failure
    Загрузочная запись на диске повреждена
  • Disk Error Writing FAT
    Ошибка при записи данных в FAT -таблицу.
  • Disk I / O Error
    Ошибка записи/чтения с устройства (диска)
  • Disk Is Write-Protected or Directory Does Not Exist
    Диск защищен от записи или указанного каталога
  • Disk - Access - Error
    Ошибка доступа к диску (дисководу).
  • Divide Overflow
  • Ошибка — деление на ноль.
  • Drive Not Ready Error Reading Device X :
    Ошибка чтения из-за неготовности устройства х:.
  • Drive Not Ready Error Writing Device X :
    Ошибка записи из-за неготовности устройства X :.
  • Duplicate File Name or File Not Found
    Обнаружено два файла с указанным именем и
  • Encryption Failed
    Кодирование файла закончилось неудачей.
  • Error Creating Archive
    Ошибка при создании архива.
  • Error Creating Volume
    Ошибка при создании архивного тома.
  • Error Excluding Paths: Two or More
    Ошибка: обнаружено два или более одинаковых пути.
  • Error Found, F Parameter Not Specified. Corrections Will Not
    Найдена ошибка . Требуемый параметр не задан
  • Error In EXE File Error Loading Operating System
    Ошибка при загрузке операционной системы.
  • Error Occurred In Environment Variable
    Произошла ошибка среди переменных .
  • Error Opening File
    Ошибка при открытии файла.
  • Error While Opening
    Ошибка при открытии файла (каталога).
    Error While Reading
    Ошибка при чтении файла .
  • Error While Reading Archive
    Ошибка при чтении архива.
  • Error While Recreating Archive
    Ошибка при обновлении архива .
  • Error While Writing
  • Ошибка при записи данных в файл.
  • Error Writing Fixed Disk
    Ошибка записи на жесткий диск.
  • Error Writing Partition Table
    Ошибка при записи данных в таблицу раздел
  • Error Writing to Device
    Ошибка записи в устройство .
  • Expanded Memory Allocation Error
    Ошибка при распределении дополнительной памяти
  • Expanded Memory Not Present or Not-Usable
    Дополнительная память не готова к использованию
  • FCB Unavailable
    Блок управления недоступен.
  • Fail on INT 24
    Сбой на INT 24.
  • File Allocation Table Bad, Drive X:
    Таблица размещения файлов на устройстве X : повреждена.
  • File Compressed With Unknown Method
    Файл упакован неизвестным методом.
  • File Creation Error
    Ошибка при создании файла.
  • File Exists
    Файл уже существует.
  • File Not Found
    Не удается найти файл .
  • File Not Found or Archive Broken
    He удается найти файл или архив поврежден.
  • Files Can Be Found At
    He удается найти файлы в текущем каталоге.
  • Floating - Point Support Not Loaded
    Поддержка вычислений с плавающей запятой не загружена.
  • Format Another (Y/N)?
    Форматировать следующий диск (да/нет)?
  • Found No Recovery Data
    Информация для восстановления архива не найдена.
  • Found Recovery Data
    Найдена информация для восстановления
  • Function Not Supported By Network
    Функция не поддерживает работу с сетью.
  • Function Not Supported By Network
    Функция не поддерживает работу с сетью.
  • General Failure
    Общий отказ системы.
  • General Failure Error Reading Device X:
    Общий отказ при чтении данных из устройстве
  • General Failure Error Writing Device X:
    Общий отказ при записи данных в устройстве
  • Header Broken
    Поврежденный заголовок.
  • Illegal Option
    Недопустимая опция.
  • Incorrect DOS Version
    Неверная версия MS - DOS .
  • Insert Disk With <NAME> In Drive X:
    Вставьте диск с именем < NAME > в дисковод X :.
  • Insert Disk With Batch File
    Вставьте диск с пакетным файлом .
  • Insert New Diskette To Drive X: And Strike ENTER When Ready
    Вставьте новую дискету в дисковод X : и нажмите клавишу < ENTER >.
  • Insufficient Disk Space
    Недостаточно свободного места на диске.
  • Insufficient Far Memory
    Недостаточно оперативной памяти.
  • Insufficient Memory
    Недостаточно оперативной памяти.
  • Integer Divide By 0
    Попытка деления на ноль.
  • Intermediate File Error During Pipe
    Ошибка при исполнении файла .
  • Invalid C 0 MMAND . COM
    Файл C 0 MMAND . COM поврежден или несоответствующая версия файла.
  • Invalid Code Page
    Недопустимая кодовая страница.
  • Invalid Code Page Specified
    Недопустимая кодовая страница.
  • Invalid Data
    Данные повреждены .
  • Invalid Device
    Указано неверное устройство.
  • Invalid Device Request Parameters
    Недопустимые параметры запроса устройства.
  • Invalid Disk Change
    Недопустимое дисковое изменение.
  • Invalid Drive In Search Path
    Неверно указан диск в параметрах поиска. П Invalid Drive Specification
  • Недопустимая спецификация диска.
    Invalid Environment
    Недопустимая среда .
  • Invalid Filename or File Not Found
    Недопустимое имя файла или файл не найден
  • Invalid Format
    Недопустимый формат.
  • Invalid Function
    Недопустимая функция.
  • Invalid Function Parameter
    Недопустимый функциональный параметр.
  • Invalid Handle
    Недопустимый дескриптор.
  • Invalid Keyboard Code Specified
    Недопустимый клавиатурный код.
  • Invalid Keyboard ID Specified
    Недопустимый идентификатор клавиатуры
  • Invalid Keyword
    Недопустимое ключевое слово.
  • Invalid List File
    Недопустимый файл списка.
  • Invalid Media Type
    Недопустимый тип носителя.
  • Invalid Memory Block Address
    Недопустимый адрес блока памяти.
  • Invalid Parameter Combination
    Недопустимая комбинация параметров.
  • Invalid Partition Table
    Недопустимый формат таблицы разделов.
  • Invalid Password
    Неверный пароль.
  • Invalid Path
    Неверный путь .
  • Invalid Path or File Name
    Неверный путь или имя файла.
  • Invalid Path, Not Directory or Directory Not Empty
    Неверный путь, отсутствует указанный каталог
  • Invalid Switch
    Недопустимый параметр
  • Invalid System Disk
    Системный диск имеет неверный формат.
  • Invalid Time
    Неверное время.
  • Invalid Unit
    Недопустимый модуль.
  • Invalid Volume Size
    Недопустимый размер тома.
  • KEYB Has Not Been Installed
    Отсутствует клавиатура .
  • Keyboard ID Specified Is Inconsistent With The Selected Keyboard Layout
    Идентификатор клавиатуры противоречит
  • Label Not Found
    Метка диска не найдена.
  • LoadHigh : Invalid Argument
    Недопустимый параметр при загрузке програм
  • Lock Violation
    Нарушение блокировки.
  • Memory Allocation Error
    Ошибка распределения памяти.
  • Memory Control Blocks Destroyed
    Ошибка при работе с блоками памяти.
  • Missing Operating System
    Не удается найти операционную систему
  • Modify of Locked Archives Impossible
    Изменение заблокированного архива невозможно
  • Modify of Volumes Impossible
    Изменение тома невозможно .
  • NLSFUNC Not Installed
    Системный файл с названием NLSFUNC не найден.
  • NN Lost Cluster Found in XX Chains
    NN потерянных кластеров найдены в ХХ-цепочке
  • Name Of List Device (PRN)
    Устройство для печати (по умолчанию PRN ).
  • Network Data Fault
    Ошибка при передаче данных по сети.
  • No More Files
    Больше нет файлов.
  • No Valid CDROM Device Drivers Selected
    Выбран неверный привод CD-ROM.
  • Non-DOS Disk X:
    Диск в дисководе X : отформатирован не средствами MS - DOS
  • Non-DOS Disk Error Reading Device X:
    Ошибка при чтении данных, диск отформатирован не средствами MS - DOS
  • Non - DOS Disk Error Writing Device X :
    Ошибка при записи данных, диск отформатирован не средствами MS - DOS
  • Non - System Disk or Disk Error
    Несистемный диск или ошибка на диске.
  • Not All Selected Files Copied
    He все выбранные файлы удалось скопировать.
  • Not Enough Drive Letters Available
    Недостаточно доступных имен дисков
  • Not Enough Expanded Memory, Reducing Number of Buffers
    Недостаточно расширенной памяти , уменьшите размер буфера
  • Not Enough Memory To Perform Operation
    Недостаточно памяти для выполнения операции.
  • Not Enough Memory or Dictionary of Archive Too Large
    He хватает памяти или архив слишком большой.
  • Not Enough Space For Environment
    Недостаточно свободного места для выполнения текущей операции.
  • Not Enough Space On Destination-Disk To Copy
    Недостаточно места на диске, на который осуществляется копирование данных.
  • Not Enough Space To Save
    Недостаточно свободного места для сохранения изменений
  • Not Enough Space on Temporary Drive
    Недостаточно свободного места на диске для размещения временных файлов
  • Not Ready Error Reading Device X;
    Ошибка при чтении данных, устройство X : не готово
  • Not Ready Error Writing Device X:
    Ошибка при записи данных, устройство х- не готово,
  • Not Same Device
    Отсутствует указанное устройство.
  • Null Pointer Assignment
    Нулевое значение параметра.
  • One or More CON Code Pages Invalid For Given Keyboard Code
    Одна или более кодовых страниц имеют недопустимый формат.
  • Operation Aborted
    Текущая операция прервана.
  • Out of Environment Space
    Недостаточно свободного пространства для выполнения операции
  • Out of Memory
    Недостаточно памяти .
  • Packed File is Corrupt
    Запакованный файл поврежден .
  • Parameter Format Not Correct
    Параметр имеет неверный формат.
  • Parameter Value Not Allowed
    Недопустимое значение параметра.
  • Parameter Value Not In Allowed Range
    Значение параметра имеет недопустимый параметр.
  • Path Not Found
    Путь указан неверно.
  • Print Queue is Empty
    Очередь печати пуста.
  • Printer Out of Paper Error
    Ошибка печати. Отсутствует или застряла бумага.
  • Probable Non-DOS Disk, Continue (Y/N)?
    Предположительно диск отформатирован не средствами МS-DOS. Продолжить (да/нет)
  • Program Too Big to Fit In Memory
    Программа слишком большая для ее размещения в оперативной памяти.
  • Read Fault Error
    Ошибка при чтении данных .
  • Read Fault Error Reading Device X:
    Ошибка при чтении данных из устройства X :
  • Read Fault Error Writing Device X :
    Ошибка при записи данных в устройство X :.
  • Recovery Data Damaged
    Информация для восстановления архива повреждена.
  • Recreation Failed
    Ошибка при создании файла.
  • Replace and Press Any Key When Ready
    Когда будете готовы, нажмите любую клавишу для выполнения команды
  • Replace and Strike Any Key When Ready
    Когда будете готовы, нажмите любую клавишу для выполнения команды.
  • Replace the Disk , and Then Press Any Key
    Замените диск в дисководе и нажмите любую клавишу
  • Required Parameter Missing
    Отсутствует обязательный параметр.
  • Required System Component Not Installed
    Требуемый системный компонент не установлен.
  • Run-Time Error
    Ошибка во время выполнения программы.
  • Sector Not Found
    Не удается найти сектор.
  • Sector Not Found Error
    He удается найти сектор или сектор имеет неверный формат.
  • Sector Not Found Error Reading Device X:
    He удается найти сектор, ошибка возникла при чтении данных из устройтва X :.
  • Sector Not Found Error Writing Device X:
    He удается найти сектор, ошибка возникла при записи данных в устройство X :.
  • Seek Error
    Найдена ошибка .
  • Seek Error Reading Device X:
    Найдена ошибка при чтении данных из уст
  • Seek Error Writing Device X:
    Найдена ошибка при записи данных в устройство х
  • Select Smaller Dictionary Size And Try Again
    Выберите меньший размер словаря и попытайтесь еще раз
  • Sharing Violation
    Ошибка совместного доступа.
  • Specified COMMAND Search Directory Bad
    He удается найти в указанном каталоге файл
  • Specified COMMAND Search Directory Bad, Access Denied
    He удается найти в указанном каталоге файл
  • Specified Files Have The Same Name
    Указанные файлы имеют другие имена.
  • Stack Overflow
    Переполнение стека.
  • Starts a New Copy of the MS-DOS Command Interpreter
    Запустите новую копию командного файла C0MMAND.CO
  • String Not Found
    Строка не найдена.
  • Syntax Error
    Синтаксическая ошибка.
  • System Resource Exhausted
    Не хватает системных ресурсов.
  • Terminate Batch Job (Y/N)?
    Прекратить выполнение пакетного файла (да/нет)?
  • This Program Cannot Be Run In DOS Mode
    Эта программа не может работать в среде MS - DOS .
  • This Program Requires Microsoft Windows
    Для запуска этой программы требуется операционная система Windows
  • Too Many Bytes Damaged
    Слишком много поврежденных файлов.
  • Too Many Open Files
    Слишком много открытых файлов .
  • Too Many Parameters
    Слишком много параметров.
  • Too Many Redirections
    Слишком много параметров.
  • Top Level Process Aborted, Cannot Continue
    Текущий процесс прерван, продолжение работы программы невозможно
  • Unable to Create Directory
    He удается создать каталог .
  • Unable to Create KEYB Table In Resident Memory
    He удается поместить таблицу значений клавиш в качестве резидента.
  • Unable to Load Translated Messages
    He удается загрузить сообщение .
  • Unable to Repair Archive By Recovery Data
    He удается воспользоваться информацией для восстановления, архив по врежден.
  • Unrecognized Switch
    Недопустимый ключ .
  • Unrecoverable Error On Directory
    При работе с текущим каталогом возникла неустранимая ошибка.
  • User Break
    Пользователь отменил текущую информацию
  • Volume in Drive X: Has No Label
    Диск в дисководе х : не имеет метки или она несоответствующая
  • Write Fault Error
    Ошибка при записи данных.
  • Write Protect Error
    Запись не удалась, обнаружена защита от записи
  • Write Protect Error Writing Device X:
    Запись на устройство х: не удалась, обнаружена защита от записи.


Сообщения Windows 95/98/ ME

Практически все сообщения, выдаваемые операционными системами Windows , имеют порядковый номер (от 1, практически, до 1000). Как уже говорилось, более или менее подробное описание подобных цифровых со общений можно получить при помощи таких профамм, как MS Windows Error Messages , хотя часть из них все-таки придется искать во встроенной справке операционной системы, как, например, любые ошибки, связанные с работой в локальной сети и сети Интернет, имеющие кодовое обозначение от 600 и выше. Это заявление имеет силу для всех операционных систем, как для Windows 9 x , так и для Windows NT . Мы не будем рассматривать их, потому что это займет очень большое количество страниц, к тому же в большинстве случаев удобнее воспользоваться встроенной справкой для получения информации именно по возникшей у вас ошибке.

Основные типы сообщений, выдаваемых программой установки:

  • SU 0010
  • На жестком диске обнаружена программа Boot Manager или подобная ей. Такие программы позволяют устанавливать на один раздел несколько опе рационных систем. Если вы продолжите установку, зафузочный сектор бу дет перезаписан и возможности этой профаммы окажутся недоступными.
  • SU 0011
  • На жестком диске обнаружен один или более разделов, защищенных па ролем. Чтобы продолжить установку, следует отключить защиту.
  • SU 0012
  • На жестком диске обнаружен раздел, созданный либо OS/2, либо NT - подобной операционной системой. Данный раздел будет недоступен при работе в Windows 9 x .
  • suooi 3
  • Не удается создать временные файлы на жестком диске, т. к. он отформатирован под файловую систему, не поддерживаемую операционными системами семейства Windows 9 x . Удалите все разделы и создайте совмес тимые с MS - DOS разделы, после чего заново запустите программу уста новки. Возможно, проблема возникла из-за применения программы сжа тия SuperStor или серверной профаммы LANtastic .
  • SU 0014
  • Обнаружено устройство, не отвечающее на запросы. Чтобы повторить попытку его инициализации, нажмите кнопку Повторить.
  • SU 0015
  • На жестком диске обнаружен раздел, предположительно созданный опе рационной системой семейства Windows NT . Этот раздел будет недоступен при работе в операционной системе семейства Windows 9 x .
  • SU 0016
  • Обнаружена установленная операционная система OS/2. Если вы про должите установку, вы больше не сможете запустить ее.
  • SU 0018
  • Не удается создать временные файлы на жестком диске, т. к. в корневом каталоге слишком много файлов или была применена программа для сжатия жестких дисков или какая-нибудь программа сетевого доступа.
  • SU 0019
  • Обнаружены недопустимые для Windows команды в файлах AUTOEXEC . BAT или CONFIG . SYS .
  • SU 0129
  • Не удается определить текущую аппаратную конфигурацию компьютера, установка не может быть продолжена.
  • SU 0130
  • Проверьте написание имени пользователя, идентификационного номера, пароля.
  • SU 0133
  • Не удается выполнить полную диагностику конфигурации ПК. Попро буйте выбрать минимальную диагностику. Обратите внимание: если и это не работает, перезапустите программу установки в безопасном режиме.
  • SU 0135
  • Не удается идентифицировать все устройства, поэтому от вас требуется указать модель неопознанных устройств самостоятельно.
  • suoi 36
  • Не удается открыть файл помощи, поэтому в процессе всей установки функции встроенной справки будут недоступны.
  • SU 0139
  • Каталог, который выбран для установки, содержит версию операционной системы с поддержкой несовместимого набора символов. Обновление ус тановленной версии Windows невозможно, попробуйте выбрать другой каталог.
  • SU 0141
  • Не удается скопировать файлы, необходимые для создания загрузочного диска. Вы можете продолжить установку без создания диска.
  • SU 0142
  • Обнаружено недостаточное количество свободного места для установки операционной системы. Удалите ненужные файлы и каталоги или выбе рите для установки другой диск.
  • SU 0147
  • Обнаружено недостаточное количество свободного места для установки операционной системы. Для продолжения установки требуется как ми нимум X свободного места. Удалите ненужные файлы" и каталоги и по вторите установку.
  • SU 0151
  • Не удается продолжить проверку, т. к. установленной памяти для этого недостаточно. Вы можете продолжить установку без проверки.
  • ? SU 0152
  • На вашем компьютере установлено X оперативной памяти. Для установки данной версии операционной системы требуется хотя бы Y байт.
  • SU 0153
  • Диск X , сжатый до X байт, должен иметь как минимум Y байт свобод ного места, чтобы можно было продолжить установку. Удалите ненужные файлы и каталоги и запустите программу установки заново.
  • SU 0156
  • Обнаружена установленная версия Pen Extensions 1.0. Если вы продолжи те установку, программа будет удалена с жесткого диска, но вы можете отменить установку нажатием клавиши Отмена.
  • SU 0159
  • В указанном каталоге обнаружена установленная операционная система Windows NT . Установка в этот каталог невозможна, перезапустите программу установки и укажите другой каталог.
  • su01 6 o
  • Указанный каталог уже содержит установленную версию операционной системы. Выберите другой каталог.
  • SU 0161
  • В указанном каталоге уже содержится установленная операционная сис тема, программа установки задаст другое имя каталога установки, кото рые вы можете позже изменить.
  • SU 0162
  • В указанном каталоге обнаружена уже установленная операционная система семейства Windows NT . Программа установки выбрала другой ката лог, который вы можете изменить позже.
  • SU 0163
  • В указанном каталоге обнаружена установленная версия MS - DOS , выбе рите другой каталог.
  • SU 0164
  • Не удается обновить установленную версию операционной системы, т. к. вы указали каталог, не содержащий файлов старой версии Windows .
  • SU 0165
  • Указанная дорожка имеет неправильный формат, укажите другую дорожку.
  • SU 0167
  • Указанный каталог содержит каталог с названием Рабочий стол. Удалите его или переименуйте, после чего повторно запустите программу установки.
  • SU 0168
  • Уже установленная версия операционной системы не может быть обнов лена данной версией, обновите версию дистрибутива.
  • SU 0325
  • Установка Windows ME не может быть продолжена из-за испорченного файла с расширением cab . Повреждение может быть вызвано вирусом или аппаратными сбоями, но вероятнее всего это вызвано загрязнением или царапиной на компакт-диске.
  • SU 0335
  • Не удается определить конфигурацию оборудования ПК. Это может быть вызвано повреждением одного из файлов установки или недостатком оперативной памяти.
  • SU 0343
  • Не удается создать каталог (файл) с названием X . Проверьте, что вы пра вильно указали имя диска, путь и нет ли уже на диске каталога (файла) с таким же именем.
  • SU 0344
  • Указанного каталога с уже установленной операционной системой не существует. Проверьте правильность указания имени диска и путь.
  • SU 0346
  • Обновление Windows невозможно. Не совпадают номера версий операционной системы и дистрибутива. Укажите другой каталог для установки.
  • SU 0347
  • Обновление версии Windows номер X в указанном каталоге невозможно. Вы должны иметь дистрибутив Windows версии Y или выше. Укажите другой каталог для установки.
  • SU 0349
  • Файл SETUPX . DLL уже загружен в память компьютера. Закройте все программы и повторите попытку или перезагрузитесь в режиме MS - DOS .
  • SU 0350
  • Не удается показать лицензионное соглашение, установка будет прервана.
  • SU 0358
  • Обнаружена одна или более запущенных программ MS - DOS . Закройте все запущенные программы и нажмите Продолжить установку.
  • SU 0360
  • Не удается создать каталог (файл) с названием X . Проверьте правиль ность указания имени диска, на котором вы хотите установить Windows . Например, C :\ Windows .
  • suo 36 i
  • Найден файл системного реестра Windows . Если вы продолжите установ ку в этот каталог, то он будет стерт новым файлом. Вы хотите продол жить?
  • SU 0362
  • Продолжение установки не рекомендуется из-за малого количества свободного места на диске. Если вы продолжите установку, она может за кончиться неверно.
  • SU 0365
  • Выбор этой опции вызовет удаление всех сетевых служб при запуске ПК.
  • SU 0366
  • Выбор этой опции вызовет удаление некоторых команд из файлов на стройки AUTOEXEC . BAT и CONFIG . SYS , которые могут вызвать про блемы с установкой операционной системы Windows , и позволит исполь зовать наиболее быстрые драйверы устройств.
  • SU 0369
  • Программа установки удалит все дополнительные компоненты. Позже вы можете выбрать компоненты для установки. Продолжить?
  • SU 0360
  • Операционная система Windows не может быть установлена на сетевой диск. Выберите локальный диск и каталог. Например, C :\ Windows .
  • SU 0403
  • Система не может найти файл X , чтобы конвертировать его в новый формат.
  • ? SU 0404
  • Программа установки уже запущена.
  • SU 0406
  • Операционная система Windows 95 ( Windows 98) для своей работы требу ет, как минимум, процессор 80386.
  • SU 0409
  • Система не может найти файл X , где х — имя файла.
  • SU 0409
  • Другой вариант расшифровки: программа установки не может обновить ваши системные файлы. Причиной могут служить заражение вирусом или установленные антивирусные программы. Временно исключите все антивирусные программы из автозагрузки и повторите запуск программы установки, предварительно запустив антивирус и проверив жесткий диск и дистрибутив на наличие вирусов.
  • SU 0410
  • Система не может открыть файл X , где X — имя файла. Данный файл от сутствует, поврежден или недостаточно памяти для его открытия. Освободите определенное количество памяти и повторите процесс установки. Установка прекращается.
  • SU 0433
  • Не удается открыть файлы настройки с расширением inf . Процесс уста новки прерван.
  • SU 0434
  • Ошибка при загрузке INF -файла с именем X .
  • SU 0507
  • Возникла неустранимая ошибка при анализе конфигурации компьютера. Процесс установки прерван.
  • SU 0515
  • Не удается настроить сетевые компоненты. Для продолжения установки без поддержки сети нажмите "Да", для прекращения установки — "Нет".
  • SU 0516
  • Обнаружена ошибка при инициализации устройства X . Для продолжения установки нажмите "Да". Если проблема повторится, запустите програм му установки в безопасном режиме.
  • SU 0700
  • Не удается обновить установленную версию операционной системы. Выберите другой каталог для установки.
  • SU 0701
  • Продолжение установки в указанный каталог невозможно. Выберите другой каталог.
  • SU 5019
  • Продолжение установки невозможно из-за повреждения данных.
  • SU 5038
  • В строке запуска программы установки имеется один или несколько неверных ключей.
  • SU 8072
  • Программа установки не может найти UI -ресурсы.
  • SU 8074
  • Программа установки обнаружила ошибку при создании окна. П SU 8075
  • Ошибка при переключении монитора в графический режим.
  • SU 8077
  • Программа установки обнаружила некорректное значение параметра HINSTvalue .
  • SU 8078
  • UI инициализировался дважды.
  • SU 8079
  • Произошла неизвестная ошибка.
  • SU 8080
  • Процесс установки прерван пользователем.
  • SU 8128
  • Каталог с указанным именем не может быть создан, потому что такой ка талог уже существует. Вы можете либо изменить имя каталога, либо от менить установку.
  • SU 8129
  • Диск X : сжат бета-версией программы DoubleSpace . Обновите версию программы или отмените сжатие.
  • SU 8130
  • Диск х-, частично сжат программой DoubleSpace . Закончите сжатие или
  • отмените его.
  • SU 995038
  • Неверный ключ программы установки. Для справки наберите ключ /?.
  • Change Directory
  • Вы не можете выбрать другой каталог для запуска Windows 95. Если вы вы брали другой каталог, тогда запустите программу установки из MS - DOS .
  • Crosslinked Files
  • Обнаружена ошибка на диске. Запустите программу SCANDISK для уст ранения проблемы.
  • Directory Already Exists
  • Каталог с указанным именем уже существует. Если вы продолжите уста новку в него, все файлы будут перезаписаны. Продолжить?
  • Machine Directory
  • Для продолжения установки следует указать каталог.
  • Problem with Drive
  • Продолжение установки невозможно из-за ошибки на диске. Запустите программу SCANDISK или CHKDISK для устранения проблемы.
  • UPI
  • Идентификационный номер обязателен для установки Windows .
  • Virtual Machine
  • Программа не может быть запущена из окна эмуляции MS - DOS .


Сообщения Windows NT /2000/ XP

Как известно, операционные системы семейства NT ( New Technology ) пред ставляют собой очень надежные оболочки, предназначенные в первую оче редь для серьезных задач вроде организации сервера локальной сети и т. п. Стабильность работы в этих операционных системах достигается в основном путем введения ограниченного доступа прикладных программ к системным ресурсам (в том числе и к аппаратному обеспечению). Но никто не может дать гарантии того, что некоторые единичные процессы, которые имеют дос туп ко всей системе, не дадут сбой при своей работе. Операционная системане способна предотвратить выполнение ошибочной операции подобных процессов, в результате чего компьютер прекращает свою работу, а при пе резагрузке запросто может "обрадовать" так называемым "синим экраном смерти" ( Blue Screen of Dead , BSOD ).

В настоящее время все большее распространение получает операционная система Windows XP , поэтому в основном мы будем рассматривать именно ее. Самой яркой особенностью этой операционной системы является то, что по умолчанию (сразу же после установки) при возникновении критических сбоев компьютер автоматически перезагружается, что иногда не позволяет быстро устранить причину сбоя. Данную функцию можно отключить в диа логовом окне Загрузка и восстановление (Панель управления | Система). Большая часть нижеследующих сообщений соответствует сообщениям в бо лее старой версии операционной системы — Windows 2000, поэтому их можно использовать для диагностики этой версии ОС.

  • KMODE _ EXCEPTION _ NOT _ HANDLED
  • Сбой, скорее всего, вызван некорректной работой драйвера одного из устройств.
  • NTFS _ FILE _ SYSTEM
  • Возникла ошибка при работе драйвера файловой системы NTFS . Причи ной могло послужить физическое повреждение поверхности жесткого диска (другими словами, появление сбойных кластеров), нарушение це лостности соединительного кабеля, а также сбой при работе драйвера IDE - или SCSI -устройства. Если система может загрузить хотя бы кон соль восстановления, запустите утилиту CHKDSK / F . Если же система вообще не может загрузиться в любом из возможных режимов, стоит по пробовать установить вторую копию Windows в другой каталог, после чего уже провести проверку всех разделов, а впоследствии путем редак тирования файла BOOT . INI вернуться к использованию старой копии.
  • DATA _ BUS _ ERROR
  • Ошибка четности оперативной памяти.
  • IRQL_NOT_LESS_OR_EQUAL
  • Сбой произошел либо из-за некорректно работающего драйвера, либо из- за аппаратного конфликта. Если вы недавно подключили новое устройство, попробуйте временно отключить его. Также можно попробовать уда лить драйвер и установить другую его версию или хотя бы переустано вить имеющуюся.
  • PAGE_FAULT_IN_NONPAGED_AREA
  • Запрашиваемые данные отсутствуют в оперативной памяти. Скорее всего, дефект имеется либо в оперативной памяти, либо в файловой системе.
  • KERNEL _ STACK _ INPAGE _ ERROR
  • Не удается прочитать данные из файла подкачки. Скорее всего, на жест ком диске имеются так называемые bad -сектора, один из которых распо лагается в том месте, где сохранен требуемый файл.
  • MISMATCHED _ HAL
  • Серьезный сбой ядра системы. Скорее всего, текущая конфигурация Windows не соответствует действительности, например, вы установили второй процессор, а операционная система устанавливалась в расчете на один и т. п.
  • KERNEL _ DATA _ INPAGE _ ERROR
  • Не удается прочитать данные из файла подкачки ( PAGEFILE . SYS ). Ско рее всего, на жестком диске имеются сбойные сектора, один из которых располагается в том месте, где сохранен требуемый файл. Стоит попробовать, запустив компьютер с компакт-диска, удалить файл, после чего система создаст его автоматически при следующем запуске. Проблема также может быть в оперативной памяти и в центральном процессоре.
  • INACCESSIBLE _ BOOT _ DEVICE
  • Сбой системы произошел из-за сбоя при чтении с жесткого диска. При чиной мог стать как некорректно работающий драйвер накопителя, так и аппаратный сбой в его работе (вплоть до появления сбойных секторов). Возможно, был поврежден загрузочный сектор. П UNEXPECTED _ KERNEL _ MODE _ TRAP
  • Возникла фатальная ошибка вроде деления на ноль.
  • STATUS _ SYSTEM _ PROCESS _ TERMINATED
    Произошел сбой в процессе, выполняемом пользователем.
  • STATUS _ IMAGE _ CHECKSUM _ MISMATCH
    Поврежден или утерян один из системных файлов.
  • DIVIDE_BY_ZERO_ERROR
  • Произошел сбой в результате деления на ноль.
  • REGISTRY _ ERROR
  • Сбой произошел из-за критической ошибки в системном реестре, хотя это может означать, что на жестком диске появились сбойные сектора. Единственный шанс восстановить работу компьютера — это скопировать системный реестр из заранее созданной резервной копии.
  • UNEXPECTED_KERNEL_MODE_TRAP
  • Сбой оперативной памяти . Проверьте корректность выставленных режи мов доступа к памяти в BIOS . Если все параметры находятся в допустимых пределах, тогда, скорее всего, придется заменить модуль памяти.
  • BAD _ POOL _ HEADER
  • Данный сбой не несет в себе какой-либо конкретной причины. В первую очередь можно попробовать воспользоваться функцией загрузки "последней удачной" конфигурации, что позволит исключить влияние последних изменений в системе.
  • NMI _ HARDWARE _ FAILURE
  • Общее сообщение о сбое, вызванном некорректной работой каких-либо аппаратных компонентов. Возможно, были установлены модули памяти, поддерживающие и не поддерживающие контроль четности, причем режим проверки был включен.


Глава 4. Диагностические программы

Во-первых, нам следует разобраться, что такое диагностика. Многие пользо ватели, только услышав, что их компьютер собираются диагностировать, сразу начинают сильно нервничать, думая, наверное, что возникла неисправность или еще что-нибудь плохое. Это совершенно не так.

Диагностика — это тщательное тестирование всех компонентов компьютера с целью выяснения соответствия их характеристик заявленным производи телем (продавцом), а также определения реальной производительности (скорости работы) и сравнения этих показателей с эталонным оборудовани ем. Естественно, что некоторые функции диагностических, или, как еще их называют, тестовых программ можно использовать для выявления оборудо вания, работающего со сбоями, но это не говорит о том, что такие програм мы применяются в основном для поиска неисправностей.

Диагностические программы позволяют без вмешательства в устройство компьютера определить модель, дату производства, характеристики установленных компонентов. Это, например, позволяет убедиться в том, что все компоненты совершенно новые.

Диагностические программы бывают двух основных типов:

  • комплексные — в основном предназначены для получения подробной информации об установленных компонентах, определения производитель ности и сравнения с эталонным оборудованием;
  • специализированные — позволяют получить наиболее полную информа цию о компонентах, а также включать/отключать различные режимы ра боты, которые недоступны при помощи стандартных средств.

Диагностические программы, проверяющие наиболее важные параметры "железа", позволяют предотвратить подавляющее большинство проблем, возникающих по вине аппаратного обеспечения. Это говорит о том, что в дальнейшем вам будет достаточно искать причину сбоев в программном обеспечении (операционной системе). Большое количество диагностических программ можно найти на интернет-сайте http :// www . benchmarkhq . ru /. Наиболее яркими представителями комплексных программ можно назвать такие, как ASTRA и SiSoft Sandra . Рассмотрим их более подробно. Очень часто только что приобретенный компьютер в качестве операционной системы имеет установленную MS - DOS версии 6.22 или выше, что на пер вый взгляд не может позволить вам проверить конфигурацию и сверить ее с указанной в имеющихся документах (например, в гарантийном талоне). Именно по этой причине в первую очередь ваше внимание должны при влечь те программы, которые способны работать в среде MS - DOS . Конечно, они не такие красивые и не такие удобные в работе, но вы еще до установки операционной системы сможете убедиться в достоверности всех заявлений компании-продавца, а также обнаружить серьезные ошибки в работе "железа", что в будущем позволит вам избежать потери важных данных.

Одной из таких программ является программа с интересным названием ASTRA , расшифровываемым как Advanced Syslnfo Tool and Reporting Assistant . Создателем этой довольно неплохой программы является компания Syslnfo Labs . В начале 2003 года вышла в свет версия программы за номером 4.11, что вовсе не означает, что все предыдущие версии стали непригодными к использованию. Последняя версия этой программы позволяет определять более ста типов процессоров и более трехсот типов материнских плат — от самых старых до современных. Естественно, что более ранние версии имеют менее полную базу, хотя на компьютерах, которым "более чем полгода, скорее всего, они будут работать нормально. Наиболее свежую версию профаммы ASTRA можно найти на сайте компании http :// www . sysinfolab . com /. Здесь можно ознакомиться со списком всех нововведений, которые "постигли" любую из версий.

Среди программ, работающих в среде Windows , наиболее известна профам- ма SiSoft Sandra ( System Analyzer , Diagnostic and Reporting Assistant ), которую можно найти на интернет-сайте http :// www . sisoftware . co . uk /. Более или ме нее интерфейс профаммы напоминает стандартную панель управления опе рационной системы. Все основные разделы здесь представлены в виде ико нок с соответствующим изображением (например, материнской платы). Чтобы получить информацию об устройстве, следует выбрать нужный раздел и двойным щелчком левой кнопки мыши открыть его.

Неплохой является также профамма под названием HWiNFO 32, которую вы можете найти на интернет-сайте http :// www . hwinfo . com /. Основное окно разделено на две половины, в одной из которых содержится древовидный каталог устройств, а в другой отображается системная информация. Надо признать, что такая организация рабочего пространства является наиболее удобной: быстрый доступ к информации совмещен с наглядностью и простотой. Категория специализированных диагностических программ более многочисленная, возможно, потому что такую программу написать несколько проще, чем предыдущей категории. Наиболее важными компонентами являются оперативная память, жесткий диск, видеоплата и центральный процессор. Перечисление проводилось в том порядке, в котором наиболее часто встре чаются сбои по вине "железа".

Профаммы подобного рода очень часто работают под управлением операци онной системы MS - DOS , т. к. она для своей работы требует очень мало сис темных ресурсов, что позволяет свести к минимуму влияние на результаты тестов. Обычно при запуске файла, при попытке скачивания его из Интерне та, предлагается создать зафузочную дискету. От вас при этом требуется, как минимум, умение переключения в BIOS последовательности зафузки (следует указать флоппи-дисковод) и минимального уровня знаний работы в среде MS - DOS , чтобы можно было запустить профамму на исполнение.

Для тестирования оперативной памяти можно использовать следующие профаммы:

  • MemTech -86. Наиболее современная версия этой профаммы может работать с объемом оперативной памяти до 2 Гбайт. Официальный сайт ее производителя находится по адресу http :// www . memtest 86. com /;
  • GoldMemory . Наиболее свежую версию можно найти в Интернете по адресу http :// www . goldmemory . cz /;
  • DocMem . Наиболее свежую версию можно найти в Интернете по адресу http :// www . simmtester . com / или http :// www . docmemory . com /;
  • MemTech . В отличие от предыдущих вариантов, эта профамма работает под управлением операционной системы Windows . Найти свежую версию программы можно по адресу в Интернете http :// www . hcidesign .com / memtest .

Практически всегда для тестирования жесткого диска вполне достаточно применить соответствующий модуль комплексной профаммы SiSoft Sandra , хотя существует и ряд специализированных программ, позволяющих определить не только скорость его работы, но и проверить на наличие сбойных секторов. Это такие программы, как:

  • Drive Fitness Test или IBM Feature Tools , предназначенные для жестких дисков IBM ( Hitachi );
  • PowerMax — для жестких дисков производства Maxtor ;
  • Quantum Data Protection System или DiskGo! — для жестких дисков Quantum;
  • SeaTools Disk Diagnostic — для жестких дисков Seagate и т . д .

Практически, все, подобные этим, программы можно найти на официаль ных сайтах производителей накопителей.

Для работы с центральным процессором существует множество различных профамм, но большая их часть предназначена не столько для тестирования, сколько для определения типа ядра, номера степпинга, объема кэш-памяти и нахождения аналогичной информации. Наиболее популярны сегодня сле дующие программы (рядом указаны адреса, по которым их можно найти в Интернете):

  • WCPUID http :// www . h - oda . com /
  • SysID http :// www . sysid . subnet . dk /
  • CPU - Z http :// www . cpuid . com /
  • CPUInfo http://www.pcanalyser.de/ П Hot CPU Tester Pro http://www.opusware.net/
  • CPU Stability Test http://www.vtoy.fi/
  • CPU Burn 4 ftp://ftp.scn.ru/pub/ftp/tests/stress/

Для простейшего тестирования поверхности жесткого диска можно приме нять как стандартную программу Scan Disk , так и популярную утилиту Disk Doctor из не менее популярного пакета программ Norton SystemWorks . Более тщательный анализ состояния винчестера можно провести при по мощи любой программы, позволяющей считывать информацию из специ альной микросхемы (или со специальной области на диске), где сохраняют ся все наиболее важные параметры, динамика их изменения и прочая служебная информация. Наиболее универсальной среди множества про грамм, выполняющих данную функцию, является программа SMARTUDM . Диагностику эта программа, несмотря на то, что она рассчитана на работу в среде MS - DOS , может осуществлять даже в среде Windows , правда, только для жестких дисков, которые подключены вторым, третьим и т. д. и, жела тельно, к внешнему контроллеру.

Для проверки состояния видеоплаты, как правило, достаточно соответст вующего модуля из программы SiSoft Sandra и тестов, встроенных в драйве ры DirectX , но при особом желании можно устроить стресс-тестирование при помощи программы MadOnion 3 DMark , которая неплохо нагружает как саму видеоплату, так и процессор. Версия программы должна соответство вать установленной модели видеоплаты.

Существует большое количество программ, определяющих тактовую частоту видеопроцессора, памяти, установленной на видеоплате, а также ширину шины памяти и подобную информацию, но все они несут не более чем ин формационный характер.

Несмотря на столь высокое многообразие диагностических программ, впол не можно обойтись программой, которая входит в комплект любой опера ционной системы от Windows 95 до Windows XP . Это утилита Сведения о системе, которая позволяет получить подробную информацию об аппаратных или программных конфликтах, проверить системный реестр, драйвера DirectX , получить подробную информацию об установленных устройствах, версиях драйверов и многое другое.


Глава 5. Вы купили компьютер

  • Вы купили компьютер
  • Правильно ли собран ваш компьютер?
  • Что такое "brand name" и "noname"?.."


Вы купили компьютер

Итак, вы купили компьютер. Что с ним делать? Как правило, в голове ри суются очень радужные картины вроде того, что сразу будете играть на нем, печатать документы и "вытворять" другие не менее сложные вещи. Но не все так просто.


Правильно ли собран ваш компьютер ?

Первый вопрос, который сразу же возникает в ответ: "Как можно собрать компьютер неправильно, ведь он нормально работает?" Ответить можно лишь следующее: "Иногда небольшими изменениями в конструкции сис темного блока можно получить более высокую скорость работы тех же са мых компонентов, которые на ваш взгляд и так прекрасно работают". Да вайте разберемся, о чем же на самом деле идет речь.

Начнем с самого главного компонента любого компьютера — материнской платы. Наиболее важным моментом здесь является хорошее прилегание пла ты к стойкам, в противном случае вы будете время от времени или постоян но слышать дребезжание. Не менее важной является установка достаточного количества стоек, чтобы плата не прогибалась, например, при подключении устройств IDE к встроенному контроллеру или при установке модулей оперативной памяти. К тому же, постоянные вибрации не могут не оказать от рицательного влияния на качество соединения в разъемах слотов расшире ния, что может не только уменьшить производительность из-за регулярных ошибок при передаче данных, но и вообще привести к выходу из строя компонентов компьютера.

Внимательно изучите инструкцию к материнской плате, особое внимание обратите на наличие различных переключателей (так называемых DIP ) и перемычек ( Jumper ). Иногда некоторые функции, например возможность включения компьютера при помощи клавиши < POWER > на клавиатуре, остаются отключенными.

Последний шаг проверки — запуск программы CMOS Setup Utility , позво ляющей как включить/отключить различные встроенные в материнскую плату устройства, так и изменить режимы их работы. Как показала практи ка, часто все настройки находятся в состоянии, установленном заводом- изготовителем как самые безопасные. То есть в таком состоянии компьютер будет работать нормально, но максимальной скорости работы от него, ско рее всего, не удастся добиться. При помощи клавиш управления курсором вы можете выбрать пункт с названием, например, Load Optimized Default и клавишей < ENTER > включить оптимальные настройки материнской платы. Более тщательная настройка потребует от вас некоторой квалификации, но дело можно значительно упростить, прочитав книгу "Секреты BIOS ", где описано очень большое количество разных параметров, влияющих на скорость и стабильность работы компонентов ПК. Эта книга выпущена в 2002 году изда тельством "БХВ-Петербург".

Следующим компонентом является центральный процессор. Наиболее важ ным здесь является рабочая температура и скорость вращения охлаждаю щего его вентилятора. Для контроля температуры следует установить спе циализированную программу, о которых шла речь в главе 1. Нормальной рабочей температурой можно считать диапазон от 35 до 50°С, более высокая температура крайне нежелательна, т. к. это часто является причиной сниже ния общей производительности ПК, а также уменьшения срока службы как процессора, так и материнской платы. Обязательно проверьте частоту системной шины и напряжение питания ядра процессора: они должны соответ ствовать номинальным параметрам для данной модели процессора.

Уменьшение рабочей температуры центрального процессора достигается установкой более дорогого кулера, который обладает большей поверхностью рассеивания тепла, а также более эффективным вентилятором. При этом следует учитывать, что второй фактор не означает, что скорость вращения вентилятора должна быть как можно большей. Наиболее оптималь ной скоростью вращения вентилятора можно считать скорость от 4500 до 5400 об/мин. Более скоростные вентиляторы издают при своей работе слишком много шума. Для уменьшения температуры иногда стоит поменять термопасту и отполировать нижнюю поверхность радиатора. Уменьшить уровень шума, издаваемый вентилятором, можно, более плотно прикрутив крепежные винты.

Модули оперативной памяти должны быть установлены, начиная со слота, имеющего название DIMM 1 или DIMM 0, т. е. с первого. Установка модуля, например во второй слот при пустом первом, на некоторых материнских платах может вызвать серьезные сбои в работе компьютера. Обязательно проверьте рабочую частоту модулей памяти, потому что по умолчанию в BIOS очень часто установлена частота 100 МГц, что при использовании модулей, рассчитанных на частоту 133 МГц, является добровольным умень шением общей производительности компьютера.

Любая современная видеоплата выделяет большое количество тепла, поэто му при установке нескольких плат расширения следует придерживаться

негласного правила: слот, находящийся непосредственно под видеоплатой, лучше оставлять незанятым, т. к. такой подход улучшает тепловой режим последней. Обязательно проверьте, все ли режимы, которые поддерживают ся видеоплатой, включены в BIOS , например, поддержка стандарта 4Х, Fast Write и т. п.

Все устройства, устанавливаемые в отсеки для накопителей компьютерного корпуса, должны быть закреплены не менее, чем на четыре винта (по два с каждой стороны), что позволит избежать вибрации при их работе. Осо бенно это важно для скоростных приводов CD - ROM , которые лучше всего закреплять на восемь винтов.

К встроенному контроллеру IDE подключать устройства лучше всего в сле дующей последовательности:

  • если в системе имеется один жесткий диск, то он должен быть подключен к первому каналу IDE в качестве master -устройства. Другие устройст ва, такие как приводы CD - ROM , Iomega ZIP и т. п., следует подключать ко второму каналу IDE , по возможности в качестве master -устройства;
  • если в системе имеются два жестких диска, лучше всего подключить их к разным каналам контроллера IDE в качестве master -устройства. Любые другие устройства следует подключать, по возможности, только ко вто рому каналу контроллера IDE в качестве slave -устройства;
  • если в системе имеются два жестких диска и два привода CD - ROM , тогда первые лучше всего подключить к первому каналу контроллера IDE (загру зочный диск в качестве master -устройства), а приводы ко второму каналу.

Привод для проигрывания компакт-дисков обязательно должен быть соединен со звуковой платой специальным кабелем, который позволяет проигры вать "обычные" аудиодиски через звуковую плату. Конечно, современные операционные системы позволяют использовать так называемое цифровое воспроизведение, позволяющее проигрывать компакт-диски через информационный шлейф IDE , но использование такого "шнурка" практически стало стандартом сборки.

Все соединительные кабели внутри системного блока должны иметь минимальную длину. Это, во-первых, уменьшает уровень электромагнитного из лучения, во-вторых, упрощает циркуляцию воздуха внутри системного бло ка, что положительно влияет на температурный режим всех компонентов компьютера.


Что такое "brand name" и "noname"?

Очень часто, как от продавцов, так и от самих пользователей (покупателей), можно услышать термины " noname " или " brand name ", которые применяют ся по отношению к отдельным компонентам компьютера. Оба этих термина имеют прямое отношение к производителям.

" Noname " — эту фразу можно перевести как "без имени". Производитель, который имеет подобную характеристику, как правило, имеет название на самом деле никому не известное. Например, о чем вам говорит марка мони тора Hansol ? Бытует мнение, что производители " noname " часто "грешат" низким качеством продукции, зато эта продукция имеет на порядок более низкую цену, чем продукция известных фирм.

" Brand Name " — эту фразу можно перевести как "фирменный знак", который обычно указывает на принадлежность продукции той или иной фирме. Бы тует мнение, что продукция производителей, входящих в класс " brand name " (это такие как ASUS , ABIT , Gigabyte и т. п.), имеет более высокое качество и на порядок более высокую цену, чем продукция менее известных произ водителей.

Откуда пошло мнение, что продукция известных фирм более качественная и работает с меньшими сбоями, чем продукция малоизвестных фирм? Давайте разберемся.

Начать, пожалуй, рассмотрение этого вопроса следует с того, что компьюте ры не зря называются IBM -совместимыми. В этом названии сразу же до пускается наличие в компонентах компьютера некоторой разницы, как в их устройстве, так и в процессе их работы. Единственно, чем все компоненты должны быть идентичны, так это тем результатом, который они выдают в результате различных операций — например, при выполнении определен ной программы. Чтобы выполнялось это условие, компоненты должны изготавливаться по единой технологии, что практически невозможно. Все мы наслышаны о законах, ревностно защищающих авторские права, ноу-хау и подобные вещи, позволяющие не только одним фирмам процветать, но и заставляющие все другие фирмы искать альтернативные подходы к реше нию проблемы. Вот здесь-то и зарыт первый камень. Наиболее полно все стандарты (спецификации) могут соблюсти только те компании, которые сами являются их разработчиками либо получили лицензию на производст во по разработанной кем-то технологии. Вполне естественно, что такими компаниями, как правило, являются наиболее крупные и известные корпо рации. Всем остальным остается или ждать, пока им продадут лицензию, а вместе с ней и подробное описание технологического процесса, или раз рабатывать самостоятельно, на свой страх и риск, собственные технологии производства. Профессиональный уровень специалистов, да и финансовые возможности, у последних поменьше, что не может не сказаться на качестве конечного продукта. Вывод прост: " noname ''-производители чаще (не путать с "часто") допускают погрешности в своей продукции, чем " brand name "-производители, что теоретически уменьшает ее совместимость с другими компонентами ПК, и особенно с " brand name ''-продукцией. Яркий при мер — модули оперативной памяти, точнее исполнение на них так называемого SPD -модуля, в котором хранятся наиболее важные их характеристики. Все эти данные оформляются таблицей. В модулях, произведенных малоизвестными фирмами, как правило, заполнены не все поля (подобную ин формацию можно получить при помощи программы SPD Tools ), что уже допускает возможность неправильной настройки материнской платы на этот модуль. Ситуация усугубляется тем, что раз "брэнды" сами четко соблюдают многие спецификации, этого же они требуют и от подключаемых устройств.

Второй не менее важный фактор — производители ключевых компонентов, таких как центральные процессоры, материнские платы, модули оператив ной памяти, обычно тестируют свою продукцию на совместимость с раз личными моделями устройств, но для тестирования, как правило, берутся только компоненты, произведенные наиболее известными компаниями, т. е. " brand name ". Менее известным компаниям (" noname ") остается только на деяться на то, что их продукция будет нормально работать, т. к. они, как правило, не способны содержать специальные испытательные лаборатории.

Существует еще несколько немаловажных факторов, влияющих на разницу в качестве продукции рассматриваемых категорий, но и приведенных выше вполне достаточно, чтобы понять причину столь единогласного мнения — продукция " brand name ", как правило, более качественная. Хотя позволю себе оговориться. Был случай, когда неплохая модель материнской платы производства ABIT упорно не хотела работать: то процессор неправильно оп ределяет, то зависает. И такое было с целым десятком (считайте с небольшой партией) материнских плат. Выводы делайте сами.


Глава 6. Питание компьютера и его компонентов

  • Стабильное питание — залог "здоровья" ПК
  • Качественный блок питания?
  • Как рассчитать реальную потребность в ваттах?
  • Компания AMD о блоках питания
  • Рекомендации по заземлению компьютера


Стабильное питание — залог " здоровья " ПК

Персональный компьютер, как и любое другое электронное устройство вро де того же телевизора или музыкального центра, получает энергию из электросети напряжением 220 В и частотой 50 Гц. Всем печально известно каче ство линий электроснабжения в нашей великой стране, именно поэтому проблема питания компьютера и отдельных его компонентов выделена в целую главу.

В электросети обычно встречаются следующие виды сбоев и неполадок:

  • отключение напряжения — может быть как кратковременным, например, из-за срабатывания автоматической защиты на подстанции, так и дли тельным, которое может возникнуть при серьезной аварии (молния, за мыкание) или при проведении плановых работ в целях профилактики;
  • "проседание" напряжения — чрезмерное понижение напряжения в элек
    тросети, например, из-за резкого увеличения нагрузки в доме или же
    в районе подстанции (возможно, на вашей улице кто-нибудь занимается
    сварочными работами). Такое также возможно при включении мощного
    электрочайника, кипятильника, лифта в подъезде и т. п.;
  • "скачок" напряжения — кратковременное увеличение напряжения в элек
    тросети, что может быть связано с резким уменьшением нагрузки, на
    пример, после того как остановился лифт в подъезде, отключился мощ
    ный электрочайник и т. п.;
  • высоковольтный импульс — сильное кратковременное увеличение на
    пряжения в электросети, которое может быть связано с грозовым разря
    дом (молнией) или же включением напряжения на подстанции после
    аварийного отключения. Кстати, обычно рекомендуют при аварийной
    ситуации все приборы отключать от розетки;
  • электромагнитные и радиопомехи — присутствуют в электросети практи чески постоянно, т. к. в нашем быту постоянно используется весьма ши рокий спектр разнообразных устройств от электробритвы до электро сварки, которые излучают в окружающее пространство не менее широкий спектр электромагнитных волн. При этом следует учитывать, что излучение передатчиков телевидения и радио "ловится" проводами электросети ничуть не хуже, чем антеннами приемников;
  • нестабильность частоты — обычно является следствием перегруженности энергосистемы населенного пункта (местной подстанции).

Как видите, неполадок в электросети может встретиться немало, поэтому для того, чтобы исключить возможность появления сбоев и неполадок при работе компьютера из-за некачественного (нестабильного) питания, прихо дится внимательно подходить к вопросу его подключения к электросети.

Наиболее распространенным мнением является то, что для защиты компью тера вполне достаточно подключить его к электросети через сетевой фильтр или, как его еще называют, "пилот". Но, к сожалению, это не более чем очередной миф.

Наиболее дорогие модели сетевых фильтров на самом деле имеют встроенные блоки, гасящие электромагнитные импульсы, исходящие от приборов вроде электробритвы, холодильника, что позволяет, например, уменьшить громкость щелчков в динамиках звуковых колонок в моменты включения/выключения холодильника. Также "пилот" может спасти от короткого замыкания, но от скачков напряжения ваш компьютер может спасти только источник бесперебойного питания.

При эксплуатации сетевого фильтра следует иметь в виду то, что подключе ние к нему сетевых розеток любых устройств обычно осуществляется со значительным усилием, т. к. только так можно гарантировать качество соединения. Наличие на нем общего выключателя вовсе не говорит о том, что все остальные устройства, включая и системный блок, не обязательно выключать.

Источник бесперебойного питания ( Uninterruptible Power Supply , UPS ) пред ставляет собой устройство, предназначенное для защиты компьютера от сбоев в электросети, вплоть до полного пропадания в ней электричества. Некоторые модели источников бесперебойного питания даже позволяют защитить компьютер от попадания молнии в линию электропередачи. Принцип работы этого устройства основан на наличии в нем аккумулято ров, от которых осуществляется питание в те моменты, когда в сети напряжение пониженное либо повышенное или, например, обнаружено серьезное изменение частоты переменного тока.

Наиболее важным параметром любого источника бесперебойного питания является мощность, которая измеряется в вольт-амперах. Чтобы выяснить реальную мощность в более привычной для нас единице измерения, в ваттах,следует умножить значение в вольт-амперах на коэффициент 0,65—0,7, что и даст в результате мощность, на которую он рассчитан. Большая часть источников бесперебойного питания рассчитана на работу без напряжения в электросети в течение 10—20 минут, в зависимости от нагрузки. Например, подключение 17-дюймового монитора вместо 15-дюймового, как правило, резко снижает количество времени работы от внутренних аккумуляторов.

Для подключения оборудования источники бесперебойного питания, как правило, оснащены стандартными разъемами, но из-за разнообразия стан дартов при выборе не помешает обратить внимание на совместимость имеющихся кабелей питания с выходными разъемами источника бесперебойного питания, в противном случае вам придется дополнительно приоб ретать различные переходники или другие кабели.

При эксплуатации источника бесперебойного питания следует иметь в виду, что к нему нельзя подключать мощные потребители энергии, такие как ла зерные принтеры или копиры ("ксероксы"), которые в некоторые моменты потребляют очень много энергии (в момент прогрева, например). Для этих целей многие производители UPS предусматривают специальные розетки, предназначенные для подключения именно таких устройств. При таком подключении источник бесперебойного питания обеспечивает только защи ту от перенапряжения и электромагнитных помех, что тоже является неплохой и вполне достаточной защитой как для лазерных принтеров, так и для копиров.

Наиболее дорогие модели обладают такой функцией, как "холодный старт". При этом имеется возможность включения компьютера при отсутствии на пряжения в сети электроснабжения.

Современные источники бесперебойного питания имеют возможность под ключения к системному блоку компьютера, что позволяет средствами опе рационной системы контролировать состояние внутренних аккумуляторов и в случае их разряда вовремя сохранить важные данные и отключить компь ютер. Эта функция предназначена для автоматического завершения работы компьютера, если, например, рядом никого нет, а заряд аккумуляторов практически исчерпан.

Обычно внутренние аккумуляторы источника бесперебойного питания рас считаны на работу в течение 3—8 лет, после чего требуется их замена.


Качественный блок питания ?

"Как, разве может быть блок питания некачественным?" — спросите вы. Да, бывает. Давайте разберемся в этом более подробно.

Проблема качественного электропитания настольных компьютеров возникла не так давно, но она уже успела стать практически основной причиной сбо ев и неполадок. Еще несколько лет назад блока питания на 200 Вт было вполне достаточно, чтобы не только питать основные компоненты компью тера, такие как процессор, жесткий диск и т. п., но и оставалось достаточно мощности для подключения еще нескольких жестких дисков, приводов CD - RW и т. п.

Первым шагом к сегодняшней ситуации было принятие нового стандарта питания — АТХ, который применялся для процессоров Intel Pentium II . Причин нововведению было несколько. Во-первых, блок питания стандарта AT без серьезной переделки не был способен выдавать достаточно большой ток на разъемы питания материнской платы, что было исправлено в стан дарте АТХ. Во-вторых, выросла номинальная мощность блоков питания до 230-250 Вт.

С приходом на рынок процессоров Intel Pentium 4 блоки питания вновь ис пытали на себе очередное нововведение, т. к. был принят новый стандарт питания АТХ v 2.03, который предполагал вывод питания центрального про цессора на отдельный разъем. Это была опять-таки вынужденная мера, т. к. со старыми блоками питания на шину +12 В подавался такой суммарный ток, что очень даже просто вызывало искрение, нагрев контактов и, в конце концов, выход из строя материнской платы.

Компания AMD до сих пор не поддалась такому искушению и не стала применять в материнских платах для своих процессоров дополнительные разъемы питания. Вот только не известно, к чему это приведет, ведь новей шее ядро для процессоров Athlon XP под названием Barton по вполне офи циальным заявлениям требует очень большого тока по шине питания (до 45 А). Да и применяемые сегодня процессоры на более старых ядрах Thoroughbred и Palomino требуют немалой мощности блока питания, что породило мнение (кстати, вполне оправданное), что процессоры от AMD более критичны к качеству питания, чем процессоры от Intel .

Из всего вышесказанного можно сделать вывод о том, что, например, для новейшей модели процессора Pentium 4 блок питания от компьютера на базе процессора Pentium II явно не подойдет в первую очередь из-за отсутст вия дополнительного разъема. Это уже повод, чтобы считать данный блок питания некачественным.

Но и это еще не все. В последнее время несколько изменился подход к обо значению мощности блоков питания для системных блоков. Если раньше на них указывалась реальная рабочая мощность, то сегодня в обозначении фи гурирует только ее пиковое значение, которое может быть достигнуто толь ко на короткий промежуток времени, например, при включении компьюте ра. Во время же работы этот показатель обычно ниже указанного, что вынуждает приобретать блок питания с "запасом" мощности.

Существует несколько способов определить качество (читайте: стабильность работы) блока питания в системном блоке.

Наиболее простой способ. Установите программу мониторинга за состоянием таких параметров, как напряжения питания, скорость вращения вентиля торов, температура. Такую программу вы, скорее всего, сможете найти на компакт-диске с драйверами для материнской платы. Она может иметь на звание Winbond HWDoctor , Hardware Doctor и т. п. Запишите показания всех напряжений питания, особенно относящихся к материнской плате (это, например, -12 В), после чего запустите игру вроде Quake 3 или подобную ей. По истечении, например, 2—3 часов игры закройте все программы и заново просмотрите значения всех напряжений. Если значения заметно изменились, то это означает, что ваш блок питания склонен к изменению своих характеристик по истечении определенного времени, например, из-за пе регрева компонентов, чего не должно быть в принципе при нормальном ка честве радиаторов и вентилятора.

Второй способ более сложен, к тому же он требует вмешательства в устройство ПК и наличие еще одного жесткого диска (желательно со скоростью вращения шпинделя 7200 об/мин). Как и в первом случае, от вас требуется установить программу и также записать значения всех напряжений. Затем следует подключить еще один жесткий диск, после чего повторить замеры. Если разница между результатами замеров очень большая (в несколько десятых вольта), тогда блок питания имеет реальную мощность, ненамного превышающую текущее потребление, и подключение дополнительных уст ройств может привести к появлению признаков нестабильной работы.

При покупке отдельного блока питания, когда имеется возможность внима тельно рассмотреть его внутренности пусть даже в щелевые отверстия, сле дует иметь в виду, что:

  • качественный блок питания, особенно если речь идет о блоке питания мощностью 300 Вт, должен иметь вес не менее 2 кг, что свидетельствует об установке внутри него достаточно качественного трансформатора, ко торый не должен быть слишком маленьким, а также и других компонен тов: радиаторов, конденсаторов, резисторов и других элементов;
  • производители, пытаясь удешевить производство блоков питания, стара ются как можно больше сэкономить в первую очередь на элементах, при званных фильтровать пульсации, поэтому в "подделке" можно найти пус тующие места, где вместо детали вообще ничего не установлено, хотя и имеется надпись, сигнализирующая о типе установленного элемента, на пример, конденсатора;
  • блок питания, помимо своей основной функции, играет роль своеобраз ной "вытяжки". При помощи вентилятора, установленного в блоке пита ния, теплый воздух из корпуса вытягивается наружу, причем параллельно этому внутрь втягивается более холодный воздух. Качественные блоки питания должны иметь щелевые отверстия со стороны, обращенной к месту установки центрального процессора, способствующие лучшей циркуляции воздуха.


Как рассчитать реальную потребность в ваттах ?

К сожалению, найти информацию о реальном потреблении компонентов компьютера практически невозможно, т. к. даже модули памяти различных производителей могут потреблять от 5 до 10 Вт. Такой разброс в параметрах еще больше усложняет выбор блока питания. Примерный расклад по по треблению компонентами персонального компьютера мощности может вы глядеть следующим образом:

  • центральный процессор потребляет в районе от 50 до 90 Вт. Здесь при менимо простое правило — чем выше тактовая частота процессора, тем выше мощность, потребляемая им;
  • материнская плата потребляет от 15 до 30 Вт. Реальная потребляемая мощность здесь зависит от того, есть ли на ней интегрированные устрой ства вроде RAID -контроллера, звуковой платы и т. п.;
  • модули оперативной памяти — от 5 до 10 Вт. Естественно, чем больше емкость модуля, тем больше он потребляет. К тому же, различные "на вески", вроде фильтрующих конденсаторов, также увеличивают потреб ляемую мощность; жесткий диск — от 7 до 30 Вт. Потребляемая мощность жесткого диска зависит от его текущего состояния — в моменты поиска файлов, когда головки "бегают" над поверхностью дисков или когда происходит копи рование очень большого количества мелких файлов, потребление при ближается к максимуму. То же самое происходит при включении компьютера, ведь жесткий диск при этом проходит диагностику, позволяющую выявить критические ошибки при его работе;
  • приводы CD - ROM , CD - RW , DVD - ROM - от 10 до 25 Вт. Потребление зависит как от максимальной скорости вращения дисков, так и от реаль ных режимов работы. При чтении плохих дисков, когда скорость враще ния постоянно меняется, привод потребляет намного больше, чем при чтении нормального диска. И еще один момент — так называемые "ком байны", совмещающие в себе и чтение DVD -дисков, и запись CD - RW , а также чтение обычных компакт-дисков, бьют все рекорды по потребле нию мощности;
  • дисковод для гибких дисков (флоппи-дисковод) — от 5 до 7 Вт. Здесь мощность, потребляемая дисководом, зависит в основном только от про изводителя, т. к. все они обладают вполне стандартной скоростью работы в любых режимах;
  • звуковая плата — от 5 до 10 Вт. Мощность, потребляемая звуковой пла той, напрямую зависит от класса — Hi - Fi платы потребляют на порядок больше, чем звуковые платы среднего класса;
  • вентилятор охлаждения — от I до 2 Вт. Расслабляться по поводу очень низкого потребления не стоит, т. к. количество вентиляторов в домашнем компьютере может достигать пяти и более. Например, один вентилятор на процессоре, один на видеоплате, один в блоке питания, один на жестком диске и один в качестве дополнительного;
  • порты ввода/вывода — от 8 до 10 Вт. Подобных портов на современном ПК можно насчитать целых пять: это два USB -порта, два СОМ-порта. один LPT . К тому же, если на материнской плате имеется интегрирован ная звуковая плата, к ним прибавляется GAME PORT (для джойстика), линейный вход/выход, да еще и микрофонный вход.

На основе этих данных можно хотя бы примерно вычислить реальную по требность вашего компьютера. Например, если на вашем ПК установ лен жесткий диск вроде Seagate Barracuda со скоростью вращения шпинделя 7200 оборотов в минуту, можно считать, что он потребляет в диапа зоне от 15 до 30 Вт. Даже в режиме холостого хода такой диск будет потреблять на порядок больше, чем аналогичный по объему диск, но со скоростью вращения шпинделя 5400 об/мин.


Компания AMD о блоках питания

В связи с установившейся инфраструктурой процессоров AMD и требованиями по питанию процессоров AMD Athlon XP , компания AMD рекомен дует для удовлетворения требованиям широкого спектра конфигураций на стольных систем использовать стандартные промышленные блоки питания. Тем не менее, не все конфигурации требуют одинаковой поддержки по на пряжению питания. OEM -производители, системные интеграторы и конеч ные пользователи должны выбрать такой источник питания, который адек ватно удовлетворяет требованиям по питанию системы определенной конфигурации со всеми использованными в системе компонентами.

В компьютерах на базе процессора AMD Athlon XP используются блоки пи тания со спецификацией ATX / ATX 12 V .

Некоторые конструктивные нормы, которым обязательно должны удовле творять блоки питания стандарта ATX / ATX 12 V :

  • электрические характеристики (типичные требования по мощности, тре бования по синхронизации, эффективность, защита выходного напряже ния и т. д);
  • механические характеристики (физические размеры, движение потоков воздуха);
  • электромагнитная совместимость;
  • надежность и безопасность.

В системах на базе AMD Athlon XP и AMD Duron обычно используются стандартные источники питания ATX / ATX 12 V . OEM -компании могут применять существующие источники питания тех же спецификаций, но не ограни чиваться традиционным исполнением. При создании систем поставщики обычно стремятся использовать источники питания, имеющиеся в наличии на складе. OEM -производители, системные интеграторы и конечные поль зователи должны определить требования к питанию, исходя из конфигура ции системы и режима ее использования. Главные параметры, которые нужно учитывать, — это стоимость, требования к питанию и размеры блока питания. Сборщики систем должны удостовериться, что данный источник питания удовлетворяет требованиям материнской платы. За более подроб ной информацией вам следует обратиться к конкретному ОЕМ-поставщику.

Компания AMD не берет на себя обязательств и не предоставляет каких- либо гарантий в отношении любых представленных здесь сведений о про дукции других фирм, категорически не признавая любые подразумеваемые гарантии рыночных качеств упомянутой продукции, ее пригодности к ис пользованию в конкретных целях, а равно и не нарушения чьих-либо свя занных с нею прав. Размещение здесь информации о той или иной продук ции не должно рассматриваться как ручательство за нее компании AMD .

Для любых компьютеров на базе процессоров AMD рекомендуются блоки
питания следующих производителей: "

  • Al Electronics — http://www.alelectronicsinc.com/;
  • AGI — интернет-сайта на момент написания книги не было;
  • АОреп — http :// www . aopen . com . tw /;
  • Allied — интернет-сайта на момент написания книги не было;
  • Amaquest — http://www.amaquest.com.tw/;
  • American Media Systems — http://www.american-media.com/;
  • Antec — http://www.antec-inc.com/;
  • Austin — интернет-сайта на момент написания книги не было;
  • Channel Well Technology — интернет-сайта на момент написания книги не было;
  • Codegen — http://www.codegenr.com/;
  • Dsep Electronics — http://www.deep.com.tw/;
  • Deer — интернет-сайта на момент написания книги не было;
  • Delta Electronics, Inc. — http://www.deltaca.com/;
  • D/napower USA — http://www.dynapowerusa.com/;
  • Eiiermax — http://www.enermax.com.tw/;
  • Enhance Electronics — http://www.enhanceusa.com/;
  • Enlight Corp. — http://www.enlightcorp.com/;
  • FSP Group — интернет-сайта на момент написания книги не было;
  • Fortron/Source — http://www.fortron-source.com/;
  • НЕС — http :// www . heroichi . com . tw /;
  • HIPRO — интернет-сайта на момент написания книги не было;
  • High Power — http://www.jdresearch.com/highpower/,
  • Huntkey — http://www.huntkey.com/;
  • Jou Jye — http://www.jj-computer.com/;
  • KeyMouse Electronics — интернет-сайта на момент написания книги не было;
  • Lite - On Electronics — интернет-сайта на момент написания книги не было;
  • Macron Power — интернет-сайта на момент написания книги не было;
  • Meridian — интернет-сайта на момент написания книги не было;
  • PC Power and Cooling — http://www.pcpowercooling.com/;
  • Sea Sonic Electronics — http://www.seasonic.com.tw/;
  • Seventeam — http://www.seventeam.com/;
  • Sinotech — http://www.sinotech.de/;
  • Skyhawk — http://www.skyhawkgroup.com/;
  • Sparkle Power Inc. — http://www.sparklepower.com/;
  • Super Power — http://www.superpower.com/;
  • TSP — http://www.winotek.com/;
  • TTGI — http://www.ttgiusa.com/;
  • Task International Inc. — http://www.task.com.tw/;
  • Topower — http://www.topower.com.tw/.

Если говорить о компьютерах на базе процессора Pentium 4/ Celeron , то для ; них обязательно требуется установка блока питания, поддерживающего спе цификацию ATX v 2.03 или, как ее еще называют, ATX 12 V , что указывает на наличие отдельного питания процессора.

Стоит также отметить, что существует, как минимум, три разновидности разъема для дополнительного питания — квадратный, а также два вида пря моугольных. Один из них похож на половинку разъема питания материн ской платы AT , другой похож на стандартный разъем питания устройства вроде жесткого диска.

Следует быть очень внимательным, т. к. наличие дополнительного разъема питания еще не говорит о принадлежности блока питания к стандарту ATX v 2.03, поэтому единственным средством защиты является покупка продукции известных фирм. Для примера можно ориентироваться на спи сок производителей блоков питания, которые сертифицированы для про дукции AMD . В частности, неплохо себя "ведут" те блоки, которые произведены всемирно известными компаниями Codegen или Enlight .


Рекомендации по заземлению компьютера

Немаловажным моментом при эксплуатации любой электроники является заземление металлического корпуса, что позволяет уменьшить вероятность поражения статикой внутренних компонентов компьютера и человека. Для персонального компьютера эта проблема не менее важна, чем, например, для радиоприемника.

Внимательно осмотрите кабель, который используется для подключения системного блока к электросети. Со стороны компьютера этот кабель имеет целых три контакта! Это означает, что изначально предусмотрена возможность заземления всего ПК, в то время как в розетках большинства жилых домов, а также в большей части офисных помещений, заземление отсутству ет. Чем это грозит? В таком случае между корпусом компьютера и, например, батареей отопления будет постоянно иметься напряжение где-то уров ня 110 В с ощутимым током. Краска по углам системного блока примерно через полгода эксплуатации практически перестает служить диэлектриком, поэтому при прикосновении одновременно к системному блоку и батарее вы будете ощущать весьма болезненный удар током. Если для вашего орга низма подобные "щелчки" проходят практически бесследно, то, например, для модема такое испытание может оказаться не "по плечу".

Обратите внимание, что на заземленную розетку рассчитаны все сетевые фильт ры ("пилоты"), причем они работают только в том случае, когда заземление реа лизовано, иначе любой фильтр будет работать обычным "удлинителем".

Категорически запрещается:

  • подключать заземление к нулевому контакту обычной двойной розетки. Если вы все-таки желаете рискнуть, то знайте, что в случае перегорания нулевого провода, что бывает не так уж и редко, вместо "нуля" на корпу се компьютера оперативно появится напряжение 220 В. Как известно, напряжение — это разность потенциалов. Это означает, что при прикос новении к системному блоку между вашим телом и корпусом компьютера возникнет разница потенциалов в 220 В, что вряд ли положительно скажется на вашем здоровье. А если вы еще случайно (в темноте) прикоснетесь к батарее отопления, обычно замкнутой на землю, то тогда вам действительно мало не покажется. Кроме того, никто не мешает "мест ному" электрику при очередном ремонте поменять местами "ноль" и "фазу", что, в принципе, никак не должно сказываться на работе обычных лампочек и других бытовых приборов;
  • подключать заземление к громоотводу, который, несмотря на свое зазем ление, обычно предназначен для других целей — в основном для отвода разряда молний на землю. Сразу представьте себе грозу, гром, молнии, яркую вспышку. Что при этом произойдет? Напряжение, наведенное на громоотводе, начнет "стекать" на землю, при этом оно будет попадать на все предметы, которые имеют контакт с ним, например, на компьютер. Представляете, какое это напряжение? В лучшем случае вы станете свидетелем очень зрелищного "фейерверка";
  • подключать заземление к газопроводу. Не положено!!! (без комментариев).

В любом случае, если вы не очень уверены в своих действиях, то не стоит заниматься экспериментами, потому что при этом цена становится слишком высокой: в первую очередь вы рискуете собственной жизнью, а уже потом дорогостоящим ПК.

Заземление можно организовать подручными средствами, закопав металлическое ведро примерно на метр во влажную землю и не забыв при этом тщательно подсоединить к нему провод, который в дальнейшем и будет служить заземлением.


Глава 7. Первое включение

  • Установка компьютера на рабочем месте
  • Подключение соединительных кабелей и кабеля питания
  • Первое включение
  • Первое выключение


Установка компьютера на рабочем месте

Итак, вы привезли компьютер домой, все соединительные кабели отсоединены, вы не знаете, что со всем этим делать и в бессилии. Давайте же выясним, как лучше всего разместить все купленное оборудование в комнате, чтобы было удобно работать и, главное, чтобы оно никому не мешало.

Самое первое, что вы должны сделать, распаковав все устройства, — осмотреть их на предмет наличия механических повреждений. Так же обязательно следует проверить полноту комплектов всех соединительных кабелей и правильность заполнения всех документов, особенно гарантийных талонов. Очень важным моментом является то, что всю упаковочную тару, вплоть до пластиковых пакетов и "скруток", лучше всего хранить в течение всего гарантийного срока. Это необходимо, например, на случай транспортировки для осуществления гарантийного ремонта или модернизации.

Самое главное условие — компьютер и дополнительные устройства никак не должны вам мешать перемещению по комнате, поэтому наилучшим размещением будет угол где-нибудь рядом с розеткой электропитания. В этом случае кабели питания не будут видны, т. к. их можно будет спрятать за столом.

Лучше, конечно, когда для установки компьютера используется специаль ный стол, в котором обязательно имеется специальная ниша для установки системного блока и выдвигающаяся доска, на которой обычно устанавлива ется клавиатура (часто вместе с мышью), что позволяет задвигать их под столешницу, когда они не нужны, а стол используется как обычный письменный. Такой подход позволяет организовать полнофункциональное место для ученика, студента. Если говорить о бытовых вещах, то за таким столом вполне безопасно можно даже пить кофе, не боясь, что случайно прольете его на клавиатуру.

Очень важно, чтобы и системный блок, и монитор, и дополнительные уст ройства не находились вблизи от отопительных приборов, а также труб цен трального отопления, потому что это может вызвать их перегрев и выход из строя. Особенно внимательно к этому вопросу следует относиться при покупке компьютера в теплое время года. Следует предусмотреть заранее, где обычно устанавливаются обогреватели и т. п.

При размещении монитора следует учитывать, что его верхний край должен быть на уровне глаз или чуть ниже, оптимальное расстояние от глаз до экрана 60—70 см, но не менее 50 см. Нежелательно, чтобы напротив экрана было окно, иначе при работе с монитором будут быстро уставать глаза. Ни в коем случае не устанавливайте рядом с монитором источник беспере бойного питания — изображение будет очень сильно дрожать из-за наводок его электронной схемы.


Подключение соединительных кабелей и кабеля питания

Первая проблема, с которой обычно сталкиваются пользователи, — это необходимость включения одновременно трех и более устройств, что требует применения "пилота" (сетевого фильтра), играющего по совместительству роль "тройника" и удлинителя. Такой подход позволяет подключить одно временно до пяти устройств, к тому же все сетевые фильтры имеют розетки, полностью совместимые с разъемами питания всех устройств, относящихся к компьютеру, — монитора, системного блока, принтера или сканера. Чего не скажешь про квартирные розетки, которые очень часто оказываются несовместимыми с достаточно толстыми контактами кабеля питания компью тера. В случае подключения устройств посредством "пилота" вам остается заменить только одну розетку.

Соединительные кабели к системному блоку следует подключать снизу вверх, т. е. сначала, например, подключается монитор, затем внешний мо дем (к СОМ-порту), следом устройства USB и в последнюю очередь клавиа тура и мышь. В принципе, эта последовательность является не более чем рекомендацией, поэтому подключение, например, сначала клавиатуры, а затем уже монитора, не будет являться ошибкой. Разъем питания лучше всего подключать в последнюю очередь. Это предотвратит случайное вклю чение компьютера.

Питание монитора можно подключить к системному блоку при помощи кабеля, который часто называют "папа-мама", к источнику бесперебойного питания таким же кабелем или к сетевому фильтру, для чего используется кабель, входящий в комплект любого монитора. Первый способ подключе ния позволяет "сэкономить" розетку для подключения дополнительных уст ройств, но требует наличия соответствующего разъема на блоке питания.


Первое включение

Первое включение компьютера следует производить только в том случае, когда вы уверены в том, что все соединительные кабели подключены правильно и питание для компьютера обеспечено. Под последним следует по нимать надежное подключение к электросети, гарантирующее защиту от самопроизвольного выпадения сетевой вилки.

При первом включении можно пока не включать и не проверять такие уст ройства, как принтер или сканер, т. к. вы еще не проверили работу основ ных компонентов.

В большинстве случаев последовательность включения может выглядеть следующим образом:

  • включите выключатель на сетевом фильтре, при этом он должен засве титься, как правило, красным цветом, что говорит о поступлении на него напряжения. Если индикатор не горит, проверьте напряжение в сети и качество подключения;
  • включите источник бесперебойного питания. При этом следует обратить особое внимание на состояние индикатора заряженности, если такой имеется. Отсутствие достаточного заряда встроенных аккумуляторов не позволит использовать такую функцию, как обеспечение напряжением в моменты перепадов напряжения в сети или в моменты полного отсут ствия напряжения. При наличии звуковых сигналов, говорящих о неис правности источника бесперебойного питания, его обязательно следует выключить до выяснения ситуации. Подробнее об этом можно прочитать в руководстве по эксплуатации;
  • включите монитор кнопкой на его передней панели, после чего надо по дождать несколько секунд. При отсутствии контакта с системным блоком на экран обычно выводится сообщение об отсутствии сигнала;
  • включите звуковые колонки;
  • включите системный блок.

Какие проблемы могут возникнуть при первом включении компьютера?

Наиболее неприятна ситуация, когда компьютер вообще не реагирует на нажатие кнопки питания. При этом следует проверить наличие и состояние выключателя на задней стенке системного блока (точнее на блоке питания). Такой выключатель есть не на всех блоках питания, поэтому при покупке компьютера сразу стоит выяснить этот вопрос. Также следует проверить каче ство подключения разъема питания как на системном блоке, так и в сетевой розетке. Если используется сетевой фильтр, стоит попробовать переключить вилку в другой разъем. Если компьютер все равно не включается, следует вос пользоваться возможностью гарантийного обслуживания, т. е. отвезти систем ный блок в сервис-центр компании, где вы купили компьютер.

При включении из системного блока обычно раздается короткий звуковой сигнал, который свидетельствует об удачном прохождении основных тестов оборудования и о начале загрузки компьютера. Если раздается целая комби нация сигналов и, тем более, если она повторяется, возникла какая-то неполадка. Более подробно об этом можно узнать из главы 2, посвященной ошибкам при загрузке компьютера.

На экране монитора последовательно появляются следующие сообщения, говорящие о том, что загрузка продолжается нормально:

  • информация об установленной в компьютере видеоплате. Часто это со общение появляется в верхней части экрана монитора примерно на одну секунду, что позволяет определить тип установленной видеоплаты и объ ем видеопамяти. Это указывает на начало тестирования всех установлен ных компонентов;
  • информация об установленном в компьютере центральном процессоре, объеме оперативной памяти, типе материнской платы (чипсета), версии BIOS и т. д. При выводе информации о процессоре указываются его тип (например, Athlon XP ) и тактовая частота (для процессоров Athlon XP может указываться как PR -рейтинг, так и реальная тактовая частота). При выводе объема оперативной памяти обычно используется система исчисления, принятая в области компьютерных технологий, т. е. 1 килобайт равен 1024 байтам, что может запутать Пользователя при под счете реального объема памяти. Так, например, при установке модуля 128 мегабайт на экране монитора отображается цифра 131072, а при уста новке 256 мегабайт — 262144 и т. д. Любая другая служебная информация в большинстве случаев не используется, поэтому ее можно не изучать;
  • все современные компьютеры при каждой загрузке автоматически опре деляют наличие устройств, таких как жесткие диски, приводы CD - ROM , DVD - ROM . Это отображается на экране монитора как сканирование уст ройств IDE;
  • в конце процесса тестирования выдается сводная таблица, где отображает ся вся основная информация о компьютере — наличие подключенных дисков, модулей памяти, тип процессора, состояние портов ввода/вывода. Прочитать эту таблицу можно после нажатия клавиши < PAUSE >, кото рая расположена в правой верхней части клавиатуры прямо над дополни тельными клавишами ( Insert , Home и т. д.);
  • после окончания процесса тестирования выводится стартовая надпись или же графическая заставка операционной системы.
Окончание загрузки операционной системы знаменуется появлением на экране так называемого рабочего стола. Только если вы думаете, что на этом загрузка закончена и можно приступать к работе, вы сильно ошибаетесь. Некоторые из установленных программ могут загружаться автоматически при каждом запуске компьютера, при этом они несколько замедляют процесс загрузки. Пример — антивирус Касперского ( AVP ).


Первое выключение

Как ни странно, компьютер нужно уметь не только правильно включать, но и выключать.

Интересно смотреть на пользователей, которые выключают компьютер, на пример, выдергиванием сетевого шнура из розетки или выключением сете вого фильтра. Все они в скором времени будут вынуждены воспользоваться гарантийным ремонтом своего "электронного друга", потому что компьютер следует выключать совершенно иначе.

Если вы работаете в среде Windows , то вам следует запомнить комбинацию, которая поможет вам правильно выключить компьютер независимо от версии операционной системы. Эта комбинация выглядит так — Пуск | Завершение работы | Выключение. После выполнения этих действий и нажатия кнопки ОК вам остается только ждать, когда специальный модуль операционной системы завершит все процессы и даст команду на выключение. Как только системный блок отключился, обязательно следует отключить все остальные устройства, например, общим выключателем на сетевом фильтре. Если выполняемая до этого программа "зависла", т. е. она не реагирует на команды, вводимые с клавиатуры, следует нажать кнопку POWER на системном блоке и удерживать ее в течение примерно шести секунд, после чего компьютер выключится. После такого выключения при первом же включении следует обязательно проверить жесткий диск программой Scan Disk , если, конечно, она не запустится автоматически.

Если вы работаете в среде MS - DOS , то вполне достаточно один раз нажать кнопкку POWER на системном блоке.

Если у вас имеется струйный принтер, то его лучше всего отключать специ альной кнопкой, расположенной на его внешней панели. Дело в том, что печатающая головка должна установиться в так называемое парковочное место, позволяющее избежать засыхания чернил в соплах головки, а делает она это только после нажатия кнопки питания именно на принтере. Звуко вые колонки иногда также рекомендуют отключать отдельно, т. к. при нажа тии выключателя на сетевом фильтре в динамиках могут раздаваться гром кие щелчки, иногда приводящие к повреждению усилителя. При использовании спящего режима следует иметь в виду, что после выхода из него операционная система пароль спрашивать не будет, т. к. считается, что вход в нее уже выполнен.


Глава 8. Установка операционной системы

  • Установка операционной системы
  • Разновидности операционных систем
  • Немного истории
  • Особенности семейства Windows 9x
  • Особенности семейства Windows NT
  • В чем состоит процесс установки операционной системы?
  • Подготовка к установке операционной системы
  • Процесс установки операционной системы
  • Автоматизация установки операционной системы
  • Обновление операционной системы
  • FAQ (ответы на часто задаваемые вопросы)


  • Установка операционной системы

Позвольте задать вам вопрос: "Часто ли вы слышали предложение переуста новить операционную систему, когда спрашивали кого-нибудь мало- мальски понимающего в настройке компьютеров о том, как можно изба виться от разнообразных сбоев в работе ПК?" Скорее всего, так вам говорил каждый второй. Откуда пошло такое довольно распространенное мнение, что с переустановкой Windows , а именно об этой операционной системе пойдет речь в данной главе, можно избавиться от проблем? Давайте попро буем разобраться.

Операционная система — комплекс программ, обеспечивающий целый ряд таких функций, как, например, распределение ресурсов компьютера между его компонентами или же ввод/вывод данных, управление этими данными, взаимодействие с пользователем и, наконец, выполнение других программ, расширяющих возможности операционной системы в частности и компьютера в целом. В состав любой операционной системы входят основной управляющий модуль (графическая оболочка в случае с Windows ) и набор программ (утилит), необходимых для нормальной работы компьютера.

Как уже говорилось ранее в главе 1, операционная система "страдает" рядом весьма характерных сбоев — это в основном сбои в файловой системе и системном реестре.

Первая категория как причина переустановки отпадает практически сразу же, потому что большая часть проблем с файловой системой решаются та кими программами, как ScanDisk , Norton Disk Doctor , без всякой переуста новки. Хотя из каждого правила существуют исключения — иногда постоянно появляющиеся ошибки можно устранить только путем полного форматирования, но такие ситуации не так уж часто встречаются, по крайней мере, с новыми винчестерами.

Вторая категория сбоев — это ошибки в системном реестре. Она требует к себе более внимательного подхода. Наиболее распространены следующие типы проблем:

  • наличие ссылок на несуществующие файлы. В принципе, данная раз новидность сбоев не столько опасна для стабильности работы ПК, как неприятна. В основном такие ссылки возникают по следующим причинам:
    • неполное удаление программ (в том числе игровых), когда файлы уже удалены, а ссылки на них по-прежнему остаются;
    • неполная установка программ (в том числе игровых), когда ссылки на файлы уже внесены в системный реестр, а сами файлы еще не созданы;
    • неполная установка или удаление драйверов устройств;
    • ошибки в файловой системе жесткого диска, когда ссылки указывают на файл, расположенный в совершенно другом каталоге. Подобная ситуация может появиться также в результате "ручного" перемещения файлов;
    • "остатки жизнедеятельности" программ установки или удаления, которые, как правило, создают временные ссылки, а затем "забывают" их удалять;
  • отсутствие необходимых ссылок на важные системные файлы, которые имеются на жестком диске, но из-за этого не могут быть использованы. Подобная ситуация может появиться также в результате "ручной" очистки системного реестра или в результате некорректной работы разнообразных "очистителей" реестра;
  • разнообразные ссылки, оставляемые trial -версиями программ, которые позволяют им при запуске определять, сколько времени осталось до кон ца испытательного срока. Очень часто такие ссылки в дальнейшем не по зволяют установить даже те версии программ, которые официально за регистрированы (куплены).

Конечно, существует ряд программ, якобы очищающих реестр от всех не правильных ссылок либо исправляющих их на верные (например, Norton WinDoctor ), но все они позволяют избавиться только от части проблемы, т. к. могут исправлять в основном те ошибки, которые связаны с изменением размещения файла или его отсутствием. Здесь же возможен вариант, когда программа путает нужный файл с похожим на него файлом, обладающим похо жими атрибутами, делая системный реестр полностью неработоспособным.

Из всего вышесказанного можно сделать вывод. Установка операционной системы может потребоваться в случаях, когда

  • на компьютере вообще не установлена операционная система;
  • на компьютере установлена операционная система, но вы хотите обновить ее версию или вернуться к предыдущей версии;
  • операционная система перестала загружаться, например, из-за повреждения системных файлов;
  • работа операционной системы больше стала напоминать езду на велосипеде со спущенным колесом;
  • не работает какая-либо программа, как вы считаете, из-за некорректной ссылки в системном реестре, которую вы не можете найти и удалить.


Разновидности операционных систем

Как уже говорилось в главе 5, операционная система является обычной программой, которая запускается при каждом старте компьютера. Заставка, которую вы видите, и рабочий стол, появляющийся по окончании загрузки, — все это часть установленной на ваш компьютер операционной системы. Очень много споров ведется вокруг того, какую операционную систему ус тановить, а какую вообще не стоит принимать во внимание. Попробуем ра зобраться, какие же из общепринятых мнений близки к истине. В настоящее время наиболее распространено целое семейство операцион ных систем Windows , которое является продуктом компании Microsoft . В свою очередь Windows -подобные системы подразделяются на два подсемейства: Windows 9 x и Windows NT .

К первому из них относятся Windows 95, Windows 98, Windows 98 SE и Windows ME , второе же имеет меньшее количество версий — Windows NT 4.0 (более младшие версии сейчас уже не используются), Windows 2000 и наиболее современная версия — Windows XP . Не так уж давно в свет вышла еще одна версия — Windows 2003 Server , но мы рассмат ривать ее пока не будем, ведь кто знает, сколько новых проблем несет она в себе? Подождем, пока ее тщательно протестируют, выпустят парочку по правок, так называемых "заплаток", а уже после этого будем пробовать уста навливать ее на домашний компьютер.


Немного истории

Если рассматривать всю историю операционных систем с графической обо лочкой, то семейство Windows берет свое начало от графической оболочки Windows 3.1 или ее сетевого варианта Windows 3.11 for Workgroup . Эта обо лочка загружалась в память компьютера подобно файловому менеджеру Norton Commander .

Появление графической операционной системы, а не оболочки ( Windows 95) было настоящим прорывом. Отныне морально устаревшая система MS - DOS является частью основной операционной системы, а не наоборот. Это главное отличие, которое было подмечено пользователями. Наиболее значимым последствием этого события стала необходимость использования программ, специально написанных для операционной системы Windows . Конечно, большую часть старых программ по-прежнему можно запускать в окне эму ляции MS - DOS , но некоторые из них, в частности те, которые предназна чены для работы с жестким диском ( NDD и т. п.), оказались несовместимы с особенностями файловой системы Windows .

Следует отметить, что существует две основных версии — Windows 95 и Windows 95 OSR 2, в которой наиболее яркой особенностью является под под держивать жесткие диски с объемом более 2 Гбайт. Если вы используете эту версию Windows , обязательно обновите ее до OSR 2, в противном случае любой жесткий диск вы сможете отформатировать только на 2 Гбайт, а остальное пространство будет недоступно для использования.

Следующим шагом в развитии операционных систем стало появление Windows 98, а за ней и Windows 98 SE ( Second Edition ). Стоит отметить, что вторая версия прилично отличается от "оригинальной" Windows 98, в первую очередь тем, что в ней исправлено немалое количество ошибок, особенно связанных с работой с локальной сетью. Да и драйверы для устройств в сумме с системой Plug and Play реализованы намного лучше, поэтому если вы вдруг захотите установить именно Windows 98, то вам следует выбирать второй выпуск, а не первый, т. е. Windows 98 SE .

Самой последней версией из семейства Windows 9 x является Windows ME , которую многие пользователи называют еще и Windows 2000, что совершен но не верно, хотя внешний вид обеих версий очень похож. На этой версии компания Microsoft все-таки решила поставить точку в жизни операцион ных систем семейства Windows 9 x .

Параллельно с разработкой все более новых версий Windows 9 x велись ис следования в направлении повышения надежности работы компьютера, которые, в конце концов, привели к появлению совершенно нового класса операционных систем — семейства Windows NT ( New Technology ). Первые версии Windows NT (наиболее популярными были версии 3.51 и 4.0, все остальные быстро "канули в лету") отличались более или менее высокой стабильностью работы за счет отсутствия как системы Plug and Play , так и под держки мультимедийных технологий, таких как драйверы DirectX . Все это весьма ограничивало их использование в качестве домашних систем, хотя в качестве рабочих станций они показали себя на высоте.

Первая попытка перевести домашние системы на семейство Windows NT проявилась в выпуске операционной системы Windows 2000, которая изна чально должна была стать Windows NT v 5.0, но, в конце концов, была пере именована. Больно уж пугала всех аббревиатура " NT ". В Windows 2000 раз работчики не только постарались учесть опыт создания NT -систем предыдущего поколения, сохранив все их традиционные достоинства, но и включили в нее много полезных наработок из привычной в своей доступно сти и простоте Windows 9 x , как бы сблизив эти две совершенно разные сис темы. Впервые платформа NT обрела совместимость со многими програм мами, которые по традиции предназначались только для Windows 9 x , правда, далеко не со всеми, но все-таки это был большой прогресс. Ни для кого не секрет, что, несмотря на все попытки "одомашнить" Windows 2000, с нею было немало проблем — игры отказывались устанавли ваться, в старых играх не было звука и многое другое. Поэтому компания Microsoft продолжила исследования, которые вылились в новой версии опе рационной системы Windows XP . На сегодня это наиболее совершенная система, когда-либо произведенная компанией Microsoft . Естественно, что и с ней также связано немало.нюансов в работе старых программ, но такова плата за прогресс.


Особенности семейства Windows 9 x

Никто не станет отрицать, что операционные системы семейства Windows 9 x самые популярные. В основном это связано с тем, что они позволяют использовать как самые новейшие программы, так и наиболее старые, которые были предназначены для работы еще в среде MS - DOS . Для пользователя в основном важны те программы, которые относятся к разряду игровых программ. Как говорится, обычно покупают компьютер совсем не для того, чтобы на нем работать, как говорят пользователи, а для того, чтобы играть на нем.

Наиболее ярким отличием семейства Windows 9 x от конкурирующей плат формы NT является крайне нестабильная работа. В основном это связано с особенностями тех модулей, которые занимаются распределением ресурсов между всеми работающими программами, т. е. обеспечением работы системы в режиме многозадачности. Здесь каждая запущенная программа самостоятельно решает, когда освободить ресурсы компьютера, чтобы какая-нибудь другая программа смогла их "захватить". Отсюда появляются частые "зависа ния", что, в общем-то, можно считать нормальным явлением. Представьте ситуацию: дается команда на чтение с компакт-диска, при этом приводу CD - ROM отсылается запрос на готовность диска к чтению. Если диск сильно поцарапан, то привод очень долго и безуспешно будет пытаться считать с диска служебную информацию, а в это время все остальные операции на компьютере будут блокированы, что фактически уже можно назвать "зависа нием". Нестабильность работы также в немалой степени связана с возможно стью запуска программ, предназначенных для работы в среде MS - DOS .

Windows 95

Операционная система Windows 95 отличается от всех остальных версий Windows

  • тем, что имеет самый маленький по объему дистрибутив, позволяющий устанавливать ее на диски небольшого объема, например, на старенький ноутбук;
  • самой маленькой базой драйверов, встроенных в дистрибутив, что прак тически сводит к нулю все преимущества системы Plug and Play , которая реализована в Windows 95 крайне плохо. Да это и понятно — "первый блин комом";
  • отсутствием поддержки популярной на сегодня шины USB . Хотя и существуют специальные обновления, включающие эту поддержку, но они, как показывает практика, далеко не всегда работают как положено;
  • плохо проработанным, хотя и быстро работающим интерфейсом;
  • практически полным прекращением поддержки со стороны компании
    Microsoft , что выражается в прекращении выпуска обновлений, вносящих
    поддержку новых устройств и стандартов.

Установка Windows 95 рекомендуется только на компьютерах конфигурации ниже, чем: Pentium 200 МГц, 32 Мбайт оперативной памяти, 1 Гбайт жест кий диск. На всех остальных (более мощных) конфигурациях, вплоть до самых современных, установка этой версии Windows является фактически добровольным отказом от преимуществ, даваемых более старшими и более функциональными версиями.

Windows 98

Операционная система Windows 98 отличается от всех остальных версий Windows :

П наиболее оптимальным соотношением "возможности — качество ". В ос новном это выражается в неплохой поддержке как наиболее новых, так и наиболее старых программ, устройств, стандартов (далвше дополните са ми). Именно поэтому эта версия Windows как применялась со времен первых Pentium , так и применяется до сих пор на компьютерах, собранных на базе Pentium 4 или Athlon XP ;

  • наличием огромного количества программ тонкой настройки, которые
    позволяют настроить компьютер практически под любого пользователя;
  • неплохо проработанным интерфейсом, который, правда, очень часто дает
    сбои.

Установка Windows 98 (имеется в виду версия 98 SE ) рекомендуется на компьютерах с конфигурацией: Pentium 200 МГц, оперативная память 32 Мбайт, жесткий диск 1 Гбайт и выше, вплоть до самых современных компьютеров. Хотя самые современные устройства позволяют полноценно использовать не которые свои функции только в более новых версиях Windows .

Windows ME

  • Windows ME является продолжением линейки Windows 95, 98, 98 SE , ника ких коренных изменений в ней, кроме интерфейса, нет. Для нее характерно следующее:
  • убрана поддержка реального режима MS - DOS , т. е. компьютер вы теперь
    уже не можете загрузить в режиме поддержки командной строки, хотя
    загрузочный диск, который создается средствами операционной системы,
    по-прежнему предлагает эту функцию;
  • впервые применена технология "отката" настроек, когда пользователь может без переустановки операционной системы вернуть старые на стройки программ;
  • наиболее полная база драйверов, встроенных в дистрибутив, из всей ли нейки Windows 9 x ;
  • отсутствует необходимость копирования дистрибутива на жесткий диск с целью организации быстрого доступа к нему, теперь операционная система при своей установке самостоятельно копирует его в строго опреде ленный каталог;
  • самый большой объем каталога Windows после установки, в основном из- за того, что в нем содержится весь дистрибутив. Это необходимо для нормальной работы системы "отката", которой, возможно, потребуется восстановить ряд системных файлов.

Стоит отметить, что финальной версией Windows ME является 4.90.3000.


Особенности семейства Windows NT

Основным отличием операционных систем Windows NT от систем предыдущей платформы является повышенная стабильность работы, что в основ ном связано с особенностями функционирования модулей, отвечающих за многозадачность. В платформе NT все запущенные программы получают строго фиксированное количество ресурсов, что не позволяет одной из них получить максимальный приоритет и заблокировать все остальные. Бла годаря этому появляется возможность в любой момент при необходимости принудительно завершить процесс, который на ваш взгляд работает некорректно.

Устойчивость платформы NT объясняется также еще и тем, что она полно стью 32-разрядная, т. е. в ней нет никакой MS - DOS , а все программы, предназначенные для работы в этой операционной среде, запускаются только лишь в окне эмуляции, не способном полностью предоставить возмож ности "чистой" MS - DOS . Любой прямой доступ к оборудованию, например к порту LPT , будет полностью заблокирован. В Windows NT также не запус тятся программы, которые обращаются напрямую к "железу", и те, которые используют VxD -драйверы, применяемые только в Windows 9 x .

В качестве "платы за прогресс" версии Windows NT плохо совместимы со всеми программами и устройствами, которые используют старые алгоритмы работы, такие как прямое обращение к портам ввода/вывода и т. п.

Операционные системы Windows NT намного лучше работают с оператив ной памятью, чем любая из операционных систем Windows 9 x . Наиболее существенно заметно увеличение производительности новых операционных систем на мощных компьютерах, особенно критичными параметрами являю тся тактовая частота центрального процессора и объем оперативной памяти. Единственный, но и самый неприятный для пользователя, недостаток Windows NT — это относительно медленные загрузка и завершение работы. Но хорошая стабильность работы вполне позволяет обойтись без переза грузки в течение рабочего дня, поэтому на этот недостаток можно и не обращать внимания.

Как ни странно сознавать, но компания Microsoft в своей операционной системе Windows NT с самого начала ее существования не реализовала сис темы Plug and Play , что сильно ограничивало ее применение, зато придавало изумительную стабильность работы. Поэтому применение операционных систем Windows NT v 4.0 и ниже обычно не рекомендуют для домашнего компьютера, т. к. это может привести к сложностям при установке драйве ров устройств.

Windows 2000

Основные особенности:

  • появилась поддержка системы Plug and Play , что в сумме с достаточно
    большой базой драйверов немало облегчило жизнь пользователя. Хотя
    здесь не обошлось, как всегда, без небольших нюансов — система авто
    матической настройки далеко не всегда правильно работает, что умень
    шает стабильность работы компьютера в целом и операционной системы
    в частности;
  • появилась поддержка мультимедийных драйверов DirectX v 7.0, что позво
    лило без особых препятствий использовать игровые программы, для
    работы которых они необходимы;
  • поддержка очень надежной файловой системы NTFS ( v 4.0 и 5.0), а также
    более распространенных файловых систем FAT 16 и FAT 32;
  • появилось разделение на несколько групп — Windows 2000 Professional,
    Server, Advanced Server и DataCenter. Финальная версия Windows 2000
    имеет номер 2195.

Устанавливать операционную систему Windows 2000 можно рекомендовать только в тех случаях, когда компьютер используется в качестве рабочей станции, например, сервера. Для домашнего компьютера эта версия Windows не подходит, хотя можно ее установить даже на игровой компью-гер, правда, при этом придется помучиться при установке игр.

Windows XP

Windows XP — это первая операционная система, максимально направлен ная на то, чтобы все пользователи перешли на использование систем семейства Windows NT . Ее основные особенности:

  • появилась возможность возвращения к прежним настройкам как про грамм, так и драйверов устройств, что позволяет пользователю во многих случаях обойтись без переустановки операционной системы, например, из-за плохой работы новой версии драйвера видеоплаты;
  • появилась возможность запуска программ в режиме совместимости прак тически с любой из предыдущих версий операционных систем, что уве личивает число тех программ, которые можно беспрепятственно исполь зовать. Естественно, что для операционной системы MS - DOS здесь места уже не нашлось и все программы, которые требуют "чистого" DOS ' a по- прежнему имеют проблемы с запуском;
  • появилась необходимость активизации, т. е. отныне недостаточно ввести серийный номер при установке операционной системы. При активиза ции Windows "привязывается" к определенной конфигурации компьюте ра, даже, например, при добавлении модуля памяти требуется повторная активизация (старый номер уже не подойдет). Хотя на каждое правило имеется свое исключение, т. к. в природе существуют так называемые корпоративные версии Windows XP , которые изначально не требуют никакой активизации. Остальные же версии, как уже стало традиционным, просто-напросто "ломаются". Стоит отметить, что русскоязычных корпо ративных версий в природе не существует со всеми вытекающими последствиями;
  • по традиции идет разделение на группы — Home Edition и Professional ,
    а также и Windows . NET . Последняя версия имеет три варианта :
    NET Server, NET Advanced Server, NET DataCenter Server. Естественно,
    что специализированные сетевые версии не предназначены для работы
    на домашних системах, поэтому мы их не будем рассматривать вообще.
    Финальная версия Windows XP имеет номер 2600.

Операционную систему Windows XP рекомендуется устанавливать на ком пьютер с конфигурацией не ниже, чем: Pentium II 500 МГц, 128 Мбайт опе ративной памяти и с жестким диском объема не менее, чем 10 Гбайт.


В чем состоит процесс установки операционной системы ?

Процесс установки операционной системы состоит из нескольких этапов:

  • копирование файлов, необходимых программе установки, на жесткий
    диск, что делается для обеспечения более быстрого доступа к ним, при
    этом файлы извлекаются из архивов дистрибутива;
  • автоматическое определение установленного оборудования;
  • копирование всех необходимых для работы компьютера файлов в рабо чий каталог (как правило, Windows ). После каждого этапа компьютер перезагружается.

Сразу стоит отметить, что "установка" и "переустановка" операционной сис темы — это совершенно разные вещи.

Под "установкой" следует понимать установку операционной системы на чистый диск или тот диск, на котором нет установленной системы. При этом все программы придется устанавливать заново, даже если программные файлы остались на жестком диске. Обычно к "чистой" установке прибегают в тех случаях, когда старая версия не загружается, загружается, но работает крайне нестабильно и т. п.

"Переустановка" операционной системы означает установку операционной системы "поверх" старой копии, когда старая версия не удаляется. При этом сохраняется системный реестр со всеми установленными программами, правда, при этом сохраняется также и большая часть проблем, связанных с неправильными ссылками. Исключение составляют операционные систе мы семейства Windows NT , которые не позволяют устанавливать новую ко пию "поверх" старой, затирая все старые системные файлы, что, в общем-то, является одним из условий стабильной работы.

В отдельной категории стоит вопрос обновления версии Windows , например, когда операционная система Windows 98 меняется на Windows ME или Win dows ХР. Здесь следует иметь в виду то, что обновлять можно только в сле дующем порядке:

  • Windows 95 на Windows 98, ME, 2000, ХР ;
  • Windows 98 на Windows ME, 2000, ХР ;
  • Windows ME на Windows 2000, ХР ;
  • Windows 2000 на Windows XP;
  • Windows NT v4.0 на Windows 2000, ХР .

Обратный порядок совершенно недопустим, т. е. при замене старшей вер сии на младшую версию следует удалить предыдущую копию, а уже затем устанавливать новую.


Подготовка к установке операционной системы

Прежде чем начать установку операционной системы, следует убедиться в наличии следующих дисков:

  • загрузочный диск, содержащий все те программы, которые необходимы для получения доступа к жесткому диску и приводу CD - ROM . Это может быть как флоппи-диск, так и компакт-диск, эмулирующий при загрузке наличие дисковода А:;
  • компакт-диск с дистрибутивом устанавливаемой операционной систе мы. Очень часто рекомендуется предварительно копировать дистрибутив на жесткий диск, а уже затем начинать инсталляцию. Такой способ удо бен по нескольким причинам:
    • во-первых, увеличивается скорость распаковки архивов;
    • во-вторых, устраняется возможность прекращения установки, напри мер, из-за царапины на компакт-диске;
    • в-третьих, в дальнейшем при установке новых компонентов операци онной системы больше не потребуется компакт-диск с дистрибутивом, т. к. путь к дистрибутиву всегда доступен, при этом система не будет задавать лишних вопросов.

Третий пункт недействителен для Windows ME , т. к. программа уста новки автоматически копирует весь дистрибутив на жесткий диск; диски с наиболее новыми драйверами таких устройств, как материнская плата, звуковая плата, видеоплата, модем, принтер, сканер и т. д. В принципе, подойдут и те драйверы, которые идут в комплекте с каж дым устройством, т. к. обновить их версию вы можете в любое удобное для вас время;

При установке операционной системы с жесткого диска следует иметь в виду, что программа установки обязательно создает копию дистрибутива на жестком диске, поэтому вам следует заранее побеспокоиться о на личии достаточного количества свободного места, [оследовательность подготовительных операций может выглядеть так. 1. Сразу после включения компьютера нажмите клавишу < Delete >, распо ложенную на дополнительной раскладке справа от основной алфавитно- цифровой клавиатуры. При этом будет запущена программа CMOS Setup Utility , которую еще называют BIOS Setup . Момент входа в эту програм му можно "отловить" по морганию трех индикаторов, имеющихся практически на любой клавиатуре, после чего клавиши на ней будут опрашиваться системой.

Здесь вам следует произвести следующие операции:

  • курсорными клавишами (<Т>, <1>, <-»>, <*->) выберите раздел, ко торый имеет название вроде Load Optimized Default , Load Turbo Defaults , Load Setup Defaults или похожее по смыслу. Нажмите клави шу < ENTER >, после запроса нажмите клавишу < Y >. После этого при каждом включении вашего компьютера все аппаратное обеспечение будет всегда работать в наиболее оптимальном режиме, т. е. в наибо лее скоростном, который возможен для данной модели устройства. Нажмите клавишу < F 10> для выхода из данной программы с сохранением всех изменений. При возникновении каких-либо сбоев в работе компьютера следует вернуться к стандартным установкам, выбрав в программе CMOS Setup Utility раздел Load BIOS Default или что- нибудь похожее по смыслу, например, Load Standard Default ;
  • после сохранения оптимальных параметров следует вновь запустить CMOS Setup Utility и установить последовательность загрузки при по мощи опции с названием вроде Boot Sequence : сначала CD - ROM , за тем Floppy Disk , а уже следом жесткий диск ( HDD или HDD 0). Это позволит вам в процессе подготовки к установке операционной системы на жесткий диск или же в процессе восстановления работоспособности загружаться с загрузочного компакт-диска или флоппи- диска. Сначала поиск загрузочного диска будет осуществляться в при воде CD - ROM , затем во флоппи-дисководе, а после этого уже будет осуществляться загрузка с жесткого диска (только в том случае, если на нем установлена операционная система);
  • теперь можно спокойно начинать подготовку жесткого диска к установке.

Бытует мнение, что при "чистой" установке операционной системы обязательно следует форматировать жесткий диск, что не совсем верно. Вполне достаточно для этого удалить каталоги Windows и Program Files , а также системные файлы из корневого каталога диска. При этом для ус корения процесса удаления можно воспользоваться программой SMARTDRIVE , которая находится в подлежащем удалению каталоге Windows (подкаталог COMMAND ). Обратите внимание,.что, в отличие от операционной системы Windows , в среде MS - DOS можно удалять файлы запущенных программ, что может привести к удалению нужных файлов.

При удалении каталога Windows имейте в виду, что вместе с ней будут удалены и все файлы (каталоги), находящиеся на рабочем столе, поэтому перед установкой следует их переместить в другой каталог.

!Если вы все-таки собираетесь форматировать жесткий диск, то вам луч ше всего воспользоваться быстрым форматированием, которое можно вызвать командой: format с: / q При этом совершенно не обязательно удалять имеющиеся разделы и соз давать на их месте новые — такой подход оправдан только в случае проблем с файловой системой жесткого диска или при необходимости изменить количество разделов.

Создание загрузочного диска

Несмотря на великий прогресс, постигший операционные системы Windows , как и в прежние времена, основой остается операционная система VIS - DOS , которая для неискушенного пользователя может показаться ка ленным топором по сравнению с бензопилой. Но ничего не поделаешь, ведь программа установки абсолютно для всех версий Windows запускается из командной строки MS - DOS . Единственный момент, который немного успокаивает, — так как MS - DOS появилась очень давно, то и раз личных программ, упрощающих работу с ней, имеется немало.

Если на компьютере уже установлена Windows 95/98, то можно воспользо ваться одним из нижеследующих способов загрузки компьютера в режиме MS - DOS .

  • При загрузке компьютера следует удерживать нажатой клавишу < CTRL >, при этом на экран монитора будет выведен список возможных вариантов загрузки. Вам следует выбрать пункт с названием Command Prompt Only . Не работает для Windows 95.
  • При появлении на экране монитора надписи вроде Starting Windows 98 следует нажать клавишу < F 8>. Также выберите пункт под названием Command Prompt Only.
  • В меню Завершение работы выберите Перезагрузить компьютер в режиме MS - DOS .

Наиболее же оптимальным вариантом остается использование загрузочного диска, который не только позволит загружать в память компьютера драйве ры для приводов CD - ROM , менеджеров расширенной памяти, русификато ров, но и загружать MS - DOS в случаях, когда на жестком диске, например, установлена операционная система Windows МЕ/2000/ХР или когда на дис ке нет даже созданных разделов.

Загрузочный диск — это диск (дискета), на котором записаны основные системные файлы, в простейшем случае это IO . SYS , MSDOS . SYS и C 0 MMAND . COM , которые, в свою очередь, позволяют запустить операци онную систему MS - DOS .

При запуске системы с загрузочного диска вы не увидите знакомого рабо чего стола, потому что загрузочные диски предназначены для подготовки к установке операционной системы и для восстановления информации.

Содержимое наиболее простого загрузочного диска может быть следующим:

вввввввввввввввввввввввввввввввввввввввввввввв

В файле AUTOEXEC . BAT также рекомендуется указать команду

a :\ smartdrv . exe 16384 16384

что позволит значительно ускорить доступ к жесткому диску. Естественно, что этот файл следует предварительно скопировать на дискету.

Создать загрузочную дискету в Windows 2000 можно следующим образом (согласно рекомендациям компании Microsoft ):

  • отформатируйте дискету. Следует отметить, что лучше всего применять полное форматирование, при котором поверхность дискеты проверяется на наличие так называемых bad -секторов (участков с поврежденной по верхностью);
  • скопируйте на дискету файл NTLDR с жесткого диска, дискеты, создан- ной в процессе установки Windows , или из дистрибутива. В последнем случае придется файл предварительно распаковать при помощи програм- мы EXPAND , которую вы сможете также найти в каталоге дистрибутива. Команда может выглядеть таким образом: EXPANDNTLDR ._ NTLDR (запакованный файл находится в каталоге с названием 1386);
  • скопируйте на дискету файл NTDETECT . COM . Его можно найти как в корневом диске с установленной Windows 2000, так и на диске с дистрибутивом в каталоге 1386;
  • создайте файл с именемBOOT . INI или скопируйте его с жесткого диска. В нем следует оставить только нижеследующие строки:
  • [boot loader] Timeout=30
  • Default= raulti(0)disk(0)rdisk(0)partition(1)\winnt [operating systems] multi(0)disk(0)rdisk(0(partition(1)\winnt="Windows NT"
  • Если вы используете дискиSCSI , тогда фразу multi ( O ) следует изменить на scsi ( O );
  • обязательно проверьте, загружается ли компьютер с созданной вами дис- кеты.

Особенности работы в режиме MS - DOS

Первая проблема, которая возникает при загрузке в режиме MS - DOS , — это отсутствие доступа к приводу CD - ROM , несмотря даже на то, что в BIOSон определяется верно, т. е. при выводе на экран монитора информации о под- ключенных устройствах IDE модель привода указывается правильно.

Для получения доступа к приводу CD - ROM следует загрузить в оперативную память компьютера специальную программу (драйвер), которая будет сохра- няться там до перезагрузки. Обычно при создании загрузочного диска этот драйвер автоматически записывается в файлы конфигурации, поэтому вам остается только лишь проверить его работу с вашим приводом CD - ROM .

Обойти эту проблему можно, заранее скопировав весь дистрибутив опера- ционной системы на жесткий диск, например, в каталог C DISTR . После загрузки в режиме MS - DOS вам будет достаточно зайти в этот каталог и за- пустить программу установки.

Этот способ имеет ряд преимуществ и недостатков перед установкой с ком- пакт-диска. Главное преимущество — в дальнейшем при установке каких- либо системных файлов операционная система больше не будет запраши- вать диск с дистрибутивом, т. к. в параметрах настройки уже будет записан каталог на жестком диске, куда надо обращаться. Главный недостаток — дистрибутив занимает на жестком диске немало свободного места, хотя в настоящее время, с распространением жестких дисков более 40 Гбайт, этот недостаток постепенно становится просто смешным.

Операционная система MS - DOS (по сравнению с Windows любой версии) имеет целый ряд весьма неприятных ограничений, которые препятствуют как нормальной работе в этой среде, так и периодически приводит, например, к порче имен файлов. Дело в том, что максимальная длина имени любого файла или каталога может иметь всего восемь символов, из-за чего название такого, например, каталога, как Program Files , отображается в MS - DOS как:

C :\ PROGRA ~1

Иногда найти нужный каталог в подобном "месиве" достаточно сложно.

Операционная система MS - DOS не может управлять оперативной памятью бо- лее чем 640 Кбайт. Для получения доступа ко всей имеющейся памяти необхо- димо загрузить менеджер расширенной памяти, например, HYMEM . SYS .

Для мало подготовленного пользователя работа в среде MS - DOS может по- казаться таким мучением, которое во сне-то не так уж часто снится, а здесь имеется в наличии. Но "не столь страшен черт, как его малюют". Да, конеч- но, операционная система MS - DOS очень сложна в использовании, для управления всеми происходящими в ней процессами имеется огромное ко- личество команд текстового формата, но на самом же деле для выполнения необходимых функций, которые могут потребоваться при подготовке к ус- тановке операционной системы, достаточно знать небольшой диапазон команд. Ниже вы найдете краткое описание этих команд.

  • dir— просмотр содержимого текущего каталога, при этом отображаются имена как файлов, так и каталогов. Вывод на экран названий, состоящих из кириллицы, возможен только после загрузки в память компьютера специального драйвера.
  • Если каталог является вложенным в другой каталог верхнего уровня, а не корневым, он содержит первые две особенные записи, где в поле имени находятся точки. Запись с одной точкой является ссылкой на текущий каталог, а запись с двумя точками — на каталог верхнего уровня, в кото- рый вложен текущий. Эти ссылки можно использовать в командах DOS в позициях, где требуется указание пути к файлу. Например, команда dir .. выведет на экран содержимое каталога верхнего уровня, хотя те- кущий каталог остается прежним.
  • Если при записи пути в командах DOS первым символом ставить обрат- ный слэш (наклонную черту вида "\"), то "отсчет" будет производиться не от текущего каталога, а от корневого. Например, команда c :\ windows \ > dir \ temp позволяет просмотреть содержимое каталога TEMP , хотя те- кущим по-прежнему останется каталог WINDOWS .
  • Анапогичного результата можно добиться, если воспользоваться ссылкой на каталог верхнего уровня (в данном случае он будет являться корневым): С:\ WINDOWS > DIR ..\ TEMP .
  • Описанные правила формирования пути к каталогам являются общими для DOS и могут использоваться в любых командах, требующих указания пути.
  • cd — изменение текущего каталога. Хотя обратиться к любому каталогу можно из любого текущего каталога с помощью способа, описанного ранее, это не всегда удобно.
  • Кроме того, некоторые программы требуют, чтобы при их выполнении текущим являлся вполне определенный каталог. Для изменения текущего каталога существует команда cd , за которой через пробел должен следовать путь к существующему каталогу на текущем диске. Это важно! Команда cd не может изменить текущий диск, но это можно сделать, набрав в приглашении DOS букву нужного диска и двоеточие и завершив набор нажатием клавиши < ENTER >, например: С:>А:.
  • Если после команды cd ввести:
    • две точки, т. е. . . — текущим каталогом станет корневой каталог;
    • три точки, т. е. ... — тогда по команде со будет происходить перемещение на один каталог вверх;
    • четыре точки — перемещение на два каталога вверх и т. д.
  • d/ rd — создание/удаление каталога. Чтобы создать пустой каталог, нуж но в ответ на приглашение DOS ввести команду md и через пробел указать имя нового каталога. Для удаления каталога можно воспользоваться командой rd с аналогичным синтаксисом. Удалить можно только пустой каталог.
  • copy — копирование файлов. Для того чтобы создать копию одного или нескольких файлов, нужно в ответ на приглашение MS - DOS ввести ко- манду copy , через пробел указать имя файла (или файлов, если использо- вать символы шаблона), который копируется, и еще через один пробел — путь, куда выполнять копирование. Формат команды:
    • С :\> COPY AUTOEXEC . ВАТ С :\ ТЕМР \ AUTOEXEC . OLD Имя файла состоит из восьми знаков: собственно имени и трех знаков расширения, которое обычно говорит о типе содержащейся в файле ин- формации. Такое имя файла можно использовать только в качестве ссылки на файлы, содержащиеся в текущем каталоге. Чтобы сослаться на файл, находящийся в другом каталоге или даже на другом диске, нужно записать его полное имя. Полное имя файла состоит из буквы диска с двоеточием, пути к каталогу и отделенного от него обратным слэшем имени файла, например: c :\ autoexec . bat — полное имя к файлу, при этом AUTOEXEC . BAT — имя файла, а c :\ путь к файлу.
  • Если нужно сослаться не на один файл, а на целую группу, можно при записи имени файла использовать символы шаблона "?" и "*". Символ "?" означает, что в данной позиции имени файла может находиться любой символ, а символ "*" означает любое количество любых символов. На- пример, *ЕХТ.ТХТ означает ссылку на все файлы с расширением ТХТ, начинающиеся с любой буквы, за которой следует ЕХТ: ТЕХТ.ТХТ, REXT . TXT , МЕХТ.ТХТ и т. д. А если написатьTEXT .*, то получится ссылка на абсолютно все файлы с именем TEXT и любым расширением: ТЕХТ.ТХТ, TEXT . DOC и т. д.
  • del — удаление файлов. Для удаления файла в ответ на приглашение DOS следует набрать команду del и через пробел указать имя удаляемого файла.
  • Например, c :\> del text .* — эта команда удалит все файлы TEXT с лю- бым возможным расширением.
  • date — вывод информации о дате с возможностью настройки. Пtime — вывод информации о времени с возможностью настройки. Пren — переименование файлов. Формат команды:
  • REN [ Оригинальное имя ] [ Имя файла после переименования ]
  • verify — проверка записи на диск. Значение on включает проверку, значение off выключает проверку записи на диск.
  • ver — вывод на экран версии операционной системы.
  • cls — очистка экрана. После ввода этой команды экран полностью очищается от всех ранее введенных команд и любой другой информации.
  • label — вывод информации о метке диска с возможностью изменения.

Подготовка жесткого диска

Следующий этап подготовки к установке операционной системы — это подготовка жесткого диска, которая включает в себя либо создание разделов на совершенно пустом диске, либо освобождение необходимого для установки пространства, а также удаление старой копии операционной системы (в случае "чистой" установки).

Перед использованием любой жесткий диск особым образом размечается. При этом на нем создается область, называемая разделом ( partitions ), которая в свою очередь размечается на определенное количество отдельных блоков, называемых кластерами. Размер (объем) отдельного кластера зависит от типа применяемой файловой системы и, в определенной степени, от используемой операционной системы.

На любом жестком диске может быть создано несколько разделов, каждый из которых в свою очередь может иметь выбранный вами размер (объем). Но при этом общий размер (объем) разделов не может превышать макси мальную емкость диска.

Каждый раздел по структуре полностью идентичен целому диску. Помимо этого на одном физическом диске может быть несколько разделов, отформатированных под совершенно разные файловые системы, например, FAT 32 и NTFS .

Исторически сложилось, что диск может быть разделен на четыре раздела, и только один из них может быть активным. Это означает, что только с этого раздела будет возможна загрузка операционной системы. Конечно, специ альными программами можно разбить диск на большее количество разде лов, но одновременно можно будет использовать только четыре из них.

Все современные операционные системы содержат встроенные средства разбиения дисков — это программа FDISK .

Файловая система не создается программой FDISK , для этого требуется обязательно форматирование, но она ставит в загрузочной записи ( MBR ) метку о типе системы (либо FAT 16 либо FAT 32). Следует помнить, что если при запуске программы вы откажетесь от поддержки больших дисков, в таком случае на диске будет создан раздел под FAT 16, которая не поддерживает дис ки более 2 Гбайт. Файловая система NTFS становится доступной после уста новки операционной системы Windows NT или во время установки.

При помощи программы FDISK можно создать только два раздела — Primary DOS Partition и Extended DOS Partition . Первый является обычным диском, а второй раздел является своеобразным "контейнером" для логиче ских дисков, которые размещаются в нем в виде подразделов, идентичных по структуре целому диску.

Программа FDISK может нормально работать только с разделами, создан ными для операционных систем Windows .

В отличие от программы FDISK , более совершенная программа Partition Magic может создавать, удалять и изменять размер разделов без уничтожения информации. Кроме того, она значительно превосходит другие программы по возможностям слияния нескольких разделов, преобразо вания разделов FAT 16 и FAT 32 в разделы NTFS и даже обратно, из NTFS в FAT 32.

Почему иногда рекомендуют создавать несколько логических дисков на од ном диске объемом более 40 Гб? Дело в том, что наиболее часто использу ются файлы, которые относятся к операционной системе и установленным программам. Работа с одним, но большим разделом постепенно приводит к тому, что они становятся разбросанными по всему диску между фильмами, музыкой и другими "массивными" файлами, что не может не сказаться на быстродействии компьютера. Использование двух разделов на жестком диске, также как и двух физически отдельных дисков, дает следующие пре имущества в дополнение к уже рассмотренному варианту:

  • вы можете на первом разделе (диске) хранить только саму операционную систему и программы, которые в любой момент можно установить с ди стрибутива, а на втором разделе (диске) ценную информацию, которую нельзя терять. Это в случае краха файловой системы несколько упростит восстановление, позволит акцентировать свое внимание только на наи более ценной информации;
  • большое количество вирусов могут работать только с первым попавшим ся разделом (диском), например, тот же WinCIH , что позволит в случае разрушения файловой системы сохранить ценную информацию в целости и сохранности.

Также следует отметить, что буквы дисков присваиваются системой автоматически при каждом включении компьютера, при этом соблюдается порядок подключения:

  • основному разделу всегда присваивается буква с. Если на вашем компьютере установлено несколько жестких дисков и каждый из них имеет ос новной раздел, основному разделу первого диска присваивается буква с, основному разделу второго диска - D и т. д.;
  • дополнительный раздел занимает место на диске, не занятое основным разделом. После создания дополнительного раздела требуется создать на нем логический диск, которому назначается буква диска, т. к. сам раздел буквы не имеет;
  • после того как всем основным дискам на физических дисках назначаются буквы, следующая по алфавиту буква назначается первому логическому диску первого дополнительного раздела, затем — второму логическому диску этого раздела и т. д.;
  • после того как буквы присвоены всем логическим дискам данного разде ла, система находит следующий доступный физический диск и на нем производит поиск логических дисков, для которых продолжает процесс назначения букв.

Если говорить достаточно простым языком, то после разметки на жестком диске появляются три области:

  • загрузочная область, в ней записываются системные файлы, позволяющие запускать операционную систему с этого диска. Физическое повреждение в данной области диска делает невозможным установку операционной системы, а то и вообще использование диска для хранения данных. Иногда подобные проблемы можно решить при помощи специализиро ванных программ, например тех, которые входят в комплект аппаратно-программного комплекса РС-3000, но обычному пользователю такие программы не доступны ни в финансовом плане, ни в плане удобства работы с ними, т. к. все они работают исключительно в среде MS - DOS ;
  • область, где размещается так называемая таблица размещения файлов ( FAT , File Allocation Table ), которая представляет собой список файлов, находящихся на диске вместе с данными об их физическом расположе нии. Нарушения в данной таблице, как правило, вызывают невозмож ность загрузки операционной системы, а также потерю файлов и ката логов. Большая часть компьютерных вирусов, которые призваны выполнять деструктивные функции, разрушают именно таблицу размещения файлов. Физическое повреждение в данной области диска делает невозможным использование диска как для установки операционной системы, так и для хранения информации. Логические повреждения (не правильные записи) в таблице размещения данных приводят к зависаниям и резкому замедлению работы компьютера, т. к. операционная система либо не может найти один или несколько системных файлов, либо постоянно занимается их поиском, что отнимает немалое количество ре сурсов центрального процессора;
  • область, где размещаются файлы пользователя. Занимает основную часть диска. Физическое повреждение в области данных может привести к потере информации, записанной в данном месте, но после проверки по верхности программой ScanDisk повреждения помечаются специальной меткой, что позволяет вполне безопасно использовать оставшееся место на диске. При этом на карте диска появляются так называемые bad - секторы. Иногда их можно скрыть при помощи специальных программ, позволяющих принудительно переназначать поврежденные секторы в ре зервные области, которые имеются на любом жестком диске.

После окончания разметки область, используемая для размещения информации, форматируется, при этом таблица размещения файлов "обнуляется" поверхность диска сканируется на наличие поврежденных областей ( bad - секторов):

  • при "быстром" форматировании осуществляется только "обнуление" FAT - таблицы без сканирования поверхности (команда format с: / q );
  • при "полном" форматировании осуществляется как "обнуление" таблицы размещения файлов, так и сканирование поверхности (команда format с:).

После форматирования жесткий диск доступен как для установки операци-нной системы, так и для хранения информации.

ели вы хотите установить операционную систему на портативном компьютере или, как их еще называют, ноутбуке, имейте в виду — у вас должна уть возможность загрузки либо с флоппи-дискеты, либо с компакт-диска, как после разметки диска компьютер следует перезагрузить (на самом жестком диске пока ничего нет, он даже не форматированный). Старые ноутбуки очень часто не позволяли этого делать, так что их владельцам приходилось после "неудачного" разбиения подключать винчестер через переходник к настольному компьютеру и уже только после форматирования и копирования на него дистрибутива продолжать установку операционной системы.


Процесс установки операционной системы

Сам процесс установки состоит из следующих этапов:

  • копирование файлов операционной системы на жесткий диск;
  • определение конфигурации компьютера при помощи системы автомати ческой настройки Plug and Play ;
  • первоначальная настройка всех программных модулей (драйверов уст ройств), входящих в состав устанавливаемой операционной системы. Данные о настройке берутся из специальных файлов, поставляемых с ди стрибутивом. В дальнейшем все настройки доступны пользователю для изменения;
  • после окончания первоначальной настройки осуществляется перезагрузка, после чего операционная система готова для использования.

Запуск программы установки может быть осуществлен несколькими спо собами:

  • операционные системы Windows 9 x имеют три варианта:
    • файл SETUP . EXE используется для запуска программы установки, если диск, на который планируется устанавливать операционную систему, уже размечен на разделы и отформатирован;
    • файл SETUPCOR используется при установке операционной системы поверх старой копии или при наличии проблем с использованием первого варианта;
    • файл OEMSETUP используется при установке операционной системы на еще не размеченный диск, при этом автоматически создается один раздел, после чего компьютер перезагружается и диск форматируется.
    • Все упомянутые файлы находятся в дистрибутиве операционной системы;
  • операционные системы Windows NT можно запустить следующими спо собами:
    • предварительно создать набор загрузочных дискет, после чего загрузиться с них. Для Windows 2000 потребуется четыре дискеты, а для Windows XP целых шесть дискет;
    • если компакт-диск с дистрибутивом является полной копией фирменного диска Microsoft , тогда он должен быть загрузочным, что сильно упрощает запуск программы установки; загрузиться с любого загрузочного диска и запустить файл WINNT . EXE , который располагается в подкаталоге 1386 дистрибутива. Естественно, что при загрузке в память компьютера должен быть за гружен драйвер привода CD - ROM ;
    • если на компьютере уже установлена одна из предыдущих версий Windows , тогда можно запустить файл SETUP . EXE , находящийся в корне каталога с дистрибутивом, или WINNT 32. EXE , находящийся в подка талоге 1386.

Следует иметь в виду, что если операционную систему планируется устанавли вать на диск, подключенный к внешнему контроллеру ( SCSI или IDE ), не за будьте заранее скопировать драйвер на дискету, т. к. программа установки мо жет неправильно определить устройство и установка окажется невозможной.

После установки операционной системы в корневом каталоге появляется целый набор файлов, необходимых для загрузки, поэтому их следует четко отличать от тех файлов, которые создаются пользовательскими программа ми. Для операционных систем Windows 2000/ XP это такие файлы, как: CMLDR , NTLDR , NTDETECT . COM , ARCLDR . EXE , ARCSETUP . EXE , BOOT . INI . В зависимости от конфигурации, если, например, на вашем компьютере имеется SCSI -контроллер, могут быть и другие файлы. Для семейства Windows 9 x характерно наличие в корневЬм каталоге файлов AUTOEXEC . BAT , CONFIG . SYS , MSDOS . SYS , IO . SYS . Все они важны для работы операционной системы, поэтому ни удалять, ни перемещать или из менять их нельзя.

Изменение параметров запуска программы установки

Нередко при запуске программы установки возникают разнообразные сбои, которые не устраняются ни после перезагрузки компьютера и повторного запуска программы установки, ни после временного удаления "лишнего" оборудования. В этом случае вам поможет решить проблему один из приве денных далее ключей запуска, которые позволяют в основном отключать некоторые функции программы установки, иногда приводящие к зависаниям или появлениям сбоев.

Формат командной строки в этом случае будет выглядеть следующим образом:

A :\ SETUP . EXE / первый ключ / второй ключ ... / последний ключ

Последовательность ввода ключей не имеет значения. Следует иметь в виду, что большая часть описываемых ключей являются недокументированными (при вызове справки выводится только небольшая их часть).

Ключи запуска программы установки Windows 9 x

  • /? — на экран монитора выводится справочная информация о ключах, которые можно использовать. При этом имеется возможность вывода справки в текстовый файл:

A :\ SETUP . EXE /? > А :\ имя файла . txt

В этом случае предполагается, что диск А; не защищен от записи, в противном же случае следует указать иной путь, по которому нужно записать текстовый файл;

  • / srcDir : [ Directory ] — ключ задает каталог для файлов дистрибутива Windows . Все новые компоненты будут впоследствии устанавливаться уже из указанного каталога. В системном реестре при этом записывается со ответствующий параметр sourcePath в разделе HKLM \ Software \ Microsoft \ Windows \ CurrentVersion \ Setup ;
  • /с — ключ запрещает запуск программы кэширования Smart Drive . Это позволяет увеличить объем свободной оперативной памяти, но сильно замедляет процесс установки;
  • / d — ключ позволяет запретить использование уже имеющихся настроек при переустановке операционной системы. При этом игнорируются все записи файлов конфигурации: win . ini . system . ini и т. д.;
  • / ia — ключ блокирует использование раздела " AfterProvider " файла Setupc . inf ;
  • / ib — ключ блокирует использование раздела " BeforeProvider " файла Setupc . inf ;
  • / ic — ключ блокирует загрузку 16-разрядных драйверов при запуске Windows 98. Если в системном реестре отсутствует параметр KeepRMDrivers = i , тогда все 16-разрядные драйверы из файлов конфигурации CONFIG . SYS и AUTOEXEC . BAT грузиться не будут;
  • / ich — окно программы ScanDisk остается видимым при проверке диска. Иногда помогает при возникновении проблем на этапе проверки диска;
  • / id — ключ блокирует проверку наличия свободного места на диске. Обычно используется, если программа установки неверно оценивает свободное место на диске при обновлении версии системы или же при уста новке "поверх";
  • / ie — ключ блокирует создание загрузочной дискеты. При этом не соз дается каталог Windows \ Command \ EBD . He работает в Windows 95;
  • / if — ключ блокирует проверку скопированных файлов, при этом ис пользуется функция кэширования имен файлов CacheFindFirst програм мы SETUPX ;
  • / ig — ключ блокирует проверку системного реестра. Это позволяет раз решить установку системы на некоторых старых моделях ПК;
  • / ih — ключ включает основной режим работы программы ScanDisk вме сто фонового режима, используемого по умолчанию. Ключ полезен для диагностики причин зависания установки при работе ScanDisk ;
  • / ii — ключ принудительно загружает драйвер мыши Logitech вместо драйвера мыши Microsoft . Используйте эту опцию, если у вас есть мышь Logitech Series С;
  • / im — ключ блокирует проверку наличия достаточного количества памя ти в переделах первых 640 Кбайт. Он используется, если программа уста новки отказывается работать из-за нехватки стандартной памяти;
  • / in — ключ блокирует установку сетевого модуля Network Setup Module , при этом мастер настройки сети во время установки не вызывается, ис пользуется в основном при отсутствии сетевой платы;
  • / ip — ключ блокирует обнаружение недокументированных устройств Plug and Play . Используется при зависаниях на этапе настройки оборудо вания;
  • / iq — ключ блокирует проверку наличия файлов с общими кластерами и папок программой ScanDisk (в случае если ее запуск не запрещен);
  • / ir — ключ блокирует обнаружение системной CMOS / BIOS и обновле ние главной загрузочной записи диска Master Boot Record ( MBR ). Ис пользуется, когда антивирусная защита в CMOS не мвжет быть отключе на. Компьютер в конце установки не будет перезагружаться, при этом может потребоваться сделать жесткий диск системным с помощью загру зочной дискеты, командой sys с:;
  • / is — ключ блокирует автоматическую проверку диска программой ScanDisk . Используется при установке на только что отформатированный диск для ускорения процесса установки или при проблемах с работой программы ScanDisk ;
  • / it — ключ блокирует проверку запущенных резидентных программ, ко торые могут послужить причиной сбоев при работе программы установки системы;
  • / iv — ключ блокирует вывод рекламно-информационных сообщений при обновлении системы из-под Windows . В Windows 95 не работает;
  • / iw — ключ блокирует вывод лицензионного соглашения (его все равно никто не читает);
  • / ix — блокирует проверку установленной кодовой страницы. Позволяет использовать различные кодовые страницы для DOS и для Windows ;
  • / iy — ключ блокирует проверку языковых конфликтов;
  • /m — ключ позволяет отключить использование звука во время установки и позволяет устранить возможность зависания из-за проблем, связанных с выводом звука. Этот ключ не работает в Windows 95;
  • /n — ключ блокирует использование манипулятора мышь. Это помогает решить ряд аппаратных конфликтов или используется при отсутствии мыши;
  • /nа=# — ключ блокирует проверку запущенных программ, вызывающих сбои при работе программы установки операционной системы. Здесь символ "#" имеет следующие значения:
    • 0 — проверять все программы. Используется по умолчанию:
    • 1 — Windows -программы не проверять, DOS -программы проверяются;
    • 2 — DOS -программы не проверять, Windows -программы проверяются;
    • 3 — проверка программ отключена. В Windows 95 не работает;
  • / nd — ключ, который при переустановке системы блокирует использова ние файла MIGRATION . DLL , в котором содержится список файлов, не подлежащих перезаписи более ранними версиями (список этот можно найти и в реестре — раздел HKLM \ Software \ Microsoft \ Wmdows \ CurrentVersion \ Setup \ Migration ). При этом разрешается заменять все файлы за исключением тех, для которых в соответствующих INF -файлах установлен параметр ,, ,32. При использовании этого ключа потеряются, в частности, обновления системных файлов, произведенные на сайте Windows Update , обновления неко торых программ типа Microsoft Office , Windows Media Player , NetMeeting , Outlook Express или же Internet Explorer . Его следует использовать при необходимости возврата всех "родных" файлов Windows , например, в слу чае, если обновление системных файлов привело к негативным результа там или обычная переустановка не решает проблему, а выборочное вос становление оригинальных файлов невозможно;
  • / nf — ключ блокирует вывод сообщения, предлагающего удалить загру зочную дискету из флоппи-дисковода после ее создания. В Windows 95 не работает;
  • / nh — ключ блокирует запуск программы HWINFO . EXE при установке системы из-под Windows . Используется при зависаниях этой программы. В Windows 95 не работает;
  • / nm — ключ блокирует проверку соответствия конфигурации компьютера минимальным требованиям операционной системы;
  • / nostart — при запуске программы установки из-под DOS или Windows З.хх копируется только минимальный набор необходимых DLL - файлов, используемых программой установки системы, после чего производится выход из программы установки в MS - DOS ;
  • /nr — ключ блокирует проверку системного реестра, что немного уско ряет процесс установки и устраняет проблемы на этапе проверки реестра;
  • d / ntidr — ключ блокирует поиск установленной операционной системы, что позволяет устанавливать OEM -дистрибутивы на компьютер с уже установленной Windows . Необходимо только создать пустой файл в корне вой директории системного диска с именем NTLDR , без расширения;
  • /nх — ключ блокирует проверку версии программы установки системы (файла SETUPX . DLL ). В Windows 95 не работает;
  • /р — ключ, не оказывающий сам по себе влияния на программу установки, но позволяющий использовать дополнительные переключатели, за писываемые после него диспетчером обнаружения устройств для выявле ния или устранения некоторых проблем, связанных с обнаружением и настройкой имеющихся устройств. С параметром /р допускается исполь зовать сразу несколько дополнительных переключателей, разделяя их точкой с запятой ,-, например: /р b ; f ; g . Только первый переключатель отделяется пробелом. После некоторых переключателей можно ставить знак "+" или "-", что будет соответствовать положениям "ВКЛ" и "ВЫКЛ" параметра (например: — /р а-).
  • Дополнительные переключатели:
  • а — отвечает за включение режима безопасного определения уст ройств, предназначенного для снижения вероятности зависания сис темы. Однако метод безопасного определения может не всегда досто верно определять устройства. Значение по умолчанию во время установки Windows — включено (а ---- выключить);
  • b — включить режим пошагового определения устройств " Prompt Before " (запрос перед запуском каждого детектирующего модуля) для возмож ности вручную отказаться от попыток определения проблемного уст ройства при установке. По умолчанию режим выключен;
  • с — включить (с --- отключить) механизм автомагического поиска
  • дополнительных подсказок, установлено ли устройство того или иного класса. То есть при наличии в файле CONFIG . SYS драйвера какого- либо устройства подразумевается, что такое устройство установлено и лишний вопрос о его наличии в системе пользователю уже не задает ся. По умолчанию включено. В Windows 98 и более старших версиях он не используется;
  • а=[имя] — заставляет программу установки искать только указанные модули, где [имя] — имя модуля или имя класса модулей. Имена мо дулей (такие, как DetectPIC и DetectAHA 154 x ) можно найти в файле MSDET . INF , именами классов модулей могут быть SCSIAdapter , NET И другие. Пример: SETUP /Р D=DetectPS2Mouse,keyboard,ports;
  • в — включить определение устройств в режиме, используемом при ус тановке. Нужен для того, чтобы разделить процесс определения уст ройств при установке системы и, например, процесс поиска новых устройств уже на установленной системе. По умолчанию режим вклю чен во время установки операционной системы;
  • f — включить режим очистки реестра при установке ОС. При этом удаляется раздел реестра HKEY _ LOCAL _ MACHINE \ Enum \ Root . По лезен при переустановке системы после замены материнской платы. Игнорируется при запуске инсталляции из-под Windows . Используется только в Windows 95. В Windows 98, 98 SE и ME игнорируется всегда. По умолчанию режим выключен. Обязательно сделайте резервную копию реестра перед использованием этого параметра, поскольку в некоторых справочных материалах утверждается, что с этим параметром полностью заменяется весь реестр;
  • g=# — устанавливает степень информативности выдаваемых при опре делении устройств сообщений. При #=о (по умолчанию) отображается только прогресс-бар, при #=з (максимальное значение) отображаются все ресурсы каждого найденного устройства. Помогает определить, какое устройство виновато в зависании программы установки;
  • i — программа установки при вводе данного ключа будет игнориро вать те данные, которые предоставляются системой Plug and Play , встроенной в BIOS , что позволяет иногда устранить конфликт между устройствами, если поддержка автоматической настройки BIOS плохо работает или же она несовместима с конкретной версией операцион ной системы. При этом будут использоваться исключительно возмож ности Plug and Play операционной системы. Используется, если сведе ний об устаревшем BIOS нет в файле MACHINE . INF и Windows не может его распознать;
  • j — в Windows 98 и выше задает принудительное включение поддерж ки ACPI (вместо АРМ), если BIOS системы поддерживает ACPI , a Windows этого определить не может ввиду отсутствия в ее файлах данных о BIOS системы. Если BIOS не поддерживает ACPI , то в Windows ее поддержка тоже не появится либо возможно зависание при установке системы. В Windows 95 отменяет результаты проведения предыдущей установки системы с использованием параметра /р i . Используется для включения определения Windows поддержки BIOS технологии Plug and Play в том случае, если предыдущая установка про изводилась с параметром /р I , а затем была обновлена версия BIOS ;
  • 1 =# — устанавливает уровень информативности сообщений в файле Detlog . txt . # может принимать значения от 0 до 3, по умолчанию уста новлено максимальное значение — 3;
  • m — включить режим mini - Windows , соответствующий сокращенному варианту Windows З.хх и использующийся для отображения графиче ского интерфейса на начальном этапе установки из-под MS - DOS .
    • По умолчанию режим включен при запуске установки из MS - DOS и выключен при установке из Windows ;
  • n — отключить режим возобновления установки ( Recovery Mode ), при котором в случае неудачной попытки установки Windows повторная процедура инсталляции системы начинается не с самого начала, а ис пользуются уже скопированные на диск временные файлы. При ис пользовании этого параметра отключается и создание файла протоко ла DETCRASH . LOG ;
  • о= [ traceoutput ] — задает директорию, в которую помещается файл трассировки TRACELOG . TXT при использовании отладочной версии файла SYSDETMG . DLL ;
  • р — разрешить запись в файл DETLOG . TXT данных о длительности процедуры определения устройств. По умолчанию режим выключен;
  • r — принудительно задействовать режим возобновления установки, при котором во время инсталляции системы используются данные из файла протокола DETCRASH . LOG , в котором зафиксировано устройст во, ставшее причиной предыдущего зависания системы. В результате, при повторной инсталляции не предпринимаются попытки определе ния этого проблемного устройства. Данный режим устанавливается либо вручную, либо автоматически при выборе во время установки Windows функции продолжения установки после сбоя;
  • s = [ name ] — задает список классов устройств или детектирующих мо дулей, которые в процессе установки следует пропустить. Вместо [ name ] следует писать названия модулей, соответствующих определенным классам устройств или имена самих классов, которые можно найти в файле MSDET . INF , разделе [ msdet ] : Detectspeaker , где DetectPS 2 Mouse — модули; keyboard , mouse — классы. В командной строке это выглядит примерно так:
  • SETUP / Р S= DetectPS2Mouse,keyboard,ports
  • t =# — при использовании отладочной версии менеджера определения устройств SYSDETMG . DLL задает уровень трассировки. # может принимать значения от 0 до 9;
  • V — включить режим verify only , при котором осуществляется толь ко проверка наличия устройств, прописанных в системном реестре, без поиска новых устройств. Используется мастером установки уст ройств PCMCIA ( PC - card ) и по умолчанию при установке системы режим выключен;
  • х= [ресурс] — заставляет модуль диагностики исключить указанные ресурсы, где [ресурс] может принимать одно из четырех значений:
  • io(xxx-yyy,xxx-yyy,...)
  • mem(xxxxx-yyyyy,xxxxx-yyyyy,...) irq(x,y,z,...) - dma ( x , y , z ,...)
  • Этот параметр защищает указанный ресурс от доступа модуля диагно стики;
  • /в: [ inffile ] — делает возможной загрузку пользовательского файла на стройки INF , что позволяет, например, установить драйверы для уст ройств еще на этапе установки операционной системы. Здесь [ inffile ] — путь и имя файла конфигурации;
  • / t : [ path ] — параметр позволяет принудительно задать каталог для хра нения временных файлов, в результате чего, например, можно сэконо мить свободное место на диске с-., выбрав для размещения временных файлов диск D .-.

Типичный пример использования вышеописанных ключей:

SETUP /NM /ID /IM /IW /IS /IE /IH /NF

Данная комбинация параметров позволяет отключить проверку оперативной памяти, места на жестком диске, запуск программы проверки диска Scan Disk и т. д., что поможет не только ускорить процесс установки операционной системы, но и позволит избежать некоторых проблем при установке.

Ключи запуска программы установки Windows NT

Для операционных систем семейства Windows NT параметры запуска про граммы установки подразделяются на два типа — для файла WINNT и для WINNT 32.

Запуск программы установки из MS - DOS

  • /а — включает использование специальных средств для людей с ограни ченными возможностями — экранную лупу и так называемого диктора;
  • /b — предписывает загрузочные файлы копировать непосредственно на жесткий диск, не используя дискеты;
  • /с — блокирует проверку на наличие свободного места на диске;
  • /е: [команда] — задает команду, которая будет выполнена по окончании графической стадии установки. В частности, с помощью этого ключа можно запустить специальный файл cmdlines . txt , в котором перечисляют ся программы (а также — какие-либо команды или сценарии), которые надо запустить в конце графической фазы инсталляции системы (т. е. часть дополнительных приложений, в принципе, можно установить вме сте с операционной системой);
  • / f — копировать файлы с загрузочных дискет без их проверки;
  • / i : [файл- inf ] — указывает имя файла (без пути) с данными о программе установки. По умолчанию используется файл \ I 386\ DOSNET . INF . Благодаря этому файлу можно, например, выбрать каталоги, которые не будут копироваться на ваш компьютер при установке операционной системы;
  • / i — ключ включает создание файла протокола $ winnt . log , в который за носятся ошибки, возникающие при копировании файлов во временную папку в начале процесса установки;
  • /г: [папка] — позволяет создавать любой каталог в системном каталоге Windows , который останется по окончании установки. Если указать несколько параметров /г, то будет создано несколько каталогов;
  • /гх: [папка] — включает создание временного каталога в системном ка талоге Windows , который будет удален по окончании установки. Если указать несколько параметров /гх, то будет создано несколько каталогов;
  • /з:[путь] — указывает путь к дистрибутиву Windows . Применяется, в частности, для установки системы с сервера (можно указывать путь к восьми серверам). Путь следует указывать в полной форме: диск:\путь или \\сервер\общий_ресурс\путь. По умолчанию используется тот же каталог, в котором расположена программа winnt . exe ;
  • / t : [диск] — задает диск, на котором в ходе инсталляции будут размеще ны временные файлы. Если этот параметр отсутствует, то программа установки использует раздел, на котором больше свободного дискового пространства;
  • /и: [файл ответов] — задает файл ответов для программы установки Windows . Обычно для автоматизации установки используется файл unattend . txt . Параметр /и следует использовать вместе с параметром / s ;
  • / udf : id [ , udf _$ clvuz ] — указывает идентификатор id , с помощью кото рого программа установки Windows определяет значения в UDF -файле для модификации файла ответов каждого компьютера при установке сис темы на большое количество компьютеров. Если файл не указан, то сис тема потребует дискету с файлом $ Unique $. udb .

Запуск программы установки из Windows

  • / checkupgradeonly — вместо установки произвести проверку возможно сти обновления текущей версии Windows , по окончании которой будет сгенерирован отчет (обычно файл Upgrade . txt для Windows 9 x или Winnt 32. log для Windows NT ) о возможности установки новой операци онной системы;
  • / cmd : [командная строка] — задает команду, которая должна быть ис полнена во время завершающей стадии установки. С помощью этого ключа можно задать запуск специального файла cmdlines . txt , в котором перечисляются программы, а также какие-либо команды или сценарии, которые надо запустить в конце фафичеекой фазы инсталляции системы;
  • / emdeons — установить консоль восстановления системы и добавить ее вызов в зафузочное меню. Установка операционной системы при этом не производится;
  • / copydir -. [папка] — включает создание дополнительного каталога с име нем [папка] в системном каталоге Windows . Если указать несколько па раметров / copydir , то будет создано несколько папок;
  • / copysourse : [каталог] — включает создание временного каталога, кото рый будет удален по окончании установки ОС. Если указать несколько параметров / copysourse , то будет создано несколько папок;
  • / debug [уровень] [:имя файла] — ВКЛЮЧаеТ ПрОТОКОЛ ОТЛЭДКИ (ПО уМОЛчанию — файл Winnt 32. log ) с заданным уровнем детализации сообщений о возникших при установке ошибках и предупреждениях (по умолча нию — 2, возможные значения 1-4);
  • / dudisabie — ключ блокирует динамическое обновление. Если динами ческое обновление отключено, программа установки выполняется только с исходными файлами установки. Этот параметр отключает динамиче ское обновление, даже если используется файл ответов, в котором заданы параметры динамического обновления;
  • / duprepare : [путь] — этот ключ задает выполнение операций по подго товке установочного общего каталога для использования с файлами дина мического обновления, которые зафужаются с web -узла Windows Update . Этот каталог может использоваться для установки Windows на несколько клиентов;
  • / dushare : [путь] — общий каталог, в котором ранее с web -узла Windows Update загружались файлы динамического обновления, и кото рый был указан в параметре / duprepare :путь. При использовании на клиентском компьютере задает использование обновленных файлов из общей папки, заданной значением путь;
  • / i : [ taiui . inf ] — указывает имя файла (без пути) с данными о программе
  • установки, по умолчанию это файл dosnet . inf ;
  • /т: [имя каталога] — задает программе установки путь к дистрибутиву;
  • / makeiocaisource — включает обязательное копирование файлов дистрибутива на локальный жесткий диск;
  • / noreboot — отменяет перезагрузку компьютера после завершения пер вого этапа установки (копирование файлов), например, для выполнения пользователем каких-либо дополнительных действий;
  • /о — предписывает программе установки создать только загрузочные дискеты;
  • /ох— создать загрузочные дискеты для инсталляции с компакт-диска или из сети;
  • /s:nyrb — указывает путь к дистрибутиву Windows. Применяется, в частности, для установки системы с сервера (можно указывать путь максимум К ВОСЬМИ Серверам Одновременно: winnt32 /s:serverl ... /s: server8). Путь следует указывать в полной форме: диск:\путь или \\сервер\ общий_ресурс\путь. По умолчанию используется та же папка, в которой расположена программа winnt32.exe;
  • /syspart:диск — подготовка диска для установки ОС. При использовании этого параметра программа установки копирует все необходимые установочные файлы дистрибутива Windows на специально выделенный жесткий диск и помечает его как активный, после чего этот диск можно установить на любой компьютер (или сделать несколько его клонов), на котором и продолжится установка. Параметр /syspart используется совместно с параметром /tempdrive, причем их значения должны указывать на один и тот же диск;
  • /tempdrive: диск — задает программе установки диск для размещения временных файлов, используется совместно с параметром /syspart;
  • /и[секунд]:[файл ответов] (равнозначно /unattend[секунд] : [файл ответов]) — ключ включает автоматизированную, основанную на файле ответов (обычно это файл unattend.txt) установку Windows. При обновлении предыдущей версии Windows NT можно, задать задержку в секундах между завершением копирования файлов до перезагрузки ПК. Используется совместно с параметром /s;
  • /unattend — включает автоматическое обновление предыдущей версии Windows, основываясь на ее конфигурации. То есть все настройки ОС сохраняются, и вмешательство пользователя не требуется; ? /udf:id[,UDF_<i>aiui] — указывает идентификатор id, с помощью которого программа установки определяет соответствующие значения в UDF-файле для модификации файла ответов каждого компьютера; 3 /х — отключает создание загрузочных дискет при установке Windows NT.

Управление процессом установки

В процессе установки операционной системы вам будет задан ряд вопросов, шторые могут повлиять на удобство работы с компьютером в дальнейшем, юэтому немного остановимся на наиболее важных моментах. Во-первых, программа установки обязательно проверяет жесткий диск на наличие на нем ошибок (конечно, если вы не отключили данную функцию). При этом особенно долго система может проверять те диски, на которых имеется большое количество небольших по размеру файлов, например картинок в формате JPG. Если есть такая возможность, то на период установки лучше отключить все дополнительные диски, они только будут замедлять процесс установки.

Следующий этап — выбор каталога установки, а при наличии нескольких дисков, то и диска, на котором будет располагаться рабочий каталог Windows. При этом следует придерживаться следующих правил:

  • имя каталога не должно быть слишком длинным, а также не должно состоять из русских символов;
  • немалое количество вирусов может работать только с каталогом под названием WINDOWS, поэтому какое-либо иное название, например, WIN предохранит вас от воздействия данной категории компьютерных вирусов. Тем более, что после этого вы сможете свободно увидеть, что на компьютере "кто-то поселился", т. к. такие вирусы обычно сами создают каталог WINDOWS, а уже потом размещают в нем свой программный код. Вам будет достаточно вручную удалить каталог и забыть про опасность;
  • лучше располагать рабочий каталог операционной системы на самом быстром диске, т. к. это будет влиять в дальнейшем на общую производительность ПК.

При запросе имени пользователя и названия организации следует придерживаться все тех же правил — имя не должно быть слишком длинным и должно состоять только из латинских символов или хотя бы цифр. В противном случае вам не избежать ряда сбоев, когда устанавливаемые программы не могут работать корректно с кириллицей. Если на вашем компьютере установлена сетевая плата, то при запросе сетевого имени и имени рабочей группы можно ввести практически любое название, т. к. впоследствии все это легко изменяется. Хотя если ваш компьютер уже подключен к локальной сети, то лучше сразу ввести правильные имена, что значительно уменьшит время настройки компьютера для работы в сети. Загрузочный диск можно не создавать, даже если система настойчиво его предлагает создать. Дело в том, что функциональность такого диска обычно оставляет желать лучшего, тем более что у вас уже имеется загрузочный диск, с которого вы запустили компьютер перед началом установки. Примерно то же самое можно сказать и по поводу предложения сохранить [ старые системные файлы. Обычно переустанавливают систему при возникновении сбоев в ее работе, так что сохранять старые (читайте сбойные) системные файлы большого смысла нет. Тем более что архив со старыми системными файлами может занимать до 100—150 Мбайт свободного пространства, а то и больше. Если вы все-таки желаете сохранить старые системные файлы, то вам следует знать, что это у вас не получится, если:

  • текущая версия операционной системы установлена на сжатом диске;
  • установка произведена в другой каталог или не как обновление текущей версии;
  • используется версия MS-DOS v5.0 и ниже.

При установке операционной системы семейства Windows NT следует иметь в виду, что вам настойчиво будут предлагать преобразовать файловую систе му в NTFS . При этом нельзя забывать, что, несмотря на все преимущества, получить доступ к диску NTFS из среды MS - DOS крайне затруднительно. Хотя с другой стороны вероятность серьезных сбоев с применением NTFS очень сильно уменьшается. В принципе, во время установки можно отло жить вопрос о преобразовании, а конвертировать файловую систему FAT в NTFS впоследствии при помощи следующей команды:

CONVERT DISK : / FS : NTFS

где DISK : — имя раздела, подлежащего конвертированию.

Плюсы файловой системы FAT :

  • для эффективной работы требуется немного оперативной памяти;
  • быстрая работа с каталогами небольшого и среднего размера;
  • магнитные головки за счет особенностей работы в целом совершают значительно меньше движений, чем в случае с NTFS ;
  • эффективная работа на медленных жестких дисках.

Минусы файловой системы FAT :

  • катастрофическая потеря быстродействия с увеличением фрагментации
  • файлов на диске, особенно на дисках большого объема;
  • низкая скорость работы при произвольном доступе к большим файлам;
  • очень медленная работа с каталогами, содержащими большое количество
    файлов;
  • низкая отказоустойчивость.

Плюсы файловой системы NTFS :

  • при фрагментации файлов затрудняется только лишь чтение самих фай лов, поиск и другие функции;
  • быстрый доступ к любому фрагменту большого файла;
  • очень быстрый доступ к маленьким файлам;
  • очень высокая отказоустойчивость.

Минусы файловой системы NTFS :

  • существенные требования к объему оперативной памяти;
  • для эффективной работы требует от жесткого диска поддержки совре менных режимов;
  • затруднена работа с каталогами среднего размера;
  • крайне низкие показатели быстродействия при заполнении диска на 80—90% в течение длительного времени.


Автоматизация установки операционной системы

При установке операционной системы на несколько компьютеров с одина ковой конфигурацией имеет смысл создать и использовать при установке так называемый файл ответов, который будет автоматически подставлять основные параметры, такие как серийный номер, имя пользователя и т. п. Для операционных систем Windows 9 x файл ответом имеет название MSBATCH . INF . Он может быть расположен как в каталоге с дистрибутивом, так и на любом диске, доступном при запуске программы установки. При этом команда запуска установки будет выглядеть следующим образом:

A :\ SETUP . EXE A :\ MSBATCH . INF

Структура этого файла вполне обычная для Windows — это ряд разделов со строго заданными названиями, заключенными в квадратные скобки и внут ри каждого раздела — список параметров (их имена также строго определе ны) со значениями. Необрабатываемые системой комментарии предваряются точкой с запятой.

[ Version ]
signature ="$ CHICAGO $"

Это обязательный заголовок для INF -файла Windows 9 x , после него следует оставить пустую строку, а уже в следующей строке ввести заголовок первой секции, отвечающей за основные параметры инсталляции ОС:

[ Setup ]

Внутри этого раздела содержится набор параметров, управляющих непо средственно процессом установки системы и эквивалентных ответам на во просы программы SETUP , а также ряд специфических ключей, влияющих на скорость установки ОС, задать которые можно только с помощью файла MSBATCH . INF . Если какой-либо параметр не прописан явным образом, то используется значение по умолчанию. Поскольку мы ставим своей задачей полностью автоматизировать инсталляцию Windows , то прописываем ниже следующие параметры:

  • Express = 1
    Значение 1 — полностью автоматическая установка, программа установки не задает никаких вопросов, значение 0 — полуавтоматическая установка, при которой пользователю разрешается изменять параметры, заданные по умолчанию;
  • NoDirWarn = 1
    Значение 1 — установка операционной системы в имеющуюся папку Windows без предупреждения, значение 0 — подтверждение выбора папки пользователем (по умолчанию);
  • InstallDir = C :\ WINDOWS
    Указывается путь к каталогу, куда будет установлена операционная сис тема, по умолчанию это — C :\ WINDOWS ;
  • ebd = 0
    Значение 0 — блокирует создание загрузочной дискеты, значение I — разрешает (по умолчанию);
  • ChangeDir = 0
    Значение 0 — блокирует возможность изменения каталога, в который бу дет установлена Windows (по умолчанию), значение 1 — разрешает;
  • OptionalComponents = 1
    Значение 1 — разрешает произвольный выбор компонентов ОС (по умолчанию), значение 0 — все компоненты определяются типом уста новки системы, диалог выбора компонентов не выводится;
  • сср=о
    Значение 0 — блокирует поиск предыдущей версии Windows , значение 1 — поиск будет вестись (по умолчанию);
  • CleanBoot = 1
    Значение 1 — отключает возможность обновления уже существующей на диске версии Windows , производится чистая установка, значение 0 — разрешает обновление (по умолчанию);
  • Display =0
    Значение 0 — блокирует на время установки вывод на экран любых диа логовых окон, значение 1 — разрешает вывод (по умолчанию);
  • InstallType =3
    Указывается тип установки: значение 0 — минимальная, значение 1 — обычная (по умолчанию), значение 2 — на переносной ПК, значение 3 — выборочная;
  • DevicePath = 1
    Значение 1 — разрешает программе установки искать не входящие в состав Windows INF -файлы драйверов устройств в папке с дистрибутивом, это позволяет интефировать все нужные драйверы прямо в дистрибутив, значение 0 — запрещает поиск внешних драйверов (по умолчанию);
  • Uninstall = 0
    Значение 0 — при наличии предыдущей версии Windows в случае обнов ления не будет создаваться архив системных файлов для отмены обнов ления, значение 1 — пользователь выбирает, сохранять возможность уда ления Windows или нет (по умолчанию), 5 — автоматически создается архив;
  • ProductKey =" XXXXX - XXXXX - XXXXX - XXXXX - XXXXX "
    CD - Key вашего дистрибутива;
  • showEula =0
    Значение 0 — не выводить лицензионное соглашение, значение 1 — вы водить (по умолчанию);
  • TimeZone =" Russian "
    Установка временной зоны;
  • NoPrompt 2 Boot = 1
    Значение 0 — перезагрузка с разрешения пользователя (по умолчанию), значение 1 — перезафузка без запросов к пользователю.

Это основные параметры раздела [ setup ]. Далее следует еще один не менее важный раздел, в котором задаются региональные установки, и для России в нем должны быть следующие параметры:

[System]
MultiLanguage=Cyrillic
Locale=L0419
SelectedKeyboard=KEYBOARD_00000419

Установка указанных параметров обязательна, поскольку полноценную под держку кириллицы в англоязычных версиях Windows можно установить только на этапе инсталляции. Но тут имеется один весьма неприятный нюанс. В любых вариантах Windows 98 и в локализованной русской версии Windows ME проблем с автоматической установкой кириллических парамет ров нет. А вот панъевропейская Windows ME почему-то никак не хочет вос принимать региональные установки из MSBATCH . INF , так что систему та ким способом "обмануть" не удастся. Если вы все-таки являетесь поклонником англоязычных Windows , то возможны два пути решения про блемы: либо никогда не выбирайте полностью автоматическую установку — всегда задавайте параметр Express = o в разделе [ setup ], чтобы иметь воз можность выставить регион и временную зону вручную. Либо разархивируй- те один файл под названием PRECOPY 1. CAB из дистрибутива Windows во временную папку, после чего найдите в ней файлы LOCALE . INF , MULTILNG . INF и CONTENT . INF . В первом из них нужно заменить строки:

Default_Locale="L0409" Resource_Locale="00000409"

на

Default_Locale="L0419" Resource_Locale="00000419"

Во втором файле — строку

De fault_Keyboard="KEYBOARD_0 0000409"

на

Default _ Keyboard =" KEYBOARD _00000419"

И в третьем файле измените строку

Default_Content="244"

на

Default_Content="203"

Теперь нужно снова создать файл PRECOPY 1. CAB , но уже с измененными файлами — в этом поможет любой архиватор, способный работать с архива ми CAB . В крайнем случае, просто поместите эти три файла в папку с дист рибутивом Windows — к ним программа установки обратится в первую оче редь вместо архива PRECOPY 1. CAB . В результате во время инсталляции Windows по умолчанию будет выбран регион — "Россия", после чего с под держкой кириллицы при полностью автоматической установке проблем в дальнейшем не будет.

В этом же разделе задаются и еще несколько менее интересных установок, например, разрешение экрана, которое будет применяться на завершающей стадии установки:

DisplChar =16,1024,768

В случае если вы указали выборочную установку без выбора компонентов вруч ную, вам следует обратиться к следующему разделу, который выглядит так:

[ OptionalComponents ]

" Портфель "=0
" Калькулятор "=1
" Фоновые рисунки "=0
" Игры "=1
" Imaging "= l и т . д .

Как видите, раздел представляет собой обычный список, в котором значе ние 1 говорит о необходимости установки компонента, а значение 0 — на оборот, о том, что данный компонент устанавливать не следует.

Чтобы программа установки не пыталась установить драйвер для принтера, что весьма характерно для Windows 95, следует создать пустой раздел [ Printers ], который не содержит ни одного параметра. Также следует за дать имя пользователя и название организации:

[ NameAndOrg ]
Name =" Имя пользователя "
Оrg =" Название организации "
Display =0

Параметр Display , точнее его значение, равное 0, блокирует вывод на экран монитора диалогового окна, предлагающего выбрать имя пользователя.

Вообще этот параметр имеет смысл прописать в каждом разделе, что позволит немного ускорить процесс установки, замедляющийся из-за блокировки мелькания на экране диалоговых окон. Естественно, что существует отдельный раздел для настройки сети:

[ Network ]
ComputerName =" Имя компьютера в сети"
Workgroup =" Имя рабочей группы" Description " Notebook "

Как ни странно это звучит, но компания Microsoft сама предусмотрела воз можность редактирования описываемого файла, поместив специальную программу в каталоге Win 98\ Tools \ Reskit \ Batch на диске с дистрибутивом. В каталоге же Win 98\ Tools \ Reskit \ Infinst имеется еще одна полезная про грамма. Она позволяет включать в дистрибутив драйверы сторонних производителей, интегрируя INF -файл каждого драйвера в файл MSBATCH . INF и копируя необходимые файлы в папку с дистрибутивом Windows . Правда, если драйвер основан не на INF -файле, а является исполняемой програм мой (яркий пример — Detonator ' bi для видеоплат от NVIDIA ), то такой но мер с ним не пройдет — придется запускать его вручную уже после установ ки системы. При работе с этой программой достаточно указать два пути — к папке с файлами драйвера и к папке с дистрибутивом Windows , после чего программа внесет нужные изменения в MSBATCH . INF . Естественно, дист рибутив при этом должен быть на жестком диске, чтобы к нему можно было дописать файлы драйвера.

Для операционной системы Windows XP файл ответов обычно имеет назва ние UNATTEND . TXT . Для более детального изучения настроек и ручной правки файла ответов читайте файл REF . CHM , который находится в DEPLOY . CAB . Если вы самостоятельно записываете установочный компакт-диск, то переименуйте файл ответов в WINNT . SIF . Для Windows NT /2000 также возможно создание файла ответов, но в этих системах он является мало функциональным.


Обновление операционной системы

Следует иметь в виду, что при установке операционной системы старые фай лы конфигурации, такие как MSDOS . SYS , AUTOEXEC . BAT и CONFIG . SYS , перезаписываются. При этом в файле CONFIG . SYS , как правило, удаляются строки, в которых упоминаются следующие драйверы/программы: cmd 640 x , ifshlp , fastopen , fastopen . exe , rambios . sys , share . exe , share . com , share , smartdrive . sys , smartdrv . exe . Помимо этого удаляются упоминания о всевозможных антиви русных программах, некоторых диспетчерах памяти (всего около 100 наиме нований). Также удаляются команды типа files , buffers , если их значение совпадает со значением, устанавливаемым по умолчанию.
Наиболее важные условия, которые требуется соблюдать, чтобы успешно завершить переустановку операционной системы "поверх" старой копии.

  1. 1. Отключите или деинсталлируйте все антивирусные программы. Они мо гут вызвать зависание компьютера во время установки, т. к. проверяют на наличие вирусов все файлы, помещаемые в оперативную память, а во время установки операционной системы файлов используется очень много. Проще всего это сделать при помощи утилиты MSCONFIG , кото рая входит в состав операционной системы семейства Windows , начиная с Windows 98.
  2. Также следует отключить проверку на вирусы в BIOS (это такие парамет ры как Boot Warning , Boot Virus Protection ). Дело в том, что эти парамет ры запрещают запись в системную область жесткого диска, которая при обычной работе никогда не используется для записи данных. При уста новке операционная система в этой области ставит специальную метку, позволяющую ей в дальнейшем загружаться с диска.
  3. 2. Закройте все выполняющиеся программы. Также следует отключить за ставки и средства автоматического управления питанием. В частности, выберите на Панели управления иконку Экран, в разделе которого Заставка | Питание выберите схему питания Включен постоянно и, при необходимости, отключите вручную Отключение дисплея, Отключение дисков и Ждущий режим включить через.
  4. 3. Закомментируйте или удалите все строки в файлах настройки AUTOEXEC . BAT и CONFIG . SYS . Для этого следует выбрать пункт Выполнить, который становится доступным после нажатия кнопки Пуск, и набрать в окошке команду sysedit , после чего вам будет предложено изменить указанные выше файлы. Для того чтобы временно отключить загрузку какой-либо программы, можно написать перед командой слово REM (комментарий), после чего строка при загрузке компьютера будет игнорироваться. Сохраните измененные файлы и перезагрузите компью тер, после чего можно продолжать подготовку.
  5. 4. Для установки операционной системы поверх старой копии следует запус кать не основной файл SETUP . EXE , а дополнительный — SETUPCOR , ко торый позволит избежать повторной инициализации системных ресурсов, что в свою очередь, как минимум, уменьшит вероятность появления ап паратных конфликтов.

Вместе с операционными системами Windows 2000/ XP пользователь узнал, 1аконец-то, от чего время от времени компьютер работает не так, как хоте- юсь бы. Речь идет, конечно же, о пакетах исправлений, которые по объему шогда занимают не менее пятой части всего дистрибутива операционной системы.

1ля операционной системы Windows NT за весь период ее существования (ыпущено шесть пакетов обновлений (от SP 1 до SP 6).

Для операционной системы Windows 2000 за весь период ее существования было выпущено четыре пакета, включающих в себя все те мелкие исправле ния, которые производились специалистами компании Microsoft . Помимо этого предлагались исправления, например, отдельно для Internet Explorer .

Обычно каждый последующий пакет обновлений содержит все исправле ния, которые были внесены предыдущими пакетами, что естественно влияет на размер файла, т. е. при выпуске, например, пакета исправлений SP 2 для Windows ХР его можно будет устанавливать как поверх обновления SP 1, так и на "голую" операционную систему.

Если вы скачивали обновления в процессе их появления, после выхода па кета обновлений многие из них можно удалить, но не все, т. к. некоторые все-таки не входят в пакет (наверное, специалисты Microsoft не уверены в действенности своей "заплатки"). Определить, можно ли удалять файлы или нет, можно по имени файла обновления. Например, если в его назва нии содержится упоминание SP 1, то смело удаляйте файл, если же имеется четкое указание на SP 2, хотя дата его выхода в свет не указана, то прежде чем удалять "заплатку", хорошо подумайте, нужна ли вам она.

Переход на предыдущую версию Windows может быть сильно осложнен на личием в системе дисков с файловой системой NTFS . При этом преобразование обратно в систему FAT 32 возможно либо при помощи удаления раз дела NTFS и создания нового раздела FAT , естественно, с полной потерей информации, либо при помощи программы PowerQuest Partition Magic , например, версии 8.0, которая способна без потери информации свободно преобразовывать разделы дисков.

Перед установкой операционной системы предыдущей версии следует уда лить те каталоги, в которых содержались системные файлы и установленные программы. Это обычно каталоги с именами Windows и Program Files . Также следует удалить файлы из корневого каталога (только относящиеся к системе; файлы, созданные вами, можно не трогать). Для ускорения процесса установки данные каталоги, если, конечно, на диске имеется достаточно свободного места, можно временно переименовать в Ct \ l , C :\2 и т. д., уда лив только файлы из корневого каталога. В дальнейшем их удаление в уже установленной операционной системе займет куда меньше времени.


FAQ ( ответы на часто задаваемые вопросы )

Вопрос: Почему очень часто можно услышать рекомендации об установке как можно более новой версии операционной системы, хотя меня вполне удовлетворяет старый, зато надежный Windows 95, да и работает он очень быстро?

Ответ: Каждая более новая версия операционной системы, как правило, обладает рядом нововведений, которые облегчают работу пользователя и уменьшают шансы получения нестабильно работающего компьютера. Например, в Windows XP , когда вы копируете файлы с компакт-диска, ав томатически снимается атрибут "только для чтения", чего нет во всех преды дущих версиях Windows .

Подобные "примочки" позволяют избежать установки дополнительных программ и утилит, которые с одной стороны делают работу с Windows на много удобней, а с другой стороны привносят массу проблем с их установ кой и настройкой. Например, немало программ для своей работы требуют установки Internet Explorer версии не ниже 6.0, что вынуждает держать "под рукой" его дистрибутив, в то время как в Windows XP он устанавливается автоматически с операционной системой. Таких примеров можно привести великое множество.


Глава 9. Настройка операционной системы

  • Настройка операционной системы
  • Создание точки отката в Windows ME/XP
  • Удаление "лишних" программ из автозагрузки
  • Размещение временных файлов Windows
  • Настройка файла подкачки
  • Редактирование файла MSDOS.SYS
  • Редактирование CONFIG.SYS и AUTOEXEC.BAT
  • Редактирование файла BOOT.INI
  • Редактирование системного реестра
  • Удаление "лишних" компонентов Windows
  • Если не работает мышь
  • FAQ (ответы на часто задаваемые вопросы)


Настройка операционной системы

Наверное, вы часто обращали внимание на то, что операционная система со временем начинает работать все медленнее и медленнее. Иногда скорость ее загрузки замедляется, что рано или поздно приводит к мысли о "чистой" переустановке.

Вполне естественно, что больше всего пользователей волнует вопрос: "А можно ли заставить компьютер работать хотя бы немного быстрее без замены комплектующих на более мощные экземпляры?" Ответ: "Да, можно". Правда, с одним отступлением. Ускорить можно работу операционной сис темы, под управлением которой на ПК и происходят все процессы.

Для того чтобы достаточно ясно понять, как можно ускорить работу опера ционной системы, следует четко классифицировать все процессы, происхо дящие с ней с того момента, когда вы нажали кнопку POWER .

Если вы имеете дело с операционной системой семейства Windows 9 x , тогда для вас будет интересна следующая информация:

  • в первую очередь, в память компьютера загружаются системные файлы IO . SYS , MSDOS . SYS , COMMAND . COM (именно в такой последовательности). MS - DOS , как можно увидеть, является основой для всех версий Windows 9 x , даже для ME . Все три файла остались в наследство от MS - DOS и в настоящее время нужны для совместимости со старыми про граммами (оборудованием).
    Файл IO . SYS фактически является логическим продолжением BIOS ма теринской платы, и его, как правило, ни в коем случае нельзя ни изме нять, ни удалять.
    Файл MSDOS . SYS является самым первым конфигурационным файлом, который может повлиять как на скорость загрузки, так и на режим за грузки, и вообще на ее возможность. То есть, если внести в него некор ректную запись или удалить его, операционная система не загрузится. Общие правила редактирования файла MSDOS . SYS мы рассмотрим немного позже. Несмотря на все уверения Microsoft о том, что Windows ME
  • полностью избавлена от MS - DOS , некорректное изменение или удаление файла MSDOS . SYS приводит к невозможности загрузки системы.
    Файл C 0 MMAND . COM является командным процессором, который вы полняет практически все команды MS - DOS , вводимые в командной строке. Правда, далеко не все команды этот файл может выполнять сам по себе. Для выполнения некоторых действий ему требуется наличие от дельных программ. Например, когда вы набираете команду TIME (теку щее время), командный процессор выполняет ее самостоятельно. Если вы набираете команду FORMAT (форматирование), тогда командный процессор пытается найти файл программы F 0 RMAT . COM . Если он его найдет, будет запущен процесс форматирования. В противном случае, ес ли данного файла нет, будет выдано сообщение об ошибке. Этот файл нельзя редактировать или удалять, т. к. это приводит к невозможности загрузки системы;
  • во вторую очередь, в память компьютера загружаются файлы CONFIG . SYS и AUTOEXEC . BAT . Сразу следует отметить, что в Windows ME эти файлы играют роль рудимента, т. к. система игнорирует их при загрузке и все изменения в них после перезагрузки компьютера стираются.
    При помощи файла CONFIG . SYS вы получаете возможность загрузки в память компьютера любых драйверов устройств и всех файлов с расши рением SYS .
    Файл AUTOEXEC . BAT предназначен для автоматической загрузки в па мять компьютера целого ряда программ, например, антивирусного мони тора, драйвера защиты какой-нибудь программы, файлового менеджера типа NC и прочих. Способы редактирования обоих типов файлов мы рассмотрим немного позже. Следует иметь в виду, что некорректные записи в этих файлах или запуск при их помощи программ, несовместимых с установленной операционной системой или используемым программным обеспечением, может вызывать серьезные сбои в работе компьютера, вплоть до регулярных зависаний;
  • третьим по счету в память компьютера загружается системный реестр, который запускает все необходимые для работы операционной системы драйверы или, как их еще называют, службы. Структура реестра любой версии Windows сложна и требует для ручного редактирования опреде ленных навыков в работе с ПК. Но начинающего пользователя это не должно сильно волновать, т. к. для изменения системного реестра имеет ся множество программ, позволяющих вносить все изменения обычной установкой или снятием галочек с нужных пунктов. При этом в про граммах обычно собраны все параметры, необходимые, например, для того, чтобы ускорить работу операционной системы или увеличить ско рость ее загрузки.

Если вы являетесь обладателем операционной системы Windows 2000/ XP , тогда вам следует обратить внимание на то, что основным файлом является NTDETECT . COM , автоматически определяющий при запуске компьютера каталоги, в которых есть установленные операционные системы, а также загружающий по умолчанию ту, которая была указана в файле BOOT . INI как установленная по умолчанию.

Теперь подойдем к этому вопросу с другой стороны — что необходимо Windows (любой версии) для быстрой работы? Ответ прост — процессор по быстрее и памяти побольше. Теперь по порядку.

Увеличить производительность центрального процессора (без риска привес ти его в негодность) нет, зато вы можете освободить часть его ресурсов, за блокировав некоторые из выполняемых операций, которые по большому счету не нужны для нормальной работы вашего компьютера. Яркий тому пример — сетевые службы, которые нужны только для работы либо в ло кальной сети, либо с модемом. Если у вас нет ни того, ни другого, следует отключить их, освободив этим самым некоторую часть ресурсов централь ного процессора.

Увеличить объем оперативной памяти вообще не представляется возможным без физического добавления дополнительных модулей, зато вы можете без особых усилий увеличить объем свободной оперативной памяти. Этот метод крайне тесно связан с первым случаем, т. к. для этого требуется уменьшить количество программ, запускаемых вместе с операционной системой. Яркий пример — модули программ, которые постоянно загружены в память ком пьютера и размещаются рядом с часами на рабочем столе. Конечно, они позволяют быстрее запускать строго определенные программы, но зато при этом замедляют работу как самой операционной системы, так и других программ. Ведь свободной оперативной памяти становится с каждым таким модулем все меньше и меньше, поэтому чаще приходится обращаться к диску, на котором располагается так называемая виртуальная память. Ес тественно, скорость работы диска намного меньше, чем у модуля памяти.

Из вышесказанного можно вывести еще одно требование: неплохих результатов при настройке компьютера можно добиться размещением и манипу лированием размеров файла подкачки, используемого в качестве виртуаль ной памяти.


Создание точки отката в Windows ME / XP

Как уже упоминалось неоднократно, в операционных системах Windows ME и ХР существует возможность создания так называемой точки отката, представляющей собой моментальный снимок системного реестра и ряда системных файлов, которые в первую очередь обычно приводят к появле нию сбоев. Точнее, к сбоям приводит их отсутствие или повреждение.

Точки отката создаются по желанию пользователя, например, способом, рассматриваемым далее, а также перед установкой любых программ, исполь зующих технологию MSI ( Microsoft Software Installed ) или если установоч ный пакет создан программой InstallShield Pro версии не ниже 6.1. Также автоматически создается точка отката при установке всех обновлений опе рационной системы, например, для Windows XP — Service Pack I .

Все снимки состояния системы хранятся в запакованном виде в каталоге _ Restore (для Windows ME ) или System Volume Information ( Windows XP ). Содержимое этих каталогов не может быть изменено, удалено, перемещено средствами Windows , так что удалить вручную их можно только, загрузив компьютер в режиме MS - DOS .

Ручное создание точки отката рекомендуется, если вы собираетесь устано вить одну или несколько программ, но не уверены, что они будут работать стабильно. Такую же рекомендацию можно дать при установке обновлений драйверов и т. п.

Для создания точки отката следует запустить программу Восстановление системы, которая находится в меню Пуск | Программы | Стандартные | Служебные, после чего выбрать пункт Создать точку отката и нажать Далее. Введите описания для точки отката, по которому в дальнейшем вы сможете отличить ее от автоматически созданных точек, после чего по-прежнему нажмите Далее и ОК. Все, снимок системы создан и готов к использованию.

Следует отметить, что под контролем находятся только те из действий поль зователя, которые производятся им в обычном режиме работы операцион ной системы, т. е. все действия, произведенные в безопасном режиме, нигде не фиксируются и не могут быть автоматически отменены.

Самый неприятный момент в использовании функции восстановления операционной системы — это то, что информация, необходимая для этого, занимает немало свободного дискового пространства, что фактически умень шает полезный объем жесткого диска. Для уменьшения данного эффекта можно рекомендовать ограничить максимальный размер дискового про странства, отдаваемый в пользование службе восстановления, или вручную время от времени удалять старые точки отката, которые, скорее всего, уже не способны при их использовании нормально восстановить работоспособ ность компьютера.

Следует иметь в виду, что каталог для сохранения файлов восстановления создается автоматически на каждом подключаемом жестком диске, что мо жет сыграть плохую роль, например, если подключенный диск требуется восстановить, ведь любая запись на диск может привести к окончательной потере информации.


Удаление " лишних " программ из автозагрузки

В первую очередь обратите внимание на область рабочего стола рядом с ча сами, где после года работы на компьютере может накопиться не менее де сятка разнообразных ярлыков, которые на самом деле являются модулями различных программ, постоянно занимающими часть оперативной памяти. Быстрый запуск программ, который якобы все они предоставляют, можно организовать намного проще — для этого существует панель быстрого за пуска, на которой размещаются ярлыки нужных программ. Ярлык, в отли чие от модуля, никакой памяти не занимает и позволяет запускать програм мы так же быстро.

Проще всего удалить из автозагрузки те программы, которые располагают ярлыки в каталоге Windows | Главное меню | Программы | Автозагрузка (для Windows 9х) или Documents and Settings | Имя пользователя | Главное меню |

Программы | Автозагрузка (для Windows 2000/ XP ). Вполне достаточно просто переместить ярлык в другой каталог, например в C :\ BACKUP , и перезагру зить компьютер. Второй способ облегчит восстановление ярлыка программы, которую все-таки следует загружать при запуске операционной систе мы, например эмулятор ключа 1С-Предприятие.

Но, к сожалению, далеко не все программы прописывают свой ярлык имен но в этом каталоге. Бывает так, что программа даже не показывает наличие своего модуля в памяти компьютера, якобы считая, что пользователю не нужно этого знать. С такими программами придется "повозиться". Но рас смотрим все по порядку.

Сразу следует отметить, что все последующие действия будут осуществлять ся с системным реестром, поэтому позаботьтесь заранее о создании его ре зервной копии. Для этого необходимо запустить программу Сведения о системе, которая имеется в меню Пуск | Программы | Стандартные | Служебные, и выбрать пункт Проверка реестра (для Windows 9 x ) или Восстановление системы (для Windows XP ). После этого в операционных системах Windows 9 x рекомендуется вручную скопировать, а еще лучше за ранее распаковать архив с резервной копией реестра в определенный ката лог. Этот архив можно найти в каталоге C :\ WINDOWS \ SYSBCKUP \, при этом имейте в виду, что там обычно содержится до пяти таких архивов, автоматически создаваемых операционной системой. Вам понадобится тот архив, который создан последним (ориентируйтесь по времени и дате соз дания файлов). В операционной системе Windows XP следует создать точку отката, которая позволит вам вернуть старые настройки вместо тех, что вы ввели во время ручного редактирования системного реестра.

Наиболее простой вариант отключения программ из автозагрузки — это ис пользование утилиты MSCONFIG , которая появилась в составе Windows начиная с Windows 98. В Windows 95 вам придется воспользоваться ручным редактированием системного реестра, т. к. данной утилиты там нет.

Для активизации этой утилиты выберите пункт Пуск | Выполнить и наберите команду MSCONFIG . При этом откроется окно программы Настройка системы, в которой вы можете отредактировать абсолютно все файлы кон фигурации, при этом для разных версий Windows список этих файлов может быть различным. Так, например, в таких операционных системах, как Windows 95/98, вам будет предложено изменить файлы AUTOEXEC . BAT и CONFIG . SYS , в то время как в Windows XP их не будет, зато вы получите возможность редактирования файла BOOT . INI , о котором не упоминается в любой из Windows 9 x версии.

Преимущество утилиты MSCONFIG перед ручным редактированием реест ра заключается в том, что вы удаляете программы из автозагрузки временно, снимая галочку напротив той профаммы, которую желаете отключить. При этом, увидев свою ошибку, вы можете запустить утилиту и вновь установить галочку, тем самым разрешив запуск этой программы.

Примечание
Особенностью Windows ME является то , что утилита MSCONFIG . SYS показы вает не только содержимое всех файлов конфигурации , но и список всех загру жаемых VxD драйверов , что позволяет динамически управлять их загрузкой . Во всех остальных версиях Windows остается лишь вручную искать их в реест ре , хотя имеется неплохая возможность использовать более совершенную утилиту из ME , для чего достаточно скопировать ее на дискету на компьютере с установленной Windows ME или достать ее из дистрибутива .

Вы в любой момент можете проконтролировать "качество" удаления профам- мы из автозагрузки, просмотрев следующие разделы системного реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\ HKEY_USERS\DEFAULT\SOPTWARE\Microsoft\Windows\CurrentVersion\ HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\

В них имеются подразделы с названиями Run , RunOnce , RunOnceEx , Run - Services и RunServicesOnce , в которых, в свою очередь, прописаны пути к запускаемым файлам. Все подразделы со словом Once в названии предна значены для записи параметров, которые создаются различными програм мами при установке, а после перезагрузки они должны, по идее, автомати чески удаляться.

Также следует обратить внимание на содержимое файла WIN . INI , в частно сти первого раздела, в котором могут находиться строки load = или run =.

Очень часто в автозафузку прописывают свои модули следующие программы:

  • Computer Browser — обновляет список компьютеров в сети. Если ваш компьютер не подключен к локальной сети, этот файл из автозагрузки можно удалить;
  • DHCP Client — отвечает за автоматическое определение IP -адресов. Если ваш компьютер не подключен к локальной сети и не имеет подключен ного модема, то можно эту программу из автозагрузки отключить;
  • Event Log — профамма ведет служебный журнал, записывая в него нее события, происходящие на данном компьютере. Если вы уверены в стабильности работы всего оборудования и всех программ, то ее можно от ключить из автозафузки;
  • File Open — программа призвана ускорять поиск всех файлов, созданных пакетом Microsoft Office . В большинстве случаев ее можно отключить из автозагрузки;
  • IPSEC Policy Agent — сервис безопасности протокола TCP/IP. Если ком пьютер не подключен к локальной сети и не имеет подключенного мо дема, то программу можно смело удалять из автозагрузки;
  • Internat — индикатор раскладки клавиатуры в Windows 9 x . Часто дает сбои вкупе с индикатором, устанавливаемым с Microsoft Office XP , кото рый имеет название CTFMON ;
  • Load Power Profile — программа управляет функциями питания. Если не будете использовать на своем компьютере функции управления питани ем, тогда можно ее отключить из автозагрузки. Обратите внимание на то, что программа обычно вносит несколько ссылок в автозагрузку;
  • Messenger — принимает и отправляет сообщения, посланные админист ратором. Если нет сети и администратора, то можно отключить;
  • Microsoft Office Wrapper — программа является ускорителем запуска таких программ, как Word , Excel и т. п. В принципе, в автозагрузке эта программа особо не нужна;
  • Network Connections — занимается управлением объектами в каталоге Network and Dial - Up Connections , то есть всеми сетевыми соединениями. Если нет сети, то она становится ненужной;
  • PCHealth и StateMgr — отвечают за службу восстановления и автоматиче ского обновления Windows ME ;
  • Print Spooler — ускоряет печать; если принтера нет, то ее можно отклю чить;
  • Protected Storage — служит для защиты важных данных, ключей пользо вателей. Если ваш компьютер не подключен к локальной сети и не имеет подключенного модема, этот сервис можно отключить;
  • Remote Registry Service — позволяет удаленные манипуляции с реестром. Если вы не желаете этого допускать или ваш компьютер не подключен к локальной сети или глобальной сети Интернет, программу можно от ключить;
  • Scan Registry — при каждом удачном запуске операционной системы проверяет системный реестр на наличие в нем ошибок и создает резервную копию. В памяти компьютера не остается, так что можно ее не уби рать из автозагрузки, хотя именно она иногда становится причиной порчи реестра;
  • Scheduling Agent — планировщик задач . Если вы не используете его, отключите, т. к. он постоянно занимает некоторый объем оперативной памяти;
  • Server — обеспечивает общий доступ к принтерам, папкам и файлам, а также обеспечивает поддержку Remote Procedure Call . Если у вас нет ни сетевой платы, ни модема, он вам не нужен;
  • System Event Notification — отслеживает системные события. Если вы
    уверены, что все у вас работает нормально, то можно отключить;
  • System Tray — программа формирует некоторые значки в системной об
    ласти панели задач. Например, значок регулятора громкости. Если вы не
    используете эту область, лучше всего отключить эту программу;
  • Task Monitor — программа создает протокол запуска приложени-й, ис пользуемый в дальнейшем при оптимизации их расположения на диске при дефрагментации. Она постоянно занимает определенный объем памяти, при небольшом объеме которой данную программу лучше отклю чить;
  • Uninterruptible power supply — управляет работой источников бесперебой
    ного питания ( UPS ). Если таковых нет, то можно отключить;
  • Web Check Monitor — программа создает файл установки Explorer ' a при первом запуске, в повседневной работе она не нужна.

Иногда можно встретить упоминание файла WINSTART . BAT , который ис пользуется некоторыми программами для автоматической загрузки.

Особенностью операционных систем Windows NT является наличие боль шого числа запускаемых служб, которые активизируются независимо от же лания пользователя и "засоряют" тем самым оперативную память. Управле ние службами можно получить, зайдя в систему с правами администратора. Для этого следует запустить программу Пуск | Настройка | Панель управления | Администрирование | Сервисы. В результате появится список всех доступных служб на вашем компьютере. В данном случае нас интересует атрибут "тип запуска" каждой из имеющихся служб. Чтобы отключить запуск любых служб предварительно изучите вкладку Зависимости, это поможет вам избе жать ошибок и конфликтов. У каждой службы есть три варианта запуска:

  • Отключено — указанная служба не будет запущена при загрузке опера ционной системы, и в то же время ее не сможет запустить ни одна программа;
  • Авто — указанная служба автоматически стартует при каждом запуске Windows ;
  • Вручную — указанная служба не запускается автоматически, но она мо жет быть активизирована любой исполняемой программой.

Для изменения атрибута достаточно нажать правой кнопкой мыши на нуж ной службе и выбрать пункт Свойства. На вкладке Тип запуска выберите необходимый пункт и нажмите Применить для сохранения изменений.


Размещение временных файлов Windows

Каталог для временных файлов, особенно для Windows 2000/ XP , рекоменду ется переместить в корневой каталог, т. е. установить путь C :\ TEMP . Это избавит вас от проблем с установкой некоторых программ, которые некор ректно работают, если переменные ТМР и TEMP ссылаются на каталог с именем, содержащим пробелы или русские символы, либо если путь к не му имеет большую длину. Так, например, по умолчанию в операционных системах Windows 2000/ XP путь выглядит следующим образом:

C:\Documents and Settings\ Пользователь \ Ьоса 1 SettingsXTemp

Как видите, здесь имеется и длинный путь, и русские символы, и пробелы.


Настройка файла подкачки

Обычно файл подкачки, позволяющий организовать так называемую вирту альную память, в настройке не нуждается, но иногда может потребоваться его изменение или даже отключение. В большинстве случаев рекомендуется увеличить его начальный размер, но не всегда это дает положительный результат, поэтому рассмотрим более подробно все возможные варианты на стройки файла подкачки. Стоит отметить, что в основном размер файла подкачки определяется не потребностями операционной системы, а потребностями запускаемых программ, что особенно заметно при запуске графического редактора Adobe Photoshop и ему подобных.

В Windows 9 x параметры файла подкачки задаются при помощи следующих строк, которые содержатся в конфигурационном файле SYSTEM . INI :

  • PagingDrive = ИМЯ диска: — имя диска может быть любым ИЗ ДОСТУПНЫХ
  • во время запуска операционной системы. Компьютер будет работать быстрее, если файл подкачки будет расположен на отдельном диске (физическом, а не логическом), а также на более быстром жестком диске;
  • PagingFile = MM * диска:\путь\имя файла— Путь к файлу подкачки должен быть как можно короче, например, C :\ page . swp , чтобы уменьшить как время доступа к нему, так и возможность возникновения проблем.
    Например, из-за слишком длинного пути к нему или наличия в пути русских символов;
  • MinPagingFiieSize = pa 3 Mep файла подкачки (в килобайтах) — естествен-
    но, что этот размер не должен быть слишком маленьким. Можно встре
    тить рекомендации о том, чтобы этот размер был равен двукратному раз
    меру оперативной памяти или размеру, равному объему оперативной
    памяти, умноженному на 2,5;
  • MaxPagingFileSize = paSMep файла подкачки (в килобайтах) — естествен-
  • но, что размер этого файла не должен быть меньше минимального раз мера, хотя иногда можно встретить рекомендации, что они должны быть равны друг другу. Стоит отметить, что, ограничив максимальный размер файла подкачки, можно устранить проблемы с запуском некоторых игро вых программ, например NFS 5;
  • conservativeSwapFiieusage — при значении, равном I , операционная система по максимуму будет использовать физическую оперативную память, в противном же случае (значение 0) Windows будет регулярно вы гружать неиспользуемые модули в файл подкачки, из-за чего последний постоянно разрастается во время работы в течение, например, всего ра бочего дня без перезагрузки компьютера. Включать этот режим стоит только при наличии 128 Мбайт и более памяти;
  • paging = off — данная строка позволяет полностью отключить использо
    вание файла подкачки, что, например, вполне рационально при наличии
    оперативной памяти 1 Гбайт.

По умолчанию в операционных системах Windows 9 x файл подкачки разме щается в файле WIN 386. SWP , который располагается в рабочем каталоге Windows .

В операционных системах Windows 2000/ XP файл подкачки сохраняется в файле PAGEFILE . SYS . По умолчанию устанавливается размер файла под качки равным объему физической памяти плюс 12 Мб.


Редактирование файла MSDOS . SYS

Во времена широкого распространения MS - DOS файл MSDOS . SYS играл важную роль в ее работе. Фактически он являлся "драйвером", необходимым для нормального функционирования операционной системы. В настоящее время он используется лишь для обеспечения совместимости со старыми программами. К тому же, заметно изменилась структура файла — если раньше он напоминал по структуре запускаемый файл, почти не подлежащий редактированию, то сейчас с ним возможно работать, как с обыкновенным текстовым файлом.

Правила редактирования файла MSDOS . SYS сводятся к изменению, удале нию или вводу новых строк с параметрами, влияющими на загрузку системы (табл. 9.1). Каждый параметр пишется с новой строки в строго определенной секции, после него ставится знак равенства <=>, после чего указывает ся значение параметра. Обратите внимание на то, что никаких других зна ков ставить ни в коем случае нельзя.

Таблица 9.1. Основные параметры файла конфигурации MSDOS . SYS

Секция [PATH] | Описание
HostWinBootDrv | Определяет загрузочный диск. Например, С (без двоеточия и слэша)
WinBootDir | Определяет расположение необходимых загрузочных фай- лов. По умолчанию — каталог, указанный при установке
WinDir | Определяет расположение каталога Windows, указанного при установке. Например, C:\WINDOWS
UninstallDir | Определяет расположение старых системных файлов в слу- чае, если при обновлении операционной системы было при- нято решение сохранить старые системные файлы
BootDelay=n | Устанавливает задержку в п секунд при загрузке для того, чтобы дать пользователю возможность успеть нажать кла- вишу <F4> или <F8> для вывода меню загрузки. Значение по умолчанию — "2". BootDelay=0 запрещает задержку, что немного ускоряет загрузку
BootSafe | Позволяет всегда загружаться в безопасном режиме (зна- чение "1"). Значение по умолчанию — "0"
BootGUI | Загрузка с графической оболочкой. Значение по умолча- нию — "1". Если же сделать его равным нулю, то графиче- ская оболочка не загружается, поэтому компьютер загружа- ется в MS-DOS с приглашением вроде С: \>
BootKeys | При значении "1" (по умолчанию) разрешает пользоваться при загрузке клавишами <F5>, <F6> и <F8>. Установка в значение "0" запрещает задержку при загрузке и блокирует возможность вывода загрузочного меню. Пользоваться функцией не рекомендуется, т. к. при этом вы теряете воз- можность запуска системы в безопасном режиме
BootMenu | Значение по умолчанию— "0". Установка в значение "1", предписывает Windows, не дожидаясь нажатия <F8>, сразу выводить загрузочное меню
BootMenuDefault=n | Выбирает пункт в загрузочном меню. Значение по умолча- нию — "3" для компьютеров без сетевых компонент и "4" для сетевых компьютеров
BootMenuDelay=n | Время, в течение которого можно успеть сделать выбор в загрузочном меню. Значение по умолчанию — "30"
BootSave | При значении параметра, равном "0", Windows стартует нормально, при значении, равном "1", Windows стартует в безопасном режиме
BootMuIti | Значение по умолчанию— "0". Установка в значение "1" предписывает Windows включить режим загрузки по не- скольким вариантам, в том числе и загрузку предыдущей версии DOS. Если при следующей загрузке, когда на экран выводится сообщение "Идет загрузка Windows xx", нажать клавишу <F4>, то начнется загрузка предыдущей версии DOS. Учтите, что это верно только для компьютеров, где Windows не является изначально установленной операцион- ной системой. Если же в процессе загрузки нажать клавишу <F8>, появится загрузочное меню, в котором будут предло- жены различные варианты загрузки
BootWarn | Разрешает предупреждение о загрузке в безопасном режи- ме. Значение по умолчанию — "1"
BootWin | Разрешает использование Windows в качестве операцион- ной системы по умолчанию. Установка этого параметра в "0" приведет к загрузке предыдущей версии DOS. Значение по умолчанию — "1"
DblSpace | Разрешает автоматическую загрузку DBLSPACE.BIN. Зна- чение по умолчанию — "1"
DoubleBuffer | Разрешает двойную буферизацию для SCSI-контроллеров. Значение по умолчанию — "0"
DrvSpace | Разрешает автоматическую загрузку DRVSPACE.BIN. Зна- чение по умолчанию — "1"
LoadTop | Разрешает загрузку COMMAND.COM или DRVSPACE.BIN в верхнюю память. Значение по умолчанию— "1". Рекоменду- ется устанавливать в "0" при работе с NetWare или любыми приложениями, использующими эту область памяти
Logo | Разрешает показывать логотип. Значение по умолчанию — "1". Установка в "0" отменяет вывод заставки при загруз- ке Windows, а также предотвращает перехват некоторых прерываний, который может привести к несовместимости с некоторыми диспетчерами памяти от независимых по- ставщиков
Network | Разрешает пункт загрузочного меню "Safe Mode With Networking". Значение по умолчанию— "1", для сетевых компьютеров. При отсутствии сетевой поддержки должно быть установлено в "0"
Autoscan=1 | Запуск ScanDisk при некорректном завершении работы Windows: "0" — блокирует запуск ScanDisk; "1" — запускает ScanDisk, а затем ожидает действий пользо- вателя; "2" — запускает ScanDisk, а затем продолжает запуск Windows
DisableLog=1 | "0" — создание файла отчета загрузки; "1" — отключить создание файла отчета загрузки
BootFailSafe=1 | "0" — запрет загрузки в безопасном режиме; "1" — разрешение загрузки в безопасном режиме
LoadTop=1 | "0" — разрешает загрузку некоторых программ и драйверов; "1" — запрещает


Редактирование CONFIG . SYS и AUTOEXEC . BAT

Для того чтобы исключить одну из строк из автозагрузки, не обязательно удалять ее, вполне достаточно написать в начале строки команду rem , кото рая означает начало комментария, игнорируемого при загрузке и исполь зуемого для справки. Например, если вы хотите пометить версию запускаемого драйвера (всего ведь не запомнишь).

Если в файле CONFIG . SYS явно не указана команда dos = noauto , в таком случае операционная система Windows по умолчанию загружает следующий "виртуальный" файл конфигурации:

DOS=HIGH, AUTO

DEVICE= С :\WINDOWS\HYMEM.SYS

DEVICE= C:\WINDOWS\IFSHLP.SYS

DEVICE= C:\WINDOWS\SETVER.EXE

FILESHIGH=30

LASTDRIVEHIGH=Z

BUFFERSHIGH=30

STACKSHIGH=9,2 56

SHELL=COMMAND.COM /p

FCBSHIGH=4

Эти строки загружаются в память компьютера даже в том случае, когда файл вообще отсутствует.

Так же, как и в случае с CONFIG . SYS , существует "скрытый" файл AUTOEXEC . BAT :

@ ЕСНО OFF

NET START

SET TMP=C:\WINDOWS\TEMP

SET TEMP=C:\WINDOWS\TEMP

SET COMSPEC=C:\COMMAND.COM

PROMPT $p$g

PATH С :\WINDOWS; C:\WINDOWS\COMMAND

При наличии в корне системного диска файла DBLSPACE . BIN или DRVSPACE . BIN Windows загрузит соответствующий драйвер сжатых дис ков, даже если вы не используете эту функцию, поэтому не забудьте удалить эти файлы!

Многие пользователи часто замечали, что помимо основных файлов в корневом каталоге содержатся файлы AUTOEXEC . DOS и CONFIG . DOS , кото рые, по всей видимости, должны играть роль конфигурационных файлов при загрузке системы в режиме эмуляции MS - DOS , но это не совсем так. При перезагрузке компьютера в режиме эмуляции MS -' DOS в память компьютера совершенно считывается другой файл — C :\ WINDOWS \ dosstart . bat . Туда следует вписать все необходимые драйверы. Для загрузки тех драйве ров, которые запускаются при помощи файла CONFIG . SYS , рекомендуется воспользоваться программой CTLOAD , например:

C:\CREATIVE\DRV\CTLOAD C:\CREATIVE\DRV\SBIDE.SYS /D:MSCD001 /V/P:1FO,14

Эту программу можно найти на официальном сайте компании Creative по адресу: http :// www . europe . creative . com / techknow / tech / ftp / ftp - sbl 6 awe . asp .

В операционной системе Windows XP существуют аналоги файлов AUTOEXEC . BAT и CONFIG . SYS , применявшихся в семействе Windows 9 x . Эти файлы имеют названия AUTOEXEC . NT и CONFIG . NT и расположены в каталоге C :\ WINDOWS \ system 32\.

Содержимое файлов влияет на работу только тех программ, которые выпол няются в окне эмуляции MS - DOS , на работу самой графической оболочки никакого влияния они не оказывают. Через AUTOEXEC . NT можно настро ить использование ресурсов (порты ввода/вывода, прерывания IRQ , каналы DMA ). Значения, которые установлены по умолчанию строкой set blaster = a 220 is di рззо, соответствуют "традиционным значениям", которые считались стандартными для SB , и менять их. как правило, не при ходится. Причем совершенно не имеет значения, какие ресурсы реально использует ваша звуковая плата, при работе в окне эмуляции все порты яв ляются виртуальными. Также следует отметить, что при указании путей в AUTOEXEC . NT могут некорректно себя вести некоторые 16-разрядные приложения, поэтому рекомендуется все необходимые пути прописать в за кладке Переменные среды, которую можно открыть при запуске ярлыка Система | Панель управления и выбора закладки Дополнительно.

Примечание В операционной системе Windows 2000 имеется возможность добавления путей при помощи файла AUTOEXEC . BAT , находящегося в корне диска , коман дой PATH .


Редактирование файла BOOT . INI

Как уже говорилось, файл BOOT . INI отвечает за порядок загрузки всех опе рационных систем, установленных на данном компьютере, и еще позволяет задавать некоторые параметры загрузки этих систем. Начинается файл разделом [ boot loader ], содержащем всего два параметра:

  • Timeout — определяет время в секундах, которое ждет система, прежде чем начать загружать систему по умолчанию в том случае, когда на ком пьютере установлено несколько операционных систем;
  • Default — определяет систему, которая грузится по умолчанию.

Второй раздел, [ operating system ], содержит список возможных к загрузке операционных систем. Для каждой системы указывается ее местоположение с использованием имен ARC ( Advanced RISC Computer ).

  • SCSI (*) или MULTI (*) — элемент SCSI (*) используется в случае кон троллера SCSI с отключенным BIOS . Элемент MULTI (*) используется для дисков всех остальных типов, включая IDE , EIDE , ESDI и SCSI с включенным BIOS . (*) — номер адаптера, с которого осуществляется загрузка. Адаптеры нумеруются с нуля, начиная с контроллера, располо женного ближе к слоту 0 на материнской плате;
  • DISK (*) — если (1) = SCSI (*), то равен логическому номеру устройства ( LUN ), установленному для диска. Если (1) = MULTII (*), то всегда ра вен нулю;
  • RDISK (*) — если (1) = MULTI (*), то равен номеру диска в цепочке, счет дисков начинается с 0. Если (1) = MULTI (*), то всегда равен нулю;
  • PARTITION (*) — определяет дисковый раздел, содержащий файлы опе рационной системы. В отличие от всех остальных элементов имен ARC , нумерация разделов начинается с 1, т. е. первый раздел обозначается PARTITION (1), второй - PARTITION (2) и т. д.;
  • PATH — определяет каталог (или подкаталог) раздела, в котором нахо дятся файлы операционной системы.
  • Кроме этого, в кавычках прописывается текст, который будет виден в пунк те выбора этой ОС в стартовом меню. После него могут быть расположены и ключи, которые влияют на загрузку операционной системы. Например, для Windows XP возможны следующие ключи:
  • basevideo — с этим ключом система будет использовать только стан дартный VGA -драйвер, поэтому параметр может пригодиться, если вы на некоторое время устанавливаете другую модель видеоплаты, но вам не хочется переустанавливать драйверы;
  • fastdetect — обычно ставится автоматически при инсталляции систе мы. При установке этого ключа система не определяет все Plug and Play - устройства в процессе загрузки;
  • махмем — определяет максимальный размер оперативной памяти, кото рый может использоваться системой;
  • noguiboot — при использовании этого ключа не будет рисоваться цветная заставка при загрузке. Может использоваться теми, кто не желает смотреть на эту картинку при частоте 60 Гц. При этом следует учитывать, что этим вы блокируете и вывод "синего экрана смерти" в случае сбоя;
  • noserialmice = [сом 1,2,3] — при использовании этого параметра не будет определяться мышь, подключенная к СОМ-порту для портов, пере численных в скобках. Если номера портов не указывать, то мышь не бу дет определяться на всех портах;
  • bootlog — при задании этого параметра система будет писать лог за грузки в % SystemRoot %\ Nbtlog . txt . Параметр можно использовать, чтобы найти причину, почему система может загрузиться только в безопасном режиме ( SAFE MODE );
  • safeboot — при его установке система загрузится в безопасном режиме ( SAFE MODE ). To же самое можно сделать, нажав < F 8> в начале загруз ки системы. Через двоеточие можно задать несколько параметров для / safeboot : minimal — минимальная конфигурация; network — с под держкой сети; dsrepair — доступна только в NET Server и позволяет восстановить Active Directory с заблаговременно сделанной резервной копии; alternateshell — позволяет использовать альтернативные гра фические оболочки. По умолчанию с системой ставится только Explorer (стандартная оболочка) и Progman (осталась в наследство от Windows 3.11 и NT 3.5);
  • sos — отображает на экране список загружаемых драйверов. Может помочь выяснить, на чем система спотыкается при загрузке;
  • baudrate — этот параметр указывает скорость, с которой будет работать СОМ-порт для отладки системы. Если не указать конкретную скорость, то будет 9600 для модема и 19200 для нуль-модемного кабеля. При вклю чении этого параметра автоматически ставится параметр / debug ;
  • crashdebug — с этим параметром загружается отладчик, остающийся в неактивном состоянии до тех пор, пока не произойдет ошибка ядра. Может использоваться разработчиками программного обеспечения;
  • debugport = com * — указывает номер СОМ-порта (* должна быть номе ром порта), используемого отладчиком. Автоматически включает ключ / DEBUG ;
  • debug — загружается отладчик, который может быть активизирован другим компьютером через любой подключенный СОМ-порт. Может ис пользоваться разработчиками программного обеспечения;
  • nodebug — на экран не выводится отладочная информация;
  • hal — указывает имя файла, который должен использоваться как hal . dll после загрузки;
  • kernel — указывает имя файла, который должен использоваться как ntoskrnl . dll после загрузки.


Редактирование системного реестра

Несмотря на то, что системный реестр на первый взгляд представляет собой единую структуру, он состоит из нескольких файлов, которые, в принципе, вполне можно редактировать по отдельности без ущерба для остальных файлов. Правда, при этом следует учитывать, что все внесенные изменения должны быть корректными и не должны содержать ошибок.

Для операционных систем семейства Windows 9 x характерны следующие файлы, логически составляющие системный реестр:

WIN . INI и SYSTEM . INI — эти файлы конфигурации впервые были при менены еще в Windows З.хх, а сегодня остались в основном только для поддержания совместимости со старыми программами (оборудованием). Эти файлы имеют текстовый формат и их можно редактировать при по мощи любого текстового редактора типа Блокнот и при помощи файло вого менеджера вроде NC . В Windows 2000/ XP эти файлы оставлены только для совместимости со старыми программами;

SYSTEM . DAT и USER . DAT — основные файлы системного реестра. Оба файла имеют довольно сложную структуру, их редактирование возможно только при помощи редактора реестра, вызываемого командой REGEDIT в строке Выполнить или в командной строке окна эмуляции MS - DOS ;

CLASSES . DAT — этот файл присутствует только в Windows ME , которая почти по традиции "отличается" от остальных представителей Windows 9 x . Он призван заменить собой файлы WIN . INI и SYSTEM . INI . Этим ново введением компания Microsoft впервые попыталась внести новую моду в мир операционных систем — отказа от старых программ в пользу новых.

В основном это связано, думаю, с поддержкой производителя программ ного обеспечения.

Как видите, физическая структура системного реестра достаточно сложна, но все это не столько результат прихоти компании Microsoft , сколько необ ходимость, связанная с неудержимым прогрессом. Дело в том, что файлы с расширением INI , которые использовались для настройки операционной системы ранее, имеют серьезнейшее ограничение — их максимальный раз мер не должен превышать 64 Кбайт.

Для ручного редактирования системного реестра используется утилита REGEDIT ( REGEDT 32 для Windows 2000), которая содержится в составе Windows , начиная с 95-й версии.

Примечани е Если вы не уверены в своих действиях , ничего не удаляйте и не меняйте в сис темном реестре , в противном случае некорректное изменение данных может привести к сбоям в работе Windows и в лучшем случае можно будет восстано вить ее работу только из резервной копии .

Независимо от версии операционной системы структура системного реестра имеет постоянный характер и состоит из шести разделов, так называемых ветвей, каждый из которых включает подразделы, отображаемые в левой части окна в виде значка обычной папки. Конечным элементом этого свое образного дерева являются ключи, которые непосредственно влияют на на стройку операционной системы, хотя для некоторых программ достаточно наличия пустого раздела.

? HKEY _ CLASSES _ ROOT

В этом разделе содержатся ключи двух типов. Первый тип хранит информацию о расширении файла. Эти данные используются для создания ассоциации файлов с определенными программами, например, файлы с расширением DOC связаны в основном с программой Microsoft Word и т. п.

Второй тип ключей как раз связан с параметрами ассоциаций. Здесь хра нятся для каждого расширения все команды, отображаемые при вызове контекстного меню в Проводнике (при нажатии правой кнопки мыши на конкретном файле). Также здесь хранится информация о значке, используемом для каждого типа файла.

При ручном редактировании этого раздела вы можете самостоятельно изменять ассоциации файлов, например если вы ошибочно указали не ту программу, или же изменять значки, используемые для файлов, а также редактировать количество и действие команд, вызываемых из контекст ного меню.

О HKEY _ CURRENT _ USER

Этот раздел содержит информацию о настройках текущего пользователя. Это все настройки меню Пуск, рабочего стола, клавиатуры и т. п.

Информация в этом разделе является динамической. Операционная сис тема после своего запуска автоматически копирует в этот раздел все необходимые данные из других разделов, а при смене пользователя или вы ключении компьютера обратно сохраняет их. В отличие от этого раздела, все остальные являются статическими.

Из вышесказанного можно сделать вывод, что при ручном редактирова нии можно внести изменения в настройки только текущего пользователя, на всех остальных пользователей ваши действия влияния не окажут.

? HKEY _ LOCAL _ MACHINE

Этот раздел содержит все основные сведения об аппаратном обеспечении компьютера, включая установленные драйверы устройств и конфигураци онную информацию. В этом разделе содержится информация глобального характера, при этом некоторые программы хранят здесь информацию о па раметрах установки. Это такие "монстры", как Microsoft Office и т. п.

При ручном редактировании этого раздела следует иметь в виду, что если удалить информацию о каком-нибудь драйвере, тогда операционная система не сможет нормально работать с соответствующим устройством, хо тя можно использовать этот способ для принудительного удаления не корректно работающих драйверов, которые не поддаются удалению другими способами.

? HKEY _ USERS

В этом разделе содержится список всех пользователей, их настройки и прочая информация, носящая, скорее, справочный характер.

При ручном редактировании раздела следует иметь в виду, что все на стройки текущего пользователя динамически копируются в вышеописанный раздел HKEY _ CURRENT USER и записываются здесь только при завершении Windows или смене пользователя.

Редактированием раздела можно изменить настройки другого пользователя, но в некоторых случаях для каждого отдельного пользователя может быть создана отдельная копия системного реестра, что может сильно затруднить изменение конфигурации пользователей, так и получение спра вочной информации о каждом из них.

? HKEY _ CURRENT _ CONFIG

Этот раздел содержит два основных подраздела: Display и System . Подраздел Display определяет шрифты, используемые операционной сис темой для вывода на экран монитора (ветвь Fonts ), а также текущее разрешение экрана и количество бит, используемых для отображения цвета (ветвь Setting ). Три шрифта, перечисленных в этом разделе, являются шрифтами по умолчанию, которые система использует для отображения значков и меню приложений. Эти настройки можно изменить в диалоговом окне свойств экрана.

В подразделе System пользователя может заинтересовать только ветвь Printers , где содержится список всех установленных принтеров, правда, за исключением всех сетевых принтеров.

? HKEY _ DYN _ DATA

Этот раздел содержит два подраздела: Config Manager и PerfStats . Из первого подраздела операционная система берет информацию, ото бражаемую во вкладке Устройства (Диспетчер устройств) диалогового ок на Система, которое можно открыть, используя Панель управления. Из второго подраздела берет информацию Системный монитор.

Очистка системного реестра от сбойных ссылок

В первую очередь хотелось бы обратить ваше внимание на утилиту, предла гаемую компанией Microsoft , которая называется RegClean . Данная про грамма позволяет анализировать ключи реестра, расположенные в разделе HKEY _ CLASSES _ ROOT , и находить ключи, содержащие ошибочные значе ния. При этом все удаленные записи копируются в специальный файл с расширением REG , поэтому любое изменение вы можете обратить запус ком данного файла и внесением удаленной записи обратно в реестр. К со жалению, программа RegClean не является универсальной программой и не способна находить и исправлять ошибки в других разделах реестра.

Более известной и распространенной сегодня является программа Norton WinDoctor , которая является частью не менее известного пакета программ Norton SystemWorks . Она позволяет не только вносить изменения в систем ный реестр, но также и изменять параметры ярлыков, например изменяя путь, указанный в свойствах, на корректный, действительно соответствую щий нужному файлу. Так же, как и остальные подобные программы, перед внесением изменений в настройки системного реестра, она создает так на зываемый "файл отката", позволяющий достаточно быстро вернуть обратно все прежние настройки.

Самый главный нюанс в очистке системного реестра от якобы сбойных ссылок — это то, что для возвращения прежних настроек требуется загру зить компьютер хотя бы в безопасном режиме, позволяющем импортировать "файл отката" обратно в реестр. В противном случае вам не избежать переус тановки операционной системы, конечно, только если вы не создали ре зервной копии реестра на этот случай.

Слежение за изменениями в системном реестре

Один из наиболее интересных представителей программ, позволяющих сле дить за изменениями в системном реестре, — это Registry Monitor . Официаль ный сайт данной профаммы находится по адресу http :// www . sysinternals . com . Эта программа способна отслеживать абсолютно ВСЕ обращения к реестру. При этом совершенно не важно, что вы делаете — устанавливаете, удаляете или просто запускаете программы (в том числе игровые). Операционная система постоянно при своей работе обращается к реестру и все эти обра щения можно записать при помощи данной программы. Наиболее важным может оказаться слежение за автозагрузкой. Еще одним плюсом программы является возможность повторного запуска программ с ограниченным сро ком бесплатного использования (так называемых trial -программ). Вам доста точно отследить все записи, внесенные определенной программой, а когда она перестанет работать, вручную удалить все ссылки, созданные программой, и снова установить ее.

Еще одна программа из категории "шпионов" — RegShot . В отличие от пре дыдущей программы, эта позволяет делать моментальный "снимок" систем ного реестра до и после установки программы, а потом путем сравнения двух "снимков" определять, где и что прописала установленная программа.


Удаление " лишних " компонентов Windows

Чтобы удалить неиспользуемые компоненты Windows 2000 так же, как, на пример, в Windows 9 x , следует сделать следующее. Чтобы в программе Установка/удаление программ появились все компоненты, которые можно удалить, надо найти файл под названием SYSOC . INF , расположенный в ка талоге C :\ WINDOWS \ INF , и возле необходимых компонентов убрать слово 1 IDE или hide .


Если не работает мышь

Комбинация клавиш | Действие, вызываемое нажатием
<ESC> | Завершить текущую задачу
<F1> | Вызов справки Windows или текущей программы
<F2> | Переименовать выделенный файл или каталог
<F3> или <WIN>+<F> | Запуск поиска файлов, каталогов и т. д.
<F4> | Открыть список всех файлов и каталогов
<F5> или <CTRL>+<R> | Обновить содержимое диска (каталога)
<F6>, <TAB>, <CTRL>+<TAB> или <SHIFT>+<TAB> | Переход между окнами запущенной программы, на- пример Проводника
<F10> | Вызов меню
<CTRL>+<A> | Выделить все файлы и подкаталоги, кроме помеченных атрибутом "скрытый"
<CTRL>+<C> | Скопировать файл, фрагмент текста и т. п.
<CTRL>+<X> | Вырезать файл, фрагмент текста и т. п.
<CTRL>+<V> | Вставить файл, фрагмент текста и т. п.
<CTRL>+<Z> | Отмена последнего выполненного действия
<CTRL>+<ESC> | Равнозначно нажатию кнопки Пуск левой кнопкой мыши
<CTRL>+<WIN>+<F> | Запуск поиска компьютера в сети
<CTRL>+<F4> | Закрытие активного окна, программы или документа
<SHIFT>+<DELETE> | Удаление файла или каталога, минуя корзину
<SHIFT>+<F10> | Вызов контекстного меню выделенного объекта (фай- ла, каталога, фрагмента текста)
<А1_Т>+подчеркнутая буква | Выполнить команду меню
<ALT>+<ENTER> | Свойства объекта (файла или каталога)
<ALT>+<TAB> | Переключение между запущенными программами
<ALT>+<F4> | Закрытие активной программы
<А1_Т>+<Дефис> | Отображение системного меню документа (дочернего окна) для управления размером и местоположением окна
<А1_Т>+<Пробел> | Отображение системного меню программы для управ- ления размером и местоположением окна
<ALT>+<^> | Вернуться назад
<ALT>+<^> | Вернуться вперед
<BACKSPACE> | Перейти к родительскому каталогу
<WIN>+<E> | Вызов проводника
<WIN>+<F> | Запуск поиска файлов, каталогов и т. д.
<WIN>+<M> | Сворачивает все развернутые окна
<WIN>+<SHIFT>+<M> | Разворачивает все окна обратно
<WIN>+<D> | Сворачивает и разворачивает все окна
<WIN>+<R> | Вызывает окно Выполнить
<WIN>+<BREAK> | Вызывает окно Свойства
<WIN>+<F1> | Вызов справки Windows, независимо от запущенных программ
<WIN>+<TAB> | Переход между приложениями на панели задач


FAQ ( ответы на часто задаваемые вопросы )

Вопрос: Ярлыки на рабочем столе вдруг стали черными. Перезагрузка ком пьютера результата не дает. Что делать?

Ответ: Просто удалите файл кэширования ярлыков, который находится в рабочем каталоге Windows и называется ShelllconCashe .

Вопрос: При загрузке операционной системы запрашивается пароль. Как убрать это окно?

Ответ: Откройте Панель управления, выберите Пароли | Профили пользователей, установите галочку в пункте Все пользователи работают с единой конфигура цией. Перезагрузите компьютер, введите в окне запроса любое имя с пустым паролем, тогда при последующей загрузке у вас уже ничего не будет спра шиваться. При наличии на вашем компьютере сетевой платы в свойствах Сетевого окружения укажите Обычный вход в Windows , а не Клиент сетей Microsoft или Семейный вход в систему. Обычно последний вариант уста навливается по умолчанию.

Если вы пользуетесь операционной системой Windows 2000/ XP , тогда вам следует загрузиться в режиме администратора и снять галочку с пункта Требовать ввода имени пользователя и пароля, что можно сделать, открыв вкладку Пользователи Панели управления.

Вопрос: Операционная система Windows 2000/ XP работает несколько мед леннее, чем это было в случае с Windows 98. Отчего это может быть? Ответ: Любая операционная система семейства Windows NT является более "тяжелой" для компьютера, чем Windows 9 x . Это заметно не только по рабо те, но и по процессу загрузки, который длится значительно дольше, чем в случае, например, с Windows 98. Все дело в несколько ином принципе работы и в большем количестве различных служб, запускаемых при загрузке компьютера. В частности, система NTFS , а точнее модуль поддержки этой файловой системы, занимает немало оперативной памяти. Это не должно вас сильно волновать, ведь главное преимущество систем на базе Windows NT — это стабильность работы, а вовсе не скорость. Если вы все-таки хотите немного ускорить работу Windows 2000/ NT , вос пользуйтесь одной из нижеследующих рекомендаций:

  • отключите все визуальные эффекты;
  • используйте файловую систему FAT32;
  • удалите все "лишние" программы из автозагрузки;
  • деинсталлируйте все ненужные компоненты операционной системы;
  • отключите все виды антивирусных мониторов.

Вопрос:

Сильно надоели постоянно появляющиеся на экране монитора со общения программы Windows Messenger . Можно ли от нее избавиться?

Ответ: Воспользуйтесь программой типа XP _ ANTISPY , которая позволяет быстро деинсталлировать эту программу, хотя можно это сделать и "вруч ную". Создайте на жестком диске файл, например, с названием KILLER . BAT и пропишите в нем строки:

undll32 advpack.dll,LaunchlNFSection %WinDir%\inf\msmsgs.inf,BLC.Remove echo Disabling it from running in the future... echo REGEDIT4&gt;%temp%\nomsngr.reg echo

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Messenger\Client]&gt;&gt; %temp%\no

msngr.reg

echo "PreventRun"=dword:OOOOOOOl&gt;&gt;%temp%\nomsngr.reg echo "PreventAutoRun"=dword:OOOOOOOl&gt;&gt;%temp%\nomsngr.reg echo "PreventAutoUpdate"=dword:OOOOOOOl&gt;&gt;%temp%\nomsngr.reg

echo "PreventBackgroundDownload"=dword:OOOOOOOl&gt;&gt; %temp%\nomsngr.reg

echo "Disabled"=dword:OOOOOOOl&gt;&gt;%temp%\nomsngr.reg regedit /s %temp%\nomsngr.reg

Перед запуском этого файла закройте программу Windows Messenger , после удаления обязательно перезагрузите компьютер.

Вопрос: Установил программу, а после перезагрузки не работает одно из устройств. Неужто придется переустанавливать операционную систему?

Ответ: Загрузите компьютер с загрузочной дискеты или компакт-диска и откройте рабочий каталог Windows . Вручную или при помощи любого

файлового менеджера (например, NC ) переименуйте файлы SYSTEM . DA 0 и USER . DA 0 в SYSTEM . DAT и USER . DAT , что позволит вернуть прежние настройки компьютера, после чего можно перезагружаться в нормальном режиме.

Если вы не можете осуществить эту операцию ввиду того, что эти файлы имеют атрибуты "системный" и "скрытый", можно воспользоваться утилитой ATTRIB . При этом ее следует запускать с ключами — <- S > для снятия ат рибута "системный", <-Н> для снятия атрибута "скрытый" или <- R > для снятия атрибута "только для чтения".

Способ может быть использован для любой версии Windows 9 x , для Windows XP стоит попробовать воспользоваться "точкой отката".


ПРИЛОЖЕНИЕ 1. ПРЕВРАТИ СВОЙ САЙТ В ПОРТАЛ

  • Преврати свой сайт в портал
  • Мир информеров
  • С миру по нитке
  • Рабочий стол современного человека


ПРЕВРАТИ СВОЙ САЙТ В ПОРТАЛ...

Секрет популярности многих сайтов - в том, что они предоставляют посетителям именно ту информацию, которая их интересует. А что интересует практически всех, независимо от склонностей, увлечений, профессии? Да наверное - прогноз погоды, курс доллара. Еще, разумеется, новости - как общемировые, так и связанные с профессией посетителя.
Всю подобную информацию предоставляют крупные сайты, так называемые порталы. Название "портал" как раз и обозначает то, что сайт универсальный и вполне может являться "точкой входа" в Интернет. Зайдя на портал, пользователь может сразу узнать и о том, что нового приключилось в мире с момента его последнего сеанса работы в Сети, и о том, какую одежду следует одевать сегодня и завтра, и даже о том, у кого из его знакомых в этот день именины.
Сделать полноценный портал и поддерживать его - задача нелегкая и довольно дорогая. И действительно - нужно контактировать и с новостными агентствами, и с Гидрометеоцентром, и изучать литературу различного назначения, дабы ежедневно предоставлять посетителям свежую и полезную информацию.
Однако если вам вдруг захочется стать владельцем портала, то вы сможете это сделать за полчаса! Причем не только практически не потратив денег, но даже и не связывая себя необходимостью впоследствии к этому порталу прикасаться. Если же у вас есть сайт, то за те же полчаса вы превратите его в многофункциональный информационный центр, добавив на него массу полезной информации и сервисов. Обновлять же такой сайт вам придется лишь тогда, когда вы решите добавить на него вашу авторскую информацию.
Как такое возможно? Посредством использования информеров.
Информер в общем случае - это некий содержащий информацию объект (графическое изображение, текст или их сочетание), который предоставляется владельцем того или иного Интернет-ресурса всем желающим для встраивания в создаваемые ими web-страницы. При этом при загрузке web-страницы, содержащей информер, сам информер загружается с ресурса, его предоставившего. Обновления и изменения информера - прерогатива его владельца: от web-мастеров, встроивших информер в свои web-страницы, никаких усилий по обновлению данных, поставляемых через информер, не требуется.
В настоящее время в Интернете есть немало сайтов, предоставляющих информеры. Ниже рассказано о некоторых из них (рассмотрена только русская часть Сети).


МИР ИНФОРМЕРОВ

Самый крупный сайт, фактически посвященный информерам и только информерам - это, по моему мнению, созданный при покровительстве компании "Росбизнесконсалтинг" сайт www.informer.ru (рис. П. 1.1).

Рис. П. 1.1. Мир информеров - каждому web-мастеру

Количество информеров на этом сайте весьма велико. Практически каждый web-мастер найдет себе что-нибудь по вкусу. Практически все информеры - графические, т. е. представляют собой рисунок в формате Gif (встраивание такового на страницу производится простым помещением на нее тэга <img згс="адрес информера">), однако есть и основанные на Javascript, и просто текстовые. Коллекция www.informer.ru состоит не только из произведений разработчиков этого сайта, но в ней представлены ведений разработчиков этого сайта, но в ней представлены и предоставляемые другими сайтами аналогичные ресурсы.
К примеру, вы хотите, чтобы ваши посетители при каждом заходе на ваш сайт могли познакомиться с прогнозом погоды? Выберите один или два из целых пятнадцати и установите! Наиболее приглянувшиеся мне информеры я привожу на рис. П. 1.2. Или, скажем, вы желаете дать посетителям возможность при каждом заходе на вашу страничку узнавать курс доллара. В чём же дело? Поставьте на ней парочку соответствующих картинок (рис. П. 1.3). Есть и информеры с графическим изображением колебания курса, и с данными о курсах множества других валют, не только доллара (рис. П. 1.4).

Рис. П. 1.2. Погода - к вашим услугам. Вернее, к услугам ваших посетителей

Рис. П. 1.3. Информеры курсов валют. Выбирай на вкус

Рис. П. 1.4. Можно выбрать, например, такой..

Для установки понравившегося информера необходимо нажать на ссылку "Установить" или "Выбрать" (см. рис. П. 1.1). На странице, открывающейся по такой ссылке, будет небольшая форма (рис. П. 1.5), где в соответствующее поле вам придется ввести свой адрес электронной почты и адрес вашего сайта. Последнее нужно в основном для учета количества информеров, так как никто, наверное, не будет выдвигать какие-либо претензии, если вы, скажем, установите информер на другом сайте, не указанном вами в этой форме.

Рис. П. 1.5. Все, что от вас требуется - ваш адрес электронной почты

После нажатия кнопки отправки данных формы введенная в нее информация попадет в базу данных www.informer.ru, и спустя некоторое время вам на указанный вами в форме адрес придет письмо с кодом заказанного вами информера, который уже и следует вставлять в web-страницы вашего сайта. Информеры предоставляются абсолютно бесплатно. Единственное, что требуют создатели http://www.informer.ru взамен, так это включение ссылки на их сайт в страницу вашего сайта. Эта ссылка уже включена в высылаемые коды информеров. Надеюсь, вы не откажете им в маленькой любезности и не станете ее оттуда удалять?
Как вам, например, телепрограмма по всем каналам на текущий день или афиша театров (рис. П. 1.6)? Если вы считаете, что вашим посетителям это будет интересно - зайдите в раздел "Рекомендуемое". Или, может быть, вас соблазнит "Конвертор валют", предлагаемый в том же разделе? Представьте, как будет приятно зайти на ваш сайт: и телепрограмму узнать можно, и сумму из долларов в рубли перевести, не говоря уже об информации о погоде. Не ровен час, посетители станут ваш сайт в качестве домашней страницы своих браузеров ставить. А уж если вы им и новости предлагать станете (рис. П. 1.7, раздел так и называется - "Новости"), то, наверное, довольно скоро по посещаемости обгоните всех своих конкурентов.

Рис. П. 1.6. А как вам вот такие информеры?

Рис. П.1.7. Новостной портал - за пять минут... Не рекламный лозунг - реальность

Информеры, содержащие текст или представляющие из себя форму с выпадающими меню (новостные ленты или, например, ТВ-информер на рис. П. 1.5), в подавляющей своей массе реализованы на Javascript. Изменять предоставляемый код формально не запрещено (обязательно лишь сохранять наличие в нем ссылки на сайт www.informer.ru), однако будьте максимально внимательны, работая таким образом с инфор-мерами на Javascript. Проверить их работоспособность можно лишь дав им возможность загружать данные с удаленного сервера, так что обязательно протестируйте полученный результат, подключившись к Интернету.
О сокровищах, скрытых в недрах сайта www.informer.ru, можно говорить еще долго. Но, надеюсь, вы сами, зайдя на этот сайт, сможете исследовать его коллекцию. Вряд ли вы уйдете оттуда без "подарков". А мы двинемся дальше по просторам Сети.


С МИРУ ПО НИТКЕ

Сайт www.translate.ru предлагает вам уникальную услугу - возможность перевода вашей страницы на английский, немецкий или французский языки (рис. П. 1.8). Если на сайт, где установлен инфор-мер от www.translate.ru, зайдет не знающий русского языка посетитель, то он, указав свой язык в соответствующем поле информера, сможет посмотреть перевод текущей страницы на этот самый язык. Прибегнув к услугам www.translate.ru, вам не придется поддерживать несколько разноязычных версий сайта в расчете на возможные визиты иностранных посетителей. Достаточно лишь информера. Конечно, качество перевода будет не слишком высоким, но для понимания содержания страницы хватит.

Рис. П. 1.8. Ваша страница - на языках мира

Кроме информеров, дающих возможность автоматического перевода на иностранный язык страниц, на которых они установлены, на www.translate.ru есть еще и собственно "переводчик", т. е. форма, введя текст в которую и нажав кнопку на ней, можно получить перевод этого текста (рис. П. 1.9). Форма передает введенный текст на сайт www.translate.ru и перевод производится средствами именно этого сайта.
Формы для перевода текста:

Рис. П. 1.9. Онлайновый переводчик - для вашего сайта

На сайте http://www.finam.ru вы найдете информеры со сведениями о котировках акций крупных российских компаний (рис. П. 1.10). Если ваш сайт содержит информацию, посвященную экономическим наукам или предназначенную для тех, кто связан с куплей-продажей акций, то информеры от Finam.ru вполне могут их заинтересовать.

Рис. П. 1.10. Финансовая информация - как из первых рук

Котировками валют и акций может вас снабжать и сайт http://www.prologia.ru. Среди выдаваемых им сведений есть и текущие цены на нефть. Даже если среди посетителей вашей странички нет менеджеров и бизнесменов, занимающихся торговлей нефтью, то все равно информер такого рода будет придавать сайту имидж солидного и серьезного.
Сайт www.softbox.ru предлагает владельцам сайтов установить на своих страницах информеры, сообщающие посетителям о новых поступлениях на www.softbox.ru или отображающие список программ, признанных лучшими. Если ваш сайт посвящен обзорам программного обеспечения, то этот бесплатный информер его однозначно украсит.
Посетители, пожелавшие узнать о новостях мира программ, вполне могут начать приходить именно к вам - особенно если вы дадите им и сведения о погоде или свежих новостях.
Хотите свежий анекдот? Наверное... А ваши посетители тоже хотят. И вы вполне можете исполнить это желание, даже не помня ни одного не только анекдота, но даже и сколь-нибудь смешного афоризма. Просто зайдите на http://sporu.net/insert и скопируйте оттуда код информера, помещающего на страницу анекдоты. Анекдот посетителю выдается новый при каждом заходе, так что вполне можно ожидать, что он неоднократно перезагрузит страницу, на которой "анекдотный" информер расположен, подарив тем самым вашему сайту лишние "хиты" на счетчиках и показы баннеров (если таковые есть на странице с информером). Анекдот от http://sporu.net/insert может размещаться на странице как средствами Javascript, так и с помощью технологии CGI.
Информеры с анекдотами предоставляют и другие сайты - например, www.relax.ru. Кстати, последний присутствует и в коллекции http://www.informer.ru.
"Кулинарный информер", получить код для установки которого можно на сайте http://homejungle.km.ru/Cook/Cook_inf.htm, выдает на каждый день свой рецепт какого-нибудь блюда (рис. П.1.11). Для сайтов о домашнем хозяйстве - настоящая находка! Поставляемый информером (с помощью сценария на Javascript) фрагмент текста с рецептом может быть размещен в любом месте страницы и примет форму той ее части, куда он поставлен (т. е. станет такой же ширины, какой и она).
Знаете ли вы, кто из ваших знакомых сегодня именинник? А у кого из знаменитостей нынче день рождения? Если нет, то вам наверняка будет весьма приятно зайти на сайт, на котором есть информер от http://www.prazdniki.ru. А если приятно вам - то будет приятно и посетителям! Так что повод для посещения страницы http://www.prazdniki.ru/export уже есть. Тем более что информер от http://www.prazdniki.ru не просто бесплатный - в ответ на ваше размещение их информера у себя они еще и добавят ваш сайт в свой каталог на почетное место!

Рис. П. 1.11. Рецепт дня - подарок хорошим женам

А не желаете ли вы, чтобы на вашем сайте находился лунный календарь для выращивания растений в согласии с ритмом звезд? Если желаете, зайдите на http://flowers.nm.ru/pick/index.html. Каждый месяц специально для вас будет готовиться календарик с пометками о благоприятных и неблагоприятных днях этого месяца (рис. П. 1.12). Чем не украшение для сайта о домашнем хозяйстве или комнатных растениях?

Рис. П. 1.12. Лунный календарь. И не надо покупать газету...

Рис. П. 1.13. Сайт карикатур. Хотите такую же себе?

На сайте www.glasbergen.ru (рис. П. 1.13) представлены карикатуры американского юмориста Рэнди Гласбергена с русским переводом, выполненным известным журналистом и специалистом в языкознании Александром Петроченковым. Владелец ресурса разрешает web-мастерам размещать на своих сайтах "карикатуру дня" со своего сайта - каждый день новую (она также отображается на главной странице сайта - см.рис. П. 1.13), вместе с переводом ее текстов на русский язык. Выбрать способ размещения информера - на Javascript или РНР - а также получить код для его размещения на своем сайте можно на специальной странице (рис. П. 1.14).

Рис. П. 1.14. Тогда просто скопируйте и вставьте нужный код

Вы, владелец сайта, находитесь даже в лучшем положении, нежели авторы информеров. Ресурсы тех посвящены лишь одной-двум темам, на большее сил хватает редко, вы же благодаря им всем можете сделать большой и мощный портал, на котором будет представлена практически вся информация, которая только может потребоваться человеку. Вместо утомительного вояжа по цепочке сайтов с целью узнать на одном из них новости, на другом - погоду, а на третьем - курс валюты, посетителю достаточно будет всего лишь открыть вашу страницу, чтобы все это было доставлено ему самым наилучшим образом. Если посетив всего только ее, он уже узнает почти все его интересующее, как он будет относиться к вашему сайту? Да наверное не с пренебрежением... А может, и сделает его домашней страницей.
Впечатляют перспективы? Тогда посвятите полчаса времени превращению вашего сайта в современный информационный портал.


РАБОЧИЙ СТОЛ СОВРЕМЕННОГО ЧЕЛОВЕКА

Но даже если на вашем попечении нет ни одного сайта, то инфор-меры все равно могут вам пригодиться. Они ведь несут весьма полезную информацию, не так ли? Так соберите со всех возможных мест их коды и создайте одну страницу, на которую все эти коды вставьте. После этого вы сможете получать все сведения, какие желаете, просто открыв эту страницу - даже не вводя в браузер никаких адресов и не нажимая на какие-либо ссылки. Запустили браузер - и вот вам погода с новостями.
А если хотите, можно сделать так, что ничего и открывать не придется. В новых версиях Windows (хотя каких уж "новых" - всех, начиная с 98-й) есть возможность в качестве фона Рабочего стола использовать web-страницу - перейти в режим так называемого "Активного Рабочего стола" (Active Desktop). Этой функцией мало кто пользуется, потому она и малоизвестна, но если в качестве подложки под Рабочий стол назначить страницу с информерами, то Рабочий стол превратится в полноценный информационный центр: и погода, и курс валют, и переводчик, и список именинников, и свежий анекдот, и даже цены на компьютерные комплектующие будут у вас просто перед глазами. Вам не надо будет даже куда-либо заходить и на что-либо нажимать -достаточно лишь посмотреть на Рабочий стол, чтобы узнать все самое свежее.
Посмотрите, например, на рис. П. 1.15. Работать за таким Столом -одно удовольствие. Как будто находишься едва ли не в центре мира. Захотелось поднять настроение - гляди вправо и вниз, пора идти на улицу - скоси взгляд к середине, познакомься с погодой. А подумайте, сколько вы времени сэкономите, заменив блуждание по Сети в поисках информации одним взглядом на Рабочий стол... Тем более что и обновляться информеры на нем могут автоматически.

Рис. П. 1.15. Рабочий стол современного человека. Почувствуйте себя в центре событий

Для того чтобы ваш Рабочий стол обрел такое же великолепие, как и показанный на рис. П. 1.15, сделайте следующее. Для начала составьте web-страницу размером с него, на которую и вставьте выбранные вами для размещения на Рабочем столе информеры. Помните, что на эту страницу вы будете смотреть каждый день долго и тщательно, так что уделите ее эргономике и красоте максимум внимания. Затем помещайте страницу на какое-либо постоянное место и, открыв вкладку "Фон" диалогового окна "Свойства экрана", нажмите кнопку "Обзор" (рис. П.1.16). В качестве типа файлов в открывшемся окне установите "Документы HTML" и откройте созданную вами страницу. При ее открытии вам будет предложено включить Active Desktop, если до этого данный режим был выключен, - то, естественно, соглашайтесь. Ну а затем нажимайте Ok - и ваш Рабочий стол волшебно преобразится.

Рис. П. 1.16. Установите здесь страницу с информерами -и вы получите "Рабочий стол современного человека"

Однако в полной мере насладиться возможностями информеров можно лишь при постоянном подключении к Интернету. Если вы используете модемный доступ, то с обновлением информеров может возникнуть проблема, да и для запуска переводчика или антивируса (см. рис. П. 1.15) придется дозваниваться и подключаться. Поэтому в таком случае вам все же лучше ограничиться простой страницей с информерами, не экспериментируя с Активным Рабочим столом. Но постоянное подключение к Сети довольно быстро движется в массы и может статься, что вышеизложенная рекомендация данной статьи станет вам доступна для реализации довольно скоро.
Казалось бы, такая малозаметная деталь Сети - информеры... Но сколько они могут принести пользы - и вам, и посетителям вашего сайта. Не допускайте, чтобы труд их создателей пропадал даром, используйте возможности Интернета на полную мощность!


ПРИЛОЖЕНИЕ 2. ИСПОЛЬЗУЙ ТО, ЧТО ПОД РУКОЮ - И НЕ ИЩИ ВСЕГДА ДРУГОЕ
  • Используй то, что под рукою - и не ищи всегда другое
  • Конвертация текстов
  • "Вытаскивание рисунков"
  • Web-графика - быстро и удобно
  • Неподвластный влияниям


ИСПОЛЬЗУЙ ТО, ЧТО ПОД РУКОЮ - И НЕ ИЩИ ВСЕГДА ДРУГОЕ

Практически всем известны встроенные в Microsoft Word всех версий, начиная с 97-й, конверторы документов в HTML-формат. И уже притчей во языцех стало качество генерируемого ими web-кода, в который все они добавляют множество ненужной информации. В самом деле - html-документ, созданный в Word97, едва ли не затопляется тэгами <font>, a web-страницы, являющиеся произведениями последующих версий Office, в целях достижения возможности сохранения абсолютно всех доступных в Word параметров документа построены на особом языке, отличительной особенностью которого является крайняя громоздкость и трудность редактирования (рис. П.2.1).

Рис. П.2.1. Слева - код документа HTML, созданного в Word 97. Справа - код документа HTML, созданного в Word

Примечание:
Вызвать конвертор HTML из Word97можно, выбрав изменю "Файл" команду "Сохранить в формате HTML" (будет там, лишь если конвертор установлен), а в Word 2000/XP - вызвав оттуда же команду "Сохранить как web-страницу". Ненужный диалог о выборе кодировки будущей web-страницы при работе с конвертором HTML из Word97 можно отключить, установив в системном реестре строковый параметр "HKEY_LOCAL_MACHlNEsSofiware\MicrosojbShared Tools\TextConverters\ Export\HTML\Options\ShowEncodingDialog" как "No" (рис.П.2.2).

Рис. П.2.2. Диалог о кодировке web-страницы в Word97 отключается здесь

Однако html-конверторы Microsoft Word могут сослужить весьма неплохую службу web-мастеру - если использовать их не по прямому назначению (вернее, по "не совсем прямому"). Как? Читайте ниже.


КОНВЕРТАЦИЯ ТЕКСТОВ

Если вам необходимо быстро отконвертировать большой обьем текста в формат HTML, Microsoft Word 97 для этого - идеальное средство. Даже если исходно информация подготавливалась в каком-либо другом редакторе, то для помещения текста в Web достаточно сохранить его в формате Rtf, а потом открыть полученный файл в Word и конвертировать в HTML. Все таблицы, содержавшиеся в исходном документе, тоже будут отконвертированы в HTML.
Однако полученный код окажется весьма громоздким - html-конвертор Word97 вставит в него множество лишних тэгов. Поэтому его придется дорабатывать. Для этого его нужно открыть в любом текстовом редакторе, поддерживающем функцию замены (весьма хорошим выбором будет Microsoft Word 6.0, поставленный поверх Word 97 в другой каталог, однако можно использовать и режим "Вид" - "Источник HTML" в самом Word 97), и удалить все тэги <font... >, </font>, &#9; (символ табуляции), все лишние ссылки и строчки, а затем немного подредактировать (добавив вручную пару-тройку гиперссылок в начало, в конец текста, установив желаемый шрифт и параметры фона). Если для редактирования полученного web-документа использовать Microsoft Word 6.0 или Microsoft Word 97 в режиме просмотра источника HTML, то имеет смысл все операции замены записать в макрокоманду и впоследствии применять ее для обработки всех отконвертированных файлов.
К сожалению, код, выдаваемый html-конвертором из Word2000/XP, ручной коррекции практически не поддается, поэтому при установке этих новых версий Office предыдущую, 97-ю версию желательно сохранить, задав при инсталляции соответствующую опцию. Но зато со храненная посредством html-конвертора из Word2000/XP почти полностью сохраняет свое форматирование (однако отобразить ее с сохранением оформления сможет лишь браузер Microsoft Internet Explorer версией не ниже четвертой), что может иногда потребоваться при необходимости размещения в Сети сложнооформленного документа. Впрочем, в HTML-конверторе Word2000 и WordXP есть функция сохранения документа "как web-страницы с фильтром", при использовании которой в создаваемый web-документ не включаются многие параметры форматирования исходного текста, в результате чего web-страница получается меньшего размера, а ее исходный код становится по крайней мере читаемым.

Комментарий:
Если имеется желание оформить документ так же, как и текст на листе бумаги (т. е. без расстояния между абзацами и с отступами красных строк), то стоит заменить все границы однотипных по выравниванию абзацев конструкциями типа < br > &nbsp;&nbsp;&nbsp;, a также добавить символы &nbsp;&nbsp;&nbsp; (попросту пробелы) в начало каждого абзаца, за исключением центрированных заголовков.


"ВЫТАСКИВАНИЕ РИСУНКОВ"

Еще одна полезная функция HTML-конвертора Word - это "вытаскивание" рисунков из документов. Вопрос о переводе рисунка, внедренного в Word, в формат Gif или Jpeg иногда встает очень остро. Простое копирование рисунка в MS Paint, Photo Editor, Adobe Photoshop через буфер обмена к хорошему результату не приведет -качество изображения будет очень плохим. Многие издательства вследствие этого не принимают к публикации файлы Word с внедренными рисунками, если у них используются для верстки другие программы. Однако "вытащить" рисунки из документа Word элементарно просто - нужно всего лишь сохранить его в формате HTML (подойдет Word любой версии). При этом все внедренные графические объекты окажутся сохраненными в формате Gif или Jpeg в той же папке, что и полученный web-документ.
HTML-конвертор Word 97 сохраняет изображения очень аккуратно. Он самостоятельно выбирает формат - Gif или Jpeg - для каждого рисунка, исходя из соотношения между размером и качеством будущего файла. Само сохранение происходит крайне корректно и экономно. Если один и тот же bmp-файл отконвертировать в Jpeg-формат с помощью графического редактора, например, ACDSee, или вставить в документ Word, сохранить тот в формате HTML и сравнить размеры полученных файлов с рисунками (качество будет одинаковым), то разница может достигать даже пары десятков процентов раз в пользу HTML-конвертора Word. Таким образом, этот конвертор можно считать на настоящее время еще и наиболее эффективным средством для конвертации графических изображений в форматы Gif или Jpeg.

Рис. П.2.3. Вытащить из Word рисунки, да еще и с определенным разрешением? Достаточно одного нажатия мыши...

В Word2000/XP есть возможность указать разрешение рисунков в получаемом с помощью html-конвертора документе. Делается это в диалоговом окне сохранения файла, в меню "Сервис" (рис. П.2.3). Воспользуйтесь этой функцией, если Вам нужна графика в определенном разрешении (это, например, иногда требуется в некоторых издательствах и редакциях). Кроме того, помимо форматов Gif и Jpeg, при сохранении документа в формате HTML в Word2000/XP может использоваться еще и Png (при установке соответствующей опции в параметрах web-документа, окно которых доступно из меню "Сервис" диалогового окна сохранения файла, см.рис. П.2.3).


WEB-ГРАФИКА - БЫСТРО И УДОБНО

С помощью html-конверторов Word можно быстро и легко создавать довольно сложные графические объекты для вставки на web-страницы, например, диаграммы и формулы. В результате для того, чтобы поместить на web-страницу график или алгебраическое выражение, не придется осваивать сложные графические редакторы или возиться со сканером. Достаточно будет, подготовив график или изображение соответственно в Microsoft Graph и Microsoft Equation Editor, вставить в документ Word и сохранить его в формате HTML, чтобы все такие обьекты превратились в файлы Gif или Jpeg.
При разработке несложной графики для размещения в Web, например, блок-схем, Word тоже может оказать неоценимую помощь, предоставив пользователю богатые возможности по рисованию с помощью автофигур. Сделать сложнотекстурную заливку фигуры (установив ей соответствующие свойства) тоже труда не составит, а при сохранении документа с рисунками из автофигур в формате HTML эти рисунки превратятся в файлы Gif или Jpeg (рис.П.2.4). Однако имейте в виду, что так происходит только в двух последних версиях Office -HTML-конвертором Word 97 автофигуры не обрабатываются и при сохранении документа игнорируются. Поэтому в том случае, если вы работаете именно с этой версией редактора, то не забудьте перед сохранением файла, содержащего картинки из автофигур, каждую из этих картинок сгруппировать и, вырезав в буфер обмена, вставить на свое же место с помощью команды "Правка - Специальная вставка" как "Рисунок Wmf'.
Вставив в документ объект WordArt и сохранив его в формате HTML, можно без всяких Photoshop'oB получить красивый заголовок для web-страницы или просто узорчатый текст в графическом файле (рис. П.2.5). (При работе с Word97 следует перед конвертацией сделать то же, что и с автофигурами, т. е. вырезать и вставить "Специальной вставкой". Html-конвертор этой версии Word объекты WordArt игнорирует.)
Грамотно используя возможности Word по созданию графических объектов вкупе с его html-конвертором, вы сможете очень часто при создании графики для Web не прибегать к услугам специализированных графических редакторов.

Рис. П.2.4. Превратить такие схемы в картинки.Gif или Jpeg - задача по плечу
лишь для Word

Рис. П 2.5. Надо сделать красивый заголовок? Достаточно Word97


НЕПОДВЛАСТНЫЙ ВЛИЯНИЯМ...

В Word 2000 и WordXP документ можно сохранить в виде "web-архива" (с расширением .mht или .mthml, рис. П.2.6), т. е. одного файла, в который включаются как текст документа, так и все рисунки и таблицы стилей. Внутренняя структура такого файла построена на основе стандарта MIME. Web-архив может просматриваться через браузер Microsoft Internet Explorer версии не ниже 4.0.
Представляется весьма интересным использование web-архива в качестве замены стандартному типу файлов .doc, используемому в Word для сохранения документов по умолчанию. В самом деле, при полном сохранении оформления текста web-архив весьма устойчив к повреждениям, так как фактически представляет собой HTML-документ с фрагментами, закодированными base64 или uuencode (повреждение хотя бы одного байта в обычном документе Word почти всегда приведет к полной нечитаемости файла, а изменение даже нескольких десятков байт в HTML-документе в самом крайнем случае приведет к нечитаемости лишь этих поврежденных байт), а, кроме того, может быть просмотрен даже в том случае, если у пользователя не установлен ни Word, ни какой-либо другой просмотрщик .doc-файлов, в Microsoft Internet Explorer'e (правда, сложноструктурированные документы могут отображаться в браузере немного некорректно).
Таким образом, можно будет обеспечить как надежность хранения информации, так и ее легкую переносимость. Вам не надо будет заботиться, есть ли у того, кому вы отправляете файл, Microsoft Word для его чтения. Однако необходимость постоянной конвертации web-архива при его открытии и сохранениях может вызвать замедление работы Word, что, впрочем, на современных компьютерах не очень существенно.

Рис. П.2.6. Web-архив: Надежность. Совместимость. Компактность

Так что, как видите, старый добрый Word сгодится не только для набора текстов. В умелых руках web-мастера он иной раз может творить буквально чудеса. Не стоит забывать об его возможностях.


ПРИЛОЖЕНИЕ 3. НА САЙТЕ - КАК В "ВИНДЕ"

Один из основных законов так называемого "usability", т. е. принципов создания удобных вещей гласит, что интерфейс объекта, с которым работает человек, должен быть ему знакомым. В применении к web-сайтам принцип сохраняется - зайдя на web-страницу, посетитель не должен гадать и думать, для чего предназначен тот или иной ее элемент. Достигнуть этого можно с помощью похожести интерфейса web-страницы на какой-нибудь другой, уже привычный пользователю. Например, на интерфейс операционной системы.
Первый, банальный прием напрашивается сразу. Можно поставить в качестве ссылок такие же иконки файлов, как и соответствующие их формату в интерфейсе операционной системы, например, всем знакомое изображение сжатых струбциной ящиков от стола для архива формата Zip или картинка листа бумаги с эмблемой Word'a для документов Word. Тогда посетитель, зайдя на страницу, сразу увидит знакомые значки и ему будет проще ориентироваться на ней, так как то, что предназначено для загрузки с сайта, будет видно сразу (рис. П.3.1).

Рис. П.3.1. Сразу ясно, что надо скачивать...

Однако просто использовать в качестве ссылок иконки архивов -это банально и неинтересно... Полной идентичности с интерфейсом операционной системы достигнуть нельзя, да и незачем, так как при работе с браузерами пользователи уже давно привыкли к одинарному щелчку для доступа к данным, а не к двойному.
Однако все, работающие с Windows 98 и более старшими версиями этой операционной системы, помнят о возможности настроить вид папок так, что при наведении курсора иконка файла будет затеняться, а при нажатии в этот момент левой кнопки мыши файл откроется (рис. П.3.2). Так, может быть, сделать иконки файлов, предназначенных для загрузки, такими же затемняющимися, как и в Windows? Представьте себе - навел посетитель курсор мыши на значок, а он стал темным, увел - он стал обычным.

Рис. П.3.2. Затенение иконки под курсором

Так почему бы не реализовать такой же эффект на web-странице, содержащей ссылки на архивы или другие файлы, подлежащие загрузке или открытию?
Но как это сделать?
Можно, разумеется, использовать традиционный метод - использовать два варианта значка (обычный и затемненный) и с помощью небольшого скрипта организовать их замену друг на друга при наведении и уходе курсора мыши. Однако такое устройство страницы приведет к тому, что на страницу придется поместить еще и сценарий для предварительной загрузки картинок (иначе соответствующие варианты значков будут загружаться лишь при наведении мыши, т. е. - не сразу). Кроме того, при сохранении web-страницы на локальном диске посетителя иконки, загружаемые в сценариях, не копируются на жесткий диск, и в итоге во время работы пользователя с сохраненной страницей при наведении курсора мыши иконки будут заменяться на белые "дырки", что, естественно, не может считаться удачным решением.
Однако для достижения требуемого эффекта вполне можно обойтись и одним изображением, если использовать так называемые "фильтры" - воспринимаемые браузером команды, позволяющие особым образом преобразовать изображение или текст, к которым они применяются.
Если вы пожелаете использовать на web-странице фильтры для достижения эффекта затемнения иконок при наведении на них курсора, то в начало страницы, в раздел <head> следует добавить небольшой скрипт, разобранный ниже по строчкам. Синтаксис Javascript во многом похож на синтаксис РНР, так что изучение данного сценария вряд ли станет для вас проблемой.
Начало сценария:

<script language="JavaScriptl. 2">

Для экономии места используется одна функция, которой сообщается имя графического объекта на web-странице, на котором используется затемнение, и требуемое действие - либо применение этого затемнения, либо его отмена.

function g (c,w)
{

Если нужно "затемнить" картинку:

if (w==0)

применяем фильтр "light", который окрашивает картинку в определенный цвет...

с.style.filter="light";

и задаем в качестве затемняющего цвета - темно-синий оттенок. Эта команда используется лишь в том случае, когда браузер может работать с фильтрами - именно поэтому она помещена после оператора if, проверяющего, существует ли для браузера фильтр light.

if (с.filters.light) {
c.filters.light.addAmbient(130,130,210,120) }

Ну а если нужно, наоборот, вернуть картинке первоначальный вид, то просто отменяем все фильтры.

else
с.style.filter=0
}

Вот и все:

}
</script>

Вышеописанный сценарий будет "обслуживать" все картинки на странице, для которых вы пожелаете применить эффект "затемнения". Ну а чтобы это происходило - в тэг каждой картинки, для которой требуется "затемнение", следует вставить команды
"onMouseover="g (this,0)" onMouseout="g (this,1)", например:

<IMG src="z.gif" border=0 height=30 width=30 on-Mouseover="g(this,0)" onMouseout="g(this,1)">

В результате при наведении курсора мыши на картинку она будет затемняться - как на рис. П.3.3.

Рис. П.3.3. Затемнение иконки под курсором. Но уже на сайте, а не на Рабочем столе

К сожалению, данный прием работает только в браузере Microsoft Internet Explorer версии 5.0 и старше. Пользователи же остальных браузеров увидят простую непереливающуюся картинку и ничего больше.
Примеры сценария, а также иконки архивов вы можете взять с адресов http://www.harchikov.ru, http://antorlov.chat.ru, http://karamur2a.chat.ru. Просто копируйте картинки и переписывайте сценарий из "Источника HTML", а затем размещайте на своем сайте.


Введение

  • Что такое сбой (неполадка)?
  • Почему компьютер дает сбои?
  • Можно ли избежать сбоев в работе ПК?
  • Классификация сбоев и неполадок
  • Типичные ошибки и заблуждения пользователя


Что такое сбой (неполадка)?

Как неприятно это сознавать, но в работе персонального компьютера (ПК) часто встречаются различные сбои и неполадки, которые мало связаны с некачественными компонентами компьютера. Речь идет о программных сбоях, которые с одной стороны легко можно устранить, но с другой стороны никто не может дать стопроцентную гарантию, что они не появятся вновь. Чтобы быстро сориентироваться в ситуации, когда, например, на экране монитора "выскочило" незнакомое сообщение, в первую очередь необходимо четко представлять себе, что такое сбой или неполадка.
Сбой (или неполадка) — это нарушение нормального функционирования отдельной программы, устройства или компьютера в целом. Внешне это выглядит как появление различных сообщений: звуковых из системного динамика либо диалоговых окон на экране монитора, зависание, резкое замедление работы компьютера и т. п.
Также сбоем можно назвать отказ аппаратного или программного обеспечения, который устраняется либо повторным выполнением действия, при совершении которого возникла данная ситуация, либо перезагрузкой компьютера (при помощи нажатия комбинации клавиш <Ctii>+<Alt>+<Del> или кнопки RESET, расположенной на системном блоке компьютера). Если эти действия не помогают устранить проблему, тогда стоит провести тщательную диагностику всего оборудования, работающего в составе компьютера, т. е. искать причину ее возникновения, в первую очередь, в неисправности аппаратного обеспечения. И только после этого пытаться переустановить операционную систему, программы и т. д.
Неисправностью можно считать регулярное появление характерных сбоев при работе "железа" (например, зависание компьютера по истечении некоторого времени работы вне зависимости от используемого программного обеспечения и т. п.).

Примечание
Если только что купленный компьютер начинает регулярно зависать (самостоятельно перезагружаться, выключаться), обязательно следует позвонить в службу техподдержки компании, где вы его приобрели. Пользуйтесь возможностью гарантийного обслуживания. Любые вопросы, возникшие в процессе эксплуатации, сначала следует обсудить по телефону — это поможет вам избежать глупых ситуаций (таких, как, например, не до конца вставленная в розетку вилка кабеля питания).


Почему компьютер дает сбои?

Очень многие пользователи задают вопрос: "Так почему же мой компьютер дал сбой, завис?" Ответить однозначно на него очень сложно, т. к. причин этому может быть великое множество. Приходится ограничиваться лишь разными рекомендациями: использовать источник бесперебойного питания, программы для проверки реестра, антивирусы и т. п. Все это мало успокаивает людей, т. к. они ожидают вполне конкретного ответа: "Нажмите сюда, и все будет работать как надо". Такой ответ, увы, дать не всегда возможно. Зато объяснить, почему компьютер время от времени дает сбои, не так и сложно.
На первый взгляд компьютер представляет собой сложное электронно-механическое устройство, но на самом деле это комплекс, в состав которого входит аппаратное и программное обеспечение. Последнее имеет несколько уровней "допуска" к ядру каждого компьютера — "железу^". Внешне компьютер выглядит как удобный для применения прибор, умеющий не только автоматически подсчитывать бухгалтерский баланс, но и позволяющий неплохо отдохнуть и даже развлечься. Этот образ сохраняется до тех пор, пока не начинаются проблемы.
Практически любой компонент компьютера сам по себе ни на что не способен, т. к. для его работы требуется определенная программа, согласно которой он выполняет все необходимые действия. В любой программе содержится последовательность (алгоритм) действий того или иного устройства или всего комплекса в целом. Программы пишут обычные люди, поэтому каждая из них может содержать некоторое количество ошибок, допущенных либо из-за ограниченного количества времени, данного на написание программы, либо из-за усталости программиста, либо по каким-то другим причинам. Для рынка компьютерных технологий всегда была характерна "гонка вооружений", когда производители спешат выпустить устройство, чтобы не только догнать, но и перегнать своих конкурентов, что не может не отразиться на качестве выпускаемой продукции. С течением времени устройство ПК становится все более сложным, что отражается в первую очередь на программном обеспечении.
Наличие на рынке комплектующих большого количества конкурирующих компаний заставляет задуматься еще над одним моментом. Существует очень большое число различных стандартов, описывающих правила их работы и которых обязательно должны придерживаться все производители устройств. Насколько точно соответствует продукция общепринятым стандартам, может сказать только сам производитель, но этого никто никогда не делает, дабы не "прогореть", предлагая покупателю модели устройств, имеющих "некоторые нюансы", например, в совместной работе с устройствами других производителей. Поэтому приходится работать с тем, что есть.
Давайте рассмотрим взаимосвязь основных компонентов компьютера и программного обеспечения. Следует понимать, что любая программа является как бы логическим продолжением соответствующего устройства. Из этого следует, что одна и та же неполадка может произойти вследствие как аппаратного, так и программного сбоя.
Материнская плата является связующим звеном для всех остальных компонентов. Иначе говоря, все компоненты компьютера получают команды от центрального процессора посредством электронных элементов, расположенных на материнской плате. Это различные микросхемы, контроллеры, стабилизаторы и т. п. Часть из них функционирует самостоятельно, выполняя одну и ту же операцию с момента включения питания и вплоть до его выключения. Другие же элементы требуют для своей работы специальной программы. Целый набор подобных программ входит в состав микросхемы, называемой BIOS (Basic Input/Output System, базовая система ввода/вывода). Также в ней содержится программа CMOS Setup Utility (или, как ее еще называют, BIOS Setup), позволяющая пользователю вручную изменять некоторые режимы работы компонентов компьютера. От того, насколько удачно написаны эти программы, зависит стабильность работы компьютера в целом и то, насколько он будет совместим с современными стандартами. Именно поэтому говорят, что обновление версии BIOS позволяет устранить большую часть проблем, а также расширить возможности материнской платы (например, включить поддержку нового процессора или жесткого диска большого объема).
Центральный процессор, на первый взгляд, не требует программного управления, ведь он сам выполняет программы, но, например, откуда ему знать, сколько установлено кэш-памяти и как с нею работать? Проще говоря, внутри процессора находится миниатюрная плата, на которой имеются такие же элементы, как и на материнской, а также микросхемы постоянной памяти, в которые заложены все необходимые программы — так называемые микрокоды. Компания Intel свои процессоры снабдила возможностью "записи" этих микрокодов извне, что позволяет, например, обновлением BIOS устранить некоторые недочеты при работе процессора, т. к. в программе CMOS Setup Utility содержится параметр, включающий обновление микрокодов при каждом запуске компьютера.
В состав модулей оперативной памяти входит специальная микросхема, содержащая таблицу основных рабочих параметров. Это так называемый SPD-модуль (Serial Presence Detect, модуль идентификации). Конечно, не совсем правильно говорить, что модуль памяти управляется программой, но от корректности заполнения таблицы параметров зависит качество автоматической настройки контроллера памяти, находящегося на материнской плате, поэтому все равно программная составляющая играет здесь важную роль.
Жесткий диск обладает не менее совершенной электроникой, чем материнcкая плата, т. к. для его нормальной работы требуется выполнять множество операций. Это такие функции, как управление механической частью винчестера, преобразование сигналов, постоянный контроль состояния основных узлов как механических, так и электронных компонентов. Всеми этими процессами управляют программы, которые записаны в микросхеме постоянной памяти, размещенной на плате электроники, которая в свою очередь расположена на самом жестком диске.
Любая видеоплата содержит собственную микросхему BIOS, примерно такую же, как на материнской плате. Ее также можно перезаписывать, обновляя версию BIOS и при этом даже добавляя различные функции. Существует весьма обоснованное мнение о том, что "перепрошивкой" видео-BIOS можно превратить, например, плату Sapphire ATI Radeon 9500 в более старшую модель Radeon 9700.
Как видите, любой компонент просто "пропитан" программным обеспечением, что еще раз свидетельствует о его важности. Описанные программы работают незаметно для пользователя, создавая полную видимость интеллектуальности компьютера. В качестве промежуточного звена между программами, "прошитыми" в устройства, и пользователем используется операционная система, позволяющая свести внутренние различия между компонентами к минимуму и "воссоединить" все компоненты компьютера в единое целое. После установки операционной системы компьютер начинает представлять собой логическую единицу, позволяющую эффективно решать практически любые вопросы.
От стабильности работы операционной системы и отдельных ее модулей зависит то, насколько хорошо будет работать компьютер и отдельные его компоненты. Не зря при возникновении серьезных сбоев обычно рекомендуют "начисто" переустановить операционную систему, т. е. удалить старую копию и после этого установить новую. У многих пользователей возникает вопрос: "А нельзя ли написать такую Windows, которая работала бы стабильно и не давала бы сбоев?" Написать, конечно, можно, но такая операционная система будет лишена основного преимущества существующих сегодня версий — универсальности, что можно уже наблюдать на примере семейства Windows NT. Повышенная стабильность работы приводит к невозможности запуска целого ряда программ, особенно старых, рассчитанных на работу в среде MS-DOS.
Интересный факт — операционные системы Windows 2000 и Windows XP, которые, в общем-то, позиционируются на рынке профаммного обеспечения как наиболее надежные, регулярно подвергаются исправлениям. Так, например, для Windows XP вышло обновление SPla, ожидается выпуск обновления SP2, который исправит не только новые ошибки, но и те ошибки, которые были внесены первым обновлением. Возникает вопрос: "Как могут работать программы, когда операционная система не может обеспечить стопроцентной стабильности работы компьютера?" Ответить на этот вопрос, думаю, не смогут даже специалисты компании Microsoft.
Наиболее высокий уровень "доступа" имеют программы, которые запускаются пользователем под управлением операционной системы. Все они взаимодействуют практически только с модулями операционной системы, которые в свою очередь передают все необходимые команды аппаратному обеспечению ПК. Неправильное обращение к одному из модулей может вызвать либо выдачу сообщения об ошибке, либо полное зависание программы или операционной системы в целом. Как видите, от качества программы может зависеть не только эффективность выполнения той или иной задачи, но и стабильность работы всего компьютера.
Все вышесказанное указывает на то, что подавляющее количество сбоев и неполадок возникает из-за некорректной работы программного обеспечения, вне зависимости от того, встроено оно в аппаратные компоненты, является ли частью операционной системы, или же это независимая программа, которую можно запускать в любой версии Windows.
Еще раз хотелось бы отметить, что заявление о преобладании программных сбоев ни в коем случае не исключает необходимости профилактики физических неполадок, таких как:

  • удаление пыли, которая способствует перегреву компонентов ПК, а иногда даже приводит к короткому замыканию;
  • смазка вентиляторов, плохая работа которых также может привести к перегреву;
  • очистка головок магнитных и оптических дисководов, что позволит значительно уменьшить число ошибок при чтении/записи данных на сменные носители.

В завершение всего вышесказанного приведу выдержку из руководства по сборке компьютеров, предлагаемого компанией AMD:

"Продукты компании AMD не разработаны, не предназначены, не авторизованы и не гарантированы для использования в качестве компонентов систем для хирургической имплантации или применения в других системах поддержания жизни или же в каких-либо других областях, где сбой в работе продукта AMD может вызвать ситуацию, которая может привести к травмам, смерти или значительному ущербу собственности или окружающей среды".

О чем это говорит? Сам производитель, в общем-то, популярных процессоров предупреждает нас о том, что его процессоры в любой момент могут дать сбой?


Можно ли избежать сбоев в работе ПК ?

Хотелось бы ответить на этот вопрос утвердительно, успокоив этим самым великое множество огорченных действительностью пользователей, но со весть не позволяет этого сделать. Можно уменьшить вероятность возникно вения сбоев и неполадок, но вообще избежать их практически невозможно, т. к. ежедневно выпускается большое количество новых программ, которые вы рано или поздно захотите установить на своем компьютере. И никто не даст гарантию, даже разработчики, что установка какой-нибудь из них не вызовет сбой в работе компьютера, потому что любая программа, если толь ко она не выпущена в России, как минимум, подвергается русификации, иногда приводящей к печальным последствиям (например, могут не рабо тать отдельные функции). Особо стоит вопрос о взломе программ, который, конечно, позволяет сэкономить немало денег на покупке ПО, но увеличивает шансы возникновения или усугубления сбоев и неполадок.

Программные сбои сопровождают работу на компьютере практически не прерывно, что вызвало у опытных пользователей устойчивое мнение о том, что если программа сразу же после написания не дала сбой, значит, в ней что-то не так. За этой, на первый взгляд милой, шуткой скрывается суровая правда: при написании программы просто невозможно учесть все факторы, которые могут встретиться при использовании этой программы. Это и ог ромные различия между версиями Windows , и различные настройки пользо вателя, и драйверы для устройств и т. п. Естественно, что в этом направле нии постоянно ведутся исследования, но появление ошибок в программном обеспечении по-прежнему возможно.

Сильно усугубляет ситуацию доминирование на российском рынке про граммного обеспечения пиратских программ, которые традиционно содержат намного большее количество ошибок, в первую очередь из-за того, что их взломом и русификацией, как правило, занимаются далеко не профес сионалы.

Естественно, в профилактике первое место продолжает занимать контроль над физическими параметрами компьютера. Прежде чем искать причину сбоев или неполадок в программном обеспечении, проверьте, нормально ли функционируют основные компоненты ПК: центральный процессор, материнская плата и блок питания. Для этого можно воспользоваться любой программой вроде Motherboard Monitor, например, той, которая идет на диске с драйверами к материнской плате. Проверьте уровень температуры центрального процессора и материнской платы, а также уровни всех напря жений. Если параметры в пределах нормы, тогда можно приступать к поис ку "виновника" среди программ.

Наиболее оптимальным вариантом всегда была и остается переустановка Windows на чистый жесткий диск (имеется в виду, что старые копии Windows следует удалить), а также переустановка всех используемых программ. Это дает почти стопроцентную гарантию устранения большей части сбоев, но, во-первых, занимает много времени, а во-вторых, вынуждает заново настраивать все программы. Отдельный разговор об этом будет в главе 8.

В случае же, когда переустановка операционной системы крайне нежела тельна, приходится пользоваться различными программами очистки реестра, деинсталляции (удаления) неиспользуемых программ. Это помогает спра виться со многими из сбоев и неполадок, но требует от пользователя опре деленной квалификации, чтобы при очистке, например, реестра не испор тить его, после чего все равно придется все переустанавливать. Отдельный разговор об этом будет в главе 12.

Особое место среди программного обеспечения, которое призвано служить защитой от сбоев и неполадок, всегда играли антивирусные программы. Умение пользоваться такими программами значительно повышает шансы стабильной работы компьютера, т. к. они защищают его от программ, вы полняющих разрушающую функцию, — от компьютерных вирусов. Отдельный разговор об этом будет в 18 главе книги.


Классификация сбоев и неполадок

Как мы уже говорили ранее, компьютер представляет собой комплекс аппа ратного и программного обеспечения, из чего можно сделать очень простой вывод, что любые сбои и неполадки можно разделить на две категории:

  • программные сбои и неполадки;
  • аппаратные сбои и неполадки.

Следует ясно представлять себе, что любая программа очень тесно взаимо действует с "железом", т. е. аппаратным обеспечением ПК, поэтому зависа ния программ вполне могут быть связаны с неисправностью, например, оперативной памяти. В свою очередь, указанные категории можно разделить на великое множество подкатегорий. Рассмотрим наиболее основные.

Первую категорию можно подразделить на следующие пункты:

  • сбои и неполадки в операционной системе — сюда относятся любые
    проблемы, связанные со стабильностью работы программного обеспече
    ния, которое входит в комплект операционной системы, а также основ
    ных системных файлов, таких как C 0 MMAND . COM , EXPLORER . EXE ,
    KERNEL . DLL и т. п.

Данная разновидность сбоев и неполадок очень тесно "привязана" к аппаратному обеспечению компьютера, поэтому нужно очень серьезно подойти к диагностике аппаратного обеспечения, прежде чем пытаться на строить все остальное;
сбои и неполадки в программном обеспечении — здесь имеются в виду все те программы, которые обычно устанавливаются "поверх" операционной системы (благодаря чему мы получаем возможность расширения ее возможностей). Яркий пример: пакет офисного программного обеспече ния Microsoft Office .

В данной категории сбоев и неполадок очень часто встречается несовместимостъ программ с операционной системой или другим программным (или аппаратным) обеспечением. Очень важным моментом является то, что осо-место занимают драйверы устройств, которые с одной стороны являются тью аппаратного обеспечения, а с другой стороны — частью установленной операционной системы, управляющей работой всех запускаемых программ или игр. Некорректная работа некоторых версий драйверов может привести к мысли о замене компонентов ПК, тогда как часто достаточно ювить их или вернуться к их предыдущей версии.

Вторую категорию можно разделить на следующие подкатегории:

  • сбои и неполадки, вызванные несовместимостью отдельных устройств, версий драйверов и т. п. Как ни прискорбно, но иногда встречаются слу чаи реальной несовместимости некоторых моделей, например, материн ских плат с некоторыми моделями жестких дисков или видеоплат. В этом случае, естественно, приходится менять исправное устройство на другую модель или приобретать аналогичное устройство, но другого производителя (например, менять жесткий диск с Western Digital на Seagate ). При чиной может служить несоблюдение производителями общепринятых спецификаций устройств;
  • сбои и неполадки, вызванные несоблюдением условий эксплуатации устройств. Наиболее яркие примеры: перегрев центрального процессора, видеоплаты, блока питания и т. п. При этом проблемы появляются после некоторого времени работы, например, по истечении' часа после запуска какой-нибудь игровой программы;
  • сбои и неполадки, вызванные неисправностью устройств. При возникно вении подобной ситуации прямая дорога вам в сервис-центр, т. к. ремонт ПК достаточно сложное занятие и без достаточной квалификации им лучше всего не заниматься. Электронные компоненты персонального компьютера могут ломаться в основном по следующим причинам:
    • перегрев из-за отсутствия охлаждения либо из-за его низкого качества;
    • статический разряд от прикосновения к отдельным элементам (сис
      темному блоку в целом);
    • чрезмерное повышение напряжения питания в электросети, например,
      из-за разряда молнии во время грозы.

Миф № 1. Компьютеры бывают хорошие или плохие

Все современные компьютеры совершенно одинаковы, т. к. на любом из них можно:

  • набирать тексты и создавать таблицы;
  • вести бухгалтерию;
  • готовиться к сдаче экзаменов в школе, институте, ГИБДД;
  • писать собственные программы;
  • слушать музыку;
  • играть в компьютерные игры;
  • работать в сети Интернет;
  • обучаться работе на компьютере;
  • устанавливать практически любые программы.

Единственное, чем компьютеры различаются, так это мощностью и, соот ветственно, ценой. Мощность важна только лишь для единичных самых "навороченных" игр или программ. Отсюда можно сделать вывод, что ком пьютеры бывают трех типов.

  • 1. Компьютеры малой мощности— они предназначены в основном для
    офисных программ, обучения работе на компьютере, работы в сети Ин
    тернет (в общем, для работы).
  • 2. Компьютеры средней мощности — они предназначены как для работы,
    так и для игры в большую часть современных компьютерных игр.
  • 3. Очень мощные компьютеры — они в основном предназначены для более
    или менее профессиональной работы с музыкой, графикой, видеоизоб
    ражениями.

Естественно, что первая категория имеет наиболее низкую стоимость по cравнению с другими.

Компьютер тем мощнее, чем у него:

  • больше тактовая частота процессора;
  • больше объем оперативной памяти;
  • больше объем жесткого диска;
  • больше объем видеопамяти.

Ни одна программа не должна давать сбой при работе, как на компьютерах слабой мощности, так и на самых мощных ПК. В противном случае в ней содержится целый ряд ошибок, как это, например, было с программами, чаписанными на языке Паскаль версии 5.0. Все они отказывались запускаться на компьютерах с частотой процессора более, чем 250 МГц. Представляете, сколько нервов испортили пользователи, прежде чем выяснили причину этой проблемы?

Конечно, для каждой программы существуют минимальные аппаратные гребования, которые необходимо соблюдать для нормальной ее работы. Но все это относится в основном к комфортности работы с конкретной программой, когда, например, объем памяти меньший, чем указано в требо ваниях, может привести к значительному замедлению выполнения програм мы. Нельзя не согласиться, что для работы игровых программ с высококаче ственной графикой требуется мощный компьютер, что вовсе не умаляет возможностей слабых конфигураций.

Миф № 2. Покупка компьютера на будущее

Покупать компьютер в расчете на будущее ни в коем случае нельзя! Практи- чески постоянно выпускаются новые модели процессоров, материнских плат и т. д. Все они привносят в мир комплектующих новые стандарты, ко торые далеко не всегда можно "состыковать" со старыми. Например, инте ресная ситуация сейчас складываться на рынке оперативной памяти — те, кто год-полгода назад установил большой объем памяти SDRAM , отдав за это приличные деньги, кусают теперь локти, т. к. за деньги значительно меньшие теперь можно приобрести более быструю DDR -память.

И как больно смотреть на лицо покупателя, когда он узнает, что компьютер, который он покупал, например, за 30 000 рублей, сегодня стоит не более 15 000. Единственно, какие компьютеры мало теряют в цене, так это ком пьютеры малой мощности, т. к. они по-прежнему способны выполнять функции "печатной машинки", в то время как мощные компьютеры и компьютеры со средней мощностью переходят в более низкую категорию с со ответствующим падением цены.

Из всего вышесказанного можно сделать вывод: покупайте компьютер, ко торый вам нужен сегодня. Все равно через некоторое время возникнет необ ходимость что-то поменять, добавить, увеличить.

Миф № 3. Компьютеры , бывшие в употреблении , дешевле

Спешу вас разочаровать: очень часто за низкой ценой "скрываются" как ус таревшие стандарты, вроде модулей памяти SIMM , которые вы не сможете поменять на более емкие, так и немалый срок службы. Если вам нужна просто "печатная машинка", то, конечно, можно предпочесть этот вариант. Но если вы предполагаете запускать на этом компьютере игры, тогда вам следует очень хорошо подумать, т. к. современные, а тем более популярные игры, в которые вам наверняка захочется поиграть, скорее всего, с трудом запустятся, а то и вообще откажутся работать.

Второй немаловажный фактор, говорящий против покупки компьютера б/у — раз он сегодня стоит так дешево, то через полгода он вообще никому не будет нужен и вам не удастся обменять его на более мощный. Останется выбросить его на помойку или же пытаться продать его хотя бы за бесценок.

Миф № 4. Существуют компьютеры " желтой " и " белой " сборки

Эта фраза означает, что вроде бы есть компьютеры, которые собирают в Ки тае, а есть такие, которые собирают в европейских странах или в Америке. Спешу разочаровать вас: собираются компьютеры, конечно, в разных мес тах, но абсолютно все запчасти изготовлены в Китае или Тайване. Вывод делайте сами.

Качество сборки в основном зависит от квалификации сборщиков, а не от качества комплектующих. Не раз приходилось видеть компьютеры, собран ные в Германии, в которых жесткий диск закреплен всего на два винта, хотя положено на четыре, и т. п.

Миф № 5. " Понимающий " сосед , друг , коллега

В ответ на это утверждение хочется спросить: ваш сосед, друг, коллега пре подает в каком-нибудь институте? Или он много лет работает в какой- нибудь компьютерной фирме, имя которой, как говорится, гремит на всю округу? Или просто у него дома есть компьютер, на котором он с грехом пополам научился работать?

Бытует мнение, что самое главное в компьютере — это тактовая частота центрального процессора, а все остальное не так уж важно. Это ошибка! Огромное значение имеют и такие показатели, как частота системной шины, скорость работы жесткого диска, поддержка различных режимов AGP , тип чипсета материнской платы, видеоплаты и т. д. Кроме того, следует поду мать о возможности последующей модернизации. Вот яркий пример: вы ку пили компьютер, бывший в употреблении, удовлетворяющий вас по всем своим параметрам со 128 мегабайтами оперативной памяти, а потом вдруг решили увеличить объем до 512 мегабайт. Каково же будет ваше удивление, когда вы узнаете о том, что ваша материнская плата поддерживает максимум 256 мегабайт? Кого вы будете винить в этом? "Понимающего" соседа, друга, коллегу? Выход один — внимательно изучайте компьютерные журналы, статьи, кото рые в великом множестве можно найти в сети Интернет. Этим вы обезопасите себя от приобретения морально устаревших компонентов.

Миф № 6. Компьютер лучше собирать самому

Это утверждение может быть действительно только в том случае, когда вы умеете самостоятельно производить сборку и первичную настройку "железа", представляете себе, какие компоненты прекрасно "уживаются" друг с дру гом, а какие могут вызвать массу проблем и т. п.

Все уважающие себя компании обычно предлагают покупателю целый ряд готовых конфигураций, которые всесторонне проверены на совместимость, стабильность и скорость работы и позволяют, не бегая по всему городу, приобрести комплект всех необходимых устройств в одном месте. Это до полнительно повышает шансы бессбойной работы всего в комплексе, пото му что компании обычно не выставляют на продажу периферийные устрой ства, плохо совместимые с их компьютерами.

Особым фактором можно отметить то, что на системные блоки в сборе часто дают значительно более длительную гарантию, чем на отдельные компоненты.

Миф № 7. Протестированные компьютеры работают надежнее

Некоторые фирмы пытаются использовать в качестве рекламы объявления вроде: "Наши компьютеры проходят тщательное тестирование в течение 72 часов". Все это, мягко говоря, не более чем рекламный шаг, призванный привлечь несведущих или же считающих себя сведущими пользовате лей. Никакое тщательное тестирование не спасет вас от возможных сбоев в программном обеспечении или сбоев по вине того же некачественного электропитания.

Компьютер не может работать плохо или хорошо. Он или работает, выпол няя все возложенные на него функции, или не работает. Если компьютер постоянно зависает, происходят разнообразные сбои, если он самостоятельно перезагружается или даже выключается, слишком долго грузится, то все это можно считать неисправностью, что требует вмешательства специалиста и, соответственно, устранения.

Миф № 8. На вашем компьютере эта программа работать не будет

Если данная программа устанавливается на других компьютерах, а на вашем ПК никак не хочет устанавливаться или работать после вполне удачной инсталляции, это говорит о наличии сбоя в работе компьютера. Только если речь идет о программе, которую не удается запустить ни на одном компью тере, можно считать, что она не будет работать вообще. Такое возможно, например, при повреждении дистрибутива.

Существует, конечно, масса примеров, когда программы отказываются работать со строго определенными моделями устройств, но подавляющее большинство таких сбоев, как правило, устраняется в более новых версиях этих программ. Поэтому следует искать причину того, почему не запуска ется программа, а не махать рукой как в известном фильме "Все будет хорошо".


Типичные ошибки и заблуждения пользователя

Миф № 1. Компьютеры бывают хорошие или плохие

Все современные компьютеры совершенно одинаковы, т. к. на любом из них можно:

  • набирать тексты и создавать таблицы;
  • вести бухгалтерию;
  • готовиться к сдаче экзаменов в школе, институте, ГИБДД;
  • писать собственные программы;
  • слушать музыку;
  • играть в компьютерные игры;
  • работать в сети Интернет;
  • обучаться работе на компьютере;
  • устанавливать практически любые программы.

Единственное, чем компьютеры различаются, так это мощностью и, соот ветственно, ценой. Мощность важна только лишь для единичных самых "навороченных" игр или программ. Отсюда можно сделать вывод, что ком пьютеры бывают трех типов.

  • Компьютеры малой мощности— они предназначены в основном для
    офисных программ, обучения работе на компьютере, работы в сети Ин
    тернет (в общем, для работы).
  • Компьютеры средней мощности — они предназначены как для работы,
    так и для игры в большую часть современных компьютерных игр.
  • Очень мощные компьютеры — они в основном предназначены для более
    или менее профессиональной работы с музыкой, графикой, видеоизоб
    ражениями.

Естественно, что первая категория имеет наиболее низкую стоимость по сравнению с другими.

Компьютер тем мощнее, чем у него:

  • больше тактовая частота процессора;
  • больше объем оперативной памяти;
  • больше объем жесткого диска;
  • больше объем видеопамяти.

Ни одна программа не должна давать сбой при работе, как на компьютерах слабой мощности, так и на самых мощных ПК. В противном случае в ней содержится целый ряд ошибок, как это, например, было с программами, чаписанными на языке Паскаль версии 5.0. Все они отказывались запус- саться на компьютерах с частотой процессора более, чем 250 МГц. Представляете, сколько нервов испортили пользователи, прежде чем выяснили причину этой проблемы?

Конечно, для каждой программы существуют минимальные аппаратные гребования, которые необходимо соблюдать для нормальной ее работы. Но все это относится в основном к комфортности работы с конкретной программой, когда, например, объем памяти меньший, чем указано в требо ваниях, может привести к значительному замедлению выполнения програм мы. Нельзя не согласиться, что для работы игровых программ с высококаче ственной графикой требуется мощный компьютер, что вовсе не умаляет возможностей слабых конфигураций.

Миф № 2. Покупка компьютера на будущее

Покупать компьютер в расчете на будущее ни в коем случае нельзя! Практически постоянно выпускаются новые модели процессоров, материнских плат и т. д. Все они привносят в мир комплектующих новые стандарты, ко торые далеко не всегда можно "состыковать" со старыми. Например, инте ресная ситуация сейчас складываться на рынке оперативной памяти — те, кто год-полгода назад установил большой объем памяти SDRAM , отдав за это приличные деньги, кусают теперь локти, т. к. за деньги значительно меньшие теперь можно приобрести более быструю DDR -память.

И как больно смотреть на лицо покупателя, когда он узнает, что компьютер, который он покупал, например, за 30 000 рублей, сегодня стоит не более 15 000. Единственно, какие компьютеры мало теряют в цене, так это ком пьютеры малой мощности, т. к. они по-прежнему способны выполнять функции "печатной машинки", в то время как мощные компьютеры и компьютеры со средней мощностью переходят в более низкую категорию с со ответствующим падением цены.

Из всего вышесказанного можно сделать вывод: покупайте компьютер, ко торый вам нужен сегодня. Все равно через некоторое время возникнет необ ходимость что-то поменять, добавить, увеличить.

Миф № 3. Компьютеры , бывшие в употреблении , дешевле

Спешу вас разочаровать: очень часто за низкой ценой "скрываются" как ус таревшие стандарты, вроде модулей памяти SIMM , которые вы не сможете поменять на более емкие, так и немалый срок службы. Если вам нужна про-

сто "печатная машинка", то, конечно, можно предпочесть этот вариант. Но если вы предполагаете запускать на этом компьютере игры, тогда вам следует очень хорошо подумать, т. к. современные, а тем более популярные игры, в которые вам наверняка захочется поиграть, скорее всего, с трудом запустятся, а то и вообще откажутся работать.

Второй немаловажный фактор, говорящий против покупки компьютера б/у — раз он сегодня стоит так дешево, то через полгода он вообще никому не будет нужен и вам не удастся обменять его на более мощный. Останется выбросить его на помойку или же пытаться продать его хотя бы за бесценок.

Миф № 4. Существуют компьютеры " желтой " и " белой " сборки

Эта фраза означает, что вроде бы есть компьютеры, которые собирают в Ки тае, а есть такие, которые собирают в европейских странах или в Америке. Спешу разочаровать вас: собираются компьютеры, конечно, в разных мес тах, но абсолютно все запчасти изготовлены в Китае или Тайване. Вывод делайте сами.

Качество сборки в основном зависит от квалификации сборщиков, а не от качества комплектующих. Не раз приходилось видеть компьютеры, собран ные в Германии, в которых жесткий диск закреплен всего на два винта, хотя положено на четыре, и т. п.

Миф № 5. " Понимающий " сосед , друг , коллега

В ответ на это утверждение хочется спросить: ваш сосед, друг, коллега пре подает в каком-нибудь институте? Или он много лет работает в какой- нибудь компьютерной фирме, имя которой, как говорится, гремит на всю округу? Или просто у него дома есть компьютер, на котором он с грехом пополам научился работать?

Бытует мнение, что самое главное в компьютере — это тактовая частота центрального процессора, а все остальное не так уж важно. Это ошибка! Огромное значение имеют и такие показатели, как частота системной шины, скорость работы жесткого диска, поддержка различных режимов AGP , тип чипсета материнской платы, видеоплаты и т. д. Кроме того, следует поду мать о возможности последующей модернизации. Вот яркий пример: вы ку пили компьютер, бывший в употреблении, удовлетворяющий вас по всем своим параметрам со 128 мегабайтами оперативной памяти, а потом вдруг решили увеличить объем до 512 мегабайт. Каково же будет ваше удивление, когда вы узнаете о том, что ваша материнская плата поддерживает максимум 256 мегабайт? Кого вы будете винить в этом? "Понимающего" соседа, друга, коллегу?

Выход один — внимательно изучайте компьютерные журналы, статьи, кото рые в великом множестве можно найти в сети Интернет. Этим вы обезопасите себя от приобретения морально устаревших компонентов.

Миф № 6. Компьютер лучше собирать самому

Это утверждение может быть действительно только в том случае, когда вы умеете самостоятельно производить сборку и первичную настройку "железа", представляете себе, какие компоненты прекрасно "уживаются" друг с дру гом, а какие могут вызвать массу проблем и т. п.

Все уважающие себя компании обычно предлагают покупателю целый ряд готовых конфигураций, которые всесторонне проверены на совместимость, стабильность и скорость работы и позволяют, не бегая по всему городу, приобрести комплект всех необходимых устройств в одном месте. Это до полнительно повышает шансы бессбойной работы всего в комплексе, пото му что компании обычно не выставляют на продажу периферийные устрой ства, плохо совместимые с их компьютерами.

Особым фактором можно отметить то, что на системные блоки в сборе часто дают значительно более длительную гарантию, чем на отдельные компоненты.

Миф № 7. Протестированные компьютеры работают надежнее

Некоторые фирмы пытаются использовать в качестве рекламы объявления вроде: "Наши компьютеры проходят тщательное тестирование в течение 72 часов". Все это, мягко говоря, не более чем рекламный шаг, призванный привлечь несведущих или же считающих себя сведущими пользовате лей. Никакое тщательное тестирование не спасет вас от возможных сбоев в программном обеспечении или сбоев по вине того же некачественного электропитания.

Компьютер не может работать плохо или хорошо. Он или работает, выпол няя все возложенные на него функции, или не работает. Если компьютер постоянно зависает, происходят разнообразные сбои, если он самостоятельно перезагружается или даже выключается, слишком долго грузится, то все это можно считать неисправностью, что требует вмешательства специалиста и, соответственно, устранения.

Миф № 8. На вашем компьютере эта программа работать не будет

Если данная программа устанавливается на других компьютерах, а на вашем ПК никак не хочет устанавливаться или работать после вполне удачной инсталляции, это говорит о наличии сбоя в работе компьютера. Только если речь идет о программе, которую не удается запустить ни на одном компью тере, можно считать, что она не будет работать вообще. Такое возможно, например, при повреждении дистрибутива.

Существует, конечно, масса примеров, когда программы отказываются работать со строго определенными моделями устройств, но подавляющее большинство таких сбоев, как правило, устраняется в более новых версиях этих программ. Поэтому следует искать причину того, почему не запуска ется программа, а не махать рукой как в известном фильме "Все будет хорошо".